[PATCH] gnu: Add ghc-alsa-core.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Gabriel Hondet
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
875ztr4lvi.fsf@gmail.com
* gnu/packages/haskell.scm (ghc-alsa-core): New variable.
---
gnu/packages/haskell.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 255e902e6..eecb5b71c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11493,4 +11493,29 @@ imported with the correct Haskell types.")
Music Player Daemon.")
(license license:expat)))
+(define-public ghc-alsa-core
+ (package
+ (name "ghc-alsa-core")
+ (version "0.5.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/alsa-core/alsa-core-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1avh4a419h9d2zsslg6j8hm87ppgsgqafz8ll037rk2yy1g4jl7b"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+ ("alsa-lib" ,alsa-lib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://www.haskell.org/haskellwiki/ALSA")
+ (synopsis "Binding to the ALSA Library API (Exceptions)")
+ (description "This package provides access to ALSA infrastructure, that is
+needed by both alsa-seq and alsa-pcm.")
+ (license license:bsd-3)))
;;; haskell.scm ends here
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxgWUEACgkQMbyBBfZZ
1CWbxw//X1QczPNgyFjQHW/s8yY5KhKbK5yGWJTVWaB2tluvbYp498U/vBAv6f0J
aIyEi56vGbsTu62TN9Nm8sd1K55i9DDMGF8X9uWYHcMzLxWzuAs+tiYMDajro2Yf
os7H0LYnEz9MzSLWmuhbzWpqGw9Muc4jgH66odk85fn1Kd+qWrfoC5QQJUlzIRmW
FdEaBOFQqo7nytlR3ijrlMk1Jxye39l7WnyASe6KQAChR/lRh1J2hcm0W005PsAr
ptrbPpZrGqQmE/HMu/5ycg5GNZzg4IscEmd6GHYKfq6bY4mzenaRCALlRaEwE8g/
995+IFxlu78CyBloqIEO8eDohTggdwog9PJWaMr3rJlslBxL3hlZgRCcvFiCIsQP
YekkF1ixpka5UZCE35+K0xqy4xvPCb4yUKhi72fKFm+me3HKKH6PMKRox2P02BfL
yHG5aq/0kOEaQ0CUp4uCVcFLuRhXuSsLEUURcYrPMaHz88HzVoLyiYe9osis6Owb
6yFxj4ui7PiTEkIscsX0P09lARQJb7iTGHAUm178Q64Mo5Pq6rU0bWqMCRzcEDfc
MrGwFFY7J7c+2kQyj3k7bB+c961dbpa0LATm5d35wSfuQsiiE9pO3KD6H4mO9RPO
Hl0ShFQVYLSQ4/tN8kso9Fx2I+aVccMlQKjpDj86ndM5Xey0A7Q=
=LEyi
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 34415-done@debbugs.gnu.org)
20190210213820.2cc64117@scratchpost.org
Thanks! Pushed to guix master as 3fc88ff0f3499b9be2eb8177084752feb2e2508f.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlxgi7wACgkQ5xo1VCww
uqW5GQf/YrKiTX2wVCl7WzYVr7dGazKLklsqMo53vsao6c8Q1xA4pDnavwNYgsq/
3LseKk8gYIYHhh0QQVO64mpfj+Av9VpcVbsiHl40aHOJZmhNj5rDMfMIwOmLYrl4
Z2J/2wSZY0Ov07ygZGPFEgcISAi3QWHD3TVMcRlgZ+37nRt4a9l70AWSnummr4Dr
wt/Of3j16yq1/olj6/DrLFlOYo257+yPLmud1quiwkJsb3FAR0Ct1VvHFzWFvpyi
QsK0vgcBS+KoJFSelOO+2ULRcqYvAOjFm1VqglbnBb7sgYfNBfDPFDDP2RyETNLr
5pHe86TgQj2C+lSP3nMYRlI4CyqyGw==
=iBjf
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34415@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34415
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help