Inferior channel (I believe 'inferior-for-channels' function specifically) sometimes fails

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pkill9
Owner
unassigned
Submitted by
pkill9
Severity
normal
P
P
pkill9 wrote on 9 Feb 2019 12:11
(name . bug-guix)(address . bug-guix@gnu.org)
E1gsQXs-0001oo-0Z@rmmprod07.runbox
Often I'll get this output when building a manifest* with an inferior:

```
itsme@antelope /tmp$ guix package -n -m example-inferior.scm
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
guix package: error: failed to load 'example-inferior.scm':
```

I believe this is the 'inferior-for-channels' function that fails.

After investigating a while back, it seems removing the relevant checkout in ~/.cache/guix/checkouts temporarily fixes it, but the issue often comes back.




* The manifest used is the example from the Guix manual in the section on Inferiors, with the guix commit in the manifest replaced with my guix revision:

```
(use-modules (guix inferior) (guix channels)
(srfi srfi-1)) ;for 'first'

(define channels
;; This is the old revision from which we want to
;; extract guile-json.
(list (channel
(name 'guix)
(commit
"722ac64cd7dc1f09fb77e2ae780427fa13c03110"))))

(define inferior
;; An inferior representing the above revision.
(inferior-for-channels channels))

;; Now create a manifest with the current "guile" package
;; and the old "guile-json" package.
(packages->manifest
(list (first (lookup-inferior-packages inferior "guile-json"))
(specification->package "guile")))
```
L
L
Ludovic Courtès wrote on 9 Feb 2019 15:12
(address . pkill9@runbox.com)(address . 34402@debbugs.gnu.org)
87pns1t5iv.fsf@gnu.org
Hello,

<pkill9@runbox.com> skribis:

Toggle quote (8 lines)
> Often I'll get this output when building a manifest* with an inferior:
>
> ```
> itsme@antelope /tmp$ guix package -n -m example-inferior.scm
> Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
> guix package: error: failed to load 'example-inferior.scm':
> ```

There’s nothing following the colon above?

Toggle quote (4 lines)
> I believe this is the 'inferior-for-channels' function that fails.
>
> After investigating a while back, it seems removing the relevant checkout in ~/.cache/guix/checkouts temporarily fixes it, but the issue often comes back.

I wonder if it could be https://issues.guix.info/issue/34016, though
I’ve never experienced it in ~/.cache/guix, despite using ‘guix pull’ &
co. a lot.

Next time this happens, could you run:

strace -s 100 -o log guix package -n -m example-inferior.scm

and post the last few hundred lines of ‘log’?

Thanks,
Ludo’.
P
P
pkill9 wrote on 9 Feb 2019 16:49
(name . Ludovic Courtès)(address . ludo@gnu.org)(name . 34402)(address . 34402@debbugs.gnu.org)
E1gsUsP-0002Sk-JN@rmmprod07.runbox
Nope, there is nothing after the colon in the output when this error shows up.

Ok, I will run that next time I get this error.

On Sat, 09 Feb 2019 15:12:24 +0100, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (30 lines)
> Hello,
>
> <pkill9@runbox.com> skribis:
>
> > Often I'll get this output when building a manifest* with an inferior:
> >
> > ```
> > itsme@antelope /tmp$ guix package -n -m example-inferior.scm
> > Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
> > guix package: error: failed to load 'example-inferior.scm':
> > ```
>
> There’s nothing following the colon above?
>
> > I believe this is the 'inferior-for-channels' function that fails.
> >
> > After investigating a while back, it seems removing the relevant checkout in ~/.cache/guix/checkouts temporarily fixes it, but the issue often comes back.
>
> I wonder if it could be <https://issues.guix.info/issue/34016>, though
> I’ve never experienced it in ~/.cache/guix, despite using ‘guix pull’ &
> co. a lot.
>
> Next time this happens, could you run:
>
> strace -s 100 -o log guix package -n -m example-inferior.scm
>
> and post the last few hundred lines of ‘log’?
>
> Thanks,
> Ludo’.
P
P
pkill9 wrote on 10 Feb 2019 18:01
(name . Ludovic Courtès)(address . ludo@gnu.org)(name . 34402)(address . 34402@debbugs.gnu.org)
E1gssTo-0001GJ-El@rmmprod07.runbox
I got the error again, I've attached the output.

It looks like line 16205 (at the bottom pretty much) shows that a permissions issue is the culprit:

openat(AT_FDCWD, "/home/itsme/.cache/guix/checkouts/pjmkglp4t7znuugeurpurzikxq3tnlaywmisyr27shj7apsnalwq/.git/FETCH_HEAD", O_WRONLY|O_CREAT|O_TRUNC|O_CLOEXEC, 0666) = -1 EACCES (Permission denied)

That file, along with is owned by root and is in the root group, and permissions are set to `-rw-r--r--`.

It looks like this is caused by me running a guix command as root, with `sudo -E` (the -E is probably why it's modifying ownership of files in my user's guix cache directory), that checks out the git commit (I assume since it's only changing the ownership on those two files, the rest in that directory are owned by my user).

Changing the owner of that file back to my user has made the error go away when running `guix package -n -m example-manifest.scm` - and if i then run that command again with 'sudo -E', the ownership of those files is changed back to root.

On Sat, 09 Feb 2019 15:12:24 +0100, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (30 lines)
> Hello,
>
> <pkill9@runbox.com> skribis:
>
> > Often I'll get this output when building a manifest* with an inferior:
> >
> > ```
> > itsme@antelope /tmp$ guix package -n -m example-inferior.scm
> > Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
> > guix package: error: failed to load 'example-inferior.scm':
> > ```
>
> There’s nothing following the colon above?
>
> > I believe this is the 'inferior-for-channels' function that fails.
> >
> > After investigating a while back, it seems removing the relevant checkout in ~/.cache/guix/checkouts temporarily fixes it, but the issue often comes back.
>
> I wonder if it could be <https://issues.guix.info/issue/34016>, though
> I’ve never experienced it in ~/.cache/guix, despite using ‘guix pull’ &
> co. a lot.
>
> Next time this happens, could you run:
>
> strace -s 100 -o log guix package -n -m example-inferior.scm
>
> and post the last few hundred lines of ‘log’?
>
> Thanks,
> Ludo’.
L
L
Ludovic Courtès wrote on 12 Feb 2019 23:35
(address . pkill9@runbox.com)(name . 34402)(address . 34402-done@debbugs.gnu.org)
87k1i4fxdr.fsf@inria.fr
Hi,

<pkill9@runbox.com> skribis:

Toggle quote (10 lines)
> It looks like line 16205 (at the bottom pretty much) shows that a permissions issue is the culprit:
>
> openat(AT_FDCWD, "/home/itsme/.cache/guix/checkouts/pjmkglp4t7znuugeurpurzikxq3tnlaywmisyr27shj7apsnalwq/.git/FETCH_HEAD", O_WRONLY|O_CREAT|O_TRUNC|O_CLOEXEC, 0666) = -1 EACCES (Permission denied)
>
> That file, along with is owned by root and is in the root group, and permissions are set to `-rw-r--r--`.
>
> It looks like this is caused by me running a guix command as root, with `sudo -E` (the -E is probably why it's modifying ownership of files in my user's guix cache directory), that checks out the git commit (I assume since it's only changing the ownership on those two files, the rest in that directory are owned by my user).
>
> Changing the owner of that file back to my user has made the error go away when running `guix package -n -m example-manifest.scm` - and if i then run that command again with 'sudo -E', the ownership of those files is changed back to root.

Great that you found out!

Commits 70a50305c495ca96fdec3d31e7e7972cfc54f8ee and
1d8b10d00f0c242bc5ce9540737af3d3f24a05c0 fix error reporting in this
case: you now get an error message mentioning Git and the invalid
permissions on a file in ~/.cache/guix/checkouts.

Thanks,
Ludo'.
Closed
?