Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
* gnu/packages/haskell.scm (ghc-stylish-haskell): New variable.
---
gnu/packages/haskell.scm | 54 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)
Toggle diff (65 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 255e902e6..872f0db14 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11493,4 +11493,58 @@ imported with the correct Haskell types.")
Music Player Daemon.")
(license license:expat)))
+(define-public ghc-stylish-haskell
+ (package
+ (name "ghc-stylish-haskell")
+ (version "0.9.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/stylish-haskell/stylish-haskell-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1ls11fdx6snvfx8yykpidz142zzxwi5bazl49hgfqlwx50rqcp7w"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-file-embed" ,ghc-file-embed)
+ ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-yaml" ,ghc-yaml)
+ ("ghc-strict" ,ghc-strict)
+ ("ghc-optparse-applicative"
+ ,ghc-optparse-applicative)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
+ (home-page "https://github.com/jaspervdj/stylish-haskell")
+ (synopsis "Haskell code prettifier")
+ (description "Stylish-haskell is a Haskell code prettifier. The goal is
+not to format all of the code in a file, to avoid \"getting in the way\".
+However, this tool can e.g. clean up import statements and help doing various
+tasks that get tedious very quickly. It can
+@itemize
+@item
+Align and sort @code{import} statements
+@item
+Group and wrap @code{{-# LANGUAGE #-}} pragmas, remove (some) redundant
+pragmas
+@item
+Remove trailing whitespaces
+@item
+Align branches in @code{case} and fields in records
+@item
+Convert line endings (customisable)
+@item
+Replace tabs by four spaces (turned off by default)
+@item
+Replace some ASCII sequences by their Unicode equivalent (turned off by
+default)
+@end itemize")
+ (license license:bsd-3)))
;;; haskell.scm ends here
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxetCcACgkQMbyBBfZZ
1CUlnA//VymjTErpXqvReKB6ubvjbQVFK1vBb4YYkTk49+C2Vyu5gjnNiRX0nZMR
JCDAhabzJp6luu+qXHuseVqyiUHeOGCT1UpLR1hckAZrLj4vp5Ld+aXwGW5juX94
nN3Wuiw1zcDiwHw8++SiSJhmZmbn/TDjNFclVgm/NtUezcU5NAy6O6bx2NYPXpWg
nV8J7uHgjnQKs9gzIH7oCd6zuwYNuiH0+uN1ezrciDAS5zidm0ziTbdl6fqQsDQA
1UeIXouhohjoz+/UdDeR3MhrUPN+dLHE7vTUrdl3HxSCKFEOPQHMV85CE1j26EnZ
BteeERTavNYJrF5HTDRm9iPfAuasLoyb6gevszC/LKqUJyBiRkef+3/HbQvLUPtI
hNBwXWUiylyM8NLjT04VWr2xu56vr3qmhlm163fHf8SVo32B3vBVb//JOP17nmm3
h7j+O7wGlWtPPNb2h/Ruutde39/TYluep37K2p58Q6Ei5F1JvN2FBuW5rwX1QRhs
Dga1F0qY8kf6HoNkcLZV/4YytMJwf/gKwoazKY2424QWO7UScEqttFWPBEqxDAME
9HDFDTyneQJEoWWZdg1w6r0jfWi1x3R3DWe/+2/STN1RDIxL7Kx6EIzOz/RfB2Aj
CCApNG4gF4+s70Cn5pmKSU3Q+L/trprHHA3JkEPyquMSxOAGvuE=
=rqPG
-----END PGP SIGNATURE-----