[PATCH] gnu: Add ghc-stylish-haskell.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Gabriel Hondet
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
878syp43x4.fsf@gmail.com
* gnu/packages/haskell.scm (ghc-stylish-haskell): New variable.
---
gnu/packages/haskell.scm | 54 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 255e902e6..872f0db14 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11493,4 +11493,58 @@ imported with the correct Haskell types.")
Music Player Daemon.")
(license license:expat)))
+(define-public ghc-stylish-haskell
+ (package
+ (name "ghc-stylish-haskell")
+ (version "0.9.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/stylish-haskell/stylish-haskell-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1ls11fdx6snvfx8yykpidz142zzxwi5bazl49hgfqlwx50rqcp7w"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-file-embed" ,ghc-file-embed)
+ ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-yaml" ,ghc-yaml)
+ ("ghc-strict" ,ghc-strict)
+ ("ghc-optparse-applicative"
+ ,ghc-optparse-applicative)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
+ (home-page "https://github.com/jaspervdj/stylish-haskell")
+ (synopsis "Haskell code prettifier")
+ (description "Stylish-haskell is a Haskell code prettifier. The goal is
+not to format all of the code in a file, to avoid \"getting in the way\".
+However, this tool can e.g. clean up import statements and help doing various
+tasks that get tedious very quickly. It can
+@itemize
+@item
+Align and sort @code{import} statements
+@item
+Group and wrap @code{{-# LANGUAGE #-}} pragmas, remove (some) redundant
+pragmas
+@item
+Remove trailing whitespaces
+@item
+Align branches in @code{case} and fields in records
+@item
+Convert line endings (customisable)
+@item
+Replace tabs by four spaces (turned off by default)
+@item
+Replace some ASCII sequences by their Unicode equivalent (turned off by
+default)
+@end itemize")
+ (license license:bsd-3)))
;;; haskell.scm ends here
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxetCcACgkQMbyBBfZZ
1CUlnA//VymjTErpXqvReKB6ubvjbQVFK1vBb4YYkTk49+C2Vyu5gjnNiRX0nZMR
JCDAhabzJp6luu+qXHuseVqyiUHeOGCT1UpLR1hckAZrLj4vp5Ld+aXwGW5juX94
nN3Wuiw1zcDiwHw8++SiSJhmZmbn/TDjNFclVgm/NtUezcU5NAy6O6bx2NYPXpWg
nV8J7uHgjnQKs9gzIH7oCd6zuwYNuiH0+uN1ezrciDAS5zidm0ziTbdl6fqQsDQA
1UeIXouhohjoz+/UdDeR3MhrUPN+dLHE7vTUrdl3HxSCKFEOPQHMV85CE1j26EnZ
BteeERTavNYJrF5HTDRm9iPfAuasLoyb6gevszC/LKqUJyBiRkef+3/HbQvLUPtI
hNBwXWUiylyM8NLjT04VWr2xu56vr3qmhlm163fHf8SVo32B3vBVb//JOP17nmm3
h7j+O7wGlWtPPNb2h/Ruutde39/TYluep37K2p58Q6Ei5F1JvN2FBuW5rwX1QRhs
Dga1F0qY8kf6HoNkcLZV/4YytMJwf/gKwoazKY2424QWO7UScEqttFWPBEqxDAME
9HDFDTyneQJEoWWZdg1w6r0jfWi1x3R3DWe/+2/STN1RDIxL7Kx6EIzOz/RfB2Aj
CCApNG4gF4+s70Cn5pmKSU3Q+L/trprHHA3JkEPyquMSxOAGvuE=
=rqPG
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 34401-done@debbugs.gnu.org)
20190210220148.66d7512e@scratchpost.org
Thanks! Pushed to guix master as 2356b7ab6d36522880abb7073ec87990b721ce1a.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlxgkTwACgkQ5xo1VCww
uqWKqwf/dCYkrB1L2kCemBnaNQcbhxyDRvn9Skzv0smI2dy2yqbSuidnvdvV+L9H
+lmc20l93cLNd8YdHOVH7knRyGGbpCUVvnntiYmRZy1VnI4aD5tnATDtQt3SNE+m
a31y6qB+C2VHbjDTWmomFSwPL/tWTUlSRhQWU6IvCvJ4A/H5YlJuWeN7K8DMuwr4
dcoArLgc04ZpHZGShajAKFtFQA0dHj3OCta41pqN673cNQUA7oZ7UDXNrplARitG
c5cLpv/fmpansJEQeFm2/u/V6HsqHvpmVrgT0xznu7dFXYbTKrf0DuTVjjP6j6Ck
LRE/PGxcu4wHa9LkJ4bLGPpRsvPilA==
=/O7l
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34401@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34401
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help