[PATCH] gnu: Add python-backports-shutil-which.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Vagrant Cascadian
  • zimoun
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
87k1i9v5ka.fsf@ponder
* gnu/packages/python-xyz.scm
(python-backports-shutil-which): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 086eb3af26..143d9c2ffc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -317,6 +317,31 @@ etc. ")
(define-public python2-babel
(package-with-python2 python-babel))
+(define-public python-backports-shutil-which
+ (package
+ (name "python-backports-shutil-which")
+ (version "3.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "backports.shutil_which" version))
+ (sha256
+ (base32
+ "0cy16w2dpv110afncag8x1zhzy3yz0iypny4iagdiyp4rdkzafgy"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/minrk/backports.shutil_which")
+ (synopsis
+ "Backport of shutil.which from Python 3.3")
+ (description
+ "Python-backports-shutil-which provides a backport of shutil.which from
+Python 3.3")
+ ;; The backported code is "psfl" license, setup.py is under "MIT" license.
+ (license
+ (list license:psfl
+ (license:non-copyleft
+ "https://raw.githubusercontent.com/minrk/backports.shutil_which/master/LICENSE")))))
+
(define-public python2-backport-ssl-match-hostname
(package
(name "python2-backport-ssl-match-hostname")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXF5zFgAKCRDcUY/If5cW
qjD+AQD6kIqvdWioiN+BQptUseu2QGTOgdMPbL6t24puKSPHrAD8ChICaZTsM4W+
312WRBEXi7QzMoeKh2QDUqyGFwLTJwU=
=O/9f
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 34398@debbugs.gnu.org)
20190211105421.3b77ef6b@scratchpost.org
Hi Vagrant,

On Fri, 08 Feb 2019 22:28:37 -0800
Vagrant Cascadian <vagrant@debian.org> wrote:

Toggle quote (6 lines)
> + (synopsis
> + "Backport of shutil.which from Python 3.3")
> + (description
> + "Python-backports-shutil-which provides a backport of shutil.which from
> +Python 3.3")

Why do we need this package? We have Python 3.7.0.
Doesn't that contain the same module already?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlxhRk0ACgkQ5xo1VCww
uqWF3Qf/VXlVxWJNHGrFNFnitD98ObuZHbHZx5JyyqjX93xGl8Mz1im5Y+LMThjQ
R0LE7Qe/5qqg1XxmZ67EnPIIsRrpqVIH51kOWiW5kW6dqHMAkbOuQTR1TFhFiCD7
Kj0zpEiym0TtMWDO6zGTHy+BJHySZyWNWw9L7q3BmjudnFSbldEz7OtMV36was9+
46ccaMzL4Q75UfCVSklZYHlsbrlr+xWXkD+G58rbKm6fGfunhWq0ghOHaleAq4Lm
I1BkbuSyRMi9CYsuLjL5uAwR2hJGqp/L5m84hB+3TOkWWkml1Uqfr0L+1mDxmygc
lfc6XSJ+OQRxtu5pSPDLllzMKk0TGA==
=J5eV
-----END PGP SIGNATURE-----


Vagrant Cascadian wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 34398@debbugs.gnu.org)
875ztq3rnr.fsf@ponder
On 2019-02-11, Danny Milosavljevic wrote:
Toggle quote (12 lines)
> On Fri, 08 Feb 2019 22:28:37 -0800
> Vagrant Cascadian <vagrant@debian.org> wrote:
>
>> + (synopsis
>> + "Backport of shutil.which from Python 3.3")
>> + (description
>> + "Python-backports-shutil-which provides a backport of shutil.which from
>> +Python 3.3")
>
> Why do we need this package? We have Python 3.7.0.
> Doesn't that contain the same module already?

I found it odd as well, but I couldn't figure out how to get the newer
versions of python-trezor-agent to build without
python-backports-shutil-which without patching python-trezor-agent.

I didn't spend too much effort looking into patching it; I'll take a
little deeper look.

Thanks for all the reviews!


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXGHyOQAKCRDcUY/If5cW
qsAaAP40cjyGT/uWoXhrllb4v3zPdIJL/n15rvaq2ddYkRYpjgEAuIeHHIw4nnvN
bD3aUuJpYwtpczVaybNp3AnPWXiSvwY=
=6FAH
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 34398@debbugs.gnu.org)
87tvh9a3rn.fsf@ponder
On 2019-02-11, Vagrant Cascadian wrote:
Toggle quote (19 lines)
> On 2019-02-11, Danny Milosavljevic wrote:
>> On Fri, 08 Feb 2019 22:28:37 -0800
>> Vagrant Cascadian <vagrant@debian.org> wrote:
>>> + (synopsis
>>> + "Backport of shutil.which from Python 3.3")
>>> + (description
>>> + "Python-backports-shutil-which provides a backport of shutil.which from
>>> +Python 3.3")
>>
>> Why do we need this package? We have Python 3.7.0.
>> Doesn't that contain the same module already?
>
> I found it odd as well, but I couldn't figure out how to get the newer
> versions of python-trezor-agent to build without
> python-backports-shutil-which without patching python-trezor-agent.
>
> I didn't spend too much effort looking into patching it; I'll take a
> little deeper look.

I don't see a need for this package anymore; I submitted an update for
python-trezor-agent/trezor-agent that fixes the issue without using
backports.shutil_which.

A slightly deeper look into: Lacking backports.shutil_which caused
"trezor-agent" to fail during tests as it tried to download the missing
library, but there was no mention of shutil_which at all in any of it's
code... turned out "python-trezor-agent" had an overly strict requires
on the backported.shutil_which, even though "python-trezor-agent"
supports the shutil_which included in newer python versions. Simply
removing the backports.shutil_which from "python-trezor-agent" requires
fixed the issue.

Thanks!

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXGJvbQAKCRDcUY/If5cW
qm3wAPwMuO4nwcCzitgl4m4eBGQs8Iql3ZVdVSXhPiG/q+CUewD+IB3Fv1NUosQS
yE0XR8PAbcTR9Pol0tDeqGrMJ7KICQs=
=MpNM
-----END PGP SIGNATURE-----

zimoun wrote 3 years ago
Re: bug#34398: [PATCH] gnu: Add python-backports-shutil-which.
(name . Vagrant Cascadian)(address . vagrant@debian.org)
86wng12j0t.fsf_-_@gmail.com
Hi,

On Mon, 11 Feb 2019 at 23:02, Vagrant Cascadian <vagrant@debian.org> wrote:

Toggle quote (4 lines)
> I don't see a need for this package anymore; I submitted an update for
> python-trezor-agent/trezor-agent that fixes the issue without using
> backports.shutil_which.

Therefore, closing. Let me know if I have missed a point.


Cheers,
simon
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34398@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34398
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help