[PATCH] gnu: Add python-pymsgbox.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
87mun5vh90.fsf@ponder
* gnu/packages/python-xyz.scm (python-pymsgbox): New variable.
---
gnu/packages/python-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 14a80b920e..086eb3af26 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1938,6 +1938,44 @@ easier to build concurrent applications.")
(define-public python2-pykka
(package-with-python2 python-pykka))
+(define-public python-pymsgbox
+ (package
+ (name "python-pymsgbox")
+ (version "1.0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; LICENSE.txt is not present on pypi
+ (url "https://github.com/asweigart/PyMsgBox")
+ (commit "55926b55f46caa969c5ddb87990ebea2737bd66f")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zy7rjfpwlrd8b64j7jk2lb8m2npc21rnpwakpfvwgl4nxdy80rg"))))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; Circular dependency to run tests:
+ ;; Tests need pyautogui, which depends on pymsgbox.
+ (delete 'check))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/asweigart/PyMsgBox")
+ (synopsis
+ "Python module for JavaScript-like message boxes")
+ (description
+ "PyMsgBox is A simple, cross-platform, pure Python module for
+JavaScript-like message boxes. Types of dialog boxes include:
+@enumerate
+@item alert
+@item confirm
+@item prompt
+@item password
+@end enumerate
+")
+ (license license:bsd-3)))
+
(define-public python-pympler
(package
(name "python-pympler")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXF436wAKCRDcUY/If5cW
qi1wAQDw0QdjLKpzcK8KYeGuvJ+8pIVya09xS9vDPHSkoPR+iwD+LzW+maV2hDAA
4ix5cPYhHs2gNPshpQQP5MurXsYzLQ8=
=6FlB
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 34396-done@debbugs.gnu.org)
20190211105249.2d050fce@scratchpost.org
Hi Vagrant,

thanks. Applied to master.

On Fri, 08 Feb 2019 18:16:11 -0800
Vagrant Cascadian <vagrant@debian.org> wrote:

Toggle quote (4 lines)
> + ;; LICENSE.txt is not present on pypi
> + (url "https://github.com/asweigart/PyMsgBox")
> + (commit "55926b55f46caa969c5ddb87990ebea2737bd66f")))

Hmm, could you report this upstream?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlxhRfEACgkQ5xo1VCww
uqVi7Qf/Un6ohCRKhJNhlexlg3/YcxgMuNELtc8laXOn1FqvaP/A2n2sJa8QuIv5
3O5FlWc2MRDKkpULnpciqYwWACKxwhRKI6tZg52c5kZ9zPgcqfsMTUXVTE3T5/L3
qtrVct87TDOuC9nvd9uu7sBls5MucLVFvyHbuWjxAqITMwPYGn62nM/xVWxV5VLW
YdXpMoa0c31Tv7hu+WzzoqEcuUgaUDXiWWAq+7R0CCAOvC4yPinBEbBgNTAZ1m3c
xSg7E9yTr7M1KWZ042ZXwvf/6BsT37UZmul0ZWNxYyX+6JUrkWH5o8ob+/5Wuvg2
oI4aJS85ZxvPrd6Q1h79hcHkmIZT/w==
=RUSR
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34396@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34396
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help