[PATCH 4/5] gnu: Add python-docstyle.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
875ztusyxz.fsf@posteo.net
From 0b66f38dd41230611cad44181a81bda38e40619f Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 7 Feb 2019 22:04:52 -0600
Subject: [PATCH 4/5] gnu: Add python-docstyle.

* gnu/packages/python-xyz.scm (python-docstyle): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5c7241621..c41c4a1cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2545,6 +2545,27 @@ Language (TOML) configuration files.")
(description "An implementation of the JSON RPC 2.0 server library for interoperability with Python.")
(license license:expat)))
+(define-public python-pydocstyle
+ (package
+ (name "python-pydocstyle")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pydocstyle" version))
+ (sha256
+ (base32
+ "1m1xv9clkg9lgzyza6dnj359z04vh5g0h49nhzghv7lg81gchhap"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-snowballstemmer" ,python-snowballstemmer)))
+ (home-page
+ "https://github.com/PyCQA/pydocstyle/")
+ (synopsis "Python docstring style checker")
+ (description "A docstring style checker/linter for the Python language server.")
+ (license license:expat)))
+
(define-public python-black
(package
(name "python-black")
--
2.20.1
Ludovic Courtès wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34382-done@debbugs.gnu.org)
87sgwsfxhb.fsf@gnu.org
Brett Gilio <brettg@posteo.net> skribis:

Toggle quote (7 lines)
>>From 0b66f38dd41230611cad44181a81bda38e40619f Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Thu, 7 Feb 2019 22:04:52 -0600
> Subject: [PATCH 4/5] gnu: Add python-docstyle.
>
> * gnu/packages/python-xyz.scm (python-docstyle): New variable.

Pushed as well.

This series ended up taking me more time than I thought. :-)
First the patches were sent in reverse order, which I only realized
later. Then each patch had tiny issues (indentation, inappropriate
description, code duplication, etc.) that I ended up fixing because they
looked tiny at first…

Please pay more attention to these things in the future.

Regardless, thank you for the patches!

Ludo’.
Closed
Brett Gilio wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87ef8cfr5d.fsf@posteo.net
Ludovic Courtès writes:

Toggle quote (23 lines)
> Brett Gilio <brettg@posteo.net> skribis:
>
>>>From 0b66f38dd41230611cad44181a81bda38e40619f Mon Sep 17 00:00:00 2001
>> From: Brett Gilio <brettg@posteo.net>
>> Date: Thu, 7 Feb 2019 22:04:52 -0600
>> Subject: [PATCH 4/5] gnu: Add python-docstyle.
>>
>> * gnu/packages/python-xyz.scm (python-docstyle): New variable.
>
> Pushed as well.
>
> This series ended up taking me more time than I thought. :-)
> First the patches were sent in reverse order, which I only realized
> later. Then each patch had tiny issues (indentation, inappropriate
> description, code duplication, etc.) that I ended up fixing because they
> looked tiny at first…
>
> Please pay more attention to these things in the future.
>
> Regardless, thank you for the patches!
>
> Ludo’.

Thank you Ludo,

This was my first series, so I appreciate the comments you gave me for
feedback and I will be more diligent in the future!

Brett
Closed
Brett Gilio wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87d0nwfr3k.fsf@posteo.net
Ludovic Courtès writes:

Toggle quote (23 lines)
> Brett Gilio <brettg@posteo.net> skribis:
>
>>>From 0b66f38dd41230611cad44181a81bda38e40619f Mon Sep 17 00:00:00 2001
>> From: Brett Gilio <brettg@posteo.net>
>> Date: Thu, 7 Feb 2019 22:04:52 -0600
>> Subject: [PATCH 4/5] gnu: Add python-docstyle.
>>
>> * gnu/packages/python-xyz.scm (python-docstyle): New variable.
>
> Pushed as well.
>
> This series ended up taking me more time than I thought. :-)
> First the patches were sent in reverse order, which I only realized
> later. Then each patch had tiny issues (indentation, inappropriate
> description, code duplication, etc.) that I ended up fixing because they
> looked tiny at first…
>
> Please pay more attention to these things in the future.
>
> Regardless, thank you for the patches!
>
> Ludo’.

This was my first patch series, so I appreciate your feedback to help me
make sure that I am doing this correct in the future!

Thank you as always
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34382@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34382
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help