Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
From 0b66f38dd41230611cad44181a81bda38e40619f Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 7 Feb 2019 22:04:52 -0600
Subject: [PATCH 4/5] gnu: Add python-docstyle.
* gnu/packages/python-xyz.scm (python-docstyle): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5c7241621..c41c4a1cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2545,6 +2545,27 @@ Language (TOML) configuration files.")
(description "An implementation of the JSON RPC 2.0 server library for interoperability with Python.")
(license license:expat)))
+(define-public python-pydocstyle
+ (package
+ (name "python-pydocstyle")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pydocstyle" version))
+ (sha256
+ (base32
+ "1m1xv9clkg9lgzyza6dnj359z04vh5g0h49nhzghv7lg81gchhap"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-snowballstemmer" ,python-snowballstemmer)))
+ (home-page
+ "https://github.com/PyCQA/pydocstyle/")
+ (synopsis "Python docstring style checker")
+ (description "A docstring style checker/linter for the Python language server.")
+ (license license:expat)))
+
(define-public python-black
(package
(name "python-black")
--
2.20.1