Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
From 915bd232185ebcab96d96dc400ee3f010e691048 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 7 Feb 2019 22:03:42 -0600
Subject: [PATCH 2/5] gnu: Add python-language-server.
* gnu/packages/python-xyz.scm (python-language-server): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 64bb85cc0..9efbbeba8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2492,6 +2492,37 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
Language (TOML) configuration files.")
(license license:expat)))
+(define-public python-language-server
+ (package
+ (name "python-language-server")
+ (version "0.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-language-server" version))
+ (sha256
+ (base32
+ "04pbxl06hg0ddm2xx99jn9jh40yv0mmzdjw8pqd2rbcdg42hhia6"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pluggy" ,python-pluggy)
+ ("python-jsonrps-server" ,python-jsonrpc-server)
+ ("python-jedi" ,python-jedi)
+ ("python-yapf" ,python-yapf)
+ ("python-pyflakes" ,python-pyflakes)
+ ("python-pydocstyle" ,python-pydocstyle)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-mccabe" ,python-mccabe)
+ ("python-rope" ,python-rope)
+ ("python-autopep8" ,python-autopep8)))
+ (home-page
+ "https://github.com/palantir/python-language-server")
+ (synopsis
+ "Python Language Server for the Language Server Protocol")
+ (description
+ "The Python Language Server (pyls) is an implementation of the Python 3 language specification for the LSP. This tool is used in many text-editing environments to provide a complete and integrated feature-set for programming Python effectively.")
+ (license license:expat)))
+
(define-public python-black
(package
(name "python-black")
--
2.20.1