[PATCH 1/4] gnu: Add ocaml-earley.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Hondet
  • Julien Lepiller
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
87lg2sf6az.fsf@gmail.com
* gnu/packages/ocaml.scm (ocaml-earley): New variable.
---
gnu/packages/ocaml.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2d33db1c0..59630028e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4727,6 +4727,36 @@ syntax checking on dedukti files.")
"Part of the Jane Street's PPX rewriters collection.")
(license license:expat)))
+(define-public ocaml-earley
+ (package
+ (name "ocaml-earley")
+ (version "2.0.0")
+ (home-page "https://github.com/rlepigre/ocaml-earley")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18k7bi7krc4bvqnhijz1q0pfr0nfahghfjifci8rh1q4i5zd0xz5"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "make" "tests")
+ #t)))))
+ (synopsis "Parsing library based on Earley Algorithm")
+ (description "Earley is a parser combinator library base on Earley's
+algorithm. It is intended to be used in conjunction with an OCaml syntax
+extension which allows the definition of parsers inside the language. There
+is also support for writing OCaml syntax extensions in a camlp4 style.")
+ (license license:cecill-b)))
+
(define-public ocaml-biniou
(package
(name "ocaml-biniou")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxb01QACgkQMbyBBfZZ
1CWdCQ//dXd+Kt4pwK+eVS0z3Nf3AFNyVthcoDD4KfUnC5HEtItT9RbwEqDK80AI
FMt+0uN+ByhFp4mileTnBPANQqQFpou1XJGE+M75VmvjFRw8iZUTQiuwoa0wJM+6
lmXfem+OPEzhV5B9LRKhXDPEMI00fs1gKyiep7SFhyx8yug/vzil65QFG1HEHkAG
ihqyLlTpYaHx5pR37CIE2NS/um1bJJpHr0ZCGA830BcbZKCPqr/nqUJNJP3ENWor
cE6uKgWLG/aR1lx/HWn+wfxQY8LytnActLBeC56JDbWJNAQrhT+Xn0wmX3qlYTiX
94zqx7vyUF64knTMtLP2K9gBidSZCn4U0HxZiVaEoX7Xwo+m9WGm7c71S3AzbmB7
QCLXSqg3eSw7Wc4DOKJdPteRXs7BdIUo2XHnCyI9EuxTewiTItKg5vuxE3It4iYW
hlnuti0BNkMpCDp6ktH4xX49T9qCBSlCAKpqKUIFI1iOH+zf5H9+P7aczZEN5XR8
2l4WSUVJpEikFgTf5pgV2xpPCD3Hzo5nXsH/6XaCFB4+SQeCB0hhszZ5PIHgTrEv
aIT8PLK2ygLS5Xkvv/tbUhLCYx3Z4UriN4Xeo0NhEDlk8FPErILPaJi2AGLn8sdF
ZunbAPj7Bd+iX0HCIdqxbusDHV0tr+4IqeEuRtBKwFthzKO0coY=
=o1No
-----END PGP SIGNATURE-----

Gabriel Hondet wrote 6 years ago
[PATCH 2/4] gnu: Add ocaml-bindlib.
(address . 34361@debbugs.gnu.org)
87k1icf603.fsf@gmail.com
* gnu/packages/ocaml.scm (ocaml-bindlib): New variable.
---
gnu/packages/ocaml.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 59630028e..ede3beb03 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4727,6 +4727,45 @@ syntax checking on dedukti files.")
"Part of the Jane Street's PPX rewriters collection.")
(license license:expat)))
+(define-public ocaml-bindlib
+ (package
+ (name "ocaml-bindlib")
+ (version "5.0.1")
+ (build-system ocaml-build-system)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rlepigre/ocaml-bindlib.git")
+ (commit (string-append "ocaml-bindlib_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1f8kr81w8vsi4gv61xn1qbc6zrzkjp8l9ix0942vjh4gjxc74v75"))))
+ (native-inputs
+ `(("ocamlbuild" ,ocamlbuild)
+ ("ocaml-findlib" ,ocaml-findlib)))
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (invoke "make")
+ #t))
+ (replace 'install
+ (lambda _
+ (invoke "make" "install")
+ #t)))))
+ (home-page "https://rlepigre.github.io/ocaml-bindlib/")
+ (synopsis "OCaml Bindlib library for bound variables")
+ (description "Bindlib is a library allowing the manipulation of data
+structures with bound variables. It is particularly useful when writing ASTs
+for programming languages, but also for manipulating terms of the λ-calculus
+or quantified formulas.")
+ (license license:gpl3+)))
+
(define-public ocaml-earley
(package
(name "ocaml-earley")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxb1NwACgkQMbyBBfZZ
1CXesg//TXQEzeLoyJ5M2gmBKrKLGnDG1YtY2+nFVi0HjfDQLp4wj1uYOXUYFDIk
O4m9zt+xD9YT3Wu9KpqhWW6/camQ8evht47zhH/+YYlQqaA2VFf8KvvHbhu+fW2A
VW6vo3n2GXNxZHTNIFW1U6Fedkcmd2ZuTgNVuZ2zUONcddlsjG/Hx5G6P/Q5Rs0N
F/0CUusURsr9j6D0/J36lOSC1Pb5wO/onPxwYWxZbXH6Q4llRjmn7h1rvyRtBmfj
bgal/Fy0rMXuC5Y4LkMWwTHglzexU1c6UcoIOWUlsYet1P8nrl/+jCqMKcUaWmpS
UTQZDF5Rj824BuNRBNcxMfTuut60l9NkWcSo2YgHyQ0UZuSyn7KZjsJxN7bzu1DX
pP2YiIyuES0S4koYn6nZTPGmz2TnfC3dHNBCgPVQvYy3TKW+ELVtSgd8fBTFn89F
Bd9emdvOeuUsRRo0NmzrPC/V1j9Ds12f/Q2UN66hEcfE/YPHpUXw32hC3eRdXKJq
KW6xWvERaMdR5HHcaGqhwaK6RPOoGiQS7Wky7vHDSH/80FsxQIliF9jD4Gvace1+
JifzG5N70lsLgvxVk6+LEQDjk/xbAvtSquGDvX5AWFcgczTFpuWxBsixxKHvIECg
6FPtuPicaOl8C6+oV+tmXJxeq7VEBaXGENUGyJRCLGVIYaX+H3Q=
=Ljky
-----END PGP SIGNATURE-----

Gabriel Hondet wrote 6 years ago
[PATCH 3/4] gnu: Add ocaml-timed.
(address . 34361@debbugs.gnu.org)
87imxwf5a9.fsf@gmail.com
* gnu/packages/ocaml.scm (ocaml-timed): New variable.
---
gnu/packages/ocaml.scm | 47 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ede3beb03..34229107f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4796,6 +4796,53 @@ extension which allows the definition of parsers inside the language. There
is also support for writing OCaml syntax extensions in a camlp4 style.")
(license license:cecill-b)))
+(define-public ocaml-timed
+ (package
+ (name "ocaml-timed")
+ (version "1.0")
+ (home-page "https://github.com/rlepigre/ocaml-timed")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append name "_" version))))
+ (sha256
+ (base32
+ "0hfxz710faxy5yk97bkfnw87r732jcxxhmjppwrbfdb6pd0wks96"))
+ (file-name (git-file-name name version))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("ocaml-findlib" ,ocaml-findlib)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (invoke "make")
+ #t))
+ (replace 'install
+ (lambda _
+ (invoke "make" "install")
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "make" "tests")
+ #t)))))
+ (synopsis "Timed references for imperative state")
+ (description "Timed references for imperative state. This module provides
+an alternative type for references (or mutable cells) supporting undo/redo
+operations. In particular, an abstract notion of time is used to capture the
+state of the references at any given point, so that it can be restored. Note
+that usual reference operations only have a constant time / memory overhead
+(compared to those of the standard library).
+
+Moreover, we provide an alternative implementation based on the references
+of the standard library (Pervasives module). However, it is less efficient
+than the first one.")
+ (license license:expat)))
+
(define-public ocaml-biniou
(package
(name "ocaml-biniou")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxb2H4ACgkQMbyBBfZZ
1CXbSQ/7BghTKXXuXkjVAZHAJkPrwhqes4UauDAeIx9QfXzAYTsp3E3OVkdTe3al
vm30/lOMQ7JlIbHCPnWSGZ8uYibE4D55QnGhrMBWMM/7WDgfBdxLQYRLWbOjPdbd
qOLeWjlQR1rIIh5+WGvm0N4BmXHwc1UqURhtP/2pm3ffwwu+vJl5W/4F0kPXwZsm
MsH2gFW8nZOsjq4Hj8aqUBppoz3VAFpbqnynd70nb5LlkmISBhrZD5OaIbWVgN+l
O5kV5QkMTvSjaobuSU1VgpCM9M8ZN+tjO2BZNDTTJHDFIc7pwKsU1Ixmv887BoRg
6eyhK969lMYy2G8ohfnXRhWut6PzqHtCq+EAIn9vKZyfieaZdI0W/t5WkZpawueh
qyy6yTVfGlPyhLA+cCQQU5iM6w02dCO8tnpLeUD9DRJSFFMC1+kc50eCBatA67yR
fwg1L2o9C0IbswwG1E7LEJiHkqIo28BZqkR3oXrZCEF7LxaoRi7Y5Df7n5VnPncy
pGk3WozRkNYazfPFUVP9kKPAKojYN79CX/obqFbewhlPUaDxmVnrcGNLhwibeQUy
ypfjxbVHwWE8VlkNqmCMXr949dKvGJUMUPOJMAD6yYyAizR9aR41bjgNB4r9KmHj
n4n8Xfku7I7gUmGdS+jKiIv8P+Bejd0d3TKJYElbJO7vGO5YW2M=
=HiSi
-----END PGP SIGNATURE-----

Gabriel Hondet wrote 6 years ago
[PATCH 4/4] gnu: Add lambdapi.
(address . 34361@debbugs.gnu.org)
87h8dgf58h.fsf@gmail.com
* gnu/packages/ocaml.scm (lambdapi): New variable.
---
gnu/packages/ocaml.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 34229107f..227a87287 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4843,6 +4843,63 @@ of the standard library (Pervasives module). However, it is less efficient
than the first one.")
(license license:expat)))
+(define-public lambdapi
+ (package
+ (name "lambdapi")
+ (version "1.0")
+ (home-page "https://github.com/Deducteam/lambdapi")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append name "-" version))))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ ;; 'Earley_core' not opened in the files
+ (substitute* '("src/pos.ml"
+ "src/parser.ml"
+ "src/lambdapi.ml")
+ (("(Input|Earley|Charset)" all)
+ (string-append "Earley_core." all)))))
+ (sha256
+ (base32
+ "0kf31xcwsgvadf3kfw8ipwkgcwh99xwb8adx8ap8sd7b4pwa5rc0"))
+ (file-name (git-file-name name version))))
+ (build-system dune-build-system)
+ (inputs
+ `(("ocaml-yojson" ,ocaml-yojson)
+ ("ocaml-easy-format" ,ocaml-easy-format)
+ ("ocaml-biniou" ,ocaml-biniou)
+ ("ocaml-menhir" ,ocaml-menhir)
+ ("ocaml-cmdliner" ,ocaml-cmdliner)
+ ("ocaml-ppx-inline-test" ,ocaml-ppx-inline-test)
+ ("ocaml-timed" ,ocaml-timed)
+ ("ocaml-bindlib" ,ocaml-bindlib)
+ ("ocaml-earley" ,ocaml-earley)
+ ("ocamlbuild" ,ocamlbuild))) ;ocamlbuild for tests
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "make" "real_tests")
+ #t)))))
+ (synopsis "Extension of Dedukti with metavariables and tactics")
+ (description "Lambdapi is an implementation of the λΠ-calculus modulo
+rewriting, which is the system of @url{https://github.com/Deducteam/Dedukti,
+Dedukti}. Lamdapi is
+@itemize
+@item
+a logical framework,
+@item
+a tool for interoperability of proof systems,
+@item
+an interactive proof system,
+@item
+an experimental proof system.
+@end itemize")
+ (license license:lgpl2.1)))
+
(define-public ocaml-biniou
(package
(name "ocaml-biniou")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxb2L4ACgkQMbyBBfZZ
1CVETA/8DfxW5i8FOQMcANbEC7HW4JaexhnwUshUqCdS/xjNe2rTrxLtfqwm7ZZw
3ribFWIeFOR1V+eG3W9jR49CIxJT/rWn31YnLh20Uvp7woWV5za20+6ZEZ+oCi6O
fyyXifyGc22rmTFjd7GpmIk3QjHpe/ozvHN5ylATac3cMHmGwF8xVqn6NfvBzgat
A4yJlcrRLk9GG8gm1JiQgFm8JXSXWMiMtgjwY9pjIDMz5Dl3CRsnvKsSzuGcsbe5
ffpgFabfFaUByoUmaXVkiP6Afn1HRfqAC+uV9W0eiSW75FiR3D6lB7FnniDVplwO
0ciNhemNIaMahc/b2foAvbHssvE79Zx6v5ycjpr6BfUzPC9YKanD++nBkq5HxQCk
99ADB1t4eOk19N682U9QK8pATzu34ayqF6cRNjd9tIuKCOog4bxkgIHYQ4EZxYjk
y+1ESPvVaTKwLmP1SlAObHT4cr8kll9E5e5TvDESJPbRpKUyQMReECUnBN7rPw/G
Uvd3BBfdPlEhpW0eaepe4f83Sj0H/+lZxSfO89VAKZu5PUMd4yBnqqBHbXKE/spA
rjYAJ1r7+el0JJEfqT4FwGOYB+aCDF2FOLBknY3lxVsUzzNC1AX2Dy/Vr7VU+miY
PZmzXHFdztny/Nnnpkq0Ts+4kh/HNjZqs5nyG8LbB+19EyZj+zs=
=6KiN
-----END PGP SIGNATURE-----

Julien Lepiller wrote 6 years ago
(address . 34361@debbugs.gnu.org)
20190213225321.0d3becac@lepiller.eu
Le Sat, 2 Feb 2019 11:51:25 +0100,
Gabriel Hondet <gabrielhondet@gmail.com> a écrit :

Toggle quote (76 lines)
> * gnu/packages/ocaml.scm (lambdapi): New variable.
> ---
> gnu/packages/ocaml.scm | 57
> ++++++++++++++++++++++++++++++++++++++++++ 1 file changed, 57
> insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 34229107f..227a87287 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -4843,6 +4843,63 @@ of the standard library (Pervasives module).
> However, it is less efficient than the first one.")
> (license license:expat)))
>
> +(define-public lambdapi
> + (package
> + (name "lambdapi")
> + (version "1.0")
> + (home-page "https://github.com/Deducteam/lambdapi")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url (string-append home-page ".git"))
> + (commit (string-append name "-" version))))
> + (modules '((guix build utils)))
> + (snippet '(begin
> + ;; 'Earley_core' not opened in the files
> + (substitute* '("src/pos.ml"
> + "src/parser.ml"
> + "src/lambdapi.ml")
> + (("(Input|Earley|Charset)" all)
> + (string-append "Earley_core." all)))))
> + (sha256
> + (base32
> +
> "0kf31xcwsgvadf3kfw8ipwkgcwh99xwb8adx8ap8sd7b4pwa5rc0"))
> + (file-name (git-file-name name version))))
> + (build-system dune-build-system)
> + (inputs
> + `(("ocaml-yojson" ,ocaml-yojson)
> + ("ocaml-easy-format" ,ocaml-easy-format)
> + ("ocaml-biniou" ,ocaml-biniou)
> + ("ocaml-menhir" ,ocaml-menhir)
> + ("ocaml-cmdliner" ,ocaml-cmdliner)
> + ("ocaml-ppx-inline-test" ,ocaml-ppx-inline-test)
> + ("ocaml-timed" ,ocaml-timed)
> + ("ocaml-bindlib" ,ocaml-bindlib)
> + ("ocaml-earley" ,ocaml-earley)
> + ("ocamlbuild" ,ocamlbuild))) ;ocamlbuild for tests
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (replace 'check
> + (lambda _
> + (invoke "make" "real_tests")
> + #t)))))
> + (synopsis "Extension of Dedukti with metavariables and tactics")
> + (description "Lambdapi is an implementation of the λΠ-calculus
> modulo +rewriting, which is the system of
> @url{https://github.com/Deducteam/Dedukti, +Dedukti}. Lamdapi is
> +@itemize
> +@item
> +a logical framework,
> +@item
> +a tool for interoperability of proof systems,
> +@item
> +an interactive proof system,
> +@item
> +an experimental proof system.
> +@end itemize")
> + (license license:lgpl2.1)))
> +
> (define-public ocaml-biniou
> (package
> (name "ocaml-biniou")

This package builds fine, but in the end, here is what I get installed:

Installing /gnu/store/1dh8ni590ai2nbbqrxxvgcfnlgwslsi3-lambdapi-1.0/lib/ocaml/site-lib/lambdapi/META
Installing /gnu/store/1dh8ni590ai2nbbqrxxvgcfnlgwslsi3-lambdapi-1.0/lib/ocaml/site-lib/lambdapi/opam
Installing /gnu/store/1dh8ni590ai2nbbqrxxvgcfnlgwslsi3-lambdapi-1.0/doc/lambdapi/README.md

and that's all. Could you fix this package so it actually installs
something usefull?

I've pushed all three dependencies already as
70c7d02590a93d3950747a9538e3882cb34bcd49 -
8213db7c951ea84597f8ac859d3ae588481ec5a2
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEtfrmKFtBNyiyoPrtQxEfRSAIagwFAlxkkdIACgkQQxEfRSAI
agyAkw/7ByKBujcsCSe1p0a1MMzc6ygffnAVaOZZmHThdD2i3xd0DOS52V+7q/uE
Yp49eYIJ4jRqDjmd140CczlizP9t8NfZBsq9F1WkusXMuGZKS+huosz0lr7+NGlF
A/7Z7sObCAKPWH4U3lo0uq6RvyuQqBXh7ybeWKiJyj+bIAXc1p+mLxDtYXL8r5Fc
XYakGiWDWR9mMHUVo4qKe+F7ykm50oLeOzaxoGe5W9PaXPbcTZnF7VDQ4V2SWkid
PtTU+OhzXw9SNvTULv8X94RAvoAR9pRrMCxoX3POeseki3Tmc9v3hHNhzxLMC7LF
WGxbChn9mvB+8SwltWkwtCE3IAhAGfN/XatM244fkhBqGjuUY3ktRmAwwZVJLgRk
itW8NwsFSJcRpyc4HcFsO+Lmv2wZEmTPUv+KEqK8Ea3gjxGAgtQ+aSM6E64Nnwyx
3V/U7+t5hwhrIxEllu6tbBt6ycK8VsEh8k7wdfxYrJnRLpjlCkbRsgS+k9y7Iepe
2Ree9uPiZIL/frEvQmqIZJW8SFRw7CGsTu4KMRcyn4ALi0FJ564aVusG5Hx1B3Lb
KaXTaFkrjJ67tWsKpSMX50JMxGtnrfiQRoKb3Kvj+P71r0HQw8SVoxw2r9+bmrlp
mGCgGjKhh8Osu5mLTwinTlvxqO737UMEPM1cAr3pYmguRqKJqIE=
=EP/A
-----END PGP SIGNATURE-----


Gabriel Hondet wrote 6 years ago
closing lambdapi
(address . 34361-done@debbugs.gnu.org)
87r29exca0.fsf@gmail.com
Sorry for the delay regarding this package, I missed an email. Anyway,
this software is still in development so I prefer not to add it.

Gabriel
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlzN5JcACgkQMbyBBfZZ
1CUqtBAAh78NUX/biukvMmflZDACqyShkQ4jr+qTzBMPk4TIH3B+L2e4LFjYGchg
DO9ESTNgbLp8mDmILPH/0/hbWUfO1q1MDyHiUT5zDijGjybbASI/tDQXtJQyIvpY
9D+Ra3/O7fwen+bdOYQcfhQny/Dy3oV3wYjibYpokhttyzEhQxIQ6nVUB1uFm+Vw
cQSVPki5eUn9oo8vh05mS/XqI2/fqoBwkwwD36KWHDGvP1dxJkhn8941KpPWjeCY
Jndx6thOn5ybVWcdTPvVX5ZLxxo7ajuV1GRzeH7u1uTnuboQlkpyzjekDusNPekB
x8oF4cDC3qfrjA/+XXYN1T9hMcEKUjF4OQZIiomCkiPbl1HR90Rw0729r9rfqVFK
mAp43KJrLua4QGpP32ihkehi0GEgVQ1tOBshOyYcWusn4Bfn8hVL7u2RCrfOHMF0
4Q+rfauzOjS/oSr8d0ktgzJzzAR1Qlv0Lq1Gmm3eaORvKh8WyguRYtHMgWQA0jAM
js1hTwzkgu57fYvrnwJRG7eUXta1NdvvyZ3BwjhvuRk1PJ1snPS2i5ueH05yJcnh
G2yLdGPZPNGGsak/Ig2MnrHWulSFV/2xTLPA6naIIPtoDrMU2V6Nt9goF73ZOWfw
5Uus6vutVBLwAZhSBY/iXfHeY4NCR3/TkpejcTscU/Aa0IWuV4E=
=uuJJ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34361@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34361
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help