Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
* gnu/packages/ocaml.scm (ocaml-earley): New variable.
---
gnu/packages/ocaml.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2d33db1c0..59630028e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4727,6 +4727,36 @@ syntax checking on dedukti files.")
"Part of the Jane Street's PPX rewriters collection.")
(license license:expat)))
+(define-public ocaml-earley
+ (package
+ (name "ocaml-earley")
+ (version "2.0.0")
+ (home-page "https://github.com/rlepigre/ocaml-earley")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18k7bi7krc4bvqnhijz1q0pfr0nfahghfjifci8rh1q4i5zd0xz5"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "make" "tests")
+ #t)))))
+ (synopsis "Parsing library based on Earley Algorithm")
+ (description "Earley is a parser combinator library base on Earley's
+algorithm. It is intended to be used in conjunction with an OCaml syntax
+extension which allows the definition of parsers inside the language. There
+is also support for writing OCaml syntax extensions in a camlp4 style.")
+ (license license:cecill-b)))
+
(define-public ocaml-biniou
(package
(name "ocaml-biniou")
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxb01QACgkQMbyBBfZZ
1CWdCQ//dXd+Kt4pwK+eVS0z3Nf3AFNyVthcoDD4KfUnC5HEtItT9RbwEqDK80AI
FMt+0uN+ByhFp4mileTnBPANQqQFpou1XJGE+M75VmvjFRw8iZUTQiuwoa0wJM+6
lmXfem+OPEzhV5B9LRKhXDPEMI00fs1gKyiep7SFhyx8yug/vzil65QFG1HEHkAG
ihqyLlTpYaHx5pR37CIE2NS/um1bJJpHr0ZCGA830BcbZKCPqr/nqUJNJP3ENWor
cE6uKgWLG/aR1lx/HWn+wfxQY8LytnActLBeC56JDbWJNAQrhT+Xn0wmX3qlYTiX
94zqx7vyUF64knTMtLP2K9gBidSZCn4U0HxZiVaEoX7Xwo+m9WGm7c71S3AzbmB7
QCLXSqg3eSw7Wc4DOKJdPteRXs7BdIUo2XHnCyI9EuxTewiTItKg5vuxE3It4iYW
hlnuti0BNkMpCDp6ktH4xX49T9qCBSlCAKpqKUIFI1iOH+zf5H9+P7aczZEN5XR8
2l4WSUVJpEikFgTf5pgV2xpPCD3Hzo5nXsH/6XaCFB4+SQeCB0hhszZ5PIHgTrEv
aIT8PLK2ygLS5Xkvv/tbUhLCYx3Z4UriN4Xeo0NhEDlk8FPErILPaJi2AGLn8sdF
ZunbAPj7Bd+iX0HCIdqxbusDHV0tr+4IqeEuRtBKwFthzKO0coY=
=o1No
-----END PGP SIGNATURE-----