Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bootloaders.scm (u-boot-novena): Disable loading u-boot.img
from FAT partition.
---
gnu/packages/bootloaders.scm | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)
Toggle diff (28 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 5bd784f73c..40b14fcce8 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -624,7 +624,20 @@ board-independent tools.")))
(make-u-boot-package "mx6cuboxi" "arm-linux-gnueabihf"))
(define-public u-boot-novena
- (make-u-boot-package "novena" "arm-linux-gnueabihf"))
+ (let ((base (make-u-boot-package "novena" "arm-linux-gnueabihf")))
+ (package
+ (inherit base)
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'patch-novena-defconfig
+ ;; Patch configuration to disable loading u-boot.img from FAT partition,
+ ;; allowing it to be installed at a device offset.
+ (lambda _
+ (substitute* "configs/novena_defconfig"
+ (("CONFIG_SPL_FAT_SUPPORT=y") "# CONFIG_SPL_FAT_SUPPORT is not set"))
+ #t)))))))))
(define-public u-boot-cubieboard
(make-u-boot-package "Cubieboard" "arm-linux-gnueabihf"))
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXFthSgAKCRDcUY/If5cW
qpBUAQCYIJolQ41EfBHjeC0a7P6o3ytJFhWc0N6oBgf9yRls8gEAuM3ljXGTEB5J
e1tocD17yf3VZi+WO2Dzs9wn0oY12wI=
=iWZ+
-----END PGP SIGNATURE-----