Update python-biopython to 1.79, seqmagick to 0.8.4

  • Done
  • quality assurance status badge
Details
5 participants
  • Arun Isaac
  • Brett Gilio
  • Maxim Cournoyer
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal
B
B
Brett Gilio wrote on 6 Feb 2019 23:11
[PATCH] gnu: python-biopython: Update to 1.73.
(address . guix-patches@gnu.org)
871s4kzhwb.fsf@posteo.net
From c3243855b975db46cb8c31f7120c2a1ab4662aaa Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Wed, 6 Feb 2019 16:10:05 -0600
Subject: [PATCH] gnu: python-biopython: Update to 1.73.

* gnu/packages/bioinformatics.scm (python-biopython): Update to 1.73.
---
gnu/packages/bioinformatics.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 516a7c1ee..99c205279 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -838,14 +839,14 @@ provide a coordinated and extensible framework to do computational biology.")
(define-public python-biopython
(package
(name "python-biopython")
- (version "1.70")
+ (version "1.73")
(source (origin
(method url-fetch)
;; use PyPi rather than biopython.org to ease updating
(uri (pypi-uri "biopython" version))
(sha256
(base32
- "0nz4n9d2y2dg849gn1z0vjlkwcpzzkzy3fij7x94a6ixy2c54z2a"))))
+ "1q55jhf76z3k6is3psis0ckbki7df26x7dikpcc3vhk1vhkwribh"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -5879,6 +5880,8 @@ bioinformatics file formats, sequence alignment, and more.")
(base32
"12bfyp8nqi0hd36rmj450aygafp01qy3hkbvlwn3bk39pyjjkgg5"))))
(build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; Updating biopython to 1.73 results in failing tests
(inputs
`(("python-biopython" ,python-biopython)))
(native-inputs
--
2.20.1
B
B
Brett Gilio wrote on 6 Feb 2019 23:19
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34354@debbugs.gnu.org)
87zhr8y2z3.fsf@posteo.net
Brett Gilio writes:

Toggle quote (49 lines)
> From c3243855b975db46cb8c31f7120c2a1ab4662aaa Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Wed, 6 Feb 2019 16:10:05 -0600
> Subject: [PATCH] gnu: python-biopython: Update to 1.73.
>
> * gnu/packages/bioinformatics.scm (python-biopython): Update to 1.73.
> ---
> gnu/packages/bioinformatics.scm | 7 +++++--
> 1 file changed, 5 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
> index 516a7c1ee..99c205279 100644
> --- a/gnu/packages/bioinformatics.scm
> +++ b/gnu/packages/bioinformatics.scm
> @@ -12,6 +12,7 @@
> ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
> ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
> ;;; Copyright © 2018 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
> +;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -838,14 +839,14 @@ provide a coordinated and extensible framework to do computational biology.")
> (define-public python-biopython
> (package
> (name "python-biopython")
> - (version "1.70")
> + (version "1.73")
> (source (origin
> (method url-fetch)
> ;; use PyPi rather than biopython.org to ease updating
> (uri (pypi-uri "biopython" version))
> (sha256
> (base32
> - "0nz4n9d2y2dg849gn1z0vjlkwcpzzkzy3fij7x94a6ixy2c54z2a"))))
> + "1q55jhf76z3k6is3psis0ckbki7df26x7dikpcc3vhk1vhkwribh"))))
> (build-system python-build-system)
> (arguments
> `(#:phases
> @@ -5879,6 +5880,8 @@ bioinformatics file formats, sequence alignment, and more.")
> (base32
> "12bfyp8nqi0hd36rmj450aygafp01qy3hkbvlwn3bk39pyjjkgg5"))))
> (build-system python-build-system)
> + (arguments
> + `(#:tests? #f)) ; Updating biopython to 1.73 results in failing tests
> (inputs
> `(("python-biopython" ,python-biopython)))
> (native-inputs

I disabled the tests on package `seqmagick' because after updating
biopython to 1.73 it was failing a test on integer iteration. I could
not reproduce this failure on the 1.70 version of biopython, so it seems
to be a temporary fix to that failure. I'm not sure if this was the
"correct" way to fix that issue, but it works.

If not, please let me know so I can send a differently modified patch.
R
R
Ricardo Wurmus wrote on 7 Feb 2019 08:46
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34354@debbugs.gnu.org)
878sysf3c3.fsf@elephly.net
Hi Brett,

Toggle quote (57 lines)
> Brett Gilio writes:
>
>> From c3243855b975db46cb8c31f7120c2a1ab4662aaa Mon Sep 17 00:00:00 2001
>> From: Brett Gilio <brettg@posteo.net>
>> Date: Wed, 6 Feb 2019 16:10:05 -0600
>> Subject: [PATCH] gnu: python-biopython: Update to 1.73.
>>
>> * gnu/packages/bioinformatics.scm (python-biopython): Update to 1.73.
>> ---
>> gnu/packages/bioinformatics.scm | 7 +++++--
>> 1 file changed, 5 insertions(+), 2 deletions(-)
>>
>> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
>> index 516a7c1ee..99c205279 100644
>> --- a/gnu/packages/bioinformatics.scm
>> +++ b/gnu/packages/bioinformatics.scm
>> @@ -12,6 +12,7 @@
>> ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
>> ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
>> ;;; Copyright © 2018 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
>> +;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
>> ;;;
>> ;;; This file is part of GNU Guix.
>> ;;;
>> @@ -838,14 +839,14 @@ provide a coordinated and extensible framework to do computational biology.")
>> (define-public python-biopython
>> (package
>> (name "python-biopython")
>> - (version "1.70")
>> + (version "1.73")
>> (source (origin
>> (method url-fetch)
>> ;; use PyPi rather than biopython.org to ease updating
>> (uri (pypi-uri "biopython" version))
>> (sha256
>> (base32
>> - "0nz4n9d2y2dg849gn1z0vjlkwcpzzkzy3fij7x94a6ixy2c54z2a"))))
>> + "1q55jhf76z3k6is3psis0ckbki7df26x7dikpcc3vhk1vhkwribh"))))
>> (build-system python-build-system)
>> (arguments
>> `(#:phases
>> @@ -5879,6 +5880,8 @@ bioinformatics file formats, sequence alignment, and more.")
>> (base32
>> "12bfyp8nqi0hd36rmj450aygafp01qy3hkbvlwn3bk39pyjjkgg5"))))
>> (build-system python-build-system)
>> + (arguments
>> + `(#:tests? #f)) ; Updating biopython to 1.73 results in failing tests
>> (inputs
>> `(("python-biopython" ,python-biopython)))
>> (native-inputs
>
> I disabled the tests on package `seqmagick' because after updating
> biopython to 1.73 it was failing a test on integer iteration. I could
> not reproduce this failure on the 1.70 version of biopython, so it seems
> to be a temporary fix to that failure. I'm not sure if this was the
> "correct" way to fix that issue, but it works.

If the tests are failing it is possibel that seqmagick doesn’t work
properly any more. This would be serious.

Could you report the test failures to the upstream developers please and
add the URL in a comment?

Also please separate these two changes. They should not go to the same
commit.

--
Ricardo
B
B
Brett Gilio wrote on 7 Feb 2019 21:05
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87mun7qs7t.fsf@posteo.net
Ricardo Wurmus writes:

Toggle quote (68 lines)
> Hi Brett,
>
>> Brett Gilio writes:
>>
>>> From c3243855b975db46cb8c31f7120c2a1ab4662aaa Mon Sep 17 00:00:00 2001
>>> From: Brett Gilio <brettg@posteo.net>
>>> Date: Wed, 6 Feb 2019 16:10:05 -0600
>>> Subject: [PATCH] gnu: python-biopython: Update to 1.73.
>>>
>>> * gnu/packages/bioinformatics.scm (python-biopython): Update to 1.73.
>>> ---
>>> gnu/packages/bioinformatics.scm | 7 +++++--
>>> 1 file changed, 5 insertions(+), 2 deletions(-)
>>>
>>> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
>>> index 516a7c1ee..99c205279 100644
>>> --- a/gnu/packages/bioinformatics.scm
>>> +++ b/gnu/packages/bioinformatics.scm
>>> @@ -12,6 +12,7 @@
>>> ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
>>> ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
>>> ;;; Copyright © 2018 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
>>> +;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
>>> ;;;
>>> ;;; This file is part of GNU Guix.
>>> ;;;
>>> @@ -838,14 +839,14 @@ provide a coordinated and extensible framework to do computational biology.")
>>> (define-public python-biopython
>>> (package
>>> (name "python-biopython")
>>> - (version "1.70")
>>> + (version "1.73")
>>> (source (origin
>>> (method url-fetch)
>>> ;; use PyPi rather than biopython.org to ease updating
>>> (uri (pypi-uri "biopython" version))
>>> (sha256
>>> (base32
>>> - "0nz4n9d2y2dg849gn1z0vjlkwcpzzkzy3fij7x94a6ixy2c54z2a"))))
>>> + "1q55jhf76z3k6is3psis0ckbki7df26x7dikpcc3vhk1vhkwribh"))))
>>> (build-system python-build-system)
>>> (arguments
>>> `(#:phases
>>> @@ -5879,6 +5880,8 @@ bioinformatics file formats, sequence alignment, and more.")
>>> (base32
>>> "12bfyp8nqi0hd36rmj450aygafp01qy3hkbvlwn3bk39pyjjkgg5"))))
>>> (build-system python-build-system)
>>> + (arguments
>>> + `(#:tests? #f)) ; Updating biopython to 1.73 results in failing tests
>>> (inputs
>>> `(("python-biopython" ,python-biopython)))
>>> (native-inputs
>>
>> I disabled the tests on package `seqmagick' because after updating
>> biopython to 1.73 it was failing a test on integer iteration. I could
>> not reproduce this failure on the 1.70 version of biopython, so it seems
>> to be a temporary fix to that failure. I'm not sure if this was the
>> "correct" way to fix that issue, but it works.
>
> If the tests are failing it is possibel that seqmagick doesn’t work
> properly any more. This would be serious.
>
> Could you report the test failures to the upstream developers please and
> add the URL in a comment?
>
> Also please separate these two changes. They should not go to the same
> commit.

Ricardo,

Understood. I will do exactly that and reply again later with a revised
patch series.

Brett Gilio
M
M
Maxim Cournoyer wrote on 13 Jul 2021 15:32
Re: bug#34354: [PATCH] gnu: python-biopython: Update to 1.73.
(name . Brett Gilio)(address . brettg@posteo.net)
875yxes5k1.fsf_-_@gmail.com
Hello,

Brett Gilio <brettg@posteo.net> writes:

Toggle quote (77 lines)
> Ricardo Wurmus writes:
>
>> Hi Brett,
>>
>>> Brett Gilio writes:
>>>
>>>> From c3243855b975db46cb8c31f7120c2a1ab4662aaa Mon Sep 17 00:00:00 2001
>>>> From: Brett Gilio <brettg@posteo.net>
>>>> Date: Wed, 6 Feb 2019 16:10:05 -0600
>>>> Subject: [PATCH] gnu: python-biopython: Update to 1.73.
>>>>
>>>> * gnu/packages/bioinformatics.scm (python-biopython): Update to 1.73.
>>>> ---
>>>> gnu/packages/bioinformatics.scm | 7 +++++--
>>>> 1 file changed, 5 insertions(+), 2 deletions(-)
>>>>
>>>> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
>>>> index 516a7c1ee..99c205279 100644
>>>> --- a/gnu/packages/bioinformatics.scm
>>>> +++ b/gnu/packages/bioinformatics.scm
>>>> @@ -12,6 +12,7 @@
>>>> ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
>>>> ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
>>>> ;;; Copyright © 2018 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
>>>> +;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
>>>> ;;;
>>>> ;;; This file is part of GNU Guix.
>>>> ;;;
>>>> @@ -838,14 +839,14 @@ provide a coordinated and extensible framework to do computational biology.")
>>>> (define-public python-biopython
>>>> (package
>>>> (name "python-biopython")
>>>> - (version "1.70")
>>>> + (version "1.73")
>>>> (source (origin
>>>> (method url-fetch)
>>>> ;; use PyPi rather than biopython.org to ease updating
>>>> (uri (pypi-uri "biopython" version))
>>>> (sha256
>>>> (base32
>>>> - "0nz4n9d2y2dg849gn1z0vjlkwcpzzkzy3fij7x94a6ixy2c54z2a"))))
>>>> + "1q55jhf76z3k6is3psis0ckbki7df26x7dikpcc3vhk1vhkwribh"))))
>>>> (build-system python-build-system)
>>>> (arguments
>>>> `(#:phases
>>>> @@ -5879,6 +5880,8 @@ bioinformatics file formats, sequence alignment, and more.")
>>>> (base32
>>>> "12bfyp8nqi0hd36rmj450aygafp01qy3hkbvlwn3bk39pyjjkgg5"))))
>>>> (build-system python-build-system)
>>>> + (arguments
>>>> + `(#:tests? #f)) ; Updating biopython to 1.73 results in failing tests
>>>> (inputs
>>>> `(("python-biopython" ,python-biopython)))
>>>> (native-inputs
>>>
>>> I disabled the tests on package `seqmagick' because after updating
>>> biopython to 1.73 it was failing a test on integer iteration. I could
>>> not reproduce this failure on the 1.70 version of biopython, so it seems
>>> to be a temporary fix to that failure. I'm not sure if this was the
>>> "correct" way to fix that issue, but it works.
>>
>> If the tests are failing it is possibel that seqmagick doesn’t work
>> properly any more. This would be serious.
>>
>> Could you report the test failures to the upstream developers please and
>> add the URL in a comment?
>>
>> Also please separate these two changes. They should not go to the same
>> commit.
>
> Ricardo,
>
> Understood. I will do exactly that and reply again later with a revised
> patch series.
>
> Brett Gilio

Any news on this?

Thanks,

Maxim
A
A
Arun Isaac wrote on 9 Oct 2021 17:38
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
871r4ujjj4.fsf@systemreboot.net
Hi,

Efraim updated python-biopython to 1.73 in
309b38bed61c21ce8ba559a679592ecc1c94dbfc. So, I'm closing this issue.

Thanks!
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmFht18bHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzkssH/AhcEzO3PGuC45RNDFCv
ueoxfxMXAB4rurLUZDnijAAUbGz1hYzuu/QLseLqVqP94gAE3PuNpVUl2GK51d/m
zV5H63gEqVQEqaqKoAcGiUsFuXdHBUQpmbFb/wSsxB+ltsEY9mL8Jqf7y9L1Cefs
EeHGzbyONVBHpcMtgFFGhcAfp8tFwauoACzXQk1DkbJffMWtri3s68sOuWk+3WsX
3a5ib5sS0QGfgPYXc8WAD5tEEkC3P+7XMwgt869yPBChSkfm+vLTJtjSddmZ4Ect
yNF0OdUmmQhnQpC0hHpQUkG06+N/ezd2+u2sob6AFFz/PN8bmCj8FFhIuKsoycEE
lc4=
=Wzv5
-----END PGP SIGNATURE-----

Closed
A
A
Arun Isaac wrote on 9 Oct 2021 18:12
(no subject)
(address . control@debbugs.gnu.org)
87wnmmi3cz.fsf@systemreboot.net
reopen 34354
retitle 34354 Update python-biopython to 1.79, seqmagick to 0.8.4
thanks

Oops, it seems I closed this bug without realizing that seqmagick is
still broken! I have fixed this problem (on my local machine) by
updating both python-biopython and seqmagick. I will send patches soon.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmFhv30bHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuznPAH/07c6O61imuWfu73OIxB
CswyZ74JMRLo+plqxGBmHmExOFvUuiXPiCJUxZ38YY8lYjBjHCN4hvKHFdeGEiH9
NWAdQ188qCFZWuEs6K2FR6pU8ZaZq+aFWd1atoGO3Bb259sSyTBCROUSHNG62kp2
bC43E9mm3p3cG1wfb7GhmdiYxe/bj9605JqgEPniC7yBB+YgR5tOydJJ+SVGcEt8
PugB5KgQRWKhUY5dBPR16tASN9aY9gKXFIfTebJWCCP2loNjCIpdYuouZ4OsCw/U
OCn2M8fOJ8RdhAgwkI6OCnoQ4ZW5S6MlfdHy8VTELsu6KKT5vWFvvfo1gJKSFPQo
Zl4=
=IbNT
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 16 Oct 2021 13:44
Re: bug#34354: Update python-biopython to 1.79, seqmagick to 0.8.4
(address . 34354@debbugs.gnu.org)
8735p1ry7c.fsf@systemreboot.net
Toggle quote (3 lines)
> I have fixed this problem (on my local machine) by updating both
> python-biopython and seqmagick. I will send patches soon.

It turns out that updating python-biopython breaks too many other
dependent packages. And, some of them take too long to reasonably build
on my machine of relatively humble specifications. So, I'm afraid I have
to bail out on this promise. Sorry!

Regards,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmFquxcbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuz0DEIAJ2XTCIEP3BxE7y4RfaY
XilF/RoyMxrOKYdNGw3hRqJQTa1mboGe9hkXpAJpa9vLWQMtJi/roSTst1t0ive/
zJF38ubadHC28FMNjv5aA51dSK3kQj9tkgEAGNhZ/Ou/Fz/+Jq4I22rE3G2JBtbv
H+6LxpYksKeQMOohpD6Eh+np8ETuq8waD9w/SvXYdoGwMDX790cjeby7nStDTLKg
X6vKzMjnNoQTMzXgoKY9kS/v5o6nI6JdusnC0KutsVNzB3ToZRtBo61offzIeryS
pJrK9ND3LpAgNgQDqQEoQ9TcleDjvHGAqcI8yOkmjNhOvXCdt4DTw4AHImgJFozH
GYY=
=OKHw
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 12 Apr 2022 12:04
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
86v8ve39ez.fsf_-_@gmail.com
Hi Arun,

On Sat, 16 Oct 2021 at 17:14, Arun Isaac <arunisaac@systemreboot.net> wrote:

Toggle quote (8 lines)
>> I have fixed this problem (on my local machine) by updating both
>> python-biopython and seqmagick. I will send patches soon.
>
> It turns out that updating python-biopython breaks too many other
> dependent packages. And, some of them take too long to reasonably build
> on my machine of relatively humble specifications. So, I'm afraid I have
> to bail out on this promise. Sorry!

Do we close this patch submission? Since it was initially an update for
1.73 which is older than the current version.

And the update of 1.79 requires more work. Therefore, is it worth to
keep this submission open? I guess the update to 1.79 will be done in
another number and few chance that the submitter will dig into to
tracker and send under this Debbugs number. :-)

Closing?


Cheers,
simon
R
R
Ricardo Wurmus wrote on 12 Apr 2022 14:28
(name . zimoun)(address . zimon.toutoune@gmail.com)
87r162xz7o.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (7 lines)
> And the update of 1.79 requires more work. Therefore, is it worth to
> keep this submission open? I guess the update to 1.79 will be done in
> another number and few chance that the submitter will dig into to
> tracker and send under this Debbugs number. :-)
>
> Closing?

Yes.

--
Ricardo
Closed
A
A
Arun Isaac wrote on 12 Apr 2022 21:48
(name . zimoun)(address . zimon.toutoune@gmail.com)
87bkx63wwo.fsf@systemreboot.net
Hi zimoun,

Toggle quote (7 lines)
> And the update of 1.79 requires more work. Therefore, is it worth to
> keep this submission open? I guess the update to 1.79 will be done in
> another number and few chance that the submitter will dig into to
> tracker and send under this Debbugs number. :-)
>
> Closing?

Definitely, I agree this issue should be closed.

Thanks!
Arun
?