Brett Gilio wrote 6 years ago
[PATCH] gnu: python-biopython: Update to 1.73.
(address . guix-patches@gnu.org)
From c3243855b975db46cb8c31f7120c2a1ab4662aaa Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Wed, 6 Feb 2019 16:10:05 -0600
Subject: [PATCH] gnu: python-biopython: Update to 1.73.
* gnu/packages/bioinformatics.scm (python-biopython): Update to 1.73.
---
gnu/packages/bioinformatics.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
Toggle diff (40 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 516a7c1ee..99c205279 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -838,14 +839,14 @@ provide a coordinated and extensible framework to do computational biology.")
(define-public python-biopython
(package
(name "python-biopython")
- (version "1.70")
+ (version "1.73")
(source (origin
(method url-fetch)
;; use PyPi rather than biopython.org to ease updating
(uri (pypi-uri "biopython" version))
(sha256
(base32
- "0nz4n9d2y2dg849gn1z0vjlkwcpzzkzy3fij7x94a6ixy2c54z2a"))))
+ "1q55jhf76z3k6is3psis0ckbki7df26x7dikpcc3vhk1vhkwribh"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -5879,6 +5880,8 @@ bioinformatics file formats, sequence alignment, and more.")
(base32
"12bfyp8nqi0hd36rmj450aygafp01qy3hkbvlwn3bk39pyjjkgg5"))))
(build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; Updating biopython to 1.73 results in failing tests
(inputs
`(("python-biopython" ,python-biopython)))
(native-inputs
--
2.20.1