(address . guix-patches@gnu.org)
The mariadb package failed to build starting from 2019-01-01. The reason for
this failure is the hard-coded "2018-12-31 21:01:23" event execution time in
the mysqldump.test. If we try to run this test after a hard-coded time then
test fails with next additional message in test log:
Toggle quote (3 lines)
> +Warnings:
> +Note 1588 Event execution time is in the past and ON COMPLETION NOT PRESERVE is set. The event was dropped immediately after creation.
* gnu/packages/databases.scm (mariadb): Change an event execution time in
mysqldump test to the future time.
---
gnu/packages/databases.scm | 6 ++++++
1 file changed, 6 insertions(+)
Toggle diff (19 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 50766fc010..cab8b89949 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -608,6 +608,12 @@ Language.")
(substitute* "mysql-test/mysql-test-run.pl"
(("/bin/ls") (which "ls"))
(("/bin/sh") (which "sh")))
+
+ ;; This test fail if a time for the "create event" command in the past
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* '("mysql-test/t/mysqldump.test"
+ "mysql-test/r/mysqldump.result")
+ (("2018-12-31") "2025-12-31")))
#t)))
(add-before 'configure 'disable-plugins
(lambda _
--
2.20.0