[PATCH] gnu: mariadb: Fix build

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Nikolai Merinov
Owner
unassigned
Submitted by
Nikolai Merinov
Severity
normal
N
N
Nikolai Merinov wrote on 6 Feb 2019 20:21
(address . guix-patches@gnu.org)
87zhr8r5am.fsf@member.fsf.org
The mariadb package failed to build starting from 2019-01-01. The reason for
this failure is the hard-coded "2018-12-31 21:01:23" event execution time in
the mysqldump.test. If we try to run this test after a hard-coded time then
test fails with next additional message in test log:
Toggle quote (3 lines)
> +Warnings:
> +Note 1588 Event execution time is in the past and ON COMPLETION NOT PRESERVE is set. The event was dropped immediately after creation.

* gnu/packages/databases.scm (mariadb): Change an event execution time in
mysqldump test to the future time.
---
gnu/packages/databases.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 50766fc010..cab8b89949 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -608,6 +608,12 @@ Language.")
(substitute* "mysql-test/mysql-test-run.pl"
(("/bin/ls") (which "ls"))
(("/bin/sh") (which "sh")))
+
+ ;; This test fail if a time for the "create event" command in the past
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* '("mysql-test/t/mysqldump.test"
+ "mysql-test/r/mysqldump.result")
+ (("2018-12-31") "2025-12-31")))
#t)))
(add-before 'configure 'disable-plugins
(lambda _
--
2.20.0
M
M
Marius Bakke wrote on 6 Feb 2019 23:32
87sgx0o8dl.fsf@fastmail.com
Hello!

Nikolai Merinov <nikolai.merinov@member.fsf.org> writes:

Toggle quote (7 lines)
> The mariadb package failed to build starting from 2019-01-01. The reason for
> this failure is the hard-coded "2018-12-31 21:01:23" event execution time in
> the mysqldump.test. If we try to run this test after a hard-coded time then
> test fails with next additional message in test log:
>> +Warnings:
>> +Note 1588 Event execution time is in the past and ON COMPLETION NOT PRESERVE is set. The event was dropped immediately after creation.

Thanks for finding the root cause of this.

[...]

Toggle quote (6 lines)
> + ;; This test fail if a time for the "create event" command in the past
> + (with-fluids ((%default-port-encoding #f))
> + (substitute* '("mysql-test/t/mysqldump.test"
> + "mysql-test/r/mysqldump.result")
> + (("2018-12-31") "2025-12-31")))

This will only delay the problem :-)

Ideally, we should locate and remove any such "time bombs" or expiry
dates in packages. Maybe by doing some time fuzzing?

In any case this particular problem is fixed on the 'staging' and
'core-updates' branches, the first of which should be merged very soon.

I'm closing this issue, but added your findings as a comment in
69fb26d4f51e9d22111cb1360e2941192afee5b9, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlxbYJYACgkQoqBt8qM6
VPobMQf+IPxngepLqKbw/hEdBcMjDwwCNXyyDylX+sL+wou0z8w6+jfeT81Zsn8q
UTfURWNPFDrBsRgeL3wqiErYO9IAu41GAaH/as6YD9NbvczgB3r2qDFxUiUjQXiZ
fhPJmFSnWcDFQwJeDHoRSfB84ef9rwRkDcBqqJPHAP8hZv1sF2UNM7pTO360ADSO
Ug4kBRqD5Ba1wnKONL9IZp8ta2ZrKAbr08TPczErmxOdzKGjYB2xAJDeiJnbad7r
vZ0du370WDLWV518LcukXRCqXOZDXjlLzGPnXLSuwOQ7B9WLRK1ouGTQzNFEglxI
KzvAldj5wLz0JSCy+m+dFSk9DyJw/g==
=fBE0
-----END PGP SIGNATURE-----

Closed
?