[PATCH] gnu: artanis: Make some improvements.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20190204235047.28301-1-mail@cbaines.net
* gnu/packages/guile-xyz.scm (artanis): Remove a tab character by the
revision.
[arguments]: Patch the site-dir for the help command, to make it work. Wrap
the art command such that it finds guile-json and guile-redis.
---
gnu/packages/guile-xyz.scm | 17 +++++++++++++----
1 file changed, 13 insertions(+), 4 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9640d17c3c..6c1e9c50ec 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -85,7 +85,7 @@
(define-public artanis
(let ((release "0.3.1")
- (revision 0))
+ (revision 0))
(package
(name "artanis")
(version (if (zero? revision)
@@ -152,6 +152,13 @@
#:test-target "test"
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-site-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "artanis/commands/help.scm"
+ (("\\(%site-dir\\)")
+ (string-append "\""
+ (assoc-ref outputs "out")
+ "/share/guile/site/2.2\"")))))
(add-before 'install 'substitute-root-dir
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -162,14 +169,16 @@
(mkdir-p (string-append out "/bin")) ;for the `art' executable
#t)))
(add-after 'install 'wrap-art
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(scm (string-append out "/share/guile/site/2.2"))
(go (string-append out "/lib/guile/2.2/site-ccache")))
(wrap-program (string-append bin "/art")
- `("GUILE_LOAD_PATH" ":" prefix (,scm))
- `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,go)))
+ `("GUILE_LOAD_PATH" ":" prefix
+ (,scm ,(getenv "GUILE_LOAD_PATH")))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix
+ (,go ,(getenv "GUILE_LOAD_COMPILED_PATH"))))
#t))))))
(synopsis "Web application framework written in Guile")
(description "GNU Artanis is a web application framework written in Guile
--
2.20.1
Ricardo Wurmus wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 34324@debbugs.gnu.org)
871s4miogv.fsf@elephly.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (5 lines)
> * gnu/packages/guile-xyz.scm (artanis): Remove a tab character by the
> revision.
> [arguments]: Patch the site-dir for the help command, to make it work. Wrap
> the art command such that it finds guile-json and guile-redis.

LGTM, thanks!

--
Ricardo
Christopher Baines wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 34324-done@debbugs.gnu.org)
87y36u60zo.fsf@cbaines.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (9 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/guile-xyz.scm (artanis): Remove a tab character by the
>> revision.
>> [arguments]: Patch the site-dir for the help command, to make it work. Wrap
>> the art command such that it finds guile-json and guile-redis.
>
> LGTM, thanks!

Great, I've pushed this as
fd9a6d83c280593bd61805a78a9f45ced3e6a527. Thanks for taking a look :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxZVntfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xda0g/+JHsUf8YoPUKIP0uYodC1hxavX9tsKaS+qUdnP3bmYvI+c6sTnXuJw1NG
ypWJoGUJ9UUPCxSEvNmfWT5o0qVAq583hNrEjM7qx6oao5KwjMUIOzmsgLqQBtmh
XLfsZopTUCPDRGo6l3/7Smiz9uSCANSpkWJlyJEccQLn/2G7KmT3v1QmhezfjRk+
0hVNmQnEIiVJYaKRS9F0dK9DyEsObk5UN4YPXz9VyhK4xo/5XARe1E1GUK1ZIVbi
N9rsJ0w7qiCDiQN/AeW5uWA9qpUUrVU5rk2axX/CkEfHThrX7gvKiZ8hjjh6m4eF
cECxOILz3JO3il23Y+JggZxUk4KGAFHb9syh9su5e+VFpA4oIx8mH/LjpcULYmw9
ChOaWRILhT7CdnbuF5pJEh+biGxsdY7v7xxd68+FwoH//T/YIBLe4081CrjtTUJb
vPBU5DotohtGxZ9TjGM/2WeJd+7ltwwuE+lXtluV11ZQL2Wmd6nBRXDztzBhk93w
EgFnnaRs4JcZRvJehAKPHx+FXYuf10ywx3Fz4251QSSvYcfAYPYFvJlMA2jBVDOF
1LYOt6Mwr03jbvWlYk8sb1l3cxJ4SzkrfbjdajWoH///ZY70o3ifBgiltwaP1XNb
o96hNc5ZQ1TiWXXZbRMAuE+preoQcRb8QDah2PPgONy1OkFS/sQ=
=QMFC
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34324@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34324
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help