Danny Milosavljevic wrote 6 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* doc/contributing.texi (Submitting Patches): Document how to enable qemu
binfmt service and how to use it.
---
doc/contributing.texi | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (34 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index ecc20dabc..c086e3c9a 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -813,6 +813,29 @@ name of the new or modified package, and fix any errors it reports
Make sure the package builds on your platform, using @code{guix build
@var{package}}.
+@item
+We recommend you also try to build the package on other platforms. We
+do not presume that you have all the platforms, therefore we recommend
+using the qemu binfmt service of GuixSD. In order to enable it, add
+the following service to your operating-system configuration's services:
+
+@example
+(service qemu-binfmt-service-type
+ (qemu-binfmt-configuration
+ (platforms (lookup-qemu-platforms "arm" "aarch64" "ppc" "mips64el"))
+ (guix-support? #t)))
+@end example
+
+Then reconfigure your system.
+
+You can then build packages like the following, respectively:
+@example
+guix build --system=armhf-linux --rounds=2 my-package
+guix build --system=aarch64-linux --rounds=2 my-package
+guix build --system=powerpc-linux --rounds=2 my-package
+guix build --system=mips64el-linux --rounds=2 my-package
+@end example
+
@item
@cindex bundling
Make sure the package does not use bundled copies of software already