[PATCH] doc: Document how to enable qemu binfmt service and how to use it.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 6 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20190203154601.32098-1-dannym@scratchpost.org
* doc/contributing.texi (Submitting Patches): Document how to enable qemu
binfmt service and how to use it.
---
doc/contributing.texi | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (34 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index ecc20dabc..c086e3c9a 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -813,6 +813,29 @@ name of the new or modified package, and fix any errors it reports
Make sure the package builds on your platform, using @code{guix build
@var{package}}.
+@item
+We recommend you also try to build the package on other platforms. We
+do not presume that you have all the platforms, therefore we recommend
+using the qemu binfmt service of GuixSD. In order to enable it, add
+the following service to your operating-system configuration's services:
+
+@example
+(service qemu-binfmt-service-type
+ (qemu-binfmt-configuration
+ (platforms (lookup-qemu-platforms "arm" "aarch64" "ppc" "mips64el"))
+ (guix-support? #t)))
+@end example
+
+Then reconfigure your system.
+
+You can then build packages like the following, respectively:
+@example
+guix build --system=armhf-linux --rounds=2 my-package
+guix build --system=aarch64-linux --rounds=2 my-package
+guix build --system=powerpc-linux --rounds=2 my-package
+guix build --system=mips64el-linux --rounds=2 my-package
+@end example
+
@item
@cindex bundling
Make sure the package does not use bundled copies of software already
Ricardo Wurmus wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 34304@debbugs.gnu.org)
87d0o8whir.fsf@elephly.net
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (3 lines)
> * doc/contributing.texi (Submitting Patches): Document how to enable qemu
> binfmt service and how to use it.

Sounds good to me!

Toggle quote (5 lines)
> +We recommend you also try to build the package on other platforms. We
> +do not presume that you have all the platforms, therefore we recommend
> +using the qemu binfmt service of GuixSD. In order to enable it, add
> +the following service to your operating-system configuration's services:

How about this:

Toggle snippet (8 lines)
We recommend you also try building the package on other supported
platforms. As you may not have access to actual hardware platforms, we
recommend using the @code{qemu-binfmt-service-type} to emulate them. In
order to enable it, add the following service to the list of services in
your @code{operating-system} configuration:


Toggle quote (8 lines)
> +You can then build packages like the following, respectively:
> +@example
> +guix build --system=armhf-linux --rounds=2 my-package
> +guix build --system=aarch64-linux --rounds=2 my-package
> +guix build --system=powerpc-linux --rounds=2 my-package
> +guix build --system=mips64el-linux --rounds=2 my-package
> +@end example

How about:

Toggle snippet (11 lines)
You can then build packages for different platforms by specifying the
@code{--system} option. For example, to build the “hello” package for
the armhf, aarch64, powerpc, or mips64 architectures, you would run the
following commands, respectively:
@example
guix build --system=armhf-linux --rounds=2 hello
guix build --system=aarch64-linux --rounds=2 hello
guix build --system=powerpc-linux --rounds=2 hello
guix build --system=mips64el-linux --rounds=2 hello
@end example
Danny Milosavljevic wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 34304-done@debbugs.gnu.org)
20190204175810.40fc03c8@scratchpost.org
Hi Ricardo,

On Mon, 04 Feb 2019 00:59:08 +0100
Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (2 lines)
>[improved version]

Thanks! Pushed with improved text to guix master as 89339a35bd8610ec585da36f3da6ddf116c3fe89.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlxYbyIACgkQ5xo1VCww
uqW/Owf7BVS0TsuDbS/6W6goOdDlX6Rgxfp7SKeCuYFwUsdr2asSTWnYAMAlyDWM
7BuDQvgqu7aSkQc5+jWZSUZqT+Pam4rIMNuJ1B2LLdPdklil1YuSDEOwzNfCGgEl
5DLy9GrOcP2qDFULW7WpKCerpLCXtv5NjCmDzmdz7kRsMkMHamkfsAzKnAWkRj31
wd0HE6KzNgOy/oSDYszGBugz1iRJGikDQKPoxriQBVbyRehDNLCYUxWjSWngX8+p
2kpocULCBqXk35+piSqGwn7eIK3n1cqzOwZcO6Z37ZivAMlVYjUQv/+FlddR1JAc
eB6Z8saZQlkaS4un9Vnqu9xqEPK2Kg==
=jfni
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34304@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34304
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help