Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
* gnu/packages/music.scm (python-discid): New variable.
---
gnu/packages/music.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (56 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4943b901e..5a07ad4ae 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4076,6 +4077,41 @@ it provides a submission URL for adding the disc ID to the database and gathers
ISRCs and the MCN (=UPC/EAN) from disc.")
(license license:lgpl2.1+)))
+(define-public python-discid
+ (package
+ (name "python-discid")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "discid" version))
+ (sha256
+ (base32
+ "1fgp67nhqlbvhhwrcxq5avil7alpzw4s4579hlyvxzbphdnbz8vq"))))
+ (build-system python-build-system)
+ (inputs
+ `(("libdiscid" ,libdiscid)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-libdiscid
+ ;; Set path of libdiscid
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((discid (assoc-ref inputs "libdiscid")))
+ (substitute* "discid/libdiscid.py"
+ (("lib_name = (.*)$" all name)
+ (string-append "lib_name = \"" discid
+ "/lib/libdiscid.so.0\"\n")))))))))
+ (home-page "https://python-discid.readthedocs.io/")
+ (synopsis "Python binding of Libdiscid")
+ (description "This package provides a python binding of Libdiscid by
+Musicbrainz. The main purpose is the calculation of an identifier for audio
+discs @url{http://musicbrainz.org/doc/Disc%20ID, Disc ID} to use for the
+@url{http://musicbrainz.org/, MusicBrainz database. Additionally the disc
+@acronym{MCN, Media Catalog Number} and track @acronym{ISRC, Internation
+Standard Recording Code} can be extracted.}")
+ (license license:lgpl3+)))
+
(define-public libmusicbrainz
(package
(name "libmusicbrainz")
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxRxfIACgkQMbyBBfZZ
1CUACQ/+Mg3P1ppfDCibfs5wdE4IFWBXu3WP+eN/460jwvhf5vmTswuAL3u6HRbi
a/sOyGWixgTSmmtsVbrDqU++vNbrFf2kOfqIFI9hveC37ZFhZki6d2i7Y9Fu8Nvf
EPB1l7piuA8TXLTSY+B0HxKJnUsN2+DXwk1yWBK0JymJDZY+xKlxe0rwflUpatsi
TveMBtXsFXYEA08nhFsrNzLJeX7fCt/VlLvdpkqhUWvM8brkyzS6K8ghgabhau4P
PM0ypcqmzGIFIEw+tiXAQ1jwuzHbAp9Skp0vzKWlJXP8LPTBJmYJ2OtDgz+muuwF
gLoFB4xGSBic08n8HopWHlgB4cfV285U/KF8nMjeknZtfpQrofJOVvJMuZ1OuQ7H
duvGyQIVEtIsBNJxEAAWogNL0HcGd7BWuHd7TnjaNRsMxyc1snddeGAGuxEhzyKb
fCMGEopNG2JpJDxg47bP7frxvVIQN2C0r93JXaBc2KmXoDhftekpQZCjxa2T2ymS
3/73GCiecpxLge56XjVWLb87MCel50PIuOoZjFUgFtqBnaKuFxtSJwfxQ6JvIssL
olsiSRRlicI+P9RzP8jbQRK0HhjbPVqcDnA7rHShxtt3mPgC0EqYL4HXY2HODpTJ
rXaqdDcY5OhmtEgat7OGcpu4siCCJLnnTT3gT7urIVbBiJAWjYA=
=r3XT
-----END PGP SIGNATURE-----