[PATCH 1/2] gnu: Add python-discid.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Hondet
  • Marius Bakke
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
87a7jixibx.fsf@gmail.com
* gnu/packages/music.scm (python-discid): New variable.
---
gnu/packages/music.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4943b901e..5a07ad4ae 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4076,6 +4077,41 @@ it provides a submission URL for adding the disc ID to the database and gathers
ISRCs and the MCN (=UPC/EAN) from disc.")
(license license:lgpl2.1+)))
+(define-public python-discid
+ (package
+ (name "python-discid")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "discid" version))
+ (sha256
+ (base32
+ "1fgp67nhqlbvhhwrcxq5avil7alpzw4s4579hlyvxzbphdnbz8vq"))))
+ (build-system python-build-system)
+ (inputs
+ `(("libdiscid" ,libdiscid)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-libdiscid
+ ;; Set path of libdiscid
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((discid (assoc-ref inputs "libdiscid")))
+ (substitute* "discid/libdiscid.py"
+ (("lib_name = (.*)$" all name)
+ (string-append "lib_name = \"" discid
+ "/lib/libdiscid.so.0\"\n")))))))))
+ (home-page "https://python-discid.readthedocs.io/")
+ (synopsis "Python binding of Libdiscid")
+ (description "This package provides a python binding of Libdiscid by
+Musicbrainz. The main purpose is the calculation of an identifier for audio
+discs @url{http://musicbrainz.org/doc/Disc%20ID, Disc ID} to use for the
+@url{http://musicbrainz.org/, MusicBrainz database. Additionally the disc
+@acronym{MCN, Media Catalog Number} and track @acronym{ISRC, Internation
+Standard Recording Code} can be extracted.}")
+ (license license:lgpl3+)))
+
(define-public libmusicbrainz
(package
(name "libmusicbrainz")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxRxfIACgkQMbyBBfZZ
1CUACQ/+Mg3P1ppfDCibfs5wdE4IFWBXu3WP+eN/460jwvhf5vmTswuAL3u6HRbi
a/sOyGWixgTSmmtsVbrDqU++vNbrFf2kOfqIFI9hveC37ZFhZki6d2i7Y9Fu8Nvf
EPB1l7piuA8TXLTSY+B0HxKJnUsN2+DXwk1yWBK0JymJDZY+xKlxe0rwflUpatsi
TveMBtXsFXYEA08nhFsrNzLJeX7fCt/VlLvdpkqhUWvM8brkyzS6K8ghgabhau4P
PM0ypcqmzGIFIEw+tiXAQ1jwuzHbAp9Skp0vzKWlJXP8LPTBJmYJ2OtDgz+muuwF
gLoFB4xGSBic08n8HopWHlgB4cfV285U/KF8nMjeknZtfpQrofJOVvJMuZ1OuQ7H
duvGyQIVEtIsBNJxEAAWogNL0HcGd7BWuHd7TnjaNRsMxyc1snddeGAGuxEhzyKb
fCMGEopNG2JpJDxg47bP7frxvVIQN2C0r93JXaBc2KmXoDhftekpQZCjxa2T2ymS
3/73GCiecpxLge56XjVWLb87MCel50PIuOoZjFUgFtqBnaKuFxtSJwfxQ6JvIssL
olsiSRRlicI+P9RzP8jbQRK0HhjbPVqcDnA7rHShxtt3mPgC0EqYL4HXY2HODpTJ
rXaqdDcY5OhmtEgat7OGcpu4siCCJLnnTT3gT7urIVbBiJAWjYA=
=r3XT
-----END PGP SIGNATURE-----

Gabriel Hondet wrote 6 years ago
[PATCH 2/2] gnu: Add python-isrcsubmit.
(address . 34258@debbugs.gnu.org)
878sz2xhxs.fsf@gmail.com
* gnu/packages/music.scm (python-isrcsubmit): New variable.
---
gnu/packages/music.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5a07ad4ae..d88ae4d22 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2578,6 +2578,28 @@ MusicBrainz database.")
(define-public python2-musicbrainzngs
(package-with-python2 python-musicbrainzngs))
+(define-public python-isrcsubmit
+ (package
+ (name "python-isrcsubmit")
+ (version "2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "isrcsubmit" version))
+ (sha256
+ (base32
+ "0jh4cni8qhri6dh83cmp0i0m0384vv0vznlygv49wj9xzh1d99qv"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-discid" ,python-discid)
+ ("python-musicbrainzngs" ,python-musicbrainzngs)))
+ (home-page "https://github.com/JonnyJD/musicbrainz-isrcsubmit")
+ (synopsis "Submit ISRCs from disc to MusicBrainz")
+ (description "@code{isrcsubmit} is a python script that allows to extract
+@acronym{ISRC, International Standard Recording Code} from audio CDs and
+submit them to @url{http://musicbrainz.org/, MusicBrainz}.")
+ (license license:gpl3)))
+
(define-public python2-pyechonest
(package
(name "python2-pyechonest")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxRx+8ACgkQMbyBBfZZ
1CXKBhAAiKwmnY7F3zg+DUj5NEfupR/1bHdMT9s/Tq+Pdg3rrgs6V4ppFg0sSmO2
TXB2ldcSm4utY37bIPUC7I4AgxPLckLjw/tLXp6ijSBPzaBIW+ij6qwHg6eRooaJ
r806d6pLAevki13rr8+ocirMhzxACmAEZJDARVRWKHn/fI3HQ1wnRd8yROL5dlnQ
OC+9ghKfwUti8iXonvk8/0oR8NXMb/8CxIFkNxD4SylWIqrjeqfMKVuRSPjUKURb
7NIjtw6We2iWO6FhXOMPb5E059FscPD5jVJ5saR4KzJZJCTRVrQFNOinWvdRrjqN
zoSIWn8nPUsuCsKlKO1pISKHEl4Kj539eOd69icUj/YNQHfULYcgU0MwRQR+REOj
i0dZ8y/XaB7Dc07FI/rTqqtxtRNrZOcO0jpVyOR3dsI34LzA2xLxFY5ywvc/oPPr
y9TjCD4Bpprr+9Wb1FltOB2tLJ61hotauC5DCrpF3KHGum99+jG7G4SzfRXaf+Zz
HwMj4BOzUHqQiJuW6nQ4534XJjkP8G15pooNKazlWFjcGcbswuP1o7G1pmer6usl
/hElmYIKeUSWnhQlSDxTBjab3j9joME5NqKQwnCxzYSGcUN/DAfqXoffuJAftcHL
MLg4/079yegCGZ0icFlLUCBw8nvLOwTAmyLWrxB5KJiIj4gLEis=
=LZfB
-----END PGP SIGNATURE-----

Marius Bakke wrote 6 years ago
Re: [bug#34258] [PATCH 1/2] gnu: Add python-discid.
871s4sa654.fsf@fastmail.com
Gabriel Hondet <gabrielhondet@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/music.scm (python-discid): New variable.

[...]

Toggle quote (2 lines)
> * gnu/packages/music.scm (python-isrcsubmit): New variable.

I fixed the indentation, made some editorialization of the descriptions
(note that the Guile TexInfo implementation does not have @acronym yet)
and pushed both patches as <84243592fe..07c82daad4>.

Thank you!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlxTY2cACgkQoqBt8qM6
VPoxwAgAtaNPO0Pa2uno0WYdE+JC0V5wiESi34IcY/6jmzdl68AMCdPGm3k+kqWu
fLGU0DpdqmjbWsem2FdQbFmcukWBitOS2bAB87Jtj2oAYd2snP0bvUhGP60R6M82
eAFoYnthv3A2qe/is5vojjVE2kqLtH1mEMOFl16Z4FlvdYmRDGYdWgnNmCTsrWhA
DgHngLTCmETKwxUDrju0DNjUyeRZXU/j2t3VupP0SF3IfzHwNEdt9W6eVLlM45q3
/0i3LT4uojJtsAZpPh4pinHXtAdx4En6KpQT1z7Vbqxgcf9fnIRITWEJVGcf7WKU
opPCPfsexUxhceQQE+++jQjkjw86SA==
=Bepm
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34258@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34258
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help