ericbavier wrote 6 years ago
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@member.fsf.org)
From: Eric Bavier <bavier@member.fsf.org>
* Makefile.am (clean-go): Ignore "test-tmp" directory.
---
Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/Makefile.am b/Makefile.am
index 0590c51519..fec9800ce7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -318,7 +318,7 @@ nobase_nodist_guileobject_DATA = $(GOBJECTS)
# Handy way to remove the .go files without removing all the rest.
clean-go:
-$(RM) -f $(GOBJECTS)
- @find . -name '*.go' -print | \
+ @find . -path ./test-tmp -prune -o -name '*.go' -print | \
if test -t 1; then \
xargs -r echo -e "\033[31mwarning:\033[0m stray .go files:"; \
else \
--
2.20.1