[PATCH] build: clean-go: Do not warn about *.go files in "test-tmp".

  • Done
  • quality assurance status badge
Details
2 participants
  • ericbavier
  • Ludovic Courtès
Owner
unassigned
Submitted by
ericbavier
Severity
normal

Debbugs page

ericbavier wrote 6 years ago
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@member.fsf.org)
20190130050858.12859-1-ericbavier@centurylink.net
From: Eric Bavier <bavier@member.fsf.org>

* Makefile.am (clean-go): Ignore "test-tmp" directory.
---
Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/Makefile.am b/Makefile.am
index 0590c51519..fec9800ce7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -318,7 +318,7 @@ nobase_nodist_guileobject_DATA = $(GOBJECTS)
# Handy way to remove the .go files without removing all the rest.
clean-go:
-$(RM) -f $(GOBJECTS)
- @find . -name '*.go' -print | \
+ @find . -path ./test-tmp -prune -o -name '*.go' -print | \
if test -t 1; then \
xargs -r echo -e "\033[31mwarning:\033[0m stray .go files:"; \
else \
--
2.20.1
Ludovic Courtès wrote 6 years ago
(address . ericbavier@centurylink.net)
87sgx07evf.fsf@gnu.org
ericbavier@centurylink.net skribis:

Toggle quote (4 lines)
> From: Eric Bavier <bavier@member.fsf.org>
>
> * Makefile.am (clean-go): Ignore "test-tmp" directory.

Neat, go for it! This had been annoying me for a while actually…

Thanks,
Ludo’.
Eric Bavier wrote 6 years ago
(address . 34254-done@debbugs.gnu.org)
20190207212243.4f2fb342@centurylink.net
On Wed, 06 Feb 2019 23:04:36 +0100
Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (11 lines)
> ericbavier@centurylink.net skribis:
>
> > From: Eric Bavier <bavier@member.fsf.org>
> >
> > * Makefile.am (clean-go): Ignore "test-tmp" directory.
>
> Neat, go for it! This had been annoying me for a while actually…
>
> Thanks,
> Ludo’.

Pushed to master in 92becc3f15ce196a94274f80ee0b6594774856fa

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlxc9hAACgkQ/XPKxxnT
JWYBig//aZyIGqHBTUtXxxaVvctwrBaxKZcSDoGf6fULWL4yuu3RU4zU8hW/3zKX
LSpa1NFzAYAJqRkBUSXdlbpmuAfogChyB7oaf3s3JzkMXCnUbJO2jstP4KrNLniC
BUvSvgI4RRVKvQQtTFmV/kbeI4u7UwBY6bxecg84nOU++uVb+SWc8Y4eIU7TGX/6
mvzMBrHAJ2HCM1A544AJAKHzhjggE7wcsbD1aMwwNeSdp7A3MKHf86tvU0fQ4o6R
zxdmvCReHk0hSURmp/ryC54pEs6irNSootp/RLLJbS/vuuavxQktGUWVLMZITzm0
689wPt+GpANa/JyxmJWLNHbcn9r0Me7Mia+9b2MZiflm1eeuU0eckEMRn0Nxvk5z
vtL8jOEkoWrXkfE+ZK9IyyYD8upX6xjX12o7f4U/GDjHeGucxLGzqkL508slPN6X
ZUtB02dprpzEDs+S/QckJPPtTVHL9Y4IZ81Y0ATH9kGPt/C8blIHsjGdAqUi8Snp
GpeVBD7ryX/u0VVsFciRdHKw4JikZrCxYF5mAGZsQQHOn5IpiedFGqnghsWizIrg
icp/ecYthzcBypgamphREYXKlDQIoaNulZSDkfoXVxkQv2GJGdjA3hna2Nr39zs0
Unm7TfbvIq6f6dZlPKhiNt9W2OXUak2Djj5HvPBoKrqGaO1cAII=
=Fs4w
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34254@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34254
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help