[PATCH 0/5] Gnome printing improvements

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
87a7jjr8y3.fsf@cbaines.net
These patches work towards allowing easy configuration of printers
within Gnome (and probably other desktop environments).

Previously, the gnome-control-center printer configuration would simply
not work, as I believe it depends on cups-pk-helper and
system-config-printer. With these two things present, it works better,
but I encounter authentication issues.


Christopher Baines (5):
gnu: Add cups-pk-helper.
services: Add cups-pk-helper.
gnu: Add python-pycups.
gnu: Add system-config-printer.
gnu: gnome: Include system-config-printer.

gnu/packages/cups.scm | 52 ++++++++++++++++++++++++
gnu/packages/gnome.scm | 88 ++++++++++++++++++++++++++++++++++++++++
gnu/services/desktop.scm | 17 ++++++++
3 files changed, 157 insertions(+)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxQOvRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XccFBAAnHObhxY0EL9G7ZtfjuZb674TWAKt7ASU8bDB2koZZ6hKuFgfVlPVkxrI
GfHXbW0LL7W9+8E+3k3/5OHJeNImqa88sA5Fi02Ob4N5HL9Bnnm0nY+NaHi/bx3X
mGUmAVsG+4POSLo6Ixq2Q/rBpfNntE9dV48ZbKIewPBY8SmFFsCZep1FpSdC4NLB
3SrRwemZN/J/AbCrLEB3MKTMPPsorHIR3jmac0+VxJNyIJLDBz2SnnZH1DemHtGW
bO1QbF09HSqUg+JQGIywGAhecnvm2T8/dYeyjUxlFW4cB6zi8YrWFl62nVH3rbW6
QcqyMk11O3fGEoLeuu7Att1P5nW6ZTEp3WYQr9ifQnh4i0OkD1Utk7Y1VxfRRBlN
/xeBR2tqzSUfosQQvYrrapLw019Rf5GA9E5WtyzgqCpyKG4vs8k/naMvW8130t+0
oWwM2LvfCmulwFkHeI3te8CgkvREVAOqb6ucxM1+nxwaai02ZrBe00CcvDx0hm8C
Aj9z2ioVj735zP3RzMPpVpqnGJenxvdNpUn/FJToiN6KvrBfEqHmRF8zN0Pz0gCk
FThMWOGjWuHuD3O1U99hGGL1yihvfsPMzAN0gr0mdpuvP9VXdOJVX0Nb7fer3QrW
MwMOWwx1C1b14k8lfTdvbwbVmQ3LanNzbrL7SDjg2AgQHzhx1ZQ=
=xIQu
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
[PATCH 1/5] gnu: Add cups-pk-helper.
(address . 34240@debbugs.gnu.org)
20190129114242.32481-1-mail@cbaines.net
* gnu/packages/cups.scm (cups-pk-helper): New variable.
---
gnu/packages/cups.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 40ffc0df80..138a1fc3ed 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -38,6 +38,7 @@
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
@@ -380,6 +381,32 @@ device-specific programs to convert and print many types of files.")
("cups-filters" ,cups-filters)
("zlib" ,zlib)))))
+(define-public cups-pk-helper
+ (package
+ (name "cups-pk-helper")
+ (version "0.2.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://freedesktop.org/software/"
+ name "/releases/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0a52jw6rm7lr5nbyksiia0rn7sasyb5cjqcb95z1wxm2yprgi6lm"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("glib" ,glib)
+ ("polkit" ,polkit)
+ ("cups" ,cups)))
+ (home-page "https://www.freedesktop.org/wiki/Software/cups-pk-helper/")
+ (synopsis "PolicyKit helper to configure cups with fine-grained privileges")
+ (description
+ "This package provides the org.opensuse.CupsPkHelper.Mechanism DBus
+system service which uses @file{cups-pk-helper-mechanism}. This package
+should only be used as part of the Guix cups-pk-helper service.")
+ (license license:gpl2+)))
+
(define-public hplip
(package
(name "hplip")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 3/5] gnu: Add python-pycups.
(address . 34240@debbugs.gnu.org)
20190129114242.32481-3-mail@cbaines.net
* gnu/packages/cups.scm (python-pycups): New variable.
---
gnu/packages/cups.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 138a1fc3ed..3b42f9e27e 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages scanner)
#:use-module (gnu packages tls)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -708,3 +709,27 @@ printers. It can only be used with printers that support the Epson ESC/P-R
language.")
(home-page "http://download.ebz.epson.net/dsc/search/01/search")
(license license:gpl2+)))
+
+(define-public python-pycups
+ (package
+ (name "python-pycups")
+ (version "1.9.74")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycups" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1ffp7sswhdsfpy88zg0cc8kl04wygkjs01rlm9f0spbwk8jhy2c6"))))
+ (build-system python-build-system)
+ (arguments
+ '(;; Tests require CUPS to be running
+ #:tests? #f))
+ (inputs
+ `(("cups" ,cups)))
+ (home-page "https://github.com/zdohnal/pycups")
+ (synopsis "Python bindings for libcups")
+ (description
+ "This package provides Python bindings for libcups, wrapping the CUPS
+API.")
+ (license license:gpl2+)))
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 5/5] gnu: gnome: Include system-config-printer.
(address . 34240@debbugs.gnu.org)
20190129114242.32481-5-mail@cbaines.net
This package enables some functionality for printers within the
gnome-control-center as well as providing a standalone configuration tool.

At the moment, due to the lack of PackageKit support within Guix, the
gnome-control-center can't help users through the process of installing this,
so make it a default package.

* gnu/packages/gnome.scm (gnome)[propagated-inputs]: Add system-config-printer.
---
gnu/packages/gnome.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0982409eeb..3a3e98a8fe 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6155,6 +6155,7 @@ associations for GNOME.")
("pinentry-gnome3" ,pinentry-gnome3)
("pulseaudio" ,pulseaudio)
("shared-mime-info" ,shared-mime-info)
+ ("system-config-printer" ,system-config-printer)
("totem" ,totem)
("xdg-user-dirs" ,xdg-user-dirs)
("yelp" ,yelp)
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 2/5] services: Add cups-pk-helper.
(address . 34240@debbugs.gnu.org)
20190129114242.32481-2-mail@cbaines.net
This service integrates cups and PolicyKit. The gnome-control-center printing
section uses this functionality.

* gnu/sevices/desktop.scm (cups-pk-helper-service-type): New variable.
(%desktop-services): Add the cups-pk-helper service.
---
gnu/services/desktop.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
index fbeabf1162..a93fa3c356 100644
--- a/gnu/services/desktop.scm
+++ b/gnu/services/desktop.scm
@@ -39,6 +39,7 @@
#:use-module (gnu system pam)
#:use-module (gnu packages glib)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages cups)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gnome)
#:use-module (gnu packages xfce)
@@ -801,6 +802,21 @@ accountsservice web site} for more information."
(service accountsservice-service-type accountsservice))
+;;;
+;;; cups-pk-helper service.
+;;;
+
+(define cups-pk-helper-service-type
+ (service-type
+ (name 'cups-pk-helper)
+ (description
+ "PolicyKit helper to configure CUPS with fine-grained privileges.")
+ (extensions
+ (list (service-extension dbus-root-service-type list)
+ (service-extension polkit-service-type list)))
+ (default-value cups-pk-helper)))
+
+
;;;
;;; GNOME desktop service.
;;;
@@ -990,6 +1006,7 @@ as expected.")))
(udisks-service)
(upower-service)
(accountsservice-service)
+ (service cups-pk-helper-service-type)
(colord-service)
(geoclue-service)
(service polkit-service-type)
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 4/5] gnu: Add system-config-printer.
(address . 34240@debbugs.gnu.org)
20190129114242.32481-4-mail@cbaines.net
* gnu/packages/gnome.scm (system-config-printer): New variable.
---
gnu/packages/gnome.scm | 87 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 87 insertions(+)

Toggle diff (100 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bf9109f680..0982409eeb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -978,6 +978,93 @@ for translations, though this is only a dependency for the maintainers. This
database is translated at Transifex.")
(license license:gpl2+)))
+(define-public system-config-printer
+ (package
+ (name "system-config-printer")
+ (version "1.5.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/zdohnal/system-config-printer/releases/"
+ "download/" version
+ "/system-config-printer-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1lq0q51bhanirpjjvvh4xiafi8hgpk8r32h0dj6dn3f32z8pib9q"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:imported-modules ((guix build python-build-system)
+ ,@%glib-or-gtk-build-system-modules)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-Makefile.am
+ (lambda _
+ ;; The Makefile generates some scripts, so set a valid shebang
+ (substitute* "Makefile.am"
+ (("/bin/bash") (which "bash")))
+ #t))
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Modify the man XML otherwise xmlto tries to access the network
+ (substitute* "man/system-config-printer.xml"
+ (("http://www.oasis-open.org/docbook/xml/4.1.2/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/")))
+ #t))
+ (add-before 'configure 'bootstrap
+ (lambda _
+ ;; Run ./bootstrap as otherwise the build fails with
+ ;; automake-1.15: command not found
+ (invoke "./bootstrap")
+ #t))
+ (add-after 'install 'wrap-for-python
+ (@@ (guix build python-build-system) wrap))
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+ (for-each
+ (lambda (program)
+ (wrap-program program
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
+ (map (lambda (name)
+ (string-append out "/bin/" name))
+ '("system-config-printer"
+ "system-config-printer-applet"
+ "install-printerdriver"
+ "scp-dbus-service"))))
+ #t)))))
+ (inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gobject-introspection" ,gobject-introspection)
+ ("python" ,python)
+ ("cups" ,cups)
+ ("python-dbus" ,python-dbus)
+ ("python-pygobject" ,python-pygobject)
+ ("python-pycups" ,python-pycups)
+ ("python-requests" ,python-requests)
+ ("python-pycairo" ,python-pycairo)
+ ("libnotify" ,libnotify)
+ ("packagekit" ,packagekit)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("glib" ,glib)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("intltool" ,intltool)
+ ("xmlto" ,xmlto)
+ ("docbook-xml" ,docbook-xml-4.1.2)
+ ("docbook-xsl" ,docbook-xsl)
+ ("libxml2" ,libxml2)))
+ (home-page "https://github.com/zdohnal/system-config-printer")
+ (synopsis "CUPS administration tool")
+ (description
+ "system-config-printer is a CUPS administration tool. It's written in
+Python using GTK+, and uses the @acronym{IPP, Internet Printing Protocol} when
+configuring CUPS.")
+ (license license:gpl2+)))
+
(define-public hicolor-icon-theme
(package
(name "hicolor-icon-theme")
--
2.20.1
Ricardo Wurmus wrote 6 years ago
Re: [bug#34240] [PATCH 1/5] gnu: Add cups-pk-helper.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 34240@debbugs.gnu.org)
87fttbpg8p.fsf@elephly.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (1 lines)
> * gnu/packages/cups.scm (cups-pk-helper): New variable.
[…]
Toggle quote (3 lines)
> + (synopsis "PolicyKit helper to configure cups with fine-grained
> privileges")

Should be “CUPS” instead of “cups”.

Toggle quote (5 lines)
> + (description
> + "This package provides the org.opensuse.CupsPkHelper.Mechanism DBus
> +system service which uses @file{cups-pk-helper-mechanism}. This package
> +should only be used as part of the Guix cups-pk-helper service.")

I’d wrap the service names in @code{…}.

Why can it not be used without the cups-pk-helper service? Is it not
enough to install the package in a location that gets searched by DBus?

--
Ricardo
Ricardo Wurmus wrote 6 years ago
Re: [bug#34240] [PATCH 3/5] gnu: Add python-pycups.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 34240@debbugs.gnu.org)
87d0ofpg5j.fsf@elephly.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (2 lines)
> * gnu/packages/cups.scm (python-pycups): New variable.

LGTM!

--
Ricardo
Christopher Baines wrote 6 years ago
Re: [bug#34240] [PATCH 2/5] services: Add cups-pk-helper.
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 34240@debbugs.gnu.org)
874l9rqu6d.fsf@cbaines.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (13 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> This service integrates cups and PolicyKit. The gnome-control-center printing
>> section uses this functionality.
>>
>> * gnu/sevices/desktop.scm (cups-pk-helper-service-type): New variable.
>> (%desktop-services): Add the cups-pk-helper service.
>
> I wonder if this service is really needed or if it would be enough to
> install the package into the system profile, for example.
>
> (It looks fine to me, but I’m still curious.)

Thanks for taking a look Ricardo. I'm unsure, this DBus/Polkit stuff is
still a bit of a mystery to me. These files are put in place by the
service [1], and I think that's what makes it do stuff...

1:
/etc/dbus-1/system-services/org.opensuse.CupsPkHelper.Mechanism.service
/etc/polkit-1/actions/org.opensuse.cupspkhelper.mechanism.policy

I guess it entirely depends on the configuration for DBus and Polkit in
Guix, but I can't see similar things in /run/current-system/profile/etc/
so I'm guessing it's not currently possible to make this work through
the system profile.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxQhbpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdrEBAAm+yq3CB1akTQiD+iS+rhXRp7XQJhvcG+tgACXF+tzZX4XrSSwDlrXJZV
8CGXSxPy2oEc+rKRWqfDtj7Ivqwm0W0rBfmK8T199T1HIaMLj2Z5NlyzFpUdoDTm
DXSbElqbhyyi/LGZf8yGDSo98qp6GDmLOJdAC324kGDq6hpqkaXQrzX/AfufOi+n
54Y4u0fUyS+tjC7tsaGXSSHbt/VweTePhSpr7Wsd9DVJesluEvn6BX2QTD4P6S7f
FsTU6x21ST007LycxmnR8X5CaRwnDKZhS9dOrS1y+8R2Qn9Yw6+BCBdJHAOGpneR
PBTFWY0AripRoFawhsKMSn8YLh1ERdmA2rL5Y8oKR+JxD1MQPzVfi8OPpjXBqBlx
OVzM4z/BUDiNfJZkdPR/eCrjNYuh8sBN7dity6UWIP3VBoT7BoOiT2tdSTs0MKYJ
t0zeb/tLiuQ+u9WGjoaMtRXdG+4Wkrbe9BFKDo6mhVSaECyYJaSPRcqbwFEijVju
RNuPTNwVuWH+1WbVEGvqxkyJD2Obm72XeLk+3oIRTl+jwONhitgPtemHgii25Up1
7hGn5hAeMLb2KaBVdQc4sEMngqhsO/fhrNGg+MdEcmZhkIhki6JPMIaPfrs0/g87
3iVZRbScjhYoYiWlZbtUZe0G7VLarFbT9s8fmqygVKyFJJ+sy5Y=
=VqP3
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
Re: [bug#34240] [PATCH 1/5] gnu: Add cups-pk-helper.
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 34240@debbugs.gnu.org)
8736pbqtv8.fsf@cbaines.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (9 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/cups.scm (cups-pk-helper): New variable.
> […]
>> + (synopsis "PolicyKit helper to configure cups with fine-grained
>> privileges")
>
> Should be “CUPS” instead of “cups”.

Sure, I'll update.

Toggle quote (10 lines)
>> + (description
>> + "This package provides the org.opensuse.CupsPkHelper.Mechanism DBus
>> +system service which uses @file{cups-pk-helper-mechanism}. This package
>> +should only be used as part of the Guix cups-pk-helper service.")
>
> I’d wrap the service names in @code{…}.
>
> Why can it not be used without the cups-pk-helper service? Is it not
> enough to install the package in a location that gets searched by DBus?

I'm not sure if I'm correct here, but it looks like this might be the
case from looking at the DBus stuff in the package.

The DBus service contains "system-services" in the name, which is
different from some other packages DBus configuration.

/gnu/store/...-cups-pk-helper-0.2.6/share/dbus-1/system-services/org.opensuse.CupsPkHelper.Mechanism.service

Also, in that file, it says "User=root".

[D-BUS Service]
Name=org.opensuse.CupsPkHelper.Mechanism
Exec=/gnu/store/...-cups-pk-helper-0.2.6/libexec/cups-pk-helper-mechanism
User=root
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxQh0tfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcGcw//Rn8B/FvmNTNyHBFEw5Ccs9hFIg8icYwoeyCByWoCtAzm0hPTgBMMdw5r
jRsOYG9+lugW/Au82QYFWKbXjcIiV4uWLl/Sn8UV1KQHGRou0LGPj8u1KQMPGSsj
b/AeWkg0zLjnjb6Wy0yPG41AlBJgFtFIao5p/u+Zuz7wTGKxhrBlVNE4kh1dQYCh
c2udCCr7GjLrY+xs4vEyLVeiI44KZc3Fa0mYKa2IOfQMgEFmKCqizyHdGuOn8bfJ
4jO0A/iNeB7JHvAdbkAJKr4R6JzdDvcSLPUjiEpRS+UiurnTaTcRi4SxjgdbuaLG
of6vFpHZAYOVPL2fQ1AM7nGPXopgkHcJVZi8G/OwtpiOp/m0qZgX7sRitSRIRhF9
TNr8GkcThIBel55gjqrtravRnVq97+tdNyHMMKWxRx/XbiU4aVpHGSiXrsN74a7i
up+J3GeVHPFLA8jZ5+0adkGbM9zJUzzvFs69eq8zcEyLTMKi6AfZ+wq5blsRdum3
Gk+bASlK5dBAGFENNBzUESs3QS6ejO3tsD88E4S6ruDARxR9WP/4sbRKzTtW7H8p
u1W3S1OOPA/fDZ1gc3BV2KMibkX0w41l//xNQxiyyygFNGbcXmCDJRaTayM6DNyY
XzSa8zmqMe/0pQva1FFrzH7cwF1/TOkZ0MbO2yQHogY/ET+6SZA=
=4sfa
-----END PGP SIGNATURE-----

Ricardo Wurmus wrote 6 years ago
Re: [bug#34240] [PATCH 5/5] gnu: gnome: Include system-config-printer.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 34240@debbugs.gnu.org)
87a7jjpfw1.fsf@elephly.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (25 lines)
> This package enables some functionality for printers within the
> gnome-control-center as well as providing a standalone configuration tool.
>
> At the moment, due to the lack of PackageKit support within Guix, the
> gnome-control-center can't help users through the process of installing this,
> so make it a default package.
>
> * gnu/packages/gnome.scm (gnome)[propagated-inputs]: Add system-config-printer.
> ---
> gnu/packages/gnome.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 0982409eeb..3a3e98a8fe 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -6155,6 +6155,7 @@ associations for GNOME.")
> ("pinentry-gnome3" ,pinentry-gnome3)
> ("pulseaudio" ,pulseaudio)
> ("shared-mime-info" ,shared-mime-info)
> + ("system-config-printer" ,system-config-printer)
> ("totem" ,totem)
> ("xdg-user-dirs" ,xdg-user-dirs)
> ("yelp" ,yelp)

Looks good to me.

--
Ricardo
Ricardo Wurmus wrote 6 years ago
Re: [bug#34240] [PATCH 2/5] services: Add cups-pk-helper.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 34240@debbugs.gnu.org)
87ef8vpg6i.fsf@elephly.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (6 lines)
> This service integrates cups and PolicyKit. The gnome-control-center printing
> section uses this functionality.
>
> * gnu/sevices/desktop.scm (cups-pk-helper-service-type): New variable.
> (%desktop-services): Add the cups-pk-helper service.

I wonder if this service is really needed or if it would be enough to
install the package into the system profile, for example.

(It looks fine to me, but I’m still curious.)

--
Ricardo
Ricardo Wurmus wrote 6 years ago
Re: [bug#34240] [PATCH 4/5] gnu: Add system-config-printer.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 34240@debbugs.gnu.org)
87bm3zpfwp.fsf@elephly.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (1 lines)
> * gnu/packages/gnome.scm (system-config-printer): New variable.
[…]
Toggle quote (11 lines)
> + (arguments
> + `(#:imported-modules ((guix build python-build-system)
> + ,@%glib-or-gtk-build-system-modules)
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'patch-Makefile.am
> + (lambda _
> + ;; The Makefile generates some scripts, so set a valid shebang
> + (substitute* "Makefile.am"
> + (("/bin/bash") (which "bash")))
> + #t))
[…]
Toggle quote (7 lines)
> + (add-before 'configure 'bootstrap
> + (lambda _
> + ;; Run ./bootstrap as otherwise the build fails with
> + ;; automake-1.15: command not found
> + (invoke "./bootstrap")
> + #t))

The build system already provides a “bootstrap” phase, so maybe it would
be better to delete “configure” in “patch-Makefile.am” to activate the
bootstrap phase.

Otherwise looks good to me. Thanks!

--
Ricardo
Christopher Baines wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 34240-done@debbugs.gnu.org)
87va1ot7yn.fsf@cbaines.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (29 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/gnome.scm (system-config-printer): New variable.
> […]
>> + (arguments
>> + `(#:imported-modules ((guix build python-build-system)
>> + ,@%glib-or-gtk-build-system-modules)
>> + #:phases
>> + (modify-phases %standard-phases
>> + (add-after 'unpack 'patch-Makefile.am
>> + (lambda _
>> + ;; The Makefile generates some scripts, so set a valid shebang
>> + (substitute* "Makefile.am"
>> + (("/bin/bash") (which "bash")))
>> + #t))
> […]
>> + (add-before 'configure 'bootstrap
>> + (lambda _
>> + ;; Run ./bootstrap as otherwise the build fails with
>> + ;; automake-1.15: command not found
>> + (invoke "./bootstrap")
>> + #t))
>
> The build system already provides a “bootstrap” phase, so maybe it would
> be better to delete “configure” in “patch-Makefile.am” to activate the
> bootstrap phase.
>
> Otherwise looks good to me. Thanks!

Great, I've made that change to the system-config-printer phases and
pushed these patches now.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxj03BfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XckkQ/7BGn0jXNxLFVApCESoN0L407O+ddQZ3stFyGioqHIvA3YpCRIMv1NmbhK
vUiGl/QyUHNSsxrpmRb9KVNE1k4dsVBMl7HEtGGGUFXFCHh2vaRaytLC4ZzmT+N/
NCaXxN2h0HfkFyWcMDfoVShuwx3xmrQVa1fbCNq6CaayaSHNi8IPln1fYpw9NQ2N
CxGXYL1d/4WX2ZxWGQ8nIVHs+s7tU39EQX1wgo4jNlTPdQalF9d4HROfWgGlNbtM
W11dcF040bgFsy0ERY+htuWLXBAlCiNcCxe5edFZzqhYXkf85E1TqSTPyCljjiQ/
vM+McKtEsmJt272d0BZIrI1W7mGC+2jxjXbIolnygOB3QSPjgyK+aCvW7F2xh4F2
NqXFLG950Gm9nBYKqD0z6FT8/jVNoEaxAh4YlFrQCnvoDNNYddeWOsisRqsQ3qEH
nSsYoUwoOmwS4Q/mau6+XTWVBlWlojfwbbqcaBvQ8FNtq90fkZpnorF6wI5zHFZt
UdctvbrtG9c2pfS6oKUmTVd/ZDOZ/yKx7sB46fFoRDmwTb2DqIJS4icfLo32SP2r
x45pVW1RqWiFOK76mm9t1LpfuRgLu9vJrSkuF/yBjkab181sdGKhmS02vD88FlUZ
ATwHI7JSQoMz04RVLDJPcTv7Ii8zQOA2W2vy5xaVQZ9JgvSmXOc=
=GbE6
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34240@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34240
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help