Shroud require xclip for x clipboard

  • Open
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Amar Singh
Owner
unassigned
Submitted by
Amar Singh
Severity
normal
A
A
Amar Singh wrote on 27 Jan 2019 11:17
(address . bug-guix@gnu.org)
87y376tneg.fsf@disroot.org
I've added xclip as a propagated input for shroud as otherwise `shroud
show --clipboard` functionality didn't work, neither primary or
secondary clipboard.

xclip is about 102 MiB in size, out of which a little more than 60% is
glibc and gcc.

I am not sure if this is the best idea though.
E
E
Efraim Flashner wrote on 27 Jan 2019 11:29
(name . Amar Singh)(address . nly@disroot.org)(address . 34216@debbugs.gnu.org)
20190127102935.GF11329@macbook41
Attachment: file
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAlxNiAsACgkQQarn3Mo9
g1HelQ/+NTUyO4aRuI8XI7Wxiu8BKDZBn6kTvZChANHG8TcWbz+xosRdj0lgkGb8
I+aQLwy5zJwx8Ao+CFwdY6lQ3ZOLDCHb3L/34Qgcp2OgcIMj4gQ9Dh3QcbIaqR3W
B40fE96NkmoBp0jeWGAYphw+QayLNZU6X0nS5S3XPP1dpqGkpb9VptTJW27Fs8US
m6LxRuPF/nnhPXx/jvmTjKr7XcouLO0OI3TwsdNBbRQntEr2kWcozvdHSDvc60O5
KHuc21N8eT2PVD0UBCQmqLZssqARRy38IoWh/VANYr31RX/5ZJOZrtmnXuv9KA+6
Hih+pfE4I9gDk6454B4W+C44BMgsbcz6c1B4fXg3WVAFchhoXzNm5IBNH0Z6aFtB
VmYYfcSeUv+vZmTejaf0vCaqQmZYcX9XxHQ5Rx1KtYG27soYjwrF2M/lBuuCodtl
tt6Aog+//ikcA82dBX4a4BrANTDtvtPFr3jSEr2b32jeNWR2lSzAV7CYzhhr7Omh
rjvaV+EP7RwjVKxny17MII2yYcrAm2PKS300RbC7qRpSf3c6U8Wz4wTq19boFB/w
mE53mmrFe3ByC65JRKjG9zqkDLJBzfbpQSr+8Nr451pqmsI8P1S9qSAkrgLBYt6m
oVbb1gIlRS40IaxMpSytsgEKIw/Z+A7l9nnUbJq2AYeeHZ4iamk=
=oRIk
-----END PGP SIGNATURE-----


N
(address . 34216@debbugs.gnu.org)
87lg36tlq7.fsf@disroot.org
Toggle quote (4 lines)
> /gnu/store/w862nkwzvv2m3ng5lg5zlic1i962g416-gnupg-2.2.12 238.8 10.1 3.8%
> /gnu/store/agz9m74v7235h30mc3bdmj2nmyxqga4c-xclip-0.13 102.7 0.1 0.0%
> Looks like xclip is already in the closure of shroud,

I see, thanks.

Toggle quote (2 lines)
> patch the reference to it so shroud can always find xclip.

How?

Snippet from (shroud utils):

;; Instance of use of xclip
(define (call-with-clipboard proc)
"Call PROC with an open output port to the X clipboard."
(call-with-output-pipe* (list %xclip "-selection" "clipboard") proc))

;; Use of gpg
(define (call-with-encrypted-output-file file user-id proc)
"Apply PROC with an output port that writes encrypted data to FILE
for the recipient USER-ID."
(call-with-output-pipe* `(,(gpg-binary)
"--no-tty" "--batch" "--yes"
"--encrypt" "--armor"
"--recipient" ,user-id
"--output" ,file)
proc))

Thanks,
amar
E
E
Efraim Flashner wrote on 27 Jan 2019 12:02
(name . nly)(address . nly@disroot.org)(address . 34216@debbugs.gnu.org)
20190127110201.GA8685@macbook41
On Sun, Jan 27, 2019 at 04:23:52PM +0530, nly wrote:
Toggle quote (33 lines)
>
>
> > /gnu/store/w862nkwzvv2m3ng5lg5zlic1i962g416-gnupg-2.2.12 238.8 10.1 3.8%
> > /gnu/store/agz9m74v7235h30mc3bdmj2nmyxqga4c-xclip-0.13 102.7 0.1 0.0%
> > Looks like xclip is already in the closure of shroud,
>
> I see, thanks.
>
> > patch the reference to it so shroud can always find xclip.
>
> How?
>
> Snippet from (shroud utils):
>
> ;; Instance of use of xclip
> (define (call-with-clipboard proc)
> "Call PROC with an open output port to the X clipboard."
> (call-with-output-pipe* (list %xclip "-selection" "clipboard") proc))
>
> ;; Use of gpg
> (define (call-with-encrypted-output-file file user-id proc)
> "Apply PROC with an output port that writes encrypted data to FILE
> for the recipient USER-ID."
> (call-with-output-pipe* `(,(gpg-binary)
> "--no-tty" "--batch" "--yes"
> "--encrypt" "--armor"
> "--recipient" ,user-id
> "--output" ,file)
> proc))
>
> Thanks,
> amar

I also looked at the code and it looks like there's already substitution
in place to record the locations of xclip and gpg. Perhaps you're trying
to paste from the wrong clipboard? "clipboard" indicates that "Control + V"
should work for pasting.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAlxNj6kACgkQQarn3Mo9
g1GkHA//XRrCCteQhW9iKPbFf9EPOq5EZJ2nwHj9E15O9GBSd6MICZGLzdQj+hyt
R26N7+SDlGwp9K8zKWcq/x0oyOp0xARK6TePUwmVGiihbyhOszdUpiJnrm8lLlJm
wMzrrl8v7UyKEgNWtNeixCC5Q7FJR/fexpb8hPHwBcgKQ9ZPjllsR5ZVFzeNpjZQ
2Td7Ov9T2MYjeSUuDB2hTFJGvs/Cb1zZP9SXXt/Mmeezz7/iIoV4nRjkupIU7+H2
h/NkTMBHwzbAa2DHkuNRodPCU42QyuI9+ga1TDUXfJ7g3ilHc5yzcL9sZIiw8B3N
+ravwZ2C4ZGWkrkDi6a2JQywLJ93hnzpHnR1kxMJYA5kWoEcGpLITwFy/cyJR+QF
J3/2WS8iZuBOnhEMgUzCNYQO4s1N/7F6n9FrQHoIYffCiffqq/aVAzsqgdhJwp09
MqkDvaicDol5o2AsxOrTGzYikk+PuVjO/2/UkmZDjn3wjGVEVoWBcdK123vVrlKL
pChJ+qbPsjSFNjkn3n62D+9uW3xLuz927PB3DmRSohC63pRP2qX3SJM/83nAiwdb
FHqXRgzKigNHp7dvnyMf16LkyRkgyOz4f19TgxCWh26VivgPc9kQ0zGaR30d7dvq
Sm43yT9FWcliVci7EHCVrO1wS7EvNOSmy3O5tjaVitSi20goSSc=
=Ynf+
-----END PGP SIGNATURE-----


?