guix --version: ERROR: In procedure display: In procedure fport_write: Broken pipe

  • Open
  • quality assurance status badge
Details
2 participants
  • Pierre Neidhardt
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
Merged with
P
P
Pierre Neidhardt wrote on 26 Jan 2019 17:31
(address . bug-guix@gnu.org)
87d0ojlmb5.fsf@ambrevar.xyz
In Bash:
Toggle snippet (16 lines)
$ guix --version | awk '{print $4; exit}'
Backtrace:
5 (primitive-load "/home/ambrevar/.config/guix/current/bin/guix")
In guix/ui.scm:
464:2 4 (show-version-and-exit _)
In ice-9/format.scm:
1590:19 3 (format #t "Copyright ~a 2019 ~a" "(C)" "the Guix authors\n")
261:19 2 (format:format-work "Copyright ~a 2019 ~a" ("(C)" "the Guix authors\n"))
70:10 1 (format:out-obj-padded _ _ _ _)
In unknown file:
0 (display "the Guix authors\n" #<output: file 1>)

ERROR: In procedure display:
In procedure fport_write: Broken pipe

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAlxMi2MACgkQm9z0l6S7
zH/MxQf9FGOgAmsexqYSfKrdBlCStim7h2ZrCoBtNxMbKIc/Yuh8s3DA7Mfwo9YP
hIh6Ro0elPmA2kKlUXf1u3Z573Xx/+1e8aGaDwsd4B6jmWy/I4aM6VNGSXmwQBSQ
tDzVcbdjUvMSkFIrpypgAdLT7HzpRIPXH8frUtwnKq1H2iE8Zk/sOdUiRrZLvfWN
UWEXSUp8QE9a3u2tJv+tA0SEr3zcl0kYAiisWex52Sj/VTYhNPNnHmEhhXZtVqj1
Vcohbw1Km9YkuzX6+T55UnC4gaxlAK0aCxQEetsU9aXU9pWGk5NxxZj5itvsJtcj
PM453H18IUdiVOJlRwFhr77JniOWlw==
=wmvc
-----END PGP SIGNATURE-----

R
R
Ricardo Wurmus wrote on 27 Jan 2019 18:57
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 34209@debbugs.gnu.org)
87imyarnkb.fsf@elephly.net
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (18 lines)
> In Bash:
> --8<---------------cut here---------------start------------->8---
> $ guix --version | awk '{print $4; exit}'
> Backtrace:
> 5 (primitive-load "/home/ambrevar/.config/guix/current/bin/guix")
> In guix/ui.scm:
> 464:2 4 (show-version-and-exit _)
> In ice-9/format.scm:
> 1590:19 3 (format #t "Copyright ~a 2019 ~a" "(C)" "the Guix authors\n")
> 261:19 2 (format:format-work "Copyright ~a 2019 ~a" ("(C)" "the Guix authors\n"))
> 70:10 1 (format:out-obj-padded _ _ _ _)
> In unknown file:
> 0 (display "the Guix authors\n" #<output: file 1>)
>
> ERROR: In procedure display:
> In procedure fport_write: Broken pipe
> --8<---------------cut here---------------end--------------->8---

This happens because awk closes the stream while we’re writing to it.
We could wrap the things in “run-guix” in (leave-on-EPIPE …).

Or we tell Guix not to ignore SIGPIPE.


--
Ricardo
R
R
Ricardo Wurmus wrote on 27 Jan 2019 18:57
(address . 34209@debbugs.gnu.org)
87h8durnji.fsf@elephly.net
merge 34209 29826
R
R
Ricardo Wurmus wrote on 31 Jan 2019 15:27
(address . control@debbugs.gnu.org)
875zu4oqaz.fsf@elephly.net
merge 34209 29826
thanks

--
Ricardo
?