[PATCH] gnu: Add lhasa.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190126012444.19033-1-kkebreau@posteo.net
* gnu/packages/compression.scm (lhasa): New variable.
---
gnu/packages/compression.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 327951fde..3fe4c74ec 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
@@ -434,6 +434,39 @@ than gzip and 15 % smaller output than bzip2.")
(license (list license:gpl2+ license:lgpl2.1+)) ; bits of both
(home-page "https://tukaani.org/xz/")))
+(define-public lhasa
+ (package
+ (name "lhasa")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/fragglet/lhasa/releases/download/v"
+ version "/lhasa-" version ".tar.gz"))
+ (sha256
+ (base32
+ "092zi9av18ma20c6h9448k0bapvx2plnp292741dvfd9hmgqxc1z"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-up-test-environment
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TZDIR" (string-append (assoc-ref inputs "tzdata")
+ "/share/zoneinfo"))
+ #t)))))
+ (native-inputs
+ `(("tzdata" ,tzdata)))
+ (home-page "http://fragglet.github.com/lhasa/")
+ (synopsis "LHA implementation")
+ (description "Lhasa is a replacement for the Unix LHA tool, for
+decompressing .lzh (LHA / LHarc) and .lzs (LArc) archives. The backend for the
+tool is a library, so that it can be reused for other purposes. Lhasa aims to
+be compatible with as many types of lzh/lzs archives as possible. It also aims
+to generate the same output as the (non-free) Unix LHA tool, so that it will
+act as a drop-in free replacement.")
+ (license license:isc)))
+
(define-public lzo
(package
(name "lzo")
--
2.20.1
Ricardo Wurmus wrote 6 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 34205@debbugs.gnu.org)
878sz7vcvr.fsf@elephly.net
Hi Kei,

Toggle quote (2 lines)
> * gnu/packages/compression.scm (lhasa): New variable.

this looks good to me.

A few minor suggestions:

Toggle quote (2 lines)
Please use HTTPS.

Toggle quote (2 lines)
> + (synopsis "LHA implementation")

I’d prefer “Parse LHA archives” or something else that hints at what
“LHA” is.

Toggle quote (7 lines)
> + (description "Lhasa is a replacement for the Unix LHA tool, for
> +decompressing .lzh (LHA / LHarc) and .lzs (LArc) archives. The backend for the
> +tool is a library, so that it can be reused for other purposes. Lhasa aims to
> +be compatible with as many types of lzh/lzs archives as possible. It also aims
> +to generate the same output as the (non-free) Unix LHA tool, so that it will
> +act as a drop-in free replacement.")

I’d say “free drop-in replacement”.

--
Ricardo
Kei Kebreau wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 34205@debbugs.gnu.org)
87pnsjbdpk.fsf@posteo.net
Thanks for the suggestions! I've attached a revised patch with the
suggested changes.
From a8ddb85540c9ee3d4b125f36652330fab565c65e Mon Sep 17 00:00:00 2001
From: Kei Kebreau <kkebreau@posteo.net>
Date: Fri, 25 Jan 2019 20:22:23 -0500
Subject: [PATCH] gnu: Add lhasa.

* gnu/packages/compression.scm (lhasa): New variable.
---
gnu/packages/compression.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 327951fde..cb56137fd 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
@@ -434,6 +434,39 @@ than gzip and 15 % smaller output than bzip2.")
(license (list license:gpl2+ license:lgpl2.1+)) ; bits of both
(home-page "https://tukaani.org/xz/")))
+(define-public lhasa
+ (package
+ (name "lhasa")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/fragglet/lhasa/releases/download/v"
+ version "/lhasa-" version ".tar.gz"))
+ (sha256
+ (base32
+ "092zi9av18ma20c6h9448k0bapvx2plnp292741dvfd9hmgqxc1z"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-up-test-environment
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TZDIR" (string-append (assoc-ref inputs "tzdata")
+ "/share/zoneinfo"))
+ #t)))))
+ (native-inputs
+ `(("tzdata" ,tzdata)))
+ (home-page "https://fragglet.github.com/lhasa/")
+ (synopsis "LHA archive decompressor")
+ (description "Lhasa is a replacement for the Unix LHA tool, for
+decompressing .lzh (LHA / LHarc) and .lzs (LArc) archives. The backend for the
+tool is a library, so that it can be reused for other purposes. Lhasa aims to
+be compatible with as many types of lzh/lzs archives as possible. It also aims
+to generate the same output as the (non-free) Unix LHA tool, so that it will
+act as a free drop-in replacement.")
+ (license license:isc)))
+
(define-public lzo
(package
(name "lzo")
--
2.20.1
Ricardo Wurmus wrote 6 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 34205-done@debbugs.gnu.org)
87a7jhopv9.fsf@elephly.net
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (10 lines)
> Thanks for the suggestions! I've attached a revised patch with the
> suggested changes.
>
> From a8ddb85540c9ee3d4b125f36652330fab565c65e Mon Sep 17 00:00:00 2001
> From: Kei Kebreau <kkebreau@posteo.net>
> Date: Fri, 25 Jan 2019 20:22:23 -0500
> Subject: [PATCH] gnu: Add lhasa.
>
> * gnu/packages/compression.scm (lhasa): New variable.

LGTM! I pushed it to “master” with commit 0dcea35d9.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34205@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34205
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help