[PATCH] gnu: Add stoken.

  • Done
  • quality assurance status badge
Details
2 participants
  • ericbavier
  • Ricardo Wurmus
Owner
unassigned
Submitted by
ericbavier
Severity
normal

Debbugs page

ericbavier wrote 6 years ago
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@member.fsf.org)
20190125193128.13038-1-ericbavier@centurylink.net
From: Eric Bavier <bavier@member.fsf.org>

* gnu/packages/crypto.scm (stoken): New variable.
---
gnu/packages/crypto.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 2c63e53191..a41543289c 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox>
;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
-;;; Copyright © 2016, 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016, 2017, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
@@ -902,3 +902,29 @@ Features:
@end itemize\n")
(home-page "https://github.com/bitcoin-core/secp256k1")
(license license:unlicense))))
+
+(define-public stoken
+ (package
+ (name "stoken")
+ (version "0.92")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/stoken/"
+ "stoken-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0npgr6y85gzwksy8jkwa4yzvqwjprwnplx3yiw3ayk4f0ldlhaxa"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("nettle" ,nettle)
+ ("libxml2" ,libxml2)))
+ (home-page "https://stoken.sf.net")
+ (synopsis "Software Token for cryptographic authentication")
+ (description
+ "@code{stoken} is a tokencode generator compatible with RSA SecurID
+128-bit (AES) tokens. This package contains a standalong command-line program
+that allows for importing token seeds, generating tokencodes, and various
+utility/testing functions.")
+ (license license:lgpl2.1+)))
--
2.20.1
Ricardo Wurmus wrote 6 years ago
(address . ericbavier@centurylink.net)
8736pfv82a.fsf@elephly.net
Hi Eric,

thanks for the patch!

Toggle quote (1 lines)
> * gnu/packages/crypto.scm (stoken): New variable.
[…]
Toggle quote (2 lines)
> + (home-page "https://stoken.sf.net")

Sourceforge home pages don’t seem to support HTTPS.

Toggle quote (8 lines)
> + (synopsis "Software Token for cryptographic authentication")
> + (description
> + "@code{stoken} is a tokencode generator compatible with RSA SecurID
> +128-bit (AES) tokens. This package contains a standalong command-line program
> +that allows for importing token seeds, generating tokencodes, and various
> +utility/testing functions.")
> + (license license:lgpl2.1+)))

“standalong” should be “standalone”; I’d also separate the term
“tokencodes”.

Other than that it looks good to me!

--
Ricardo
Eric Bavier wrote 6 years ago
20190126174854.33644e9f@centurylink.net
On Sat, 26 Jan 2019 14:53:49 +0100
Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (10 lines)
> Hi Eric,
>
> thanks for the patch!
>
> > * gnu/packages/crypto.scm (stoken): New variable.
> […]
> > + (home-page "https://stoken.sf.net")
>
> Sourceforge home pages don’t seem to support HTTPS.

Hm, transcription error, I guess.

Toggle quote (12 lines)
>
> > + (synopsis "Software Token for cryptographic authentication")
> > + (description
> > + "@code{stoken} is a tokencode generator compatible with RSA SecurID
> > +128-bit (AES) tokens. This package contains a standalong command-line program
> > +that allows for importing token seeds, generating tokencodes, and various
> > +utility/testing functions.")
> > + (license license:lgpl2.1+)))
>
> “standalong” should be “standalone”; I’d also separate the term
> “tokencodes”.

Done.

Toggle quote (3 lines)
>
> Other than that it looks good to me!

Thanks for the review, Ricardo!

Pushed with fixes to master in c2ab3b84398df0b26e6127ea0c336a39e8950d17.

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlxM8eYACgkQ/XPKxxnT
JWbhHw/+LxPR7j3+yt4M5HXvxZpZLOhAf1ztMWVQi41WfJCPs66OS6eeKcoyHKCS
S7KejgVuPNoruN0R7zf9vsWzlf9LwBgYX8DdnHMgBg2D0NnhUDgbxGuUHnwAZMRI
FNmIfapJFbCGPlLNrly3KegXy9bBkewoGkIni1TbC9Ec2R19ynoHtq17A+IkwOZ6
/B36NZ0aEDcTdvZT8zX+oQrmuF5NRWo4SUNbAULPbMlNbgmiTD+AeJzukd8+cvNe
GhDSOR3KX2fJInlnM2Hyzg9TY4uoozpMmjqyln7tKSriJ+iDOK/HGLAYRJVMMKlI
/5cJAz/opmIN1TcZoN6DjMR+cuHi1JS0we74OnihQyWAZnkVDa3JZJILPjezbhtr
utItWvYdh7WfbdkHbEGiQ34oqo7vQC65hu7UNiQXF7biqNJ+KqnyxrUQNS6ySOpB
ReCR0r4zPhenlaRRX7E8afzgDdY6UhGwxXf4xQeubE0omlKAA/K2IDR7j8oH/Lyz
FXiLI3gLQwBwRkq5AipHM9gAa4xd919DwJum59sQ2qsHx65N/qW01LIRufBjXk6f
aIOKH+oMIEq8J1b3LK6F14Ez5VXrfABrK3qD13S7I/4BrbVY4+QifiQy7sRUFGm2
tqpeSZwVPyTTd5zbE0KCtjkU/jZKtZP08S6ubNgDe/LRUNtuSxw=
=ui1q
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34200@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34200
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help