Update electrum, add python-aiohttp-socks and python-aiorpcx

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
87ef98nr6q.fsf@ponder
The following patches update electrum, requring updated inputs, and two
new packages, python-aiohttp-socks and python-aiorpcx.

finance.scm | 8 ++++++--
python-web.scm | 45 +++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 51 insertions(+), 2 deletions(-)

Thanks in advance for the review!

live well,
vagrant
From 3564dce5223f99397864c90a6080ad82fa4441ce Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Thu, 17 Jan 2019 00:17:11 +0000
Subject: [PATCH 1/3] gnu: Add python-aiohttp-socks.

* gnu/packages/python-web.scm (python-aiohttp-socks): New variable.
---
gnu/packages/python-web.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index af0595b36..3141600c6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -102,6 +102,27 @@ Callback Hell.
@end itemize")
(license license:asl2.0)))
+(define-public python-aiohttp-socks
+(package
+ (name "python-aiohttp-socks")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "aiohttp_socks" version))
+ (sha256
+ (base32
+ "0473702jk66xrgpm28wbdgpnak4v0dh2qmdjw7ky7hf3lwwqkggf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-aiohttp" ,python-aiohttp)))
+ (home-page
+ "https://github.com/romis2012/aiohttp-socks")
+ (synopsis "SOCKS proxy connector for aiohttp")
+ (description "SOCKS proxy connector for aiohttp. SOCKS4(a) and SOCKS5 are
+supported.")
+ (license license:asl2.0)))
+
(define-public python-aiodns
(package
(name "python-aiodns")
--
2.20.1
From 415058c95d1568c2677a424084d78d0f12e0eca8 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Thu, 17 Jan 2019 00:18:41 +0000
Subject: [PATCH 2/3] gnu: Add python-aiorpcx.

* gnu/packages/python-web.scm (python-aiorpcx): New variable.
---
gnu/packages/python-web.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3141600c6..3caba6637 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -146,6 +146,30 @@ asynchronous DNS resolutions with a synchronous looking interface by
using @url{https://github.com/saghul/pycares,pycares}.")
(license license:expat)))
+(define-public python-aiorpcx
+(package
+ (name "python-aiorpcx")
+ (version "0.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "aiorpcX" version))
+ (sha256
+ (base32
+ "1p88k15jh0d2a18pnnbfcamsqi2bxvmmhpizmdlxfdxf8vy5ggyj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)))
+ (home-page
+ "https://github.com/kyuupichan/aiorpcX")
+ (synopsis
+ "Generic async RPC implementation, including JSON-RPC")
+ (description
+ "A generic asyncio library implementation of RPC suitable for an application that is a client, server or both.
+
+The package includes a module with full coverage of JSON RPC versions 1.0 and 2.0, JSON RPC protocol auto-detection, and arbitrary message framing. It also comes with a SOCKS proxy client.")
+ (license (list license:expat license:bsd-2))))
+
(define-public python-falcon
(package
(name "python-falcon")
--
2.20.1
From 9256c2bbea5d79b2ad827f9a570932be2b38acdb Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Tue, 15 Jan 2019 04:51:34 +0000
Subject: [PATCH 3/3] gnu: electrum: Update to 3.3.2.

* gnu/packages/finance.scm (electrum): Update to 3.2.2.
[inputs]: Add python-aiohttp, python-aiohttp-socks, python-aiorpcx and
python-certifi.
---
gnu/packages/finance.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 468388797..293aa1f7d 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -293,7 +293,7 @@ do so.")
(define-public electrum
(package
(name "electrum")
- (version "3.2.2")
+ (version "3.3.2")
(source
(origin
(method url-fetch)
@@ -302,7 +302,7 @@ do so.")
version ".tar.gz"))
(sha256
(base32
- "1fxaxlf5vm2zydj678ls3pazyriym188iwzk60kyk26cz2p3xk39"))
+ "0vgfdhwvrrl6dr4rd4hhxr8304bxm00sh7fw4nalm4hf7gfsbcji"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -320,6 +320,10 @@ do so.")
("python-requests" ,python-requests)
("python-qrcode" ,python-qrcode)
("python-protobuf" ,python-protobuf)
+ ("python-aiohttp" ,python-aiohttp)
+ ("python-aiohttp-socks" ,python-aiohttp-socks)
+ ("python-aiorpcx" ,python-aiorpcx)
+ ("python-certifi" ,python-certifi)
("python-dnspython" ,python-dnspython)
("python-jsonrpclib-pelix" ,python-jsonrpclib-pelix)))
(arguments
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXEO3ngAKCRDcUY/If5cW
qp6qAP0ZrwX7GYv+ZXkINGlQZISdSYuI7wQlVTWqYQOvmKJhawEAp7hi1hqaR73l
wCnrZPy4iSiUGt3C+jNiCuXFfdkNewA=
=qB0G
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 34139@debbugs.gnu.org)
87tvhwmo3e.fsf@gnu.org
Hello Vagrant,

Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (3 lines)
> The following patches update electrum, requring updated inputs, and two
> new packages, python-aiohttp-socks and python-aiorpcx.

Nipick: could you adjust the indentation of the new packages (you can
pass them through ./etc/indent-code.el if you want¹), and make sure
descriptions contain full sentences²?

With these changes we’ll be all set. :-)

Thank you!

Ludo’.

Vagrant Cascadian wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 34139@debbugs.gnu.org)
87h8doe9qk.fsf@ponder
On 2019-01-25, Ludovic Courtès wrote:
Toggle quote (5 lines)
> Vagrant Cascadian <vagrant@debian.org> skribis:
>
>> The following patches update electrum, requring updated inputs, and two
>> new packages, python-aiohttp-socks and python-aiorpcx.

New patch series...

Updated to electrum 3.3.3.

Toggle quote (3 lines)
> Nipick: could you adjust the indentation of the new packages (you can
> pass them through ./etc/indent-code.el if you want¹),

Done.

Toggle quote (2 lines)
> and make sure descriptions contain full sentences²?

Struggled with this a bit. Thankfully, mbakke made some minimal
suggestions in irc about fixing up the description for
python-aiohttp-socks. Hopefully that's good enough.

Thanks!

live well,
vagrant
From 65b287d82f90b821e0ef6ce21d8563e7df4607f3 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Thu, 17 Jan 2019 00:17:11 +0000
Subject: [PATCH 1/3] gnu: Add python-aiohttp-socks.

* gnu/packages/python-web.scm (python-aiohttp-socks): New variable.
---
gnu/packages/python-web.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 97b1f0661..739f5fd8a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -102,6 +102,27 @@ Callback Hell.
@end itemize")
(license license:asl2.0)))
+(define-public python-aiohttp-socks
+ (package
+ (name "python-aiohttp-socks")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "aiohttp_socks" version))
+ (sha256
+ (base32
+ "0473702jk66xrgpm28wbdgpnak4v0dh2qmdjw7ky7hf3lwwqkggf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-aiohttp" ,python-aiohttp)))
+ (home-page
+ "https://github.com/romis2012/aiohttp-socks")
+ (synopsis "SOCKS proxy connector for aiohttp")
+ (description "This package provides a SOCKS proxy connector for
+aiohttp. It supports SOCKS4(a) and SOCKS5.")
+ (license license:asl2.0)))
+
(define-public python-aiodns
(package
(name "python-aiodns")
--
2.20.1
From 8e1f70364b46dc416116147342a4236a4232f196 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Thu, 17 Jan 2019 00:18:41 +0000
Subject: [PATCH 2/3] gnu: Add python-aiorpcx.

* gnu/packages/python-web.scm (python-aiorpcx): New variable.
---
gnu/packages/python-web.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 739f5fd8a..823a007ce 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -146,6 +146,30 @@ asynchronous DNS resolutions with a synchronous looking interface by
using @url{https://github.com/saghul/pycares,pycares}.")
(license license:expat)))
+(define-public python-aiorpcx
+ (package
+ (name "python-aiorpcx")
+ (version "0.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "aiorpcX" version))
+ (sha256
+ (base32
+ "1p88k15jh0d2a18pnnbfcamsqi2bxvmmhpizmdlxfdxf8vy5ggyj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)))
+ (home-page
+ "https://github.com/kyuupichan/aiorpcX")
+ (synopsis
+ "Generic async RPC implementation, including JSON-RPC")
+ (description
+ "A generic asyncio library implementation of RPC suitable for an application that is a client, server or both.
+
+The package includes a module with full coverage of JSON RPC versions 1.0 and 2.0, JSON RPC protocol auto-detection, and arbitrary message framing. It also comes with a SOCKS proxy client.")
+ (license (list license:expat license:bsd-2))))
+
(define-public python-falcon
(package
(name "python-falcon")
--
2.20.1
From 54d18a3a69ebbe6430d13bbb15f603cdc31a4129 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Tue, 15 Jan 2019 04:51:34 +0000
Subject: [PATCH 3/3] gnu: electrum: Update to 3.3.3.

* gnu/packages/finance.scm (electrum): Update to 3.3.3.
[inputs]: Add python-aiohttp, python-aiohttp-socks, python-aiorpcx and
python-certifi.
---
gnu/packages/finance.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 250b1db14..b48aaa9c5 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -299,7 +299,7 @@ do so.")
(define-public electrum
(package
(name "electrum")
- (version "3.2.2")
+ (version "3.3.3")
(source
(origin
(method url-fetch)
@@ -308,7 +308,7 @@ do so.")
version ".tar.gz"))
(sha256
(base32
- "1fxaxlf5vm2zydj678ls3pazyriym188iwzk60kyk26cz2p3xk39"))
+ "0z2zfhyawrbzs0w1426a2w0d4wsajl34ymj77qmpm41138g2ysf2"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -326,6 +326,10 @@ do so.")
("python-requests" ,python-requests)
("python-qrcode" ,python-qrcode)
("python-protobuf" ,python-protobuf)
+ ("python-aiohttp" ,python-aiohttp)
+ ("python-aiohttp-socks" ,python-aiohttp-socks)
+ ("python-aiorpcx" ,python-aiorpcx)
+ ("python-certifi" ,python-certifi)
("python-dnspython" ,python-dnspython)
("python-jsonrpclib-pelix" ,python-jsonrpclib-pelix)))
(arguments
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXFN4NQAKCRDcUY/If5cW
qnQiAPwIYZsKAoMb/5LyM//uuvbU0bu6OFq6FGS2BI38yvcc8gD+OUyTRz2gb88O
C2xTr+NnGI+YGuteWmshmpQIxrfeWAw=
=6pbz
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 34139-done@debbugs.gnu.org)
87lg2opp84.fsf@gnu.org
Hello,

Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (7 lines)
> From 65b287d82f90b821e0ef6ce21d8563e7df4607f3 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@debian.org>
> Date: Thu, 17 Jan 2019 00:17:11 +0000
> Subject: [PATCH 1/3] gnu: Add python-aiohttp-socks.
>
> * gnu/packages/python-web.scm (python-aiohttp-socks): New variable.

[...]

Toggle quote (7 lines)
> From 8e1f70364b46dc416116147342a4236a4232f196 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@debian.org>
> Date: Thu, 17 Jan 2019 00:18:41 +0000
> Subject: [PATCH 2/3] gnu: Add python-aiorpcx.
>
> * gnu/packages/python-web.scm (python-aiorpcx): New variable.

[...]

Toggle quote (9 lines)
> From 54d18a3a69ebbe6430d13bbb15f603cdc31a4129 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@debian.org>
> Date: Tue, 15 Jan 2019 04:51:34 +0000
> Subject: [PATCH 3/3] gnu: electrum: Update to 3.3.3.
>
> * gnu/packages/finance.scm (electrum): Update to 3.3.3.
> [inputs]: Add python-aiohttp, python-aiohttp-socks, python-aiorpcx and
> python-certifi.

I finally applied all three patches with minor tweaks to the
descriptions; I also added a copyright line for you in python-web.scm.
Sorry for the delay!

Unfortunately qtwebkit, a dependency of Electrum, currently fails to
build on ‘master’:

Toggle snippet (10 lines)
[ 81%] Generating ../../DerivedSources/WebKit2/AuthenticationManagerMessageReceiver.cpp, ../../DerivedSources/WebKit2/AuthenticationManagerMessages.h
cd /tmp/guix-build-qtwebkit-5.212.0-alpha2.drv-0/qtwebkit-5.212.0-alpha2/Source/WebKit2 && /gnu/store/g87hamjyipk1j6dfq5pjfzfnfb64spbv-python2-2.7.15/bin/python2.7 /tmp/guix-build-qtwebkit-5.212.0-alpha2.drv-0/qtwebkit-5.212.0-alpha2/Source/WebKit2/Scripts/generate-message-receiver.py Shared/Authentication/AuthenticationManager.messages.in > /tmp/guix-build-qtwebkit-5.212.0-alpha2.drv-0/build/DerivedSources/WebKit2/AuthenticationManagerMessageReceiver.cpp
Traceback (most recent call last):
File "/tmp/guix-build-qtwebkit-5.212.0-alpha2.drv-0/qtwebkit-5.212.0-alpha2/Source/WebKit2/Scripts/generate-message-receiver.py", line 28, in <module>
import webkit.messages
EOFError: EOF read where object expected
cd /tmp/guix-build-qtwebkit-5.212.0-alpha2.drv-0/qtwebkit-5.212.0-alpha2/Source/WebKit2 && /gnu/store/g87hamjyipk1j6dfq5pjfzfnfb64spbv-python2-2.7.15/bin/python2.7 /tmp/guix-build-qtwebkit-5.212.0-alpha2.drv-0/qtwebkit-5.212.0-alpha2/Source/WebKit2/Scripts/generate-messages-header.py NetworkProcess/NetworkResourceLoader.messages.in > /tmp/guix-build-qtwebkit-5.212.0-alpha2.drv-0/build/DerivedSources/WebKit2/NetworkResourceLoaderMessages.h
make[2]: *** [Source/WebKit2/CMakeFiles/WebKit2.dir/build.make:194: DerivedSources/WebKit2/ChildProcessMessageReceiver.cpp] Error 1

See

Interestingly this was first reported here for WebkitGTK:

To be continued…

Thanks,
Ludo’.
Closed
Vagrant Cascadian wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 34139-done@debbugs.gnu.org)
878syourjw.fsf@ponder
On 2019-02-09, Ludovic Courtès wrote:
Toggle quote (4 lines)
> Vagrant Cascadian <vagrant@debian.org> skribis:
>> Subject: [PATCH 1/3] gnu: Add python-aiohttp-socks.
>> Subject: [PATCH 2/3] gnu: Add python-aiorpcx.
>> Subject: [PATCH 3/3] gnu: electrum: Update to 3.3.3.
...
Toggle quote (4 lines)
> I finally applied all three patches with minor tweaks to the
> descriptions; I also added a copyright line for you in python-web.scm.
> Sorry for the delay!

Thanks!

Toggle quote (2 lines)
> Unfortunately qtwebkit, a dependency of Electrum, currently fails to
> build on ‘master’:
...
Toggle quote (3 lines)
> See
> <https://ci.guix.info/log/901miwpk9srhwq3646v6bm7zni3qda8m-qtwebkit-5.212.0-alpha2>.

FWIW, I was eventually able to build qtwebkit locally after freeing up
some disk space; it takes at *least* 12GB free to build, in my
experience... saw the build go as high as ~11.5GB at one point, don't
know how much it eventually needed.

So I've managed to install the new version of electrum without local
patches!


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXF+6BAAKCRDcUY/If5cW
qnRYAQDoZ0qTzBadhxHQRYTV+eUR6R5X9KKj6I7xBmjy2/LCZgD+LY3EByJlPGjX
R1CqaF9f1Y5IHJNhdu2N/wojEegUVgk=
=JLdV
-----END PGP SIGNATURE-----

Closed
Ludovic Courtès wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 34139-done@debbugs.gnu.org)
87mun2s31k.fsf@gnu.org
Hi Vagrant,

Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (3 lines)
> On 2019-02-09, Ludovic Courtès wrote:
>> Vagrant Cascadian <vagrant@debian.org> skribis:

[...]

Toggle quote (11 lines)
>> Unfortunately qtwebkit, a dependency of Electrum, currently fails to
>> build on ‘master’:
> ...
>> See
>> <https://ci.guix.info/log/901miwpk9srhwq3646v6bm7zni3qda8m-qtwebkit-5.212.0-alpha2>.
>
> FWIW, I was eventually able to build qtwebkit locally after freeing up
> some disk space; it takes at *least* 12GB free to build, in my
> experience... saw the build go as high as ~11.5GB at one point, don't
> know how much it eventually needed.

In the meantime I also fixed the qtwebkit issue:


Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34139@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34139
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help