[PATCH 1/2] gnu: Add ghc-mtl.

  • Done
  • quality assurance status badge
Details
3 participants
  • Gabriel Hondet
  • Ludovic Courtès
  • Timothy Sample
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
878szgv0tw.fsf@gmail.com
* gnu/packages/haskell.scm (ghc-mtl): New variable.
---
gnu/packages/haskell.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a3ce2a3e4..97616d451 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11405,4 +11405,29 @@ from a shell. The @code{tldr} pages are a community effort to simplify the
man pages with practical examples.")
(license license:bsd-3)))
+(define-public ghc-mtl
+ (package
+ (name "ghc-mtl")
+ (version "1.2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/ghc-mtl/ghc-mtl-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0h6r6gip9nsjlsq88wj105hhqliy7ac2dmmndsfzbjz07b03cklk"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)))
+ (home-page "https://hub.darcs.net/jcpetruzza/ghc-mtl")
+ (synopsis
+ "Mtl compatible version of the Ghc-Api monads and monad-transformers")
+ (description "Provides an @code{mtl} compatible version of the @code{GhcT}
+monad-transformer defined in the @code{GHC-API} since version 6.10.1.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxDiwsACgkQMbyBBfZZ
1CXD+Q/+Oe4swMWWd9ktDNwZmi8hgWNB9StJWpXjfe491xvPWuG4t4kPUVI5vPLr
CoCPrxTx3U5buEyZXSzluIAmFQHNQCqL6MZgANNHUaanuGkt+Ga61wC6W2DUZ0GD
X2ch0fOrm5Nf0cOeqNqKpx8LZLQAipQbY+uoe+AhCcH1YliecCpHVKClpLd6yheS
yTr4CpDQ12f4m6KfjLh0yuwAxgCt7TLslABQ9M/GFK2At2U2mdO0sDjRUTAV0ATi
SXT9VQfZPABaKK0CEQPRBgUOQ5p9tQA+d9K1Lu/4fEg+I/6M6U6HKEy5WmsUeV7/
fItpzlwoWC4E2LLcq8esEk25Kmgd6vrMaPLK6c/ZJTUrtzI4QmU32KauooJdf/ry
WbDEW41g+RAVFM2ENQrPADiJR+pQe8XLWWljnMr2Rh7XxU1g+UefNTKvNCDhmaIC
3yNE87Wol3r748qt5lWsJtzjVJU7eb3S1qdM5K2w2DrXpBb5n1MEnAO2VR/HMsQF
UeTp7+7+R+z8nSvM6kGWs3T2UvAbtxAYkMipse5NKBan4bUwnXoHOpYu3DEYTJJQ
6/J8mQoaVdiX2oWxKzgKGKecKpmk7oo3z1D48Lyx8ZFr5W6FQ+pUZc63GuCrHwV2
g6AyfWJjGnXYJulmBPvSdmvTfIMUqSaV5q9kSDGKrJgF7xFOycQ=
=R7kc
-----END PGP SIGNATURE-----

Gabriel Hondet wrote 6 years ago
[PATCH 2/2] gnu: Add ghc-libmpd.
(address . 34137@debbugs.gnu.org)
877ef0v09g.fsf@gmail.com
* gnu/packages/mpd.scm (ghc-libmpd): New variable.
---
gnu/packages/mpd.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 3fe5d06f4..34fc9f6b7 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
+ #:use-module (guix build-system haskell)
#:use-module (gnu packages avahi)
#:use-module (gnu packages boost)
#:use-module (gnu packages gcc)
@@ -47,6 +49,8 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages mp3)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages haskell)
+ #:use-module (gnu packages haskell-check)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -360,3 +364,39 @@ Daemon (MPD). It supports playlists, multiple profiles (connecting to different
MPD servers, search and multimedia key support.")
(home-page "https://www.nongnu.org/sonata/")
(license license:gpl3+)))
+
+(define-public ghc-libmpd
+ (package
+ (name "ghc-libmpd")
+ (version "0.9.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/libmpd/libmpd-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1931m23iqb4wddpdidm4ph746zpaw41kkjzmb074j7yyfpk7x1jv"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-text" ,ghc-text)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-network" ,ghc-network)
+ ("ghc-utf8-string" ,ghc-utf8-string)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
+ (arguments
+ '(#:tests? #f)) ;song parsing test fail
+ (home-page
+ "http://github.com/vimus/libmpd-haskell#readme")
+ (synopsis "MPD client library")
+ (description
+ "A client library for MPD, the Music Player Daemon.")
+ (license license:expat)))
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxDjesACgkQMbyBBfZZ
1CWgFRAAqF2fd5PVE8eGFC+rnj71d81gFOBECcSkwXkROgtxbLoxpGrdFjfmpqT6
FWGWX2l+JybEbNg1wA1t+0/TxnUWmhBTR93dYozhl8ZhZdgaKx2EHbhT2Tt69o+i
bqRfnvxYu25Y3bjLqKB8JG6s4RgCfltJi1PilMg+rOvnMhxL8mdVchxvS6TSuXeR
b/ppZbeRZlW0ZwHoo8eCZhp6iGYYzPtBrMmJUeXpzC2wPLpCJ3wj2Wo7GxkV5pg/
A7IVjHjLgmjLgHrhBH9zTchOvvWHcnPpaaqH9lPPMVs2ey1ZWZzZfxKXVYcx6m7C
DUNuOntAYiRJyK/uoWIHV6XgFrRRRdh2SBY+s20NBmr/NTvVuXr134uP1cMUzWAk
JErMxBx6vN566pnkriexkfFicWN3ZBKfZLT6zI1odibMCLjrX7IlZrvcRTGbd8h1
GxcBbnuMce+W8GvlnP6bwe7tNDzt7K7xy+hzX/uRzv4k6SW3JC5P0AFvfm0IFpM6
caNmx+8CyNCuCs2LQEMAXq0rkL6C/0HYGOctxQw/VTwGD0TC20r/X9Xe9klJ1J90
bSdehvY4D7OCv4rVJUhTUUKp1QQHlBSnTiTHu/imUjVFlJvdDAS+gTki4739+dpt
b5Tm9AbiqMGGMvElBx5U1Yjtz++gw793l8S0pTLGtROK6mZGuXE=
=YML5
-----END PGP SIGNATURE-----

Timothy Sample wrote 6 years ago
Re: [bug#34137] [PATCH 1/2] gnu: Add ghc-mtl.
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 34137@debbugs.gnu.org)
87ef978fco.fsf@ngyro.com
Hi Gabriel,

Gabriel Hondet <gabrielhondet@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/haskell.scm (ghc-mtl): New variable.

Thank you very much for the patch!

GHC 8.4.3 has ghc-mtl built-in. This means that we don’t need to have a
separate package for it. We used to have a package for it, but it was
removed in commit f54f04756f6d90c9fb3b5e45f3947329287f9b05 as a part of
upgrading GHC. We try to avoid having separate packages for Haskell
libraries that are built-in to GHC because they cause problems
(incompatibilities in the dependency graph).

You should be able to remove the “ghc-mtl” input from the MPD package
without any issue.

(Sadly, the importer is not clever enough to filter out built-in
libraries, so it has to be done manually.)

Toggle quote (3 lines)
> [...]


-- Tim
Gabriel Hondet wrote 6 years ago
Re: [bug#34137] [PATCH] gnu: Add ghc-libmp.
(name . Timothy Sample)(address . samplet@ngyro.com)(address . 34137@debbugs.gnu.org)
874la2v4et.fsf@gmail.com
Hi Timothy,

On Sun 20 Jan 2019 at 17:26 Timothy Sample wrote:

Toggle quote (3 lines)
> You should be able to remove the “ghc-mtl” input from the MPD package
> without any issue.

Indeed and it works even better, so here is the new patch:

* gnu/packages/mpd.scm (ghc-libmpd): New variable.
---
gnu/packages/mpd.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (69 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 3fe5d06f4..df4f64470 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
+ #:use-module (guix build-system haskell)
#:use-module (gnu packages avahi)
#:use-module (gnu packages boost)
#:use-module (gnu packages gcc)
@@ -51,6 +53,8 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages haskell)
+ #:use-module (gnu packages haskell-check)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages video)
@@ -360,3 +364,34 @@ Daemon (MPD). It supports playlists, multiple profiles (connecting to different
MPD servers, search and multimedia key support.")
(home-page "https://www.nongnu.org/sonata/")
(license license:gpl3+)))
+
+(define-public ghc-libmpd
+ (package
+ (name "ghc-libmpd")
+ (version "0.9.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/libmpd/libmpd-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1931m23iqb4wddpdidm4ph746zpaw41kkjzmb074j7yyfpk7x1jv"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-text" ,ghc-text)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-network" ,ghc-network)
+ ("ghc-utf8-string" ,ghc-utf8-string)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "http://github.com/vimus/libmpd-haskell#readme")
+ (synopsis "MPD client library")
+ (description "A client library for MPD, the Music Player Daemon.")
+ (license license:expat)))
--
2.20.1

Thanks for your help!
Gabriel
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxFeOoACgkQMbyBBfZZ
1CXZNg//ZEQ+XL1oDGuWpWoJ5hQzX0iGOVxID1pcPZlXTJP+e4l8Ov/RvVSTSFJ9
d/Rr8nVnSDGEnlCJbokOmHKgWC7fo5iaynYDO4zh8aLUSKRqFuw6ge3H7Nuw4z5t
KGHveQhYYGzTtWnr5ns+CQnXLer203NzavwG5YrkGCD3uBBdPEetnk2DnEGvqlVU
0S4iMDEnylrIyA9gyhGmVobW6uI5fEfGAOeTE3xVGSF+RsGyD9SE0ZGu/Go5CKCR
Soq1F2sX7F653jOEIMQX8UBaE/qYdb1k+QrmrSJJLotYHhSc9CugiztNzUYTIk0R
jPp/xkwGEFDHccYJJiKQoEMi1+xiMA76ILBw93kZieodg0TvXIcfo83+pWN8ehjk
tQ/eRB7Rw+0GNU710yzMGZcnC9OolmcBcD648m7SucN7Ra/WnvS3NCB+iYGjoCLG
H8JXNhyz7SH6rKF8imW9Cji2iio+N4d/CHFiBHiLn3VZxoPQC7ooUtK2qQoPdhBk
iEQy6GR984ooBmxkG4qegA9ynoVJndhXvB0kyX/xF0gIaUbScp2iYeosW19vvckO
rTBH6xZwEcTdS48SJYhBl7C+1W0+jErS9sl/9vUGiyiAaM/IkeRWikYWmhN+vowx
cxk7OMyNd4gSTiWDgnCbvOtKN6yZ6CRdDWAWHjbTtXX2hJw5ogk=
=mOkR
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)
87fttjdnvx.fsf@gnu.org
Hi Gabriel,

Gabriel Hondet <gabrielhondet@gmail.com> skribis:

Toggle quote (27 lines)
> diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
> index 3fe5d06f4..df4f64470 100644
> --- a/gnu/packages/mpd.scm
> +++ b/gnu/packages/mpd.scm
> @@ -6,6 +6,7 @@
> ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
> ;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
> ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
> +;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -31,6 +32,7 @@
> #:use-module (guix build-system gnu)
> #:use-module (guix build-system meson)
> #:use-module (guix build-system python)
> + #:use-module (guix build-system haskell)
> #:use-module (gnu packages avahi)
> #:use-module (gnu packages boost)
> #:use-module (gnu packages gcc)
> @@ -51,6 +53,8 @@
> #:use-module (gnu packages pkg-config)
> #:use-module (gnu packages python)
> #:use-module (gnu packages python-xyz)
> + #:use-module (gnu packages haskell)
> + #:use-module (gnu packages haskell-check)

In an effort to avoid pulling in all the Haskell package collection from
mpd.scm, could you move ghc-libmpd to haskell.scm or a new
haskell-audio.scm file?

Thanks!

Ludo’.
Timothy Sample wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 34137@debbugs.gnu.org)
87d0omzt5t.fsf@ngyro.com
Hi Gabriel,

Gabriel Hondet <gabrielhondet@gmail.com> writes:

Toggle quote (9 lines)
> Hi Timothy,
>
> On Sun 20 Jan 2019 at 17:26 Timothy Sample wrote:
>
>> You should be able to remove the “ghc-mtl” input from the MPD package
>> without any issue.
>
> Indeed and it works even better, so here is the new patch:

Glad to hear it. I checked the ghc-libmpd package, and have a few notes
(in addition to what Ludo said about moving it).

Toggle quote (67 lines)
> * gnu/packages/mpd.scm (ghc-libmpd): New variable.
> ---
> gnu/packages/mpd.scm | 35 +++++++++++++++++++++++++++++++++++
> 1 file changed, 35 insertions(+)
>
> diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
> index 3fe5d06f4..df4f64470 100644
> --- a/gnu/packages/mpd.scm
> +++ b/gnu/packages/mpd.scm
> @@ -6,6 +6,7 @@
> ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
> ;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
> ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
> +;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -31,6 +32,7 @@
> #:use-module (guix build-system gnu)
> #:use-module (guix build-system meson)
> #:use-module (guix build-system python)
> + #:use-module (guix build-system haskell)
> #:use-module (gnu packages avahi)
> #:use-module (gnu packages boost)
> #:use-module (gnu packages gcc)
> @@ -51,6 +53,8 @@
> #:use-module (gnu packages pkg-config)
> #:use-module (gnu packages python)
> #:use-module (gnu packages python-xyz)
> + #:use-module (gnu packages haskell)
> + #:use-module (gnu packages haskell-check)
> #:use-module (gnu packages pulseaudio)
> #:use-module (gnu packages sqlite)
> #:use-module (gnu packages video)
> @@ -360,3 +364,34 @@ Daemon (MPD). It supports playlists, multiple profiles (connecting to different
> MPD servers, search and multimedia key support.")
> (home-page "https://www.nongnu.org/sonata/")
> (license license:gpl3+)))
> +
> +(define-public ghc-libmpd
> + (package
> + (name "ghc-libmpd")
> + (version "0.9.0.9")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://hackage.haskell.org/package/libmpd/libmpd-"
> + version
> + ".tar.gz"))
> + (sha256
> + (base32
> + "1931m23iqb4wddpdidm4ph746zpaw41kkjzmb074j7yyfpk7x1jv"))))
> + (build-system haskell-build-system)
> + (inputs
> + `(("ghc-attoparsec" ,ghc-attoparsec)
> + ("ghc-old-locale" ,ghc-old-locale)
> + ("ghc-text" ,ghc-text)
> + ("ghc-data-default-class" ,ghc-data-default-class)
> + ("ghc-network" ,ghc-network)
> + ("ghc-utf8-string" ,ghc-utf8-string)))
> + (native-inputs
> + `(("ghc-quickcheck" ,ghc-quickcheck)
> + ("ghc-hspec" ,ghc-hspec)
> + ("hspec-discover" ,hspec-discover)))
> + (home-page "http://github.com/vimus/libmpd-haskell#readme")

Maybe drop the anchor here (the “#readme” part). The linter complains
about it, and I don’t think it adds much.

Toggle quote (2 lines)
> + (synopsis "MPD client library")

This might be better if it mentions Haskell and spells out the
initialism: “Haskell client library for the Music Player Daemon (MPD)”.

Toggle quote (2 lines)
> + (description "A client library for MPD, the Music Player Daemon.")

We try to use complete sentences in the description. Often, you just
need to add the words “this package provides” to the beginning. For
this, I might write:

This package provides a pure Haskell client library for the Music
Player Daemon (MPD).

Toggle quote (2 lines)
> + (license license:expat)))

Other than that it looks good!


-- Tim
Gabriel Hondet wrote 6 years ago
Re: [bug#34137] [PATCH] gnu: Add ghc-libmpd.
(address . 34137@debbugs.gnu.org)
87va2dc1dw.fsf@gmail.com
Hi,

Here is a new patch following your remarks. I have also used
'mirror://' for hackage.

* gnu/packages/haskell.scm (ghc-libmpd): New variable.
---
gnu/packages/haskell.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b8ea36852..255e902e6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11461,4 +11461,36 @@ foreign imports by hand (or using hsc2hs), this ensures that C functions are
imported with the correct Haskell types.")
(license license:gpl2)))
+(define-public ghc-libmpd
+ (package
+ (name "ghc-libmpd")
+ (version "0.9.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/libmpd/libmpd-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1931m23iqb4wddpdidm4ph746zpaw41kkjzmb074j7yyfpk7x1jv"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-text" ,ghc-text)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-network" ,ghc-network)
+ ("ghc-utf8-string" ,ghc-utf8-string)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "https://github.com/vimus/libmpd-haskell")
+ (synopsis "Haskell client library for the Music Player Daemon")
+ (description "This package provides a pure Haskell client library for the
+Music Player Daemon.")
+ (license license:expat)))
+
;;; haskell.scm ends here
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxKDvsACgkQMbyBBfZZ
1CX8eg/+I1me+LT09iqLEl5y7Mc3164CZtD0l5QmQnrCFvjiTqO0dGpHfZDR6JdK
T6F9+qhdrFktnbbMbdaqWObelPJTdB8ahBsHZWq8NM60gcqWuCfZvntscVJxSObl
A+7pJFYwh1i4T1hKNfggMpavTBh1zTZFmd7xmCzecXnSVCMsvq4wCXjbOU8BJ8FI
de0VTRoh5OHPWH8d7GLJssz2+gg8S4w9FbenHQHUNbLZC2aoHur2ojffmmFSpY2j
NYkELDifdP+g+48JQDLLlLXcSkXI2Hy3IVPPXC2psmq4tK7dpK1STcAko/Rjzn4Q
nyvJcBz7AC7mk5eQ6Um3ae+KV71iRoOvpjg9xfK5Fe9VKhDNclTPcvwEyhOx3l4Q
yIuO+H5v6Y8OVcWmucFcUSuu9g7d/EPTojpBVoHopz/QSGlbEA2mIrQz11GVuukT
vbCENUEBHNErsnwL+0zDbZjtBSU0wgzR0sp4SqfE14edLsvNqVYcaSq7JvbbitdU
Zkedj6pdWLx6DrllVbGfCMjYREw0a5vt5EUtbJu1hNAiHa4JzIpRgLskVQiTU2en
FGs6JzZG0bEV5Tw0yZ74AnBniDloQtrARYEKueLNo0VGtqj2Cbkd5ewSVjDDXEBY
ufQDWIKWczhOy48AT8lREc8ORGk/XMTun1pFbdboMB3Ex4XiRBY=
=9OsN
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)
871s50sx8f.fsf@gnu.org
Hello,

Gabriel Hondet <gabrielhondet@gmail.com> skribis:

Toggle quote (5 lines)
> Here is a new patch following your remarks. I have also used
> 'mirror://' for hackage.
>
> * gnu/packages/haskell.scm (ghc-libmpd): New variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34137@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34137
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help