Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bootloaders.scm (u-boot): Update to 2019.01.
(u-boot-tools): Disable CONFIG_SOUND in sandbox configs.
(u-boot-pinebook): Drop patches applied upstream.
* gnu/packages/patches/u-boot-pinebook-*: Drop obsolete patches.
* gnu/local.mk: Drop u-boot-pinebook patches.
---
gnu/local.mk | 6 -
gnu/packages/bootloaders.scm | 24 +-
.../u-boot-pinebook-a64-update-dts.patch | 1485 -----------------
.../patches/u-boot-pinebook-dts.patch | 388 -----
.../u-boot-pinebook-mmc-calibration.patch | 98 --
.../u-boot-pinebook-r_i2c-controller.patch | 70 -
.../patches/u-boot-pinebook-syscon-node.patch | 38 -
.../u-boot-pinebook-video-bridge.patch | 50 -
8 files changed, 8 insertions(+), 2151 deletions(-)
delete mode 100644 gnu/packages/patches/u-boot-pinebook-a64-update-dts.patch
delete mode 100644 gnu/packages/patches/u-boot-pinebook-dts.patch
delete mode 100644 gnu/packages/patches/u-boot-pinebook-mmc-calibration.patch
delete mode 100644 gnu/packages/patches/u-boot-pinebook-r_i2c-controller.patch
delete mode 100644 gnu/packages/patches/u-boot-pinebook-syscon-node.patch
delete mode 100644 gnu/packages/patches/u-boot-pinebook-video-bridge.patch
Toggle diff (748 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 4fed45174..9f6df0d7e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1230,12 +1230,6 @@ dist_patch_DATA = \
%D%/packages/patches/totem-meson-easy-codec.patch \
%D%/packages/patches/tuxpaint-stamps-path.patch \
%D%/packages/patches/twinkle-include-qregexpvalidator.patch \
- %D%/packages/patches/u-boot-pinebook-a64-update-dts.patch \
- %D%/packages/patches/u-boot-pinebook-mmc-calibration.patch \
- %D%/packages/patches/u-boot-pinebook-r_i2c-controller.patch \
- %D%/packages/patches/u-boot-pinebook-dts.patch \
- %D%/packages/patches/u-boot-pinebook-syscon-node.patch \
- %D%/packages/patches/u-boot-pinebook-video-bridge.patch \
%D%/packages/patches/unzip-CVE-2014-8139.patch \
%D%/packages/patches/unzip-CVE-2014-8140.patch \
%D%/packages/patches/unzip-CVE-2014-8141.patch \
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 1cf7720a7..2a4f43f87 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -376,7 +376,7 @@ tree binary files. These are board description files used by Linux and BSD.")
(define u-boot
(package
(name "u-boot")
- (version "2018.11")
+ (version "2019.01")
(source (origin
(method url-fetch)
(uri (string-append
@@ -384,7 +384,7 @@ tree binary files. These are board description files used by Linux and BSD.")
"u-boot-" version ".tar.bz2"))
(sha256
(base32
- "0znkwljfwwn4y7j20pzz4ilqw8znphrfxns0x1lwdzh3xbr96z3k"))))
+ "08hwsmh5xsb1gcxsv8gvx00bai938dm5y3889n8jif3a8rd7xgah"))))
(native-inputs
`(("bc" ,bc)
("bison" ,bison)
@@ -440,6 +440,11 @@ also initializes the boards (RAM etc).")
(("def test_ctrl_c")
"@pytest.mark.skip(reason='Guix has problems with SIGINT')
def test_ctrl_c"))
+ ;; This test requires a sound system, which is un-used in u-boot-tools.
+ (for-each (lambda (file)
+ (substitute* file
+ (("CONFIG_SOUND=y") "CONFIG_SOUND=n")))
+ (find-files "configs" "sandbox_.*defconfig$"))
#t))
(replace 'configure
(lambda* (#:key make-flags #:allow-other-keys)
@@ -595,20 +600,7 @@ board-independent tools.")))
(make-u-boot-sunxi64-package "pine64_plus" "aarch64-linux-gnu"))
(define-public u-boot-pinebook
- (let ((base (make-u-boot-sunxi64-package "pinebook" "aarch64-linux-gnu")))
- (package
- (inherit base)
- (source (origin
- (inherit (package-source u-boot))
- (patches (search-patches
- ;; Add patches to enable Pinebook support from sunxi
- ;; maintainer tree: git://git.denx.de/u-boot-sunxi.git
- "u-boot-pinebook-a64-update-dts.patch"
- "u-boot-pinebook-syscon-node.patch"
- "u-boot-pinebook-mmc-calibration.patch"
- "u-boot-pinebook-video-bridge.patch"
- "u-boot-pinebook-r_i2c-controller.patch"
- "u-boot-pinebook-dts.patch")))))))
+ (make-u-boot-sunxi64-package "pinebook" "aarch64-linux-gnu"))
(define-public u-boot-bananapi-m2-ultra
(make-u-boot-package "Bananapi_M2_Ultra" "arm-linux-gnueabihf"))
diff --git a/gnu/packages/patches/u-boot-pinebook-a64-update-dts.patch b/gnu/packages/patches/u-boot-pinebook-a64-update-dts.patch
deleted file mode 100644
index 9d0a08c8b..000000000
--- a/gnu/packages/patches/u-boot-pinebook-a64-update-dts.patch
+++ /dev/null
@@ -1,1485 +0,0 @@
-From 1b39a1834ed182bbd8036a5cd74a9ea111fa4691 Mon Sep 17 00:00:00 2001
-From: Andre Przywara <andre.przywara@arm.com>
-Date: Mon, 29 Oct 2018 00:56:47 +0000
-Subject: [PATCH 03/13] sunxi: A64: Update .dts/.dtsi files
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Update the .dts/.dtsi file from the Linux sunxi/dt64-for-4.20 tree:
-commit 679294497be31596e1c9c61507746d72b6b05f26
-Author: Rodrigo Exterckötter Tjäder <rodrigo@tjader.xyz>
-Date: Wed Sep 26 19:48:24 2018 +0000
- arm64: dts: allwinner: a64: a64-olinuxino: set the PHY TX delay
-
-Signed-off-by: Andre Przywara <andre.przywara@arm.com>
-Acked-by: Maxime Ripard <maxime.ripard@bootlin.com>
-Reviewed-by: Jagan Teki <jagan@openedev.com>
----
- arch/arm/dts/sun50i-a64-amarula-relic.dts | 168 +++++++++++++-
- arch/arm/dts/sun50i-a64-bananapi-m64.dts | 34 ++-
- arch/arm/dts/sun50i-a64-nanopi-a64.dts | 89 +++++++-
- arch/arm/dts/sun50i-a64-olinuxino.dts | 103 ++++++++-
- arch/arm/dts/sun50i-a64-orangepi-win.dts | 179 ++++++++++++++-
- arch/arm/dts/sun50i-a64-pine64.dts | 32 ++-
- arch/arm/dts/sun50i-a64-sopine-baseboard.dts | 32 ++-
- arch/arm/dts/sun50i-a64-sopine.dtsi | 15 ++
- arch/arm/dts/sun50i-a64.dtsi | 313 +++++++++++++++++++++++++--
- 9 files changed, 920 insertions(+), 45 deletions(-)
-
-diff --git a/arch/arm/dts/sun50i-a64-amarula-relic.dts b/arch/arm/dts/sun50i-a64-amarula-relic.dts
-index f3b4e93ece..6cb2b7f0c8 100644
---- a/arch/arm/dts/sun50i-a64-amarula-relic.dts
-+++ b/arch/arm/dts/sun50i-a64-amarula-relic.dts
-@@ -22,11 +22,11 @@
- stdout-path = "serial0:115200n8";
- };
-
-- reg_vcc3v3: vcc3v3 {
-- compatible = "regulator-fixed";
-- regulator-name = "vcc3v3";
-- regulator-min-microvolt = <3300000>;
-- regulator-max-microvolt = <3300000>;
-+ wifi_pwrseq: wifi-pwrseq {
-+ compatible = "mmc-pwrseq-simple";
-+ clocks = <&rtc 1>;
-+ clock-names = "ext_clock";
-+ reset-gpios = <&r_pio 0 2 GPIO_ACTIVE_LOW>; /* WL-PMU-EN: PL2 */
- };
- };
-
-@@ -34,10 +34,34 @@
- status = "okay";
- };
-
-+&mmc1 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&mmc1_pins>;
-+ vmmc-supply = <®_dcdc1>;
-+ /*
-+ * Schematic shows both dldo4 and eldo1 connected for vcc-io-wifi, but
-+ * dldo4 connection shows DNP(Do Not Populate) and eldo1 connected with
-+ * 0Ohm register to vcc-io-wifi so eldo1 is used.
-+ */
-+ vqmmc-supply = <®_eldo1>;
-+ mmc-pwrseq = <&wifi_pwrseq>;
-+ bus-width = <4>;
-+ non-removable;
-+ status = "okay";
-+
-+ brcmf: wifi@1 {
-+ reg = <1>;
-+ compatible = "brcm,bcm4329-fmac";
-+ interrupt-parent = <&r_pio>;
-+ interrupts = <0 3 IRQ_TYPE_LEVEL_LOW>; /* WL-WAKE-AP: PL3 */
-+ interrupt-names = "host-wake";
-+ };
-+};
-+
- &mmc2 {
- pinctrl-names = "default";
- pinctrl-0 = <&mmc2_pins>;
-- vmmc-supply = <®_vcc3v3>;
-+ vmmc-supply = <®_dcdc1>;
- bus-width = <8>;
- non-removable;
- cap-mmc-hw-reset;
-@@ -48,9 +72,138 @@
- status = "okay";
- };
-
-+&r_rsb {
-+ status = "okay";
-+
-+ axp803: pmic@3a3 {
-+ compatible = "x-powers,axp803";
-+ reg = <0x3a3>;
-+ interrupt-parent = <&r_intc>;
-+ interrupts = <0 IRQ_TYPE_LEVEL_LOW>;
-+ x-powers,drive-vbus-en; /* set N_VBUSEN as output pin */
-+ };
-+};
-+
-+#include "axp803.dtsi"
-+
-+®_aldo1 {
-+ regulator-always-on;
-+ regulator-min-microvolt = <2800000>;
-+ regulator-max-microvolt = <2800000>;
-+ regulator-name = "avdd-csi";
-+};
-+
-+®_aldo2 {
-+ regulator-always-on;
-+ regulator-min-microvolt = <1800000>;
-+ regulator-max-microvolt = <3300000>;
-+ regulator-name = "vcc-pl";
-+};
-+
-+®_aldo3 {
-+ regulator-always-on;
-+ regulator-min-microvolt = <3000000>;
-+ regulator-max-microvolt = <3000000>;
-+ regulator-name = "vcc-pll-avcc";
-+};
-+
-+®_dcdc1 {
-+ regulator-always-on;
-+ regulator-min-microvolt = <3300000>;
-+ regulator-max-microvolt = <3300000>;
-+ regulator-name = "vcc-3v3";
-+};
-+
-+®_dcdc2 {
-+ regulator-always-on;
-+ regulator-min-microvolt = <1040000>;
-+ regulator-max-microvolt = <1300000>;
-+ regulator-name = "vdd-cpux";
-+};
-+
-+/* DCDC3 is polyphased with DCDC2 */
-+
-+®_dcdc5 {
-+ regulator-always-on;
-+ regulator-min-microvolt = <1500000>;
-+ regulator-max-microvolt = <1500000>;
-+ regulator-name = "vcc-dram";
-+};
-+
-+®_dcdc6 {
-+ regulator-always-on;
-+ regulator-min-microvolt = <1100000>;
-+ regulator-max-microvolt = <1100000>;
-+ regulator-name = "vdd-sys";
-+};
-+
-+®_dldo1 {
-+ regulator-min-microvolt = <3300000>;
-+ regulator-max-microvolt = <3300000>;
-+ regulator-name = "vcc-hdmi-dsi-sensor";
-+};
-+
-+®_dldo2 {
-+ regulator-min-microvolt = <3300000>;
-+ regulator-max-microvolt = <3300000>;
-+ regulator-name = "vcc-mipi";
-+};
-+
-+®_dldo3 {
-+ regulator-min-microvolt = <2800000>;
-+ regulator-max-microvolt = <2800000>;
-+ regulator-name = "dovdd-csi";
-+};
-+
-+®_dldo4 {
-+ regulator-min-microvolt = <3300000>;
-+ regulator-max-microvolt = <3300000>;
-+ regulator-name = "vcc-wifi-io";
-+};
-+
-+®_drivevbus {
-+ regulator-name = "usb0-vbus";
-+ status = "okay";
-+};
-+
-+®_eldo1 {
-+ regulator-always-on;
-+ regulator-min-microvolt = <1800000>;
-+ regulator-max-microvolt = <1800000>;
-+ regulator-name = "cpvdd";
-+};
-+
-+®_eldo3 {
-+ regulator-min-microvolt = <1800000>;
-+ regulator-max-microvolt = <1800000>;
-+ regulator-name = "dvdd-csi";
-+};
-+
-+®_fldo1 {
-+ regulator-min-microvolt = <1200000>;
-+ regulator-max-microvolt = <1200000>;
-+ regulator-name = "vcc-1v2-hsic";
-+};
-+
-+/*
-+ * The A64 chip cannot work without this regulator off, although
-+ * it seems to be only driving the AR100 core.
-+ * Maybe we don't still know well about CPUs domain.
-+ */
-+®_fldo2 {
-+ regulator-always-on;
-+ regulator-min-microvolt = <1100000>;
-+ regulator-max-microvolt = <1100000>;
-+ regulator-name = "vdd-cpus";
-+};
-+
-+®_rtc_ldo {
-+ regulator-name = "vcc-rtc";
-+};
-+
- &uart0 {
- pinctrl-names = "default";
-- pinctrl-0 = <&uart0_pins_a>;
-+ pinctrl-0 = <&uart0_pb_pins>;
- status = "okay";
- };
-
-@@ -61,5 +214,6 @@
-
- &usbphy {
- usb0_id_det-gpios = <&pio 7 9 GPIO_ACTIVE_HIGH>; /* PH9 */
-+ usb0_vbus-supply = <®_drivevbus>;
- status = "okay";
- };
-diff --git a/arch/arm/dts/sun50i-a64-bananapi-m64.dts b/arch/arm/dts/sun50i-a64-bananapi-m64.dts
-index 0716b14411..ef1c90401b 100644
---- a/arch/arm/dts/sun50i-a64-bananapi-m64.dts
-+++ b/arch/arm/dts/sun50i-a64-bananapi-m64.dts
-@@ -60,6 +60,17 @@
- stdout-path = "serial0:115200n8";
- };
-
-+ hdmi-connector {
-+ compatible = "hdmi-connector";
-+ type = "a";
-+
-+ port {
-+ hdmi_con_in: endpoint {
-+ remote-endpoint = <&hdmi_out_con>;
-+ };
-+ };
-+ };
-+
- leds {
- compatible = "gpio-leds";
-
-@@ -86,6 +97,10 @@
- };
- };
-
-+&de {
-+ status = "okay";
-+};
-+
- &ehci0 {
- status = "okay";
- };
-@@ -103,6 +118,17 @@
- status = "okay";
- };
-
-+&hdmi {
-+ hvcc-supply = <®_dldo1>;
-+ status = "okay";
-+};
-+
-+&hdmi_out {
-+ hdmi_out_con: endpoint {
-+ remote-endpoint = <&hdmi_con_in>;
-+ };
-+};
-+
- &i2c1 {
- pinctrl-names = "default";
- pinctrl-0 = <&i2c1_pins>;
-@@ -151,7 +177,7 @@
-
- &mmc2 {
- pinctrl-names = "default";
-- pinctrl-0 = <&mmc2_pins>;
-+ pinctrl-0 = <&mmc2_pins>, <&mmc2_ds_pin>;
- vmmc-supply = <®_dcdc1>;
- bus-width = <8>;
- non-removable;
-@@ -296,9 +322,13 @@
- regulator-name = "vcc-rtc";
- };
-
-+&simplefb_hdmi {
-+ vcc-hdmi-supply = <®_dldo1>;
-+};
-+
- &uart0 {
- pinctrl-names = "default";
-- pinctrl-0 = <&uart0_pins_a>;
-+ pinctrl-0 = <&uart0_pb_pins>;
- status = "okay";
- };
-
-diff --git a/arch/arm/dts/sun50i-a64-nanopi-a64.dts b/arch/arm/dts/sun50i-a64-nanopi-a64.dts
-index e2dce48fa2..31884dbc88 100644
---- a/arch/arm/dts/sun50i-a64-nanopi-a64.dts
-+++ b/arch/arm/dts/sun50i-a64-nanopi-a64.dts
-@@ -51,12 +51,44 @@
- compatible = "friendlyarm,nanopi-a64", "allwinner,sun50i-a64";
-
- aliases {
-+ ethernet0 = &emac;
- serial0 = &uart0;
- };
-
- chosen {
- stdout-path = "serial0:115200n8";
- };
-+
-+ hdmi-connector {
-+ compatible = "hdmi-connector";
-+ type = "a";
-+
-+ port {
-+ hdmi_con_in: endpoint {
-+ remote-endpoint = <&hdmi_out_con>;
-+ };
-+ };
-+ };
-+
-+ leds {
-+ compatible = "gpio-leds";
-+
-+ blue {
-+ label = "nanopi-a64:blue:status";
-+ gpios = <&pio 3 24 GPIO_ACTIVE_LOW>; /* PD24 */
-+ };
-+ };
-+
-+ wifi_pwrseq: wifi_pwrseq {
-+ compatible = "mmc-pwrseq-simple";
-+ clocks = <&rtc 1>;
-+ clock-names = "ext_clock";
-+ reset-gpios = <&r_pio 0 2 GPIO_ACTIVE_LOW>; /* PL2 */
-+ };
-+};
-+
-+&de {
-+ status = "okay";
- };
-
- &ehci0 {
-@@ -67,6 +99,26 @@
- status = "okay";
- };
-
-+&emac {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&rgmii_pins>;
-+ phy-mode = "rgmii";
-+ phy-handle = <&ext_rgmii_phy>;
-+ phy-supply = <®_dcdc1>;
-+ status = "okay";
-+};
-+
-+&hdmi {
-+ hvcc-supply = <®_dldo1>;
-+ status = "okay";
-+};
-+
-+&hdmi_out {
-+ hdmi_out_con: endpoint {
-+ remote-endpoint = <&hdmi_con_in>;
-+ };
-+};
-+
- /* i2c1 connected with gpio headers like pine64, bananapi */
- &i2c1 {
- pinctrl-names = "default";
-@@ -78,6 +130,13 @@
- bias-pull-up;
- };
-
-+&mdio {
-+ ext_rgmii_phy: ethernet-phy@1 {
-+ compatible = "ethernet-phy-ieee802.3-c22";
-+ reg = <7>;
-+ };
-+};
-+
- &mmc0 {
- pinctrl-names = "default";
- pinctrl-0 = <&mmc0_pins>;
-@@ -88,6 +147,24 @@
- status = "okay";
- };
-
-+&mmc1 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&mmc1_pins>;
-+ vmmc-supply = <®_dcdc1>;
-+ vqmmc-supply = <®_dldo4>;
-+ mmc-pwrseq = <&wifi_pwrseq>;
-+ bus-width = <4>;
-+ non-removable;
-+ status = "okay";
-+
-+ rtl8189etv: wifi@1 {
-+ reg = <1>;
-+ interrupt-parent = <&r_pio>;
-+ interrupts = <0 3 IRQ_TYPE_LEVEL_LOW>; /* PL3 */
-+ interrupt-names = "host-wake";
-+ };
-+};
-+
- &ohci0 {
- status = "okay";
- };
-@@ -125,9 +202,9 @@
-
- ®_dcdc1 {
- regulator-always-on;
-- regulator-min-microvolt = <3000000>;
-- regulator-max-microvolt = <3000000>;
-- regulator-name = "vcc-3v";
-+ regulator-min-microvolt = <3300000>;
-+ regulator-max-microvolt = <3300000>;
-+ regulator-name = "vcc-3v3";
- };
-
- ®_dcdc2 {
-@@ -195,9 +272,13 @@
- regulator-name = "vcc-rtc";
- };
-
-+&simplefb_hdmi {
-+ vcc-hdmi-supply = <®_dldo1>;
-+};
-+
- &uart0 {
- pinctrl-names = "default";
-- pinctrl-0 = <&uart0_pins_a>;
-+ pinctrl-0 = <&uart0_pb_pins>;
- status = "okay";
- };
-
-diff --git a/arch/arm/dts/sun50i-a64-olinuxino.dts b/arch/arm/dts/sun50i-a64-olinuxino.dts
-index 3b3081b10e..f7a4bccaa5 100644
---- a/arch/arm/dts/sun50i-a64-olinuxino.dts
-+++ b/arch/arm/dts/sun50i-a64-olinuxino.dts
-@@ -51,6 +51,7 @@
- compatible = "olimex,a64-olinuxino", "allwinner,sun50i-a64";
-
- aliases {
-+ ethernet0 = &emac;
- serial0 = &uart0;
- };
-
-@@ -58,12 +59,74 @@
- stdout-path = "serial0:115200n8";
- };
-
-+ hdmi-connector {
-+ compatible = "hdmi-connector";
-+ type = "a";
-+
-+ port {
-+ hdmi_con_in: endpoint {
-+ remote-endpoint = <&hdmi_out_con>;
-+ };
-+ };
-+ };
-+
-+ reg_usb1_vbus: usb1-vbus {
-+ compatible = "regulator-fixed";
-+ regulator-name = "usb1-vbus";
-+ regulator-min-microvolt = <5000000>;
-+ regulator-max-microvolt = <5000000>;
-+ regulator-boot-on;
-+ enable-active-high;
-+ gpio = <&pio 6 9 GPIO_ACTIVE_HIGH>; /* PG9 */
-+ status = "okay";
-+ };
-+
- wifi_pwrseq: wifi_pwrseq {
- compatible = "mmc-pwrseq-simple";
- reset-gpios = <&r_pio 0 2 GPIO_ACTIVE_LOW>; /* PL2 */
- };
- };
-
-+&de {
-+ status = "okay";
-+};
-+
-+&ehci0 {
-+ status = "okay";
-+};
-+
-+&ehci1 {
-+ status = "okay";
-+};
-+
-+&emac {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&rgmii_pins>;
-+ phy-mode = "rgmii";
-+ phy-handle = <&ext_rgmii_phy>;
-+ phy-supply = <®_dcdc1>;
-+ allwinner,tx-delay-ps = <600>;
-+ status = "okay";
-+};
-+
-+&hdmi {
-+ hvcc-supply = <®_dldo1>;
-+ status = "okay";
-+};
-+
-+&hdmi_out {
-+ hdmi_out_con: endpoint {
-+ remote-endpoint = <&hdmi_con_in>;
-+ };
-+};
-+
-+&mdio {
-+ ext_rgmii_phy: ethernet-phy@1 {
-+ compatible = "ethernet-phy-ieee802.3-c22";
-+ reg = <1>;
-+ };
-+};
-+
- &mmc0 {
- pinctrl-names = "default";
- pinctrl-0 = <&mmc0_pins>;
-@@ -92,6 +155,14 @@
- };
- };
-
-+&ohci0 {
-+ status = "okay";
-+};
-+
-+&ohci1 {
-+ status = "okay";
-+};
-+
- &r_rsb {
- status = "okay";
-
-@@ -100,6 +171,7 @@
- reg = <0x3a3>;
- interrupt-parent = <&r_intc>;
- interrupts = <0 IRQ_TYPE_LEVEL_LOW>;
-+ x-powers,drive-vbus-en; /* set N_VBUSEN as output pin */
- };
- };
-
-@@ -142,10 +214,14 @@
-
- /* DCDC3 is polyphased with DCDC2 */
-
-+/*
-+ * The board uses DDR3L DRAM chips. 1.36V is the closest to the nominal
-+ * 1.35V that the PMIC can drive.
-+ */
- ®_dcdc5 {
- regulator-always-on;
-- regulator-min-microvolt = <1500000>;
-- regulator-max-microvolt = <1500000>;
-+ regulator-min-microvolt = <1360000>;
-+ regulator-max-microvolt = <1360000>;
- regulator-name = "vcc-ddr3";
- };
-
-@@ -180,6 +256,11 @@
- regulator-name = "vcc-wifi-io";
- };
-
-+®_drivevbus {
-+ regulator-name = "usb0-vbus";
-+ status = "okay";
-+};
-+
- ®_eldo1 {
- regulator-min-microvolt = <1800000>;
- regulator-max-microvolt = <1800000>;
-@@ -214,8 +295,24 @@
- regulator-name = "vcc-rtc";
- };
-
-+&simplefb_hdmi {
-+ vcc-hdmi-supply = <®_dldo1>;
-+};
-+
- &uart0 {
- pinctrl-names = "default";
-- pinctrl-0 = <&uart0_pins_a>;
-+ pinctrl-0 = <&uart0_pb_pins>;
-+ status = "okay";
-+};
-+
-+&usb_otg {
-+ dr_mode = "otg";
-+ status = "okay";
-+};
-+
-+&usbphy {
- status = "okay";
-+ usb0_id_det-gpios = <&pio 7 9 GPIO_ACTIVE_HIGH>; /* PH9 */
-+ usb0_vbus-supply = <®_drivevbus>;
-+ usb1_vbus-supply = <®_usb1_vbus>;
- };
-diff --git a/arch/arm/dts/sun50i-a64-orangepi-win.dts b/arch/arm/dts/sun50i-a64-orangepi-win.dts
-index bf42690a33..b0c64f7579 100644
---- a/arch/arm/dts/sun50i-a64-orangepi-win.dts
-+++ b/arch/arm/dts/sun50i-a64-orangepi-win.dts
-@@ -1,5 +1,6 @@
- /*
- * Copyright (C) 2017 Jagan Teki <jteki@openedev.com>
-+ * Copyright (C) 2017-2018 Samuel Holland <samuel@sholland.org>
- *
- * This file is dual-licensed: you can use it either under the terms
- * of the GPL or the X11 license, at your option. Note that this dual
-@@ -51,23 +52,127 @@
- compatible = "xunlong,orangepi-win", "allwinner,sun50i-a64";
-
- aliases {
-+ ethernet0 = &emac;
- serial0 = &uart0;
-+ serial1 = &uart1;
-+ serial2 = &uart2;
-+ serial3 = &uart3;
-+ serial4 = &uart4;
- };
-
- chosen {
- stdout-path = "serial0:115200n8";
- };
-+
-+ hdmi-connector {
-+ compatible = "hdmi-connector";
-+ type = "a";
-+
-+ port {
-+ hdmi_con_in: endpoint {
-+ remote-endpoint = <&hdmi_out_con>;
-+ };
-+ };
-+ };
-+
-+ leds {
-+ compatible = "gpio-leds";
-+
-+ status {
-+ label = "orangepi:green:status";
-+ gpios = <&pio 7 11 GPIO_ACTIVE_HIGH>; /* PH11 */
-+ };
-+ };
-+
-+ reg_gmac_3v3: gmac-3v3 {
-+ compatible = "regulator-fixed";
-+ regulator-name = "gmac-3v3";
-+ regulator-min-microvolt = <3300000>;
-+ regulator-max-microvolt = <3300000>;
This message was truncated. Download the full message here.
-----BEGIN PGP SIGNATURE-----
iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXD+8kgAKCRDcUY/If5cW
qnjnAPsE9PTrH+uwQxFeB4tPRKbHelhL1gQDXkK+ly8/I46n1gD9H0hcvQ5BLOi/
yO1tFEQKhElLmoDo4W31H9MsMfPNgA8=
=p7hM
-----END PGP SIGNATURE-----