[PATCH] Add pencil2d.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pkill9
Owner
unassigned
Submitted by
pkill9
Severity
normal

Debbugs page

pkill9 wrote 6 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
E1gjn6L-0004yG-02@rmmprod07.runbox
This patch adds the Pencil2D software package (https://www.pencil2d.org). I've run `guix lint`, and checked that it builds/runs fine.
From d0c680e629b4c85ee462b624c65683a0a52306d9 Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Wed, 16 Jan 2019 15:14:45 +0000
Subject: [PATCH] gnu: Add pencil2d.

* gnu/packages/animation.scm (pencil2d): New variable.
---
gnu/packages/animation.scm | 41 ++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index a10747ef3..5b9ca033b 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -26,6 +26,7 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
@@ -258,3 +259,43 @@ easy to lip sync animated characters by making the process very simple – just
type in the words being spoken, then drag the words on top of the sound’s
waveform until they line up with the proper sounds.")
(license license:gpl3+))))
+
+(define-public pencil2d
+ (package
+ (name "pencil2d")
+ (version "0.6.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pencil2d/pencil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1iv7drwxs32mqs3hybjx2lxyqn8cv2b4rw9ny7gzdacsbhi65knr"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("bash" ,bash) ;; Bash is used for wrap-program
+ ("qtbase" ,qtbase)
+ ("qtxmlpatterns" ,qtxmlpatterns)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtsvg" ,qtsvg)))
+ (arguments
+ `(#:phases
+ (modify-phases standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (qmake (string-append (assoc-ref inputs "qtbase")
+ "/bin/qmake")))
+ (invoke qmake (string-append "PREFIX=" out)))))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (plugin-path (getenv "QT_PLUGIN_PATH")))
+ (wrap-program (string-append out "/bin/pencil2d")
+ `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))))))))
+ (home-page "https://www.pencil2d.org")
+ (synopsis "Tool to make 2D hand-drawn animations")
+ (description "Pencil2D is an easy, intuitive tool to make 2D hand-drawn animations.")
+ (license license:gpl2)))
--
2.20.1
Ludovic Courtès wrote 6 years ago
(address . pkill9@runbox.com)(address . 34105-done@debbugs.gnu.org)
87k1iznqai.fsf@gnu.org
Hello,

<pkill9@runbox.com> skribis:

Toggle quote (7 lines)
> From d0c680e629b4c85ee462b624c65683a0a52306d9 Mon Sep 17 00:00:00 2001
> From: Pkill -9 <pkill9@runbox.com>
> Date: Wed, 16 Jan 2019 15:14:45 +0000
> Subject: [PATCH] gnu: Add pencil2d.
>
> * gnu/packages/animation.scm (pencil2d): New variable.

Applied with the minor changes below. Thank you!

Ludo’.
Toggle diff (59 lines)
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 5b9ca033b5..965fff6d46 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,7 +27,6 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
- #:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
@@ -275,27 +275,28 @@ waveform until they line up with the proper sounds.")
"1iv7drwxs32mqs3hybjx2lxyqn8cv2b4rw9ny7gzdacsbhi65knr"))))
(build-system gnu-build-system)
(inputs
- `(("bash" ,bash) ;; Bash is used for wrap-program
- ("qtbase" ,qtbase)
+ `(("qtbase" ,qtbase)
("qtxmlpatterns" ,qtxmlpatterns)
("qtmultimedia" ,qtmultimedia)
("qtsvg" ,qtsvg)))
(arguments
`(#:phases
- (modify-phases standard-phases
+ (modify-phases %standard-phases
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (qmake (string-append (assoc-ref inputs "qtbase")
- "/bin/qmake")))
- (invoke qmake (string-append "PREFIX=" out)))))
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "qmake" (string-append "PREFIX=" out)))))
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(plugin-path (getenv "QT_PLUGIN_PATH")))
(wrap-program (string-append out "/bin/pencil2d")
- `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))))))))
+ `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))
+ #t))))))
(home-page "https://www.pencil2d.org")
- (synopsis "Tool to make 2D hand-drawn animations")
- (description "Pencil2D is an easy, intuitive tool to make 2D hand-drawn animations.")
+ (synopsis "Make 2D hand-drawn animations")
+ (description
+ "Pencil2D is an easy-to-use and intuitive animation and drawing tool. It
+lets you create traditional hand-drawn animations (cartoons) using both bitmap
+and vector graphics.")
(license license:gpl2)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34105@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34105
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help