[PATCH] core-updates -- gnu: python2: Fix test flags.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • ericbavier
  • Christopher Baines
Owner
unassigned
Submitted by
ericbavier
Severity
normal

Debbugs page

ericbavier wrote 6 years ago
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@member.fsf.org)
20190113071850.14337-1-ericbavier@centurylink.net
From: Eric Bavier <bavier@member.fsf.org>

* gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' ->
'TESTOPTS'. This overrides the default '-l' argument for memory leak checks
which is not compatible with the -j for parallelism.
---
gnu/packages/python.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9b43f465cc..dffded738d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -194,7 +194,7 @@
(assoc-ref %outputs "out") "/lib"))
;; With no -j argument tests use all available cpus, so provide one.
#:make-flags
- (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
+ (list (format #f "TESTOPTS=-j~d" (parallel-job-count)))
#:modules ((ice-9 ftw) (ice-9 match)
(guix build utils) (guix build gnu-build-system))
--
2.20.1
Efraim Flashner wrote 6 years ago
(address . ericbavier@centurylink.net)
20190113074859.GB2050@macbook41
On Sun, Jan 13, 2019 at 01:18:49AM -0600, ericbavier@centurylink.net wrote:
Toggle quote (26 lines)
> From: Eric Bavier <bavier@member.fsf.org>
>
> * gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' ->
> 'TESTOPTS'. This overrides the default '-l' argument for memory leak checks
> which is not compatible with the -j for parallelism.
> ---
> gnu/packages/python.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 9b43f465cc..dffded738d 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -194,7 +194,7 @@
> (assoc-ref %outputs "out") "/lib"))
> ;; With no -j argument tests use all available cpus, so provide one.
> #:make-flags
> - (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
> + (list (format #f "TESTOPTS=-j~d" (parallel-job-count)))
>
> #:modules ((ice-9 ftw) (ice-9 match)
> (guix build utils) (guix build gnu-build-system))
> --
> 2.20.1
>

I'm building out python2 now on my aarch64 board but I assume it'll
work. While I do prefer the parallelism in the test suite, between the
two I'd consider the memory leak checks the more important of the two.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAlw67WYACgkQQarn3Mo9
g1EdRhAArJY3I000F9pJRLUf+vvWhFJlWNosq1ExHRRr4fuGKbE45ZYNLpCAOCLP
OK+Xz490rYEhbXG/4UcIbS1/6rLOCYAQkGL2FSfkiub0zUqp//itXcrv5C1Mrjlp
khPQlhiHSX6QqWet0WLy7Q08inLglevwzcOIx+L67rKsXdGUZ4NsSNhu75UuHbJ5
LpQlBtCnpQ4mJRKjjz9Ih2LUMcUZksJsa2eMRaz8I/VncDefnzn/NpdkZDpcdXYo
QKHyE+hsPxF+U6Fe0QE7ByVsLUOr1jxG0tBLrXKn8YXt0K7IjDP6J1jb8Wc4SySz
uV2GSRtz/4xSFkSgpF1vQa9qfJxSWjjAoVHq5jQp0zIQrIglbPmxTLM+NGa1Q20h
t/yk6pC8SvLhucl9ccxhXWs2RVr+1roTQeMQD/sPUhWDyV+/wLeeJUd6T9sbCgLF
9Fun8oOAnvj2VzoIz4goD5qDgTi1A6VGXc1jVR0XwvT8rifcE3HeFcirxaCxanHV
r6rCKcG355xUioIjHUwTy5swpWmpq4YqmrawLJZiEKGKzqGxE2oj27GEz3mG0bxy
9cMMPTzgvtML/apFzOxPPDdl6OEfuCUeCFr2rVWCFoXFLVcAo8CMHPOn6/gLnBn0
11VATSnlRHnLZ/npDAXUZ9+VcMYNBW8fAW0gs47sMPw6qVZ0DgU=
=FAsP
-----END PGP SIGNATURE-----


Eric Bavier wrote 6 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)
20190113102320.543cba28@centurylink.net
On Sun, 13 Jan 2019 09:48:59 +0200
Efraim Flashner <efraim@flashner.co.il> wrote:

Toggle quote (32 lines)
> On Sun, Jan 13, 2019 at 01:18:49AM -0600, ericbavier@centurylink.net wrote:
> > From: Eric Bavier <bavier@member.fsf.org>
> >
> > * gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' ->
> > 'TESTOPTS'. This overrides the default '-l' argument for memory leak checks
> > which is not compatible with the -j for parallelism.
> > ---
> > gnu/packages/python.scm | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> > index 9b43f465cc..dffded738d 100644
> > --- a/gnu/packages/python.scm
> > +++ b/gnu/packages/python.scm
> > @@ -194,7 +194,7 @@
> > (assoc-ref %outputs "out") "/lib"))
> > ;; With no -j argument tests use all available cpus, so provide one.
> > #:make-flags
> > - (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
> > + (list (format #f "TESTOPTS=-j~d" (parallel-job-count)))
> >
> > #:modules ((ice-9 ftw) (ice-9 match)
> > (guix build utils) (guix build gnu-build-system))
> > --
> > 2.20.1
> >
>
> I'm building out python2 now on my aarch64 board but I assume it'll
> work. While I do prefer the parallelism in the test suite, between the
> two I'd consider the memory leak checks the more important of the two.
>

Are the memory-leak checks something that we need to worry about in our
packaging of python2? Can memory leaks be introduced in the way we
configure and build our python? Otherwise I assume that's something
more interesting to someone developing python itself and not as
interesting in system CI. IMHO.

I see I should probably move the comment about this overriding -l from
the commit message to the code comment.

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlw7ZfgACgkQ/XPKxxnT
JWaHzw/7BHtgXNhjZanqCInPisZFGyFvAy1WSp+83iQgg5OtsjNm3R8M6W0fRCYH
9ZqC7jYddM52T/Etpv+RCSAfLLZVx2/9anGYMeZ49PjQUcJFm1PTodtotsrJhIFZ
N4xcMA/zMshAne4HlvAwd93YdAYTMGHzinPl9wacZUM8IrxhZHlN394qcd63Y4hc
pJvNkDYm/Kh0QQANRMPZoL/BBk8aGGC4A5+HcpCXZBP3Oe5G//DrdxZTmILXZMmp
kLnMApRiNW0x10WNniCcq2EfUO9aqWr9pGa4nhc2FTEDGRbXxTXEmTVoe8gQaurY
WKVlB08JuTdN57jFf5+Ubs8EKzKiFJAYbmBGi9GPnqwrVr8v3gkgoNEfzZgPJY/V
YeszSk+ZfQB6xNkzbe6QTKl0ej9oCvcahPVUJOKXP0Sab2ki4kq8heGIQUHntTzs
t8DpxEfMHef+hhC0jomOd28F9E6FC2N5QzGAwkhOt2UI+krcE/IErvMLPELgBAhJ
Vs/jZgY0rm9PSP7lsio79iVQVLfbMDEqdd5E4vKB5XsAzoPB8+sekdFhHTH2iXkY
eO8Qvlj7UiHquVB9YrsHx6XsTgvV97Hf2QoPzjS4lBEqMPHRFwCm2wAxWy8VfgpX
PQ6n/4xduZ01LjLFFXLsr0NVzK/DkMlQu5nwvOONDmNczwgaNtE=
=JnpZ
-----END PGP SIGNATURE-----


Efraim Flashner wrote 6 years ago
(name . Eric Bavier)(address . ericbavier@centurylink.net)
20190113171610.GB25281@macbook41
On Sun, Jan 13, 2019 at 10:23:20AM -0600, Eric Bavier wrote:
Toggle quote (41 lines)
> On Sun, 13 Jan 2019 09:48:59 +0200
> Efraim Flashner <efraim@flashner.co.il> wrote:
>
> > On Sun, Jan 13, 2019 at 01:18:49AM -0600, ericbavier@centurylink.net wrote:
> > > From: Eric Bavier <bavier@member.fsf.org>
> > >
> > > * gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' ->
> > > 'TESTOPTS'. This overrides the default '-l' argument for memory leak checks
> > > which is not compatible with the -j for parallelism.
> > > ---
> > > gnu/packages/python.scm | 2 +-
> > > 1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> > > index 9b43f465cc..dffded738d 100644
> > > --- a/gnu/packages/python.scm
> > > +++ b/gnu/packages/python.scm
> > > @@ -194,7 +194,7 @@
> > > (assoc-ref %outputs "out") "/lib"))
> > > ;; With no -j argument tests use all available cpus, so provide one.
> > > #:make-flags
> > > - (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
> > > + (list (format #f "TESTOPTS=-j~d" (parallel-job-count)))
> > >
> > > #:modules ((ice-9 ftw) (ice-9 match)
> > > (guix build utils) (guix build gnu-build-system))
> > > --
> > > 2.20.1
> > >
> >
> > I'm building out python2 now on my aarch64 board but I assume it'll
> > work. While I do prefer the parallelism in the test suite, between the
> > two I'd consider the memory leak checks the more important of the two.
> >
>
> Are the memory-leak checks something that we need to worry about in our
> packaging of python2? Can memory leaks be introduced in the way we
> configure and build our python? Otherwise I assume that's something
> more interesting to someone developing python itself and not as
> interesting in system CI. IMHO.

No idea.

Toggle quote (4 lines)
> I see I should probably move the comment about this overriding -l from
> the commit message to the code comment.
>

Sounds like a good idea :)


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAlw7clcACgkQQarn3Mo9
g1H5Aw/+PfP68e0wfLIeMp27gv+zelSFdSadj0ipcM5ZaVRDF4F/VfQ7l33MWezr
jfhqLRxG8RGuHr1PWia7QtT417SnhOsD0IgWjLFUq6k34dSEXCUxV4OhSw6sArCs
zoG4RuBr2MfaCkTxZD/9+g5qGk2e//eBDk3AoephMPh9D9WcHHDJgUlYHp0XNOMy
ItAsafitKaSXdL8yT1WsE1DB3R8ls+pHZt1zgo4j8NS6FbqpIqvqPr5oLhYJ7qPw
t9tzgZl/FGO7KxkCRDorNhQn4W7OaSDs/l+psdT2ixue+/2vIJoDJqFG/lh4Ja6d
WuzA++jm1Cj+fd1vRwUllaUZ8cm8GEbz6nvHC1MDBUSONduu2aTArfi/rzr4Xnbj
hDBydzhH7VcAcKMl73sXc9G6mrU4sHASFqDj461EW0FmQkqh3YvrpBN3yDG+BiCa
0JTP+wzgowFXLkXfTCSfn0d2ND9vgkDDGFsP5eNing+s097lQJ4yqKE3CwTpQ7Yl
N/AnWw4qOgE9DqYY3yDauCKrmVV5rqozZ1GheV9qpkPHP6KzkezNvwdWbWi6jXf5
hFqLZheqdAI6o6aGoJ9zSF03nC6md2r/BL8d/Gfho10JzC1r8el50jsTROVpvniM
tJsVwGQc52+7ApcgdVanWkzAkI+XLZmWSg8YO4bAzCULjg6Jilg=
=acPX
-----END PGP SIGNATURE-----


Christopher Baines wrote 6 years ago
(address . ericbavier@centurylink.net)(address . 34056@debbugs.gnu.org)
8736pwjhes.fsf@cbaines.net
ericbavier@centurylink.net writes:

Toggle quote (23 lines)
> From: Eric Bavier <bavier@member.fsf.org>
>
> * gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' ->
> 'TESTOPTS'. This overrides the default '-l' argument for memory leak checks
> which is not compatible with the -j for parallelism.
> ---
> gnu/packages/python.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 9b43f465cc..dffded738d 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -194,7 +194,7 @@
> (assoc-ref %outputs "out") "/lib"))
> ;; With no -j argument tests use all available cpus, so provide one.
> #:make-flags
> - (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
> + (list (format #f "TESTOPTS=-j~d" (parallel-job-count)))
>
> #:modules ((ice-9 ftw) (ice-9 match)
> (guix build utils) (guix build gnu-build-system))

Hey Eric,

I've also been looking at some Python 2 things on core-updates today,
trying to get the linkchecker package building again.

I've just pushed a slightly different patch, but to this effect to
core-updates, and only just seen this message, sorry about that.

Thanks for looking at it though, this approach is probably neater, as I
used substitute* instead.

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlw7whtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdZdRAAlZYtgZqkOY1Mla83DlAYANxJrPjKgszdz9iTmNoA3Acs7QRGfRdaV975
ODyxoHx/eP7wEdK6d5ueOkkgOyOYlt4t3G5uUHw6BZtLJcPsfBKJfpMTk4NcL5Dt
7gp5gbNprHuwb7Djjk5Ew/7luMeLaZwkLZIZtNjdesoVWbKdRNrE5aiTvobvvhVA
6u1FKur4F6PKI3vhiashZKvGYemyKj91JkGwU5tWLlkfKz0P9Vd2DxkYzO5GcRv/
B4AOCGeGAmI+IlfjrEQuXIQjkxsWfVSTP2WDwRKX3EUGhben+YuxnKJrXxTUe1VW
HzuNQZRp4qF1xM7E9324oWeACVZGLB0Q0lgV7s+6LWHFKQ5I3MaBHbvTIaApz94Y
klVojzzU8OS+PFMz9fj0GCas+wpiaIXDwiKFiRy7twjTUITqnKWDj7gRFGCxeiAD
CUEeoBO4iykLbpYYwC/tRCS09cfDeFJHm1MsRYdxr3TNUHLjWNLX15Kte6zlrnsS
eiC4sNwvh3ZYAtFoE4VDmhK54J9Di+ChjvGdCd89KVK/REBVRMuArqiCz72PuDPa
Ijdy3zwijL0sIrPtxDy6r38tERrA6HtmYlXr8r4edk0IOiNI7rblgF2SmqPpDFLr
gPuDWsl5mwKwKn40ZYdIKNVV4Dt0PhYHTbRHSjji21mahD6Tb7Y=
=KBCn
-----END PGP SIGNATURE-----

Eric Bavier wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 34056@debbugs.gnu.org)
20190113204242.55461ef2@centurylink.net
On Sun, 13 Jan 2019 22:56:27 +0000
Christopher Baines <mail@cbaines.net> wrote:

Toggle quote (33 lines)
> ericbavier@centurylink.net writes:
>
> > From: Eric Bavier <bavier@member.fsf.org>
> >
> > * gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' ->
> > 'TESTOPTS'. This overrides the default '-l' argument for memory leak checks
> > which is not compatible with the -j for parallelism.
> > ---
> > gnu/packages/python.scm | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> > index 9b43f465cc..dffded738d 100644
> > --- a/gnu/packages/python.scm
> > +++ b/gnu/packages/python.scm
> > @@ -194,7 +194,7 @@
> > (assoc-ref %outputs "out") "/lib"))
> > ;; With no -j argument tests use all available cpus, so provide one.
> > #:make-flags
> > - (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
> > + (list (format #f "TESTOPTS=-j~d" (parallel-job-count)))
> >
> > #:modules ((ice-9 ftw) (ice-9 match)
> > (guix build utils) (guix build gnu-build-system))
>
> Hey Eric,
>
> I've also been looking at some Python 2 things on core-updates today,
> trying to get the linkchecker package building again.
>
> I've just pushed a slightly different patch, but to this effect to
> core-updates, and only just seen this message, sorry about that.

Not a problem.

Toggle quote (5 lines)
>
> Thanks for looking at it though, this approach is probably neater, as I
> used substitute* instead.
>

Would you like to keep your patch, or apply this one instead?

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlw79yIACgkQ/XPKxxnT
JWal3Q//XFkdB6e10XHnOLxLe8itSBOZM1AY6FbPaD52gphtVXpDkpSrK1CS4TyC
lB+uaIemr5vGS9MZUgwd1jroYt0kVKvaW1LncUqSo+AQxd3UX4xz7iMAzcChyUAU
D/vaiR3uT8aeUsrBzz2q282TyCqH5FtabDanQuK90CD5Jl8SeyWCvD/L1Xb6PjGS
M6gvvM/6JLeUA2rKl7vvQGnf/jkUuaGKOQy/DwC8kRYli7jCRaLPi1g/xLT3+u42
7uFR4Q6FbmOMI+GWVYLlFcEpp+L7kWhsyXSt/DFJzhU3v03EA4HKzMPopdrRWjRU
9nKf7aQ797gIGDs5rNzviGgDwU0G65mK25wwoEtXlOSQOkrLVWfMx2N46BZHgFDS
38WWQt5UG3xaAceNYbnQtbYghEYSQlc4Wy3w1NGtq2jHODuVdorAc9b4TNsPnThn
/FNoTwMt3LYM05Z5cTW9iuVMO4RtDd26LmJvu2mGplOE8vYiVMHQNzlorz0t6MT4
Mmelxddts986mFlz19WisLYK0LK+R1xmoeXVHodNlJj28qW7XgOg04+g+5UCR6L6
qzrnpGRsF0fNG9EV7yS3exlZProWC9it3yIQvvoPVpjSqq0W4s2elqm5syF4O2Hh
FRdaI9/1y1JW+h2e/t8DO6PVkv7XRVXQMuVNy7X58O0TUCJ1iOE=
=vPAp
-----END PGP SIGNATURE-----


Christopher Baines wrote 6 years ago
(name . Eric Bavier)(address . ericbavier@centurylink.net)(address . 34056@debbugs.gnu.org)
87imyhj08h.fsf@cbaines.net
Eric Bavier <ericbavier@centurylink.net> writes:

Toggle quote (43 lines)
> On Sun, 13 Jan 2019 22:56:27 +0000
> Christopher Baines <mail@cbaines.net> wrote:
>
>> ericbavier@centurylink.net writes:
>>
>> > From: Eric Bavier <bavier@member.fsf.org>
>> >
>> > * gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' ->
>> > 'TESTOPTS'. This overrides the default '-l' argument for memory leak checks
>> > which is not compatible with the -j for parallelism.
>> > ---
>> > gnu/packages/python.scm | 2 +-
>> > 1 file changed, 1 insertion(+), 1 deletion(-)
>> >
>> > diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
>> > index 9b43f465cc..dffded738d 100644
>> > --- a/gnu/packages/python.scm
>> > +++ b/gnu/packages/python.scm
>> > @@ -194,7 +194,7 @@
>> > (assoc-ref %outputs "out") "/lib"))
>> > ;; With no -j argument tests use all available cpus, so provide one.
>> > #:make-flags
>> > - (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
>> > + (list (format #f "TESTOPTS=-j~d" (parallel-job-count)))
>> >
>> > #:modules ((ice-9 ftw) (ice-9 match)
>> > (guix build utils) (guix build gnu-build-system))
>>
>> Hey Eric,
>>
>> I've also been looking at some Python 2 things on core-updates today,
>> trying to get the linkchecker package building again.
>>
>> I've just pushed a slightly different patch, but to this effect to
>> core-updates, and only just seen this message, sorry about that.
>
> Not a problem.
>
>> Thanks for looking at it though, this approach is probably neater, as I
>> used substitute* instead.
>
> Would you like to keep your patch, or apply this one instead?

I'm quite happy to switch to this approach. I don't know whether the
best way to do that is to switch out the patches by force-pushing to
core-updates, or to just apply your patch on top though...

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxGGQ9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfXUBAAi1pJXn8YsUImq5oC96kGHxqSeAqhTJ35zCno3pUhCnqf85rNhakCVrrr
+msmIo5tvi5y/CtTKeVhH6KAtcXKBBEVzH8B/P08D7OuuqIazqE8EMEpWtWAM41p
569ADdDxUC1Eu8GOiqrCFnHVzKZ8pXx5fp3TXyh5IG2R2xczPM25j+1hQ8cJ5SAu
gSyQF56qMCVSs8nxO0VpbvVv6WgKywMuoS7yYW+TETXS4p7Qalb23OxPM1VfyV/n
uBm1RoBhDj3AtsNh0YXee1Gg22XiKuGpeBYDT40WvburR/pxxhRWeT9eOIzYQjAt
/WfdnBn/2j6F4cndMBy1pxTVC+gkYZEsSCYWpwn2hVSR3zyzYkSj+rP/w7kc+BlG
h8sfSKueHvlqF1vZGrntzBIYwoYMgw+b7BwDFtIHSoegTolE0ZJAz6Eq/ipGiXaf
50/H4rikXZ4dSWjoKg6CsyCWScmsYymfljh61X87p2LOx/QetcaMt0Ln+rkvAKoH
naFO3x6WTFVr2vcO3DuhkCp4zQ151oI0U1qB1WkwISMtn3+IAcNtem/BSXd63fbI
I7NPiBpxVur6d5mEu/5N49H7ZhswYVjYvTamdy3EmZGdI/Z+DMsoOauszDxrHPX5
pJksQ3UxDoPMc3v/64M6Fl8ek+Myw0eHSI5vWNL0PkZFPfa45Nc=
=2LFR
-----END PGP SIGNATURE-----

Eric Bavier wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 34056@debbugs.gnu.org)
20190121191622.428b0932@centurylink.net
On Mon, 21 Jan 2019 19:10:06 +0000
Christopher Baines <mail@cbaines.net> wrote:

Toggle quote (49 lines)
> Eric Bavier <ericbavier@centurylink.net> writes:
>
> > On Sun, 13 Jan 2019 22:56:27 +0000
> > Christopher Baines <mail@cbaines.net> wrote:
> >
> >> ericbavier@centurylink.net writes:
> >>
> >> > From: Eric Bavier <bavier@member.fsf.org>
> >> >
> >> > * gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' ->
> >> > 'TESTOPTS'. This overrides the default '-l' argument for memory leak checks
> >> > which is not compatible with the -j for parallelism.
> >> > ---
> >> > gnu/packages/python.scm | 2 +-
> >> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >> >
> >> > diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> >> > index 9b43f465cc..dffded738d 100644
> >> > --- a/gnu/packages/python.scm
> >> > +++ b/gnu/packages/python.scm
> >> > @@ -194,7 +194,7 @@
> >> > (assoc-ref %outputs "out") "/lib"))
> >> > ;; With no -j argument tests use all available cpus, so provide one.
> >> > #:make-flags
> >> > - (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
> >> > + (list (format #f "TESTOPTS=-j~d" (parallel-job-count)))
> >> >
> >> > #:modules ((ice-9 ftw) (ice-9 match)
> >> > (guix build utils) (guix build gnu-build-system))
> >>
> >> Hey Eric,
> >>
> >> I've also been looking at some Python 2 things on core-updates today,
> >> trying to get the linkchecker package building again.
> >>
> >> I've just pushed a slightly different patch, but to this effect to
> >> core-updates, and only just seen this message, sorry about that.
> >
> > Not a problem.
> >
> >> Thanks for looking at it though, this approach is probably neater, as I
> >> used substitute* instead.
> >
> > Would you like to keep your patch, or apply this one instead?
>
> I'm quite happy to switch to this approach. I don't know whether the
> best way to do that is to switch out the patches by force-pushing to
> core-updates, or to just apply your patch on top though...

I can just adjust my patch. I think we don't want to force-push since
there are people working on it.

Thanks for your attention to core-updates :)

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlxGbuYACgkQ/XPKxxnT
JWY8pA/+KQ+z3Ny5UglwQvS5+Wel8cT0nacDyFDlXuDq4FaxnpkJLGvqRIG7mKJz
xhQnEbM+nbHTSvp2cFP1qMAvnM9RFBAr50t1CGeIebHNLy8V8yudPhhf2OTqxUnD
6MHMh2rtBquNJbdPAYmRgPtFMEJTeQyWf5JoJGQ/61jRs2V4pb6IXc2b1MEdZnkd
2eR6PgL9CILRGkdH2eqf8Lcrz7V1EgqkpjX+wm74dAqi/w6MugziYPQTnlpjo6y5
Lg/rVNlrTfPEfiiD0YL+jQo9vQljuLAbH3InXH6I6XqyUcxlq8KS4ny/NNKMfq1Y
g2PTjoAdyVEfs+C5eGMl7Xc0IlrYkdVVw7Dmdybt7tOyZXJJwLWHkdQnfNqyEcoa
6j+CY1cOCx2ffopMFYqOwD2rwK93a8aYO8dCKAtWsCVowxzY9B80PnFpahQTsJaP
xNM7yRfA+OeuEuAIaPsiG/4n7cw1GFG1j+eOcbykC0kBqoSRRi+v8LgTYqKXZ40l
uW13IyUt8o5+0UcYq0nG6kfp6JsNbMGSs9/OzA7mZntsoEm3jiP6BNHG4kE6VPgS
C6V1KEja29rkzOuVkT+Qj5bmvIe3PaxlMd1bgnDDZPVuVYSL/OXp9KSpUOeEBmXy
X6Mgb5s/DvpV9gn1N7d2AYAzZarPVINHr1HMO7+Kxe9MtYsHFLc=
=8cc/
-----END PGP SIGNATURE-----


Eric Bavier wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 34056-done@debbugs.gnu.org)
20190122220534.50f0bf69@centurylink.net
On Mon, 21 Jan 2019 19:16:22 -0600
Eric Bavier <ericbavier@centurylink.net> wrote:

Toggle quote (54 lines)
> On Mon, 21 Jan 2019 19:10:06 +0000
> Christopher Baines <mail@cbaines.net> wrote:
>
> > Eric Bavier <ericbavier@centurylink.net> writes:
> >
> > > On Sun, 13 Jan 2019 22:56:27 +0000
> > > Christopher Baines <mail@cbaines.net> wrote:
> > >
> > >> ericbavier@centurylink.net writes:
> > >>
> > >> > From: Eric Bavier <bavier@member.fsf.org>
> > >> >
> > >> > * gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' ->
> > >> > 'TESTOPTS'. This overrides the default '-l' argument for memory leak checks
> > >> > which is not compatible with the -j for parallelism.
> > >> > ---
> > >> > gnu/packages/python.scm | 2 +-
> > >> > 1 file changed, 1 insertion(+), 1 deletion(-)
> > >> >
> > >> > diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> > >> > index 9b43f465cc..dffded738d 100644
> > >> > --- a/gnu/packages/python.scm
> > >> > +++ b/gnu/packages/python.scm
> > >> > @@ -194,7 +194,7 @@
> > >> > (assoc-ref %outputs "out") "/lib"))
> > >> > ;; With no -j argument tests use all available cpus, so provide one.
> > >> > #:make-flags
> > >> > - (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
> > >> > + (list (format #f "TESTOPTS=-j~d" (parallel-job-count)))
> > >> >
> > >> > #:modules ((ice-9 ftw) (ice-9 match)
> > >> > (guix build utils) (guix build gnu-build-system))
> > >>
> > >> Hey Eric,
> > >>
> > >> I've also been looking at some Python 2 things on core-updates today,
> > >> trying to get the linkchecker package building again.
> > >>
> > >> I've just pushed a slightly different patch, but to this effect to
> > >> core-updates, and only just seen this message, sorry about that.
> > >
> > > Not a problem.
> > >
> > >> Thanks for looking at it though, this approach is probably neater, as I
> > >> used substitute* instead.
> > >
> > > Would you like to keep your patch, or apply this one instead?
> >
> > I'm quite happy to switch to this approach. I don't know whether the
> > best way to do that is to switch out the patches by force-pushing to
> > core-updates, or to just apply your patch on top though...
>
> I can just adjust my patch.

An adjusted patch, which reverts Christopher's patch was pushed to
core-updates in commit 32922190977f701694880254a71feb2752222f94

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlxH6A4ACgkQ/XPKxxnT
JWb+kQ//ZuZhwED4cADSgCXYr6VcntsWXrqrDFJpjsOgzuAUAA1efjD4ehXJDWs7
44K4QMRIEtPnp9JSOcv+3ZgV6Z9JWf1sUg6wv4rQ4KkM5RZNux3lfOfSXnaSdDTQ
p2cDInqWYQRNFAbLFi0aJ23e7JyHnrrpZnR7okgaHbgScq59bd3LgwM6YTAwQcE6
U/8gtgHTlcLwySGgfTjhhr7FIvQIMWVrhcsL9vyKFy7NC756RQ63y/dyDxL/pK1L
X0Fr0Wnr4v4OqpuawB3GaSshN5Qa4tb1ew2TCsVBXtBIitvE24C+0wYpPv26yNYp
xd0KeOo0Vmc78QKnA+Y2uHHmdlO1KvmH7j9hrBwKpLb+OM4LK9Gt50kzOtvCdkTH
WQddCChOSSqqINljrDDe7MOYirYSWe+vkPMw14n1FfAyejLzUiqw62Q0EFlPq8pt
3S0kqbrqQpAENZPd+QaGo/fp/PBYOvcg165ofRrnsyk1yKLQQAkmY9RRYZ8AeMgl
VpXMmVYDbIf1wSrnm7H6Ok06FjggeKTk8C9aBh0CGEmUS0exVkaz2eA/ybUdjrQD
z7JufvJc/n1g0pp+u/3FdeK1Co/IuGXiZFzRJT079RnXE1PWPbdZ6bleNJFXYb6o
ucGMerr1KX0wkfmnDn+lfiB6dRzOOwzSDHIv4+vsEWDppkLRfP8=
=xzra
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34056@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34056
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help