[PATCH] gnu: Add emacs-general.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Hondet
  • Ludovic Courtès
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
871s5q86lo.fsf@gmail.com
* gnu/packages/emacs.scm (emacs-general): New variable.
---
gnu/packages/emacs.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 07619e302..8ef2b94ee 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12963,3 +12963,34 @@ other frame parameters.")
(description "Emacs major mode for editing Arduino sketches.")
(home-page "https://github.com/bookest/arduino-mode")
(license license:gpl3+))))
+
+(define-public emacs-general
+ (let ((commit "675050199b5a30d54a24b58a367db32c0bdc47f5"))
+ (package
+ (name "emacs-general")
+ (version (git-version "0" "0" commit))
+ (home-page "https://github.com/noctuid/general.el")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit commit)))
+ (sha256
+ (base32
+ "175yyhzk57yk1sskxh3d2jzhrh2waiibbcfsll167qxr117yji5h"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (synopsis "More convenient key definitions in emacs")
+ (description "@code{general.el} provides a more convenient method for
+binding keys in emacs (for both evil and non-evil users). Like
+@code{use-package}, which provides a convenient, unified interface for
+managing packages, @code{general.el} is intended to provide a convenient,
+unified interface for key definitions. While this package does implement some
+completely new functionality (such as the ability to make vim-style
+keybindings under non-prefix keys with an optional timeout), its primary
+purpose is to build on existing functionality to make key definition more
+clear and concise. @code{general-define-key} is user-extensible and supports
+defining multiple keys in multiple keymaps at once, implicitly wrapping key
+strings with (@code{kbd ...}), using named prefix key sequences (like the
+leader key in vim), and much more.")
+ (license license:gpl3+))))
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwxzZMACgkQMbyBBfZZ
1CXc9A//c4evCuoQGqB/MvRQS376eZHbYMf6ZcBte7SVk7hvto/GzyONlCEG5cEe
OcWHKItdIvjuJS5SIVx8ix8nqXCu5ykDaYNnEPjweLhjBVus7/zBxMbe/KfEXjgk
lekkZZgI2hUoV7voRbgnu5iBDbEMx4cWJ/h8Ccl6bPSw953woc4eyTVP0v8lFnjo
0f8LgG9VMsK0kVJ8ZvCjpVbRwZpiz7DmPGSq6HhAwKjgtWJ7oarZw5ttamCcEmPS
AmJpQof6IXI3bbV0p73qCAct2sty/Ajq9kQakkmPazn8RLuJriqJcqE2HnHKPad2
y4I/yjuZJqzu+DzI2XVQRUZj8VTzVs6Nfpl61F6uWu2/yhvmG3sWdmQWiM3VOBDE
l1TQdtoyMpEecLESPhyRvMpM4P26ayO8pnxIv3fBnE3QItAq2Cb5NY4trhBq/xpT
BtiT3vGd7/CBFmsD53R8fXrmt1vmQUUsiSb7bM9dkm1BpK5L3ufv0ZyqMvGWqYdu
JinkrCQLuv6c3Y2KSv+BlYulGtJfD/CKKF9j2LwN1dUC8jNCneBxsvCPyefoJQXv
hNQE9swknjTVjkHGQoRg98sfDZqgmoM6hWedH2QWKfMwumEKBW+4Ft8P+bYL+uwp
GWO5bDH3r2AfOAKV2cqM9XmqrDVAQqpWcpD6R6TV9RGf8C8NbJo=
=zmXD
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 33995-done@debbugs.gnu.org)
87k1jb8oef.fsf@gnu.org
Gabriel Hondet <gabrielhondet@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-general): New variable.

Applied, thanks!

Ludo'.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33995@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33995
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help