[PATCH] gnu: python-pillow: Update to 5.4.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190106062145.9143-1-kkebreau@posteo.net
* gnu/packages/python.scm (python-pillow): Update to 5.4.0.
[arguments]: Add 'patch-ldconfig' phase.
[home-page]: Update URL.
---
gnu/packages/python.scm | 35 +++++++++++++++++++----------------
1 file changed, 19 insertions(+), 16 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ad5c56427..d7d6d1b8b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4151,17 +4151,17 @@ the OleFileIO module from PIL, the Python Image Library.")
(define-public python-pillow
(package
(name "python-pillow")
- (version "5.2.0")
+ (version "5.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pillow" version))
(sha256
(base32
- "1ary9mj2ddllq3lkxgn6aac7qxqiwbcg2pacrl94py58ql9x9czq"))))
+ "0qrkcjszym7ixffg5zphhp8a07w8w11yyc2ylcbdrhwm771z316m"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest)))
(inputs
`(("freetype" ,freetype)
("lcms" ,lcms)
@@ -4173,19 +4173,22 @@ the OleFileIO module from PIL, the Python Image Library.")
(propagated-inputs
`(("python-olefile" ,python-olefile)))
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after
- 'install 'check-installed
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (begin
- (setenv "HOME" (getcwd))
- ;; Make installed package available for running the
- ;; tests
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "selftest.py" "--installed")
- (invoke "python" "-m" "pytest" "-vv"))))
- (delete 'check))))
- (home-page "https://pypi.python.org/pypi/Pillow")
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-ldconfig
+ (lambda _
+ (substitute* "setup.py"
+ (("\\['/sbin/ldconfig', '-p'\\]") "['true']"))))
+ (delete 'check) ; We must run checks after python-pillow is installed.
+ (add-after 'install 'check-installed
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (begin
+ (setenv "HOME" (getcwd))
+ ;; Make installed package available for running the tests.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "selftest.py" "--installed")
+ (invoke "python" "-m" "pytest" "-vv")))))))
+ (home-page "https://python-pillow.org")
(synopsis "Fork of the Python Imaging Library")
(description
"The Python Imaging Library adds image processing capabilities to your
--
2.20.1
Marius Bakke wrote 6 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)
875zuu7pb6.fsf@fastmail.com
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (4 lines)
> * gnu/packages/python.scm (python-pillow): Update to 5.4.0.
> [arguments]: Add 'patch-ldconfig' phase.
> [home-page]: Update URL.

LGTM! I'd prefer the home page change as a separate commit, but no
strong opinion.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlw5JR0ACgkQoqBt8qM6
VPqjugf/VzKe0ZY6qi3EJyMWnsDOK46+Qi1zS170hrqh0VUXCm0L560FUW1jF94b
ZGL1fWHx4U5g7c2ZDLUGBcfCRk/lgMp5HqBhNu1fvc78dpEeQIWHVf5Pz5b7e4Of
dq580VVzG8K1LVL/hZT9GEz5XsJCOTCDSwDDX92Dd3EkheItmFHTsKEW8FrE8juT
bapFAc9oqXWw8Jd/N/wAl8P6X1omSCrzi9Y09t2tyw1C2Bvnm377TRGv524qJsT7
JEjybIInzT7R4g4JVmDL0DAPf8gDEMpX6gOdsn16uPr1XU3NO7eIaFKBEn8G3ce/
aYcp6KbvKv8uLZSuuL/CsfdM2W1zqw==
=K9zw
-----END PGP SIGNATURE-----

Kei Kebreau wrote 6 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 33994-done@debbugs.gnu.org)
87d0p1eeli.fsf@posteo.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (9 lines)
> Kei Kebreau <kkebreau@posteo.net> writes:
>
>> * gnu/packages/python.scm (python-pillow): Update to 5.4.0.
>> [arguments]: Add 'patch-ldconfig' phase.
>> [home-page]: Update URL.
>
> LGTM! I'd prefer the home page change as a separate commit, but no
> strong opinion.

Thanks for reviewing! I've split the patch and pushed.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlw6X5kACgkQ5qXuPBlG
eg2CEg/9GhSZZ4UUaVA6YFIvG7mHn8pBHww3WqXujuAgF3bZMbybJ1BRL2j244v/
2X2u9JS/nLUxYXPRHNsv562Sv/0NwYyGBELrV9vzGYHYTAy2Xx5cSOrMbDyXdFIe
1F1GXajYIlY/a6/RNr4a+YmoV/fAofx5EowkLlGaBKHCF7IxRIZ/N9cH5umGbRrt
1Z2kCw6jt10Eo+xvzoHBVsElmhgI1BuUx8G/U4KBtiKC53B5kdYrpAEhA0Dh2Sej
okFTNGAIHYMA6syId24qMF3pOyNca/hL6BPYCgyXtLRQmRSxVvKcQ8oJG/qmudeX
AH/qXk/GKpTuXL+zd9QAgD9LPA3OOY/CI4YzBS0aIGfs6i8eqpz6GFIfnjippKhd
unwAUNsXKiCoXR4JGkE5kIOxmZF/oTaKOYs97/Zlcf8HwhZZkvZ0qzo+w05UkMSx
WoWHpEPkHVVDdoOVgpqUaAvNVl/Yig4VZSAfkfbGmz+VSc0qDKslsYxy7mIoGqDb
Zc6q8xlM0qH+Jt8NNcU818DYO6YKLHJL7CD2Z8R0ZE1NKN2ZjXYpAHODMHmwA5Dc
b4rVjXv3zupbE7JdOqG60KXLj9GuaN2UrEr0jzI59wkN1kigmqOPyL2+xwhnKrA7
TRyxdeiw2sqNn3k5EbtDISGGQHVuIruyObrFvC3b55nb7LXdS1k=
=8ac4
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33994@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33994
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help