[PATCH] gnu: Add ghc-tldr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Hondet
  • Ludovic Courtès
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
878szz8fzn.fsf@gmail.com
* gnu/packages/haskell.scm (ghc-tldr): New variable.
---
gnu/packages/haskell.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8d0e2aef6..9a05f2a5c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11365,4 +11365,37 @@ embedded in your Haskell code.")
avoid the problem of partial intermediate files.")
(license license:expat)))
+(define-public ghc-tldr
+ (package
+ (name "ghc-tldr")
+ (version "0.4.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/tldr/tldr-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0nc581y9jjzwd8l88g48c72mla7k6q1w102akl7gl5jsk9ljamd3"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-cmark" ,ghc-cmark)
+ ("ghc-text" ,ghc-text)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-optparse-applicative"
+ ,ghc-optparse-applicative)
+ ("ghc-typed-process" ,ghc-typed-process)
+ ("ghc-semigroups" ,ghc-semigroups)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)))
+ (home-page
+ "https://github.com/psibi/tldr-hs#readme")
+ (synopsis "Haskell tldr client")
+ (description
+ "Haskell tldr client with support for updating and viewing tldr pages.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwwngwACgkQMbyBBfZZ
1CW1jg//eq3UxYHLkmuVpWNcyB57wlDmwY5zPYoZY86dtitGYCLl6E3iZp5xnoi3
+2EJ1oy6AaQ9YYiQiYuIVeMlx3Qhh3kYNSybCxDyovO2XnRX0pL6+HG9ThZ6bWtM
x4AcuZj/1SwaaJ1cnmwHzmVZim15uD3Lo9jB0OGYrzEENFIqY06NzYXKBPtc8dhc
CCEZ3jOEMTMGnsYycqziRS+QGX6HlE48oeE5fzPOf7ixsGPEnQPsoZGrVCqgLTfW
mR1P4huyl5sc0Zai+SVN+5CdHnRl3CGpNpq6YqybHprMJjruJIhOjIyzl0OKCJYO
vnPyZ0CjfqY37W392lzvnmNtjOPD6wEfqMXB+nDGXSStpRrvazPGK4EV/tciNFCE
froBBgpoS+Q0vuxdtVi5GXzE2rPqhTKqT2+2U3pj6cNvQ9R/TC088eWWB2RcFxRR
CIN5a3mvyCLwRe7w9hhT0cKZVMJe0+7sUXUes4Gpv7js6kFEzm7uXxLP7qWtfHxX
tIGOZvYV4R1Foe05ddANKpImIU0SOCmyRZS40JMYd28iXHUM0PPKa+zBQZmmYz6p
L4wmJiUppOtOoTey6v/hlPMo2RpbaCYWN3zbJCgrvje5kweYYuZNDZYvkxz1EXf1
+eA2FHCFWWqCVyoKrzh7owGyR49tn/QAOZ2xmRjvO6YmdRXxiYI=
=X47P
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 33987@debbugs.gnu.org)
87k1j6q44t.fsf@gnu.org
Hi,

Gabriel Hondet <gabrielhondet@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/haskell.scm (ghc-tldr): New variable.

This fails to build for me on 64d25f0be214795050b058047133d11f1d5dcbf5:

Toggle snippet (153 lines)
[1 of 1] Compiling Tldr ( src/Tldr.hs, dist/build/Tldr.o )

src/Tldr.hs:60:61: error:
• Couldn't match expected type ‘Text’
with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the second argument of ‘TIO.hPutStrLn’, namely ‘txt’
In the expression: TIO.hPutStrLn handle txt
In an equation for ‘renderNode’:
renderNode (TEXT txt) handle = TIO.hPutStrLn handle txt
|
60 | renderNode (TEXT txt) handle = TIO.hPutStrLn handle txt
| ^^^

src/Tldr.hs:61:61: error:
• Couldn't match expected type ‘Text’
with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the second argument of ‘TIO.hPutStrLn’, namely ‘txt’
In the expression: TIO.hPutStrLn handle txt
In an equation for ‘renderNode’:
renderNode (HTML_BLOCK txt) handle = TIO.hPutStrLn handle txt
|
61 | renderNode (HTML_BLOCK txt) handle = TIO.hPutStrLn handle txt
| ^^^

src/Tldr.hs:62:61: error:
• Couldn't match expected type ‘Text’
with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the second argument of ‘TIO.hPutStrLn’, namely ‘txt’
In the expression: TIO.hPutStrLn handle txt
In an equation for ‘renderNode’:
renderNode (CODE_BLOCK _ txt) handle = TIO.hPutStrLn handle txt
|
62 | renderNode (CODE_BLOCK _ txt) handle = TIO.hPutStrLn handle txt
| ^^^

src/Tldr.hs:63:61: error:
• Couldn't match expected type ‘Text’
with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the second argument of ‘TIO.hPutStrLn’, namely ‘txt’
In the expression: TIO.hPutStrLn handle txt
In an equation for ‘renderNode’:
renderNode (HTML_INLINE txt) handle = TIO.hPutStrLn handle txt
|
63 | renderNode (HTML_INLINE txt) handle = TIO.hPutStrLn handle txt
| ^^^

src/Tldr.hs:64:62: error:
• Couldn't match expected type ‘Text’
with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the second argument of ‘TIO.hPutStrLn’, namely
‘(" " <> txt)’
In the expression: TIO.hPutStrLn handle (" " <> txt)
In an equation for ‘renderNode’:
renderNode (CODE txt) handle = TIO.hPutStrLn handle (" " <> txt)
|
64 | renderNode (CODE txt) handle = TIO.hPutStrLn handle (" " <> txt)
| ^^^^^^^^^^^^

src/Tldr.hs:87:41: error:
• Couldn't match expected type ‘Text’
with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the expression: txt
In an equation for ‘handleSubsetNodeType’:
handleSubsetNodeType (HTML_BLOCK txt) = txt
|
87 | handleSubsetNodeType (HTML_BLOCK txt) = txt
| ^^^

src/Tldr.hs:88:43: error:
• Couldn't match expected type ‘Text’
with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the expression: txt
In an equation for ‘handleSubsetNodeType’:
handleSubsetNodeType (CODE_BLOCK _ txt) = txt
|
88 | handleSubsetNodeType (CODE_BLOCK _ txt) = txt
| ^^^

src/Tldr.hs:89:35: error:
• Couldn't match expected type ‘Text’
with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the expression: txt
In an equation for ‘handleSubsetNodeType’:
handleSubsetNodeType (TEXT txt) = txt
|
89 | handleSubsetNodeType (TEXT txt) = txt
| ^^^

src/Tldr.hs:90:42: error:
• Couldn't match expected type ‘Text’
with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the expression: txt
In an equation for ‘handleSubsetNodeType’:
handleSubsetNodeType (HTML_INLINE txt) = txt
|
90 | handleSubsetNodeType (HTML_INLINE txt) = txt
| ^^^

src/Tldr.hs:91:35: error:
• Couldn't match expected type ‘Text’
with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the expression: txt
In an equation for ‘handleSubsetNodeType’:
handleSubsetNodeType (CODE txt) = txt
|
91 | handleSubsetNodeType (CODE txt) = txt
| ^^^

src/Tldr.hs:114:34: error:
• Couldn't match expected type ‘text-1.2.3.0:Data.Text.Internal.Text’
with actual type ‘Text’
NB: ‘Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
‘text-1.2.3.0:Data.Text.Internal.Text’
is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
• In the second argument of ‘commonmarkToNode’, namely ‘page’
In the expression: commonmarkToNode [] page
In an equation for ‘node’: node = commonmarkToNode [] page
|
114 | let node = commonmarkToNode [] page
| ^^^^

Also, some minor issues:

Toggle quote (6 lines)
> + (home-page
> + "https://github.com/psibi/tldr-hs#readme")
> + (synopsis "Haskell tldr client")
> + (description
> + "Haskell tldr client with support for updating and viewing tldr pages.")

Please write a full sentence for the description. It’s also a good idea
to write “a client library for the tldr foo bar service” rather than
just “tldr client”, to give a bit of context (replace “foo bar” with
whatever makes sense, of course :-)).

Could you send an updated patch?

Thanks,
Ludo’.
Gabriel Hondet wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33987@debbugs.gnu.org)
87d0oydk8o.fsf@gmail.com
Hello,

On Mon 14 Jan 2019 at 23:13 Ludovic Courtès wrote:

Toggle quote (156 lines)
> This fails to build for me on 64d25f0be214795050b058047133d11f1d5dcbf5:
>
> --8<---------------cut here---------------start------------->8---
> [1 of 1] Compiling Tldr ( src/Tldr.hs, dist/build/Tldr.o )
>
> src/Tldr.hs:60:61: error:
> • Couldn't match expected type ‘Text’
> with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
> NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the second argument of ‘TIO.hPutStrLn’, namely ‘txt’
> In the expression: TIO.hPutStrLn handle txt
> In an equation for ‘renderNode’:
> renderNode (TEXT txt) handle = TIO.hPutStrLn handle txt
> |
> 60 | renderNode (TEXT txt) handle = TIO.hPutStrLn handle txt
> | ^^^
>
> src/Tldr.hs:61:61: error:
> • Couldn't match expected type ‘Text’
> with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
> NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the second argument of ‘TIO.hPutStrLn’, namely ‘txt’
> In the expression: TIO.hPutStrLn handle txt
> In an equation for ‘renderNode’:
> renderNode (HTML_BLOCK txt) handle = TIO.hPutStrLn handle txt
> |
> 61 | renderNode (HTML_BLOCK txt) handle = TIO.hPutStrLn handle txt
> | ^^^
>
> src/Tldr.hs:62:61: error:
> • Couldn't match expected type ‘Text’
> with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
> NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the second argument of ‘TIO.hPutStrLn’, namely ‘txt’
> In the expression: TIO.hPutStrLn handle txt
> In an equation for ‘renderNode’:
> renderNode (CODE_BLOCK _ txt) handle = TIO.hPutStrLn handle txt
> |
> 62 | renderNode (CODE_BLOCK _ txt) handle = TIO.hPutStrLn handle txt
> | ^^^
>
> src/Tldr.hs:63:61: error:
> • Couldn't match expected type ‘Text’
> with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
> NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the second argument of ‘TIO.hPutStrLn’, namely ‘txt’
> In the expression: TIO.hPutStrLn handle txt
> In an equation for ‘renderNode’:
> renderNode (HTML_INLINE txt) handle = TIO.hPutStrLn handle txt
> |
> 63 | renderNode (HTML_INLINE txt) handle = TIO.hPutStrLn handle txt
> | ^^^
>
> src/Tldr.hs:64:62: error:
> • Couldn't match expected type ‘Text’
> with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
> NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the second argument of ‘TIO.hPutStrLn’, namely
> ‘(" " <> txt)’
> In the expression: TIO.hPutStrLn handle (" " <> txt)
> In an equation for ‘renderNode’:
> renderNode (CODE txt) handle = TIO.hPutStrLn handle (" " <> txt)
> |
> 64 | renderNode (CODE txt) handle = TIO.hPutStrLn handle (" " <> txt)
> | ^^^^^^^^^^^^
>
> src/Tldr.hs:87:41: error:
> • Couldn't match expected type ‘Text’
> with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
> NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the expression: txt
> In an equation for ‘handleSubsetNodeType’:
> handleSubsetNodeType (HTML_BLOCK txt) = txt
> |
> 87 | handleSubsetNodeType (HTML_BLOCK txt) = txt
> | ^^^
>
> src/Tldr.hs:88:43: error:
> • Couldn't match expected type ‘Text’
> with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
> NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the expression: txt
> In an equation for ‘handleSubsetNodeType’:
> handleSubsetNodeType (CODE_BLOCK _ txt) = txt
> |
> 88 | handleSubsetNodeType (CODE_BLOCK _ txt) = txt
> | ^^^
>
> src/Tldr.hs:89:35: error:
> • Couldn't match expected type ‘Text’
> with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
> NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the expression: txt
> In an equation for ‘handleSubsetNodeType’:
> handleSubsetNodeType (TEXT txt) = txt
> |
> 89 | handleSubsetNodeType (TEXT txt) = txt
> | ^^^
>
> src/Tldr.hs:90:42: error:
> • Couldn't match expected type ‘Text’
> with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
> NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the expression: txt
> In an equation for ‘handleSubsetNodeType’:
> handleSubsetNodeType (HTML_INLINE txt) = txt
> |
> 90 | handleSubsetNodeType (HTML_INLINE txt) = txt
> | ^^^
>
> src/Tldr.hs:91:35: error:
> • Couldn't match expected type ‘Text’
> with actual type ‘text-1.2.3.0:Data.Text.Internal.Text’
> NB: ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘Text’ is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the expression: txt
> In an equation for ‘handleSubsetNodeType’:
> handleSubsetNodeType (CODE txt) = txt
> |
> 91 | handleSubsetNodeType (CODE txt) = txt
> | ^^^
>
> src/Tldr.hs:114:34: error:
> • Couldn't match expected type ‘text-1.2.3.0:Data.Text.Internal.Text’
> with actual type ‘Text’
> NB: ‘Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> ‘text-1.2.3.0:Data.Text.Internal.Text’
> is defined in ‘Data.Text.Internal’ in package ‘text-1.2.3.0’
> • In the second argument of ‘commonmarkToNode’, namely ‘page’
> In the expression: commonmarkToNode [] page
> In an equation for ‘node’: node = commonmarkToNode [] page
> |
> 114 | let node = commonmarkToNode [] page
> | ^^^^
> --8<---------------cut here---------------end--------------->8---

It builds correctly for me on 38f18309e1f13b1df9add9dafcbc634f0e15004c
and on 64d25f0be214795050b058047133d11f1d5dcbf5 as well, so I don't
know... But interestingly, I have already seen this error, with
text-1.2.3.0 (when trying to build ghc-conduit-extra for instance).

On the other hand I have removed two dependencies that were specified by
the ~guix import~ command but seemed useless, as it works without them
(ghc-text and ghc-ansi-terminal).

* gnu/packages/haskell.scm (ghc-tldr): New variable.
---
gnu/packages/haskell.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8d0e2aef6..280d0150f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2018 Tonton <tonton@riseup.net>
;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11365,4 +11366,36 @@ embedded in your Haskell code.")
avoid the problem of partial intermediate files.")
(license license:expat)))
+(define-public ghc-tldr
+ (package
+ (name "ghc-tldr")
+ (version "0.4.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/tldr/tldr-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0nc581y9jjzwd8l88g48c72mla7k6q1w102akl7gl5jsk9ljamd3"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-cmark" ,ghc-cmark)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-typed-process" ,ghc-typed-process)
+ ("ghc-semigroups" ,ghc-semigroups)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)))
+ (home-page
+ "https://github.com/psibi/tldr-hs#readme")
+ (synopsis "Haskell tldr client")
+ (description "Haskell client allowing the user to update and view
+@code{tldr} pages from a shell. The @code{tldr} pages are a community effort
+to simplify the man pages with practical examples.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here
--
2.20.1

Gabriel
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlw9+UcACgkQMbyBBfZZ
1CWWrA/8DSYD9YKIEjMRjNwUBOnSPd0LfNFmXE/JgThuet83CGD3Dm2CavnQlqEu
1/DQoH9FT22qa0gNXFIKcbpmUlrKORF0vMtpSoxPnbbthPRRbYMk57li04sGjgt3
F06oUiZJ/Tip7XJ4LGkiBAuSJlCVY1UhbTogDDrEUEeD/71oL9UYqx+cnG3bfltT
3+i3S0SPkZyRBrUarge4LbSOA5np3FuWxMPMbI0w5kczrSrxfGcZR7WkWYaAkCiZ
Oa3Xor1Z2Nt46IgZshgt5AkHTiOFJxUAyZipiv5OGfsIfnnORhWH84ohwOxcyGjv
uUYibBM1oNLNAUEtg+rPjYgwZfsDwAI6ZAai4HU4+WB6fTQAAU2ntWee+DWbH7cm
y3wbA0BuSnzXuE9B6/0Dl7K0zGq9+/cvb+xpgBUmilkf/YIwzc0ZxF9RmOHgujQ/
Cx1ruXXtpJ9oPUmqpTRRLE8OR9eHt+Ch/1FdT6J2l3o9iswkz/1YPdYq7IDKPw1I
i4s9uigx8nWfSzQ1JsdmmJNG+wtqGXZ49nt3KPw0VoxBJ22hPn7UIeQ50wwDMlBR
2g2WywCkbbqHcePMc+QDAwBiEgzDzBHLlMHidGq6X/ivrVpj2oCtOTjIZf4zVGg4
ry9R89yV+snQQORbqe+NoHPSFHOS0A1RJS2q8z+dYH4NsduWayk=
=nyw8
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 33987-done@debbugs.gnu.org)
87fttry7qa.fsf@gnu.org
Hi,

Gabriel Hondet <gabrielhondet@gmail.com> skribis:

Toggle quote (11 lines)
> It builds correctly for me on 38f18309e1f13b1df9add9dafcbc634f0e15004c
> and on 64d25f0be214795050b058047133d11f1d5dcbf5 as well, so I don't
> know... But interestingly, I have already seen this error, with
> text-1.2.3.0 (when trying to build ghc-conduit-extra for instance).
>
> On the other hand I have removed two dependencies that were specified by
> the ~guix import~ command but seemed useless, as it works without them
> (ghc-text and ghc-ansi-terminal).
>
> * gnu/packages/haskell.scm (ghc-tldr): New variable.

Well, it works for me this time.

Applied with the minor changes below.

The ‘tldr’ command looks pretty handy!

Thanks,
Ludo’.
Toggle diff (22 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9db23be01e..b40a5d05da 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11389,12 +11389,12 @@ avoid the problem of partial intermediate files.")
(native-inputs
`(("ghc-tasty" ,ghc-tasty)
("ghc-tasty-golden" ,ghc-tasty-golden)))
- (home-page
- "https://github.com/psibi/tldr-hs#readme")
+ (home-page "https://github.com/psibi/tldr-hs#readme")
(synopsis "Haskell tldr client")
- (description "Haskell client allowing the user to update and view
-@code{tldr} pages from a shell. The @code{tldr} pages are a community effort
-to simplify the man pages with practical examples.")
+ (description "This package provides the @command{tldr} command and a
+Haskell client library allowing users to update and view @code{tldr} pages
+from a shell. The @code{tldr} pages are a community effort to simplify the
+man pages with practical examples.")
(license license:bsd-3)))
;;; haskell.scm ends here
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33987@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33987
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help