[PATCH] gnu: Add dev86.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 6 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20190104172414.21142-1-dannym@scratchpost.org
* gnu/packages/assembly.scm (dev86): New variable.
---
gnu/packages/assembly.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 763d183cf..63f799f41 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -122,3 +122,37 @@ abstracts over the target CPU by exposing a standardized RISC instruction set
to the clients.")
(home-page "https://www.gnu.org/software/lightning/")
(license license:gpl3+)))
+
+(define-public dev86
+ (package
+ (name "dev86")
+ (version "0.16.21")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://v3.sk/~lkundrak/dev86/Dev86src-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "154dyr2ph4n0kwi8yx0n78j128kw29rk9r9f7s2gddzrdl712jr3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "-j" "1" ; They use submakes wrong
+ "CC=gcc"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:system "i686-linux" ; Standalone ld86 had problems otherwise
+ #:tests? #f ; No tests exist
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'mkdir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ (mkdir-p (string-append out "/man/man1"))
+ #t))))))
+ (synopsis "X86 16-bit assembler, C compiler and linker")
+ (description "This package provides a X86 16-bit assembler, a C compiler
+and a linker.")
+ (home-page "https://github.com/jbruchon/dev86")
+ (license license:gpl2)))
Ludovic Courtès wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 33976@debbugs.gnu.org)
874lah4x94.fsf@gnu.org
Hi,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/assembly.scm (dev86): New variable.

[...]

Toggle quote (3 lines)
> + (arguments
> + `(#:make-flags (list "-j" "1" ; They use submakes wrong

Maybe #:parallel-build? #f for clarity.

Toggle quote (2 lines)
> + #:system "i686-linux" ; Standalone ld86 had problems otherwise

Please add ‘supported-systems’ accordingly.

Toggle quote (14 lines)
> + #:tests? #f ; No tests exist
> + #:phases
> + (modify-phases %standard-phases
> + (delete 'configure)
> + (add-before 'install 'mkdir
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((out (assoc-ref outputs "out")))
> + (mkdir-p (string-append out "/bin"))
> + (mkdir-p (string-append out "/man/man1"))
> + #t))))))
> + (synopsis "X86 16-bit assembler, C compiler and linker")
> + (description "This package provides a X86 16-bit assembler, a C compiler
> +and a linker.")

s/X86/Intel 8086/, no?

It’d be nice to add a few words about what’s special about this
toolchain (not obvious from their README…).

Toggle quote (3 lines)
> + (license license:gpl2)))

There are no headers in source files so it should be gpl2+.

OK with these changes, thank you!

Ludo’.
Danny Milosavljevic wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33976@debbugs.gnu.org)
20190109193410.53a1465e@scratchpost.org
Toggle quote (3 lines)
> It’d be nice to add a few words about what’s special about this
> toolchain (not obvious from their README…).

It's primarily 16-bit. I package it because of xen which uses it to compile
old-school BIOSes.

It was quite popular in 1990 and used even by the Linux kernel.

Nowadays, few projects still use it.

I pushed it as 1bde3d2cbf311f6d6c733339a000b7395cb2f945.

Please amend description if necessary.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlw2PqIACgkQ5xo1VCww
uqU+Jgf/VWrr/vjU5TlLyTaDxp6j3gvvVnNtj3CXkQJZKoNrsNzykntfTna9ai2J
BRYcTbEdcglrZNOx5Ao6COzrqfYcEHJc1DNbADuvvFpzjPmwqSlpVVCnfwsD+lFL
pn+K8/b0LYT9zUXLawQ4aqfTO6IvR56229OARJPOGREezaXARxcPh5l2422xIDHS
fKA0eR6YP1+7I/L0J9/N0pYx3fsXjHWFNBtfHvurS92a6G7qxbu1MniCHpVKw/QJ
4D5iyTjflFXFACxtHyIeZ6/vP/7bD14qZZeKERUHKbqDJXRhq0yEvACYCQP1OaXC
4nZKK3GYvyi7T1XW0vOmP9bThqtLQg==
=4nST
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 6 years ago
(no subject)
(address . control@debbugs.gnu.org)
20190109193442.1642753e@scratchpost.org
close 33976
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlw2PsIACgkQ5xo1VCww
uqU+tAf/dxJAy04shEMhC2R999Xt4foocXoXs3XEXMymJnbNE0d6SB74EH7xG8kh
scsiIkL1UXmgde0JAwRF9ltQUEH6mk13KW2lPPsmfFuSzYkrKskYPUmRpZRTatBe
xpdeO4XYTDE0bha/sWa9a3zd220QiCr4ayHd4ry8QrcNG5UpjM6WAs4zWpfh9Puw
dFNfgIz0IE7+NwXWg0FxnlW62Z+xs9pb8HbhUKQie/Y3uXkGay1+NnFyfabvfHP1
THKnAGE/6JwauojOh9w0OILZfNEX6dQewdgGoOIHnHj5CQ5LeeOzSbqATnsRifwO
MAjO395j6Xcgp9XldasZlrMPg3KLsg==
=isHV
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 6 years ago
Re: [bug#33976] [PATCH] gnu: Add dev86.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 33976-done@debbugs.gnu.org)
871s5kgbgk.fsf@gnu.org
Hello,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (5 lines)
> It's primarily 16-bit. I package it because of xen which uses it to compile
> old-school BIOSes.
>
> It was quite popular in 1990 and used even by the Linux kernel.

Oh, fun.

Toggle quote (2 lines)
> I pushed it as 1bde3d2cbf311f6d6c733339a000b7395cb2f945.

Thanks!

Toggle quote (2 lines)
> Please amend description if necessary.

I’m not in a good position to do that because I know too little about
it. In general, I don’t think the burden should be on the reviewer—we
already have too few people reviewing patches.

Ludo’.
Closed
Danny Milosavljevic wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33976-done@debbugs.gnu.org)
20190110140102.50560e36@scratchpost.org
Hi Ludo,

On Thu, 10 Jan 2019 09:31:55 +0100
Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (6 lines)
> > Please amend description if necessary.
>
> I’m not in a good position to do that because I know too little about
> it. In general, I don’t think the burden should be on the reviewer—we
> already have too few people reviewing patches.

I agree! I had already extended the description. I meant don't hesitate to
edit it further if you want to.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlw3Qg4ACgkQ5xo1VCww
uqXQ1Af/exSRnJ10Js5HMhdkQPPgH9y7SGASUQKnIgGK276G0pb+vC2AnEDxZ3h7
/hbDPC9bRxeQ+6p53ynyHNAv4i0Yj9FoR5wDCxSYgCpD0hpxi9kBDUmgAedpi9ds
nNCPIcjd+cwtHdAjLRscwSTO6r6G3OVyLzZlAIKciQON8SOwEAiI8PbKVNVUfla7
UIX/7QRLTGfU6L2JVp3uB3k9azMzTXhNmI6IZ5hBUliwqoW1pC6jts1Jjsx0TINU
uEuGopTMztgx/gxyt3C6WbIcl01k+CN5WSf21IHtZkH6Xa+hs9QO+ZVE6EjieEna
g8YFRLobAHij/zLHpJ6nMo2JhxQ+bA==
=2Fzi
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33976@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33976
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help