Danny Milosavljevic wrote 6 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/packages/assembly.scm (dev86): New variable.
---
gnu/packages/assembly.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (42 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 763d183cf..63f799f41 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -122,3 +122,37 @@ abstracts over the target CPU by exposing a standardized RISC instruction set
to the clients.")
(home-page "https://www.gnu.org/software/lightning/")
(license license:gpl3+)))
+
+(define-public dev86
+ (package
+ (name "dev86")
+ (version "0.16.21")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://v3.sk/~lkundrak/dev86/Dev86src-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "154dyr2ph4n0kwi8yx0n78j128kw29rk9r9f7s2gddzrdl712jr3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "-j" "1" ; They use submakes wrong
+ "CC=gcc"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:system "i686-linux" ; Standalone ld86 had problems otherwise
+ #:tests? #f ; No tests exist
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'mkdir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ (mkdir-p (string-append out "/man/man1"))
+ #t))))))
+ (synopsis "X86 16-bit assembler, C compiler and linker")
+ (description "This package provides a X86 16-bit assembler, a C compiler
+and a linker.")
+ (home-page "https://github.com/jbruchon/dev86")
+ (license license:gpl2)))