[PATCH] gnu: Add emacs-tldr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Hondet
  • Ludovic Courtès
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
87ftuaix63.fsf@gmail.com
* gnu/packages/emacs.scm (emacs-tldr): New variable.
---
gnu/packages/emacs.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ffb5a1518..58c6e718c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12961,3 +12961,25 @@ other frame parameters.")
(description "Emacs major mode for editing Arduino sketches.")
(home-page "https://github.com/bookest/arduino-mode")
(license license:gpl3+))))
+
+(define-public emacs-tldr
+ (let ((commit "398b197c8d2238628b07e1b32d0f373876279f4c"))
+ (package
+ (name "emacs-tldr")
+ (version (git-version "0" "0" commit))
+ (home-page "https://github.com/kuanyui/tldr.el")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit commit)))
+ (sha256
+ (base32
+ "0iq7qlis6c6r2qkdpncrhh5vsihkhvy5x4y1y8cjb7zxkh62w33f"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (synopsis "Simplified and community-driven man pages for emacs")
+ (description "@code{emacs-tldr} allows the user to access tldr pages
+from within emacs. The @code{tldr} pages are a community effort to simplify
+the man pages with practical examples.")
+ (license license:wtfpl2))))
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwtKJQACgkQMbyBBfZZ
1CVa3g/9Ew3jKEP0DnU+ATPlkH+BTrPRfs+RiNlLs2jnAb/vncnRsMraa9EHqXiK
/X4kOviqpbtc1ODYnYDEDisL5Y6yEZlsZ0B9pfjlVsaQ5x8+5tDLsNpjkvBaZK75
jsUQVEW5kEbibAwFGddO+p3QWCUS3hdhqKRcuLAijjKYodHWkbD02zaTQvWQJ53h
V4SxZ1aDjK1D50vvhY5iJJMdr9hag7N23xlhpXLLOk1xmHUWxR63mnH2YLfWFwUc
Frn17HuyUPcice65M9whqN0Q3AB3rQVUvUDz+5GMWpmViQiTMNxBvd7ENTFAI1jv
gh5bpFwIdDav9C4+q117N7ZOpsg8M0HeVOT6anqxccNpPp0NXvl0tuuIJnZ13fot
z1zzkgbBduPBqLFpXtNXjbpwEJAB6vt6tvV/mDlQfUXdF7t3DO+DaQt469yB8/nK
vAQ3iO4GS30kc7x7JU70FgIzOpr/7mzamfRClJ/EZw62nRf8isqSyzddpk5kiVy8
YyT4cKfTSTk/QD7cT5xEVK6/WKnjstnS87/BFIHU0/pA3AN3BOUEqfnwNDEhR/Z4
qM0nodvipt/s2ZOHD3PAX8CTvaP7LJUUVzYvFTjIdCiQaTLEWxyk3ejOoz2LASSR
3F1ceumhxmRbJS3pBr44BYtAjvFpm6HBn84aZmIBb/hpqvJXqcM=
=MkS5
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 33956-done@debbugs.gnu.org)
8736pwyz5q.fsf@gnu.org
Gabriel Hondet <gabrielhondet@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-tldr): New variable.

Applied, thanks!

Ludo'.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33956@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33956
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help