[PATCH] gnu: cmake-extra-modules: Fix QTPLUGINDIR.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hartmut Goebel
  • Meiyo Peng
Owner
unassigned
Submitted by
Meiyo Peng
Severity
normal

Debbugs page

Meiyo Peng wrote 6 years ago
(address . guix-patches@gnu.org)
87k1jns7mm.fsf@gmail.com
Hi,

This patch fixes the regular expression for QTPLUGINDIR.

The source code of "kde-modules/KDEInstallDirs.cmake" has been changed
by upstream in recent releases. This regular expression bug caused
dependent packages install qt plugins into a wrong directory.
From a242fed166b0939365a6e6f3259c65471dc01db7 Mon Sep 17 00:00:00 2001
From: Meiyo Peng <meiyo.peng@gmail.com>
Date: Sat, 29 Dec 2018 00:06:00 +0800
Subject: [PATCH] gnu: cmake-extra-modules: Fix QTPLUGINDIR.

* gnu/packages/kde-frameworks.scm (cmake-extra-modules)[arguments]: Fix
QTPLUGINDIR.
---
gnu/packages/kde-frameworks.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6c1854379..5c21a7fb7 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -98,7 +99,7 @@
(("\"lib64\"") "\"lib\"")
;; TODO: Base the following on values taken from Qt
;; Install plugins into lib/qt5/plugins
- (("_define_relative\\(QTPLUGINDIR LIBDIR \"plugins\"")
+ (("_define_relative\\(QTPLUGINDIR \"\\$\\{_pluginsDirParent\\}\" \"plugins\"")
"_define_relative(QTPLUGINDIR LIBDIR \"qt5/plugins\"")
;; Install imports into lib/qt5/imports
(("_define_relative\\(QTQUICKIMPORTSDIR QTPLUGINDIR \"imports\"")
--
2.20.1
Hartmut Goebel wrote 6 years ago
Re: [bug#33955] [PATCH 0/6] KDE: Enable more tests.
(name . Meiyo Peng)(address . meiyo.peng@gmail.com)(address . 33951@debbugs.gnu.org)
dac51d24-9f0e-cb04-e625-532e6eea9554@crazy-compilers.com
Hi Meiyo,
Toggle quote (2 lines)
> Would you mind having a look at patch #33951:

Thanks for pointing me to this.

This mainly is a duplicate of
few days earlier.

The difference is that #33951 does not care about the Android
special-case, while #33812 tries to do and adds a respective comment. So
IMHO #33812 is to be preferred. WDYT?

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
Meiyo Peng wrote 6 years ago
(name . Hartmut Goebel)(address . h.goebel@crazy-compilers.com)(address . 33951@debbugs.gnu.org)
8736q9kysf.fsf@gmail.com
Hi Hartmut,

Hartmut Goebel <h.goebel@crazy-compilers.com> writes:

Toggle quote (9 lines)
> Hi Meiyo,
>> Would you mind having a look at patch #33951:
>
> Thanks for pointing me to this.
>
> This mainly is a duplicate of
> <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=33812#5> which I files a
> few days earlier.

Sorry, I didn't notice your patch.

Toggle quote (4 lines)
> The difference is that #33951 does not care about the Android
> special-case, while #33812 tries to do and adds a respective comment. So
> IMHO #33812 is to be preferred. WDYT?

You are doing a great job. I agree to keep #33812 and drop #33951.

--
Meiyo Peng
Hartmut Goebel wrote 6 years ago
(name . Meiyo Peng)(address . meiyo.peng@gmail.com)(address . 33951-close@debbugs.gnu.org)
923fbee7-2521-41da-abf5-3af3b7f3c1a9@crazy-compilers.com
Am 04.01.19 um 02:16 schrieb Meiyo Peng:

Toggle quote (2 lines)
> You are doing a great job.

Thanks :-)

Toggle quote (2 lines)
> I agree to keep #33812 and drop #33951.

I applied #33812 as b824dbec5d331e79a50734fb543bbe064eb7fc17.


--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33951@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33951
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help