[PATCH 3/7] gnu: Add emacs-treepy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jelle Licht
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jelle Licht
Severity
normal

Debbugs page

Jelle Licht wrote 6 years ago
(address . guix-patches@gnu.org)(name . Jelle Licht)(address . jlicht@fsfe.org)
20181229150301.30567-4-jlicht@fsfe.org
* gnu/packages/emacs.scm (emacs-treepy): New variable.
---
gnu/packages/emacs.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 0e1a525ab..2e441d41a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -627,6 +627,28 @@ these arguments. The prototypical use is for the command to call an external
process, passing on the arguments as command line arguments.")
(license license:gpl3+)))
+(define-public emacs-treepy
+ (package
+ (name "emacs-treepy")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/volrath/treepy.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04zwm6gx9pxfvgfkizx6pvb1ql8pqxjyzqp8flz0432x0gq5nlxk"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/volrath/treepy.el")
+ (synopsis "Tree traversal tools")
+ (description
+ "Generic tools for recursive and iterative tree traversal based on
+clojure.walk and clojure.zip respectively.")
+ (license license:gpl3+)))
+
(define-public emacs-ghub
(package
(name "emacs-ghub")
--
2.20.1
Ludovic Courtès wrote 6 years ago
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 33909@debbugs.gnu.org)
87muo96dl2.fsf@gnu.org
Jelle Licht <jlicht@fsfe.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-treepy): New variable.

LGTM!
Jelle Licht wrote 6 years ago
control message for bug #33909
(address . control@debbugs.gnu.org)
87bm4pfpje.fsf@fsfe.org
tags 33909 fixed
close 33909
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33909@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33909
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help