[PATCH] gnu: Add dummy linker for arm-elf.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 6 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20181228133637.18665-1-dannym@scratchpost.org
* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add case for arm-elf.
---
gnu/packages/bootstrap.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (12 lines)
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 936d6c1a2..a3ecbeb07 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -180,6 +180,7 @@ return value is ignored."
;; XXX: This one is used bare-bones, without a libc, so add a case
;; here just so we can keep going.
+ ((string=? system "arm-elf") "no-ld.so")
((string=? system "arm-eabi") "no-ld.so")
((string=? system "xtensa-elf") "no-ld.so")
((string=? system "avr") "no-ld.so")
Ludovic Courtès wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 33895@debbugs.gnu.org)
87y37xy25k.fsf@gnu.org
Hi Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add case for arm-elf.

OK!

Ludo'.
Danny Milosavljevic wrote 6 years ago
(no subject)
(address . control@debbugs.gnu.org)
20190107164021.003c8684@scratchpost.org
close 33895
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlwzcuUACgkQ5xo1VCww
uqWcyQf7B+zhKB13meAd47MWx+D11lSf1lqnpyJyzHHYjzKxa+FtytCJ5usTHWzu
FURFGef7iIgLb7frJRHw2nXuwKfsupHd5AYzyKuq28UvpGlqrbLDbxuYNXqjUEGT
L+gBLNXd4184SjepgKMq9nDoYD1OWpaSlfWYKugA1eNKzd8G75r4gcEvmHQWRkDM
It8zcaEc9vV0SRloKPKJZQxT/Xs7Q49TozieffE/+oNHtz1URnSjPmKWnt2lFoUJ
sI0Ny21HOK8sWYLHdTzKv0GeTAJ9zPhQ4ZUPrXlrVV35fyEjJBpKW7sm01WVNiMx
dUyNpMoUSYb8knFymWQwm3IR8ZCykA==
=Ya69
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 33895@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33895
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help