[PATCH] gnu: Add ocaml-merlin.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Hondet
  • Ludovic Courtès
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
87o997watf.fsf@gmail.com
* gnu/packages/ocaml.scm (ocaml-merlin): New variable.
---
gnu/packages/ocaml.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6a16f0729..5b36456fb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5124,3 +5124,34 @@ speedup, polymorphic variants and optional syntax for tuples and variants.
yojson package. The program @code{atdgen} can be used to derive OCaml-JSON
serializers and deserializers from type definitions.")
(license license:bsd-3)))
+
+(define-public ocaml-merlin
+ (package
+ (name "ocaml-merlin")
+ (version "3.2.2")
+ (home-page "https://ocaml.github.io/merlin/")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/merlin.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15ssgmwdxylbwhld9p1cq8x6kadxyhll5bfyf11dddj6cldna3hb"))))
+ (build-system dune-build-system)
+ (inputs
+ `(("ocaml-biniou" ,ocaml-biniou)
+ ("ocaml-yojson" ,ocaml-yojson)
+ ("ocaml-easy-format" ,ocaml-easy-format)))
+ (native-inputs
+ `(("ocaml-findlib" ,ocaml-findlib)))
+ (arguments
+ '(#:tests? #f)) ;; Errors in tests in version 3.2.2
+ (synopsis "Context sensitive completion for OCaml in Vim and Emacs")
+ (description "Merlin is an editor service that provides modern IDE
+features for OCaml. Emacs and Vim support is provided out-of-the-box.
+External contributors added support for Visual Studio Code, Sublime Text and
+Atom.")
+ (license license:expat)))
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwkojwACgkQMbyBBfZZ
1CWX1A//QIoUqOjWbUZmV50ishW2KmNPjgO2EqhpTH/2rdx5gy0uX1SYOVfAibdw
OSd1dY+zX5OsGEnUr8YfbeWL2rbq0GqA6zOGxAJgDCBjPtcOGz2N/PAPCbVsSK+R
Y9mxpTW1JcXM34nkUV6eN1ScujFOkJrPNTwHvUE5CoORmYsKOrlTz2YK189a1xq8
YJnQjSU8f+tj7k/N8TqQzHwEvUJiISeLHzv3rRgjzWrtI8x0gL31hbl7e4HzTgCF
KXqeNvp1p5lpH3hNYTMF/bGVklri6AoKipZvPXhWyvdA1aOI6IAJWqnRPcq417I2
blfZQKn7UZDNG5A/zPfMqsDxx6UoL3KzwggUgNmo3l3bpMBn7JXcMF2Q2NEtCIYZ
u+3cG3gs+J1DNheLJyV3kI3Z6R0TIYYkrtfUPL94FQ3hSNivLMcDxW1Rq0JfP8g+
FzvU6ZhMl93QZ/QpIPF21Nqw3fDad0VBfEGoGwiArZ2yXeymFZ8Qowk+jxq+LDxP
iD9/W/rj/gnx2Tj8SQ6wHxeuqYMvRDdyrXlRSxrK2aAhr//4Oc4d2WAKvIkAhdzM
lvmSYcuDsKGq/9jBzMzJHfqEyj9hiofuWYaL0l3CKV9vM/IZX0X7Ys2OT/bznuHx
oHLXSyQBaiY1szHiQb0QBpOlq8ZXZicJD7o6Z6Yj9jg10339I0A=
=l1dG
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 33886-done@debbugs.gnu.org)
87y37oxkbb.fsf@gnu.org
Gabriel Hondet <gabrielhondet@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/ocaml.scm (ocaml-merlin): New variable.

Looks like this one had fallen through the cracks… Applied!

Toggle quote (3 lines)
> + (arguments
> + '(#:tests? #f)) ;; Errors in tests in version 3.2.2

It would be nice to figure out what’s wrong.

Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33886@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33886
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help