Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
* gnu/packages/ocaml.scm (ocaml-biniou): New variable.
---
gnu/packages/ocaml.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)
Toggle diff (51 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 603db34db..4cfd203bd 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5044,3 +5044,44 @@ dependent types. The λΠ-calculus modulo theory is itself an extension of the
rules. This system is not designed to develop proofs, but to check proofs
developed in other systems. In particular, it enjoys a minimalistic syntax.")
(license license:cecill-c)))
+
+(define-public ocaml-biniou
+ (package
+ (name "ocaml-biniou")
+ (version "1.2.0")
+ (home-page "https://github.com/mjambon/biniou")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mjpgwyfq2b2izjw0flmlpvdjgqpq8shs89hxj1np2r50csr8dcb"))))
+ (build-system ocaml-build-system)
+ (inputs
+ `(("ocaml-easy-format" ,ocaml-easy-format)))
+ (native-inputs
+ `(("which" ,which)
+ ("ocaml-jbuilder" ,ocaml-jbuilder)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ ;; install target in makefile is missing from this version
+ (lambda _
+ (invoke "jbuilder" "install"
+ (string-append "--prefix="
+ (assoc-ref %outputs "out"))))))))
+ (synopsis "Data format designed for speed, safety, ease of use and backward
+compatibility")
+ (description "Biniou (pronounced \"be new\" is a binary data format
+designed for speed, safety, ease of use and backward compatibility as
+protocols evolve. Biniou is vastly equivalent to JSON in terms of
+functionality but allows implementations several times faster (4 times faster
+than yojson), with 25-35% space savings.")
+ (license license:bsd-3)))
+
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwj0LgACgkQMbyBBfZZ
1CVVgA//cztYbwaFfmtiFN9YyNH+KreBImAdHUsSSkYMw2Sg1TCDc15lkgWrDPTn
dGPCAB1OI2IJiJDN1/LUsaT/laBkJKhIHFS2kSBEhRi86dPUpVuytLIO7QpFPzBH
AF7fqQvzX8mmsoCBW3X43QATQOFUvluVYPXcoYZp5PSfLMaQ4Rbpp3z6c0GigsXg
lPPvqNxGjxazEe+3zvp6206sJnTNMeKqbJDa0uII1Q6Yh+No6XgvSKF+1oo9EklR
zp3KXVogFE4VyeXPTXaf8uledGWoFXy/UMWkDis5+tW/k5m0r7RQDaHKp3wPQuIn
DnEDZRX53pRZoqaCNjhG2JJABUMsbnp+wBB0bvmpAZiMO6RgguDxMX5rBG3LTi3E
WGUALYCZIfP6OESp+h7OeVC1itM/bGgUI9tTFd0c5c+toDTgPZWg3SGalp7Z69T4
P+KxPWLTYE5uwTIgi3kpSoTdLhLKwtuy26M5xu8vFYul0XWFq8ULNZTfTUESkHFH
5qBgyU3mi4oj+0sCab2C6eVo9v9f1yRZOwp92B4187byevvfjomQdEXpXvXJLDRd
U8YQK4dV18vGPvi/n6Tc1xzf1X7N07mVFmq8V3C4duS/Sswl/eiCA4QezvVuLr96
lX3xurLUX372ltxvCqFWMOBo5atG/QvjMPuZIMtlQPr2RJmOrdE=
=4qdK
-----END PGP SIGNATURE-----