[PATCH] gnu: Add ocaml-biniou.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Hondet
  • Julien Lepiller
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
87r2e4w1mv.fsf@gmail.com
* gnu/packages/ocaml.scm (ocaml-biniou): New variable.
---
gnu/packages/ocaml.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 603db34db..4cfd203bd 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5044,3 +5044,44 @@ dependent types. The λΠ-calculus modulo theory is itself an extension of the
rules. This system is not designed to develop proofs, but to check proofs
developed in other systems. In particular, it enjoys a minimalistic syntax.")
(license license:cecill-c)))
+
+(define-public ocaml-biniou
+ (package
+ (name "ocaml-biniou")
+ (version "1.2.0")
+ (home-page "https://github.com/mjambon/biniou")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mjpgwyfq2b2izjw0flmlpvdjgqpq8shs89hxj1np2r50csr8dcb"))))
+ (build-system ocaml-build-system)
+ (inputs
+ `(("ocaml-easy-format" ,ocaml-easy-format)))
+ (native-inputs
+ `(("which" ,which)
+ ("ocaml-jbuilder" ,ocaml-jbuilder)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ ;; install target in makefile is missing from this version
+ (lambda _
+ (invoke "jbuilder" "install"
+ (string-append "--prefix="
+ (assoc-ref %outputs "out"))))))))
+ (synopsis "Data format designed for speed, safety, ease of use and backward
+compatibility")
+ (description "Biniou (pronounced \"be new\" is a binary data format
+designed for speed, safety, ease of use and backward compatibility as
+protocols evolve. Biniou is vastly equivalent to JSON in terms of
+functionality but allows implementations several times faster (4 times faster
+than yojson), with 25-35% space savings.")
+ (license license:bsd-3)))
+
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwj0LgACgkQMbyBBfZZ
1CVVgA//cztYbwaFfmtiFN9YyNH+KreBImAdHUsSSkYMw2Sg1TCDc15lkgWrDPTn
dGPCAB1OI2IJiJDN1/LUsaT/laBkJKhIHFS2kSBEhRi86dPUpVuytLIO7QpFPzBH
AF7fqQvzX8mmsoCBW3X43QATQOFUvluVYPXcoYZp5PSfLMaQ4Rbpp3z6c0GigsXg
lPPvqNxGjxazEe+3zvp6206sJnTNMeKqbJDa0uII1Q6Yh+No6XgvSKF+1oo9EklR
zp3KXVogFE4VyeXPTXaf8uledGWoFXy/UMWkDis5+tW/k5m0r7RQDaHKp3wPQuIn
DnEDZRX53pRZoqaCNjhG2JJABUMsbnp+wBB0bvmpAZiMO6RgguDxMX5rBG3LTi3E
WGUALYCZIfP6OESp+h7OeVC1itM/bGgUI9tTFd0c5c+toDTgPZWg3SGalp7Z69T4
P+KxPWLTYE5uwTIgi3kpSoTdLhLKwtuy26M5xu8vFYul0XWFq8ULNZTfTUESkHFH
5qBgyU3mi4oj+0sCab2C6eVo9v9f1yRZOwp92B4187byevvfjomQdEXpXvXJLDRd
U8YQK4dV18vGPvi/n6Tc1xzf1X7N07mVFmq8V3C4duS/Sswl/eiCA4QezvVuLr96
lX3xurLUX372ltxvCqFWMOBo5atG/QvjMPuZIMtlQPr2RJmOrdE=
=4qdK
-----END PGP SIGNATURE-----

Julien Lepiller wrote 6 years ago
(address . 33879-done@debbugs.gnu.org)
20181227095054.75dc1ee9@lepiller.eu
Pushed as 2939fe7b3cb5a53daebab7b7734e29be3ba8d153, thank you!

I've modified the definition to use the dune-build-system, as that's
what used by the opam file anyway. In that case, no need to add jbuild
as an input, it's added implicitely (well, actually it's dune, but it
works).
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEtfrmKFtBNyiyoPrtQxEfRSAIagwFAlwkkm4ACgkQQxEfRSAI
agzs7Q/9Hj1CA63Ihb43NadAF5LmEvr57PjYZS7zH52H/VIymw6YCvT91hD+BhTB
vKdFNWKKPHySbPIzePIKC5hI6uQCI3w885gP+vqOv8pb+RD9OGNh6WR8IlUVSFZ6
BpP0t3exWHkuUMS4/dV0FNKgv5tIByxUB2wpdDhB+ZbPHdpdr+IAoCU/b9UpawAq
Nr3BrhrdtwMM2H+1hmnk/NcO7poY5FvbIuJJnY3uj8l2Y8ZGLsnfz74KSERsHom9
qTUfx2LEiafvGSHm2ISccIiyNnKb1Yimv2FNFunOTKNFsIV1i7ScqZ+Qj/pAlgdo
ufOoUGgdcQs9zMTplqVAeKxZMVxneuKrAO0MvcIlzur7fiYy/+SXssXQYEpR1MXm
H1/Q05tfcdMJx8FM30WvFeko+rPCylEhrhkvqPTCky/I8oyt00UW32x93LZ1+oU0
uflrDCXUrJ5obFGi52FAABhuP9C3U9Qc8SqbbBsnFEhg2IKzzJFgvZYIlrKdgUNa
A3IlqLXgxJw7/IH3M8g6EfcJ9qWEGAOzCIbziaLuxd3w20osYdDg99+qN0uI+4Ij
tM6cupWJrBMIaecIwJzcdZ58XPEZjwDrK2YMhxsZxzCfKEwwaKItNVHfP66exNvF
MVLUdvC8BT0xaQYWjfVh6lii5xiU8t/cFExxAmVqvhZaJnFPDoA=
=nZjP
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33879@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33879
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help