[PATCH] gnu: Add emacs-dedukti-mode emacs-flycheck-dedukti.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Hondet
  • Julien Lepiller
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
87zhstx41e.fsf@gmail.com
* gnu/packages/emacs.scm (emacs-dedukti-mode emacs-flycheck-dedukti): New variable.
---
gnu/packages/emacs.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7fdcfb1a3..8c8ae6fb9 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12854,3 +12854,46 @@ functions to ensure they are called with the right arguments during testing.")
@code{wordnet}. Features include completion, if the query is not found
too ambiguous and navigation in the result buffer.")
(license license:gpl3+))))
+
+(define-public emacs-dedukti-mode
+ (package
+ (name "emacs-dedukti-mode")
+ (version "git")
+ (home-page "https://github.com/rafoo/dedukti-mode")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit "d7c3505a1046187de3c3aeb144455078d514594e")))
+ (sha256
+ (base32
+ "1842wikq24c8rg0ac84vb1qby9ng1nssxswyyni4kq85lng5lcrp"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (synopsis "Emacs major mode for Dedukti files")
+ (description "This package provides an Emacs major mode for editing Dedukti
+files.")
+ (license license:cecill-b)))
+
+(define-public emacs-flycheck-dedukti
+ (package
+ (name "emacs-flycheck-dedukti")
+ (version "git")
+ (home-page "https://github.com/rafoo/flycheck-dedukti")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit "3dbff5646355f39d57a3ec514f560a6b0082a1cd")))
+ (sha256
+ (base32
+ "1ffpxnwl3wx244n44mbw81g00nhnykd0lnid29f4aw1av7w6nw8l"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("dedukti-mode" ,emacs-dedukti-mode)
+ ("flycheck-mode" ,emacs-flycheck)))
+ (synopsis "Flycheck integration for the dedukti language")
+ (description "This package provides a frontend for Flycheck to perform
+syntax checking on dedukti files.")
+ (license license:cecill-b)))
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwiDk0ACgkQMbyBBfZZ
1CVA1g/8Dg4zgC55tMPzPA8dqyhUvnEze5uSzPH91dYNOvdVyIPuYtCkyulSVRQ7
nhpjX/Wsn3gAElyzTgjXWg8axwReAmFarnltLa58jr8gJtBJ0ZaeIQzABqd9wWhj
iI8G/qxEVx6LWWqKulHNsr9mc7Mij4uhrhBaCZOlvJkrQKRwli63ifMsOioYGoOA
76fnJvj3SomqPm3UI32UHUTjEait8leWRI68+WgwzMK9hcJmr1hXFe5up5YGL4pf
nV9b0ST/aU2ueae2tZTKU775pd7ROUEaM/mXxINSWnxe2/ghC+UV6c37l547e8Jb
vSc3pguf8J6bcSLLKNS0i74QWp9o8nK6SFa3YvONJZst9mLEdI1I+JGdfyXvs/po
U5Maax9gJGV9cDdC8gG4UBOFuEWG1rc2wxO9hFj2PJerBNMTOF91LYcWtufsDqpo
7vcxIB0jYE2y/5cfggqHvCRf6Vkg7kUu0MkGNCVNM8weC3hQ/dfcMDtU0PcwKd1q
fc0H7rf3tGEkzWOX4fYBS8MUCTz3yw35TYQ+9oxpwW8MUMhDzAirfWGUmNeC6yBL
c3N7XTR1Ykmg2p/yUrjLSYMFrlQjzpOnlOVvymKUdRw0oyVsqxWeEB+6O0YlQxrc
P2wLGOeSE0LN4atdiQ+953lKqNPM2HfrPkym5du/lEsKmXyhMPM=
=1vz+
-----END PGP SIGNATURE-----

Julien Lepiller wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 33866@debbugs.gnu.org)
20181225184654.6ccc561a@lepiller.eu
Le Tue, 25 Dec 2018 11:57:48 +0100,
Gabriel Hondet <gabrielhondet@gmail.com> a écrit :

Toggle quote (62 lines)
> * gnu/packages/emacs.scm (emacs-dedukti-mode emacs-flycheck-dedukti):
> New variable. ---
> gnu/packages/emacs.scm | 43
> ++++++++++++++++++++++++++++++++++++++++++ 1 file changed, 43
> insertions(+)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 7fdcfb1a3..8c8ae6fb9 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -12854,3 +12854,46 @@ functions to ensure they are called with the
> right arguments during testing.") @code{wordnet}. Features include
> completion, if the query is not found too ambiguous and navigation in
> the result buffer.") (license license:gpl3+))))
> +
> +(define-public emacs-dedukti-mode
> + (package
> + (name "emacs-dedukti-mode")
> + (version "git")
> + (home-page "https://github.com/rafoo/dedukti-mode")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url home-page)
> + (commit
> "d7c3505a1046187de3c3aeb144455078d514594e")))
> + (sha256
> + (base32
> +
> "1842wikq24c8rg0ac84vb1qby9ng1nssxswyyni4kq85lng5lcrp"))
> + (file-name (git-file-name name version))))
> + (build-system emacs-build-system)
> + (synopsis "Emacs major mode for Dedukti files")
> + (description "This package provides an Emacs major mode for
> editing Dedukti +files.")
> + (license license:cecill-b)))
> +
> +(define-public emacs-flycheck-dedukti
> + (package
> + (name "emacs-flycheck-dedukti")
> + (version "git")
> + (home-page "https://github.com/rafoo/flycheck-dedukti")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url home-page)
> + (commit
> "3dbff5646355f39d57a3ec514f560a6b0082a1cd")))
> + (sha256
> + (base32
> +
> "1ffpxnwl3wx244n44mbw81g00nhnykd0lnid29f4aw1av7w6nw8l"))
> + (file-name (git-file-name name version))))
> + (build-system emacs-build-system)
> + (inputs
> + `(("dedukti-mode" ,emacs-dedukti-mode)
> + ("flycheck-mode" ,emacs-flycheck)))
> + (synopsis "Flycheck integration for the dedukti language")
> + (description "This package provides a frontend for Flycheck to
> perform +syntax checking on dedukti files.")
> + (license license:cecill-b)))

Thank you! I'm not an emacs-package expert, but they look fine, except:

please add a copyright line for yourself at the beginning of the file
the version numbers don't follow what can be found elsewhere. I've
never used it, but it seems that you can use git-version instead of
"git". Can you try that?

Thank you!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEtfrmKFtBNyiyoPrtQxEfRSAIagwFAlwibQ4ACgkQQxEfRSAI
agxj9w//WfiJVlJEl9DdlpyQEGHG97fbXBqWhYf4ffGte560hvR3vgXUl3PavMhR
g3O2hyq7FR8S6VNzNeZB/amrT9QnIa38YHvlwsV/Zmo8LhSAHn1r89vYcMV7fEI1
M1r2Idqm+P+IDPhg7andobtuH2cPcClhSOClvZNgtdk6/B9nMH86PYdCNkNACGZ8
Ogng7lNh9rt/d2DfT5yUtrGGp0cI+vaXLu8PbO4le7aS5ZM2Jhhpyz1Cbc7stAu5
r0Iy18ksybmfxv9NTi/ntchDaMVgZYSyone381aj/IoJTRwfqR4XqLDtoyNwqsPH
kHF9S4UQG1ee5jsp+FiirHY+z7a2hqKt830XktCAmlaceC/zq0sIOZejVWBuMOYd
q+5R+qrm4eJO11ZRPRqBBQqyT5SDP6mQP+GBMkA+g/Xcz9NjxwvWqmFXeD+F+iqp
4aiCfAUm6ceGbOzx6XADdztT3KAnmAVOWLVHvLuG9d92/SXUXG6mxK/izx8CfSnQ
7YL87iC6GDWORiqLlKst8dVAOghIFZVSf5c2aw/gCt7aFiJ/THGwVd4Q8cHJmjcW
Eu7e03UBxH4dCRB5KfoYbiXf8MCkM5KVjj+Qk8DbBKfN6FVlmcFjj9iGHsleahPx
97wFew8g9DgwE1PXviaLkgNEF8AhdADGPVeDJOVRlxkUcDaHthU=
=Ot0H
-----END PGP SIGNATURE-----


Julien Lepiller wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 33866@debbugs.gnu.org)
20181225185155.038cee5b@lepiller.eu
Le Tue, 25 Dec 2018 11:57:48 +0100,
Gabriel Hondet <gabrielhondet@gmail.com> a écrit :

Toggle quote (62 lines)
> * gnu/packages/emacs.scm (emacs-dedukti-mode emacs-flycheck-dedukti):
> New variable. ---
> gnu/packages/emacs.scm | 43
> ++++++++++++++++++++++++++++++++++++++++++ 1 file changed, 43
> insertions(+)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 7fdcfb1a3..8c8ae6fb9 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -12854,3 +12854,46 @@ functions to ensure they are called with the
> right arguments during testing.") @code{wordnet}. Features include
> completion, if the query is not found too ambiguous and navigation in
> the result buffer.") (license license:gpl3+))))
> +
> +(define-public emacs-dedukti-mode
> + (package
> + (name "emacs-dedukti-mode")
> + (version "git")
> + (home-page "https://github.com/rafoo/dedukti-mode")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url home-page)
> + (commit
> "d7c3505a1046187de3c3aeb144455078d514594e")))
> + (sha256
> + (base32
> +
> "1842wikq24c8rg0ac84vb1qby9ng1nssxswyyni4kq85lng5lcrp"))
> + (file-name (git-file-name name version))))
> + (build-system emacs-build-system)
> + (synopsis "Emacs major mode for Dedukti files")
> + (description "This package provides an Emacs major mode for
> editing Dedukti +files.")
> + (license license:cecill-b)))
> +
> +(define-public emacs-flycheck-dedukti
> + (package
> + (name "emacs-flycheck-dedukti")
> + (version "git")
> + (home-page "https://github.com/rafoo/flycheck-dedukti")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url home-page)
> + (commit
> "3dbff5646355f39d57a3ec514f560a6b0082a1cd")))
> + (sha256
> + (base32
> +
> "1ffpxnwl3wx244n44mbw81g00nhnykd0lnid29f4aw1av7w6nw8l"))
> + (file-name (git-file-name name version))))
> + (build-system emacs-build-system)
> + (inputs
> + `(("dedukti-mode" ,emacs-dedukti-mode)
> + ("flycheck-mode" ,emacs-flycheck)))
> + (synopsis "Flycheck integration for the dedukti language")
> + (description "This package provides a frontend for Flycheck to
> perform +syntax checking on dedukti files.")
> + (license license:cecill-b)))

Also, please send two separate patches, one per package :)
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEtfrmKFtBNyiyoPrtQxEfRSAIagwFAlwibjsACgkQQxEfRSAI
agzexw/9GcWbQazLE0wl8yPVNyB7jiKkCIMajO8XA9sYwNCqN5pzuB3elakIKzEv
yk816fH9lNkh7PyTv2gOWi03cfNHq90xEfu4DpbFgtROMpx3NF5qhZNLwyazR/mI
sklxQv1zWCnhN34kScfJdYkTiH4fVZ5VJSKr42Ts1GLtlV7XPtG/6RQWVfnSsrY6
4cK9Hq28v6vkkJPqBc1PuGbPRVxRCGbJvgPa7aOwDCxvtZEi6G9BWhQ4bIKrJTTe
Cjn4Ov3dpYcD1bOTu2jo51Xj7mEJgj0UjJfKle8jB1KAJlnVF5mlH3YH5dmzjYxR
mMnkWnPEy0YcTbtYy03eohVf9v4giAwuvwxE3RZ5/sF+ZNe1bqd6McZed6jvPtRG
SxfmjNyoutlcPEN8h6LwVG6tp9249h6sgpRh72IN8R3OnfUumYN5536az7UzWrLU
GsLi2aBRKQRu7KCAHi19f8Mc4/tyqQVPy9rKRjTEdCdmku0bcHYIut/KFtPGbIsZ
W++qVsH/Kzlo3Hqy8o7xrsBHN8QJRLdqe5Q7t5WUt7laiL3S7YbumnwQ+jIqo2Ir
oOAWIrRbU5ptUlReePNtTWNV2DWgE4MvYHk78E3DpyUuV2h2BelI5zEUH1WfoP+f
x57woiOvT3P9y4bWLSuulajnZ5uI0fskLyI/tCLTtS/I2FgmWRw=
=ABUg
-----END PGP SIGNATURE-----


Gabriel Hondet wrote 6 years ago
Re: [bug#33866] [PATCH 1/2] gnu: Add emacs-dedukti-mode.
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 33866@debbugs.gnu.org)
87wonxwimk.fsf@gmail.com
* gnu/packages/emacs.scm (emacs-dedukti-mode): New variable.
---
gnu/packages/emacs.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7fdcfb1a3..02fd25fef 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -12854,3 +12855,24 @@ functions to ensure they are called with the right arguments during testing.")
@code{wordnet}. Features include completion, if the query is not found
too ambiguous and navigation in the result buffer.")
(license license:gpl3+))))
+
+(define-public emacs-dedukti-mode
+ (let ((commit "d7c3505a1046187de3c3aeb144455078d514594e"))
+ (package
+ (name "emacs-dedukti-mode")
+ (version (git-version "0" "0" commit))
+ (home-page "https://github.com/rafoo/dedukti-mode")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "1842wikq24c8rg0ac84vb1qby9ng1nssxswyyni4kq85lng5lcrp"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (synopsis "Emacs major mode for Dedukti files")
+ (description "This package provides an Emacs major mode for editing
+Dedukti files.")
+ (license license:cecill-b))))
--
2.20.1

On Tue 25 Dec 2018 at 18:51 Julien Lepiller wrote:

> Also, please send two separate patches, one per package :)
Fine, so this is the first one, the other is on its way.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwierMACgkQMbyBBfZZ
1CW4uA//R/PKoYMvjBsJcXoV3l6Ys5x2XNbO/dpSsf6Uv7n7lrTXzC9+JyFtUY8a
gHPjdHbtJjCVfQhcSM8yZCR5O72ID5YZmOspWwL2hHdfyu7svC8uFSQoyRpiVU3D
DhfkjShxrZ8uuh6IyYo8boIrNmG0MwEEyuIkTDH7Llgt6E10hRAql7WkEKiBNdW1
7ybgFO19fvF45IhBfAlUq21nRvJg0TIM0cO+Usub6P0GNZ/1K6DjQtC8S27uzn/w
Qeve7TKSsxazY++6DRDa/5L2LMKcBNRMUTWze5E9Cgf94cSu9rQpy3Plb/+vjrk7
TEDYOPC6CgC+GUmqO850jAAYiSg9ZkQACEBjgYAHuj7qoSNVViS4+2LJFGxl8zFe
yI1de06pWZ/p9xl6eqKbI67NrVHU8mMu1Q4o2jzkPqxI+haHi5gGqdrFvcFin6Oa
Jz80XYklPMW8Fv2HacDZmGOg+UeBfaQMsoaHNi5D0i2d4t+2z0rQ0p00Qx6aKVdb
XPA2kX40U+s+4Z/gN9NGU59pw8rsjCVv4Z74cNRglwPLyWrOWmgZ+huyF49j1HWR
XKra1wtGCMZig2TKPrKibCxAwkyGQAHp02VrBjbxl4V4nqLYCq95U9Ylsi7aurKg
LgR/Qxu1xtkMDlRZETc62oX5LqaGETplPfaOaKFQVtXd1JR/akM=
=hgSc
-----END PGP SIGNATURE-----

Gabriel Hondet wrote 6 years ago
Re: [bug#33866] [PATCH 2/2] gnu: Add emacs-flycheck-dedukti.
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 33866@debbugs.gnu.org)
87va3hwiij.fsf@gmail.com
* gnu/packages/emacs.scm (emacs-flycheck-dedukti): New variable.
---
gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 02fd25fef..70cf96614 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12876,3 +12876,27 @@ too ambiguous and navigation in the result buffer.")
(description "This package provides an Emacs major mode for editing
Dedukti files.")
(license license:cecill-b))))
+
+(define-public emacs-flycheck-dedukti
+ (let ((commit "3dbff5646355f39d57a3ec514f560a6b0082a1cd"))
+ (package
+ (name "emacs-flycheck-dedukti")
+ (version (git-version "0" "0" commit))
+ (home-page "https://github.com/rafoo/flycheck-dedukti")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "1ffpxnwl3wx244n44mbw81g00nhnykd0lnid29f4aw1av7w6nw8l"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("dedukti-mode" ,emacs-dedukti-mode)
+ ("flycheck-mode" ,emacs-flycheck)))
+ (synopsis "Flycheck integration for the dedukti language")
+ (description "This package provides a frontend for Flycheck to perform
+syntax checking on dedukti files.")
+ (license license:cecill-b))))
--
2.20.1

On Tue 25 Dec 2018 at 18:51 Julien Lepiller wrote:

> Also, please send two separate patches, one per package :)
And here is the 2nd!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwie0QACgkQMbyBBfZZ
1CWVsA//YUJ8Qw2ucDQVjdiagdBHomjAgN0VSbLdsS3wirm+wHKIbFZ0GS7LK6IE
vwJ/NgRKKylW/ub/t4+QlVpxGtkMF0rEGKzax0Gk80MqnqElUCyuN/Fm86iodtPR
SArs2/aTGgJsgkKjzb38B6gNnOcLIMFfK+N5ngb1y3JO3MlLUZMMzZOvVERNH2bQ
64HMXcI/iViBJj+mYIGAb9fSDlCHY9zILDlAeruDWt799aUwJKjMpze9gFOWzsMk
leXY+nnBW5eTW90VVOUaX/olft2wg0crt5iQm69La8efhg5xchRwIORfODu7/HVX
pJ4YvNsFDhqM0ZUiVZUgmrQJG1Ztj0PaEHq1OAobKXIzq38Eu1XHYE6IoqgoDfdb
GOe1aAzuS+bxBSmM+Wa3Zg9UF4rpRk+EAZHLMXLukIGuG3vEN6VNS8SSqtkFhJfH
mfL2Gljh1Tc+XA/FTNgblrrSExo0r4NyD/f8ASMaGjK4+/4ek0r9IWFoJWfXtJpR
Gz7OQ+0EWIKjvN0s/8+HabpxLWXWoF00S9n9I1zm63QxhPrQAA+YqdeYpIV9irhQ
k6OIAfOtkxvkTdYrhqfmklE0+OXMJmrEZDRzgPHaAizYVV7y8hJ6aCQtycbOpWJr
AFLqCYdxsadSO36UokxB/p2MpjO3i2gk6KYVRElOM8kAa5LGE2Q=
=AgOu
-----END PGP SIGNATURE-----

Julien Lepiller wrote 6 years ago
Re: [bug#33866] [PATCH 1/2] gnu: Add emacs-dedukti-mode.
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 33866@debbugs.gnu.org)
20181226152735.5cdb50aa@lepiller.eu
Le Tue, 25 Dec 2018 19:45:07 +0100,
Gabriel Hondet <gabrielhondet@gmail.com> a écrit :

Toggle quote (44 lines)
> * gnu/packages/emacs.scm (emacs-dedukti-mode): New variable.
> ---
> gnu/packages/emacs.scm | 22 ++++++++++++++++++++++
> 1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 7fdcfb1a3..02fd25fef 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -41,6 +41,7 @@
> ;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
> ;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
> ;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
> +;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -12854,3 +12855,24 @@ functions to ensure they are called with the
> right arguments during testing.") @code{wordnet}. Features include
> completion, if the query is not found too ambiguous and navigation in
> the result buffer.") (license license:gpl3+))))
> +
> +(define-public emacs-dedukti-mode
> + (let ((commit "d7c3505a1046187de3c3aeb144455078d514594e"))
> + (package
> + (name "emacs-dedukti-mode")
> + (version (git-version "0" "0" commit))
> + (home-page "https://github.com/rafoo/dedukti-mode")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url home-page)
> + (commit commit)))
> + (sha256
> + (base32
> +
> "1842wikq24c8rg0ac84vb1qby9ng1nssxswyyni4kq85lng5lcrp"))
> + (file-name (git-file-name name version))))
> + (build-system emacs-build-system)
> + (synopsis "Emacs major mode for Dedukti files")
> + (description "This package provides an Emacs major mode for
> editing +Dedukti files.")
> + (license license:cecill-b))))

I'm not an emacs user, so I'm a bit worried that this package won't be
able to find dedukti (it's not an input at all!). I see this in the
code:

(defcustom dedukti-path "/usr/bin/dkcheck" ...)

I would say that it means that dedukti-mode will not find dkcheck at
all... What do you think? If that's the case, could you add dedukti as
an input and substitute* that path in a custom phase? Or make sure it
loads dedukti from the path at least.
Gabriel Hondet wrote 6 years ago
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 33866@debbugs.gnu.org)
87sgykw477.fsf@gmail.com
On Wed 26 Dec 2018 at 15:27 Julien Lepiller wrote:

Toggle quote (11 lines)
> I'm not an emacs user, so I'm a bit worried that this package won't be
> able to find dedukti (it's not an input at all!). I see this in the
> code:
>
> (defcustom dedukti-path "/usr/bin/dkcheck" ...)
>
> I would say that it means that dedukti-mode will not find dkcheck at
> all... What do you think? If that's the case, could you add dedukti as
> an input and substitute* that path in a custom phase? Or make sure it
> loads dedukti from the path at least.

Well seen indeed, here is the new version, which should hopefully be ok!

* gnu/packages/emacs.scm (emacs-dedukti-mode): New variable.
---
gnu/packages/emacs.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7fdcfb1a3..2cc6ca438 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -122,6 +123,7 @@
#:use-module (gnu packages video)
#:use-module (gnu packages haskell)
#:use-module (gnu packages wordnet)
+ #:use-module (gnu packages ocaml)
#:use-module (guix utils)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match))
@@ -12854,3 +12856,35 @@ functions to ensure they are called with the right arguments during testing.")
@code{wordnet}. Features include completion, if the query is not found
too ambiguous and navigation in the result buffer.")
(license license:gpl3+))))
+
+(define-public emacs-dedukti-mode
+ (let ((commit "d7c3505a1046187de3c3aeb144455078d514594e"))
+ (package
+ (name "emacs-dedukti-mode")
+ (version (git-version "0" "0" commit))
+ (home-page "https://github.com/rafoo/dedukti-mode")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "1842wikq24c8rg0ac84vb1qby9ng1nssxswyyni4kq85lng5lcrp"))
+ (file-name (git-file-name name version))))
+ (inputs
+ `(("dedukti" ,dedukti)))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'patch-dkpath
+ (lambda _
+ (let ((dkcheck-path (which "dkcheck")))
+ (substitute* "dedukti-mode.el"
+ (("dedukti-path \"(.*)\"")
+ (string-append "dedukti-path \"" dkcheck-path "\"")))))))))
+ (synopsis "Emacs major mode for Dedukti files")
+ (description "This package provides an Emacs major mode for editing
+Dedukti files.")
+ (license license:cecill-b))))
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwjw7wACgkQMbyBBfZZ
1CXs7BAAkxwCKeLkXP4H7VAPrQAb7ziYeOobz4/87wDCXC5Ps+6RkFff/RiNXEp/
XOEu+b2AvXJ+2UGYJcs5J4veTU8PX20P1TgO/gUPOJddEk4ds3+RnizVuxsIX1ns
6ACwwY2A+q8On50z309F4EFGUym6EVaT4dHDqBw6+mfshzq+HjcsufClwrmGYqlP
iZcT78KaW1GhpFMn6Vppn8bk2EqUWeYXYvoIB7YLGv5hL52dfOQfDTdLVRPvSqBz
5cWdCkQzUCDWGI3h4JnvB1VHB+quluAYOFHuSiKgZiwjls+ExbhgrZbbqHWb3W9c
W4GDfLwPi33GZwGlnbD5sUbhUnIH36DImCL0LaCq0V17/hWveywYz7QoKzUxONQV
4yzsPHFDZZlLkDutSBXQWeMljwnoQNbzl9//ZUzg4GcOpXyaKxPlrrJMqRkKZ8pf
n/8ReyEcr7osxHIH4vaG3LT9T86LEnwrWo3exZWv12/WqiYLqLFZg5cXDv9Me/Ej
vuKsp2Sox8uwxOo//anTl0N7z9DC5OTBfe9XkoVq22HFr80r/vOCpQoNqZwU7OVn
2OKP1N1fgbUMSZeaZ2e4H7Enc6rwJxEW1xR4BRsdGiwfHHhAfRJiGtFXo478FQHh
20bchv3vHkN+/OGEsFohACmF0JCiMuKimG1ZcnMkRk6Xq0DzUgo=
=chWb
-----END PGP SIGNATURE-----

Julien Lepiller wrote 6 years ago
Re: [bug#33866] [PATCH] gnu: Add emacs-dedukti-mode emacs-flycheck-dedukti.
(address . 33866-done@debbugs.gnu.org)
20181227092043.3ba0df88@lepiller.eu
Pushed as 4a2e1e72806fd62e54201a4aacde213d419d04bd and
ad536c98f9125f47dd948be7dd42d5c34e84bdfd, thank you!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEtfrmKFtBNyiyoPrtQxEfRSAIagwFAlwki1sACgkQQxEfRSAI
agwcXQ/7Beo1h+e0k3iYJOFbXRrJpkv7lw/R6fm1wkrBzQvLQL64JeGIvq9kpjEr
26s0xLkv3C82qrj2wTTKu/+sSlhtGTYHzZxYpJFZayHuzqoMuN4H7FANXqTY+/M/
9DO/Jh3tYhDgMQg9Ov0q3ArIu6B+laCFbZ/Q58s/QNDA5FygKdl+/Ge2HqNiYB1l
Qp/dpL2LTJqJITO3qseBD66XXvshS8QhexaZMRQB4s/8RjbaM904oZlXZcREqyk/
MZAw9BdtjMXxVZJs4LccFDmyMlHM/xHfpJa5kPyXbNialCwrkozJhCtO2q/a+p5S
XoLlPKUgxdTwbmRMz3hh5SZB7XgphZmiXQzwesRRj7Nz9jAD5MPZHFr1KBsdBfFG
/vPkdcgTJTUmvmIGrCVtFHmMmfK7ZOzL+Yb1o5qmE5oon5XU9Dq8glLGOQGtYmbt
P+JJIDOBCuJPhXhHGAnPSkA7bLMEzp7r4KqQK0YofjZr3kI3T6+bhmb9Cp2vBvCm
j5fntctcKjxoqfFU9PVCrTgVDmJUnO5WWMn0OwOXbHWjK3n0YgpJxNwsPT7vZoyV
QK2lJcXG+Pfp6m7LbIey4nDUEjf4k2Pxwlq2LCxXmCxQ+++B8ikACo+G8BPQb9Jw
AjWNxN9PwKGoWgP02rCufVuItCgg4gExrVMntkNFSvOpCnH5AEI=
=CV4T
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33866@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33866
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help