Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
* gnu/packages/ocaml.scm (dedukti): New variable.
---
gnu/packages/ocaml.scm | 55 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)
Toggle diff (65 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3b1ddcb5b..28e223e75 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4989,3 +4989,58 @@ provides BigN, BigZ, BigQ that used to be part of Coq standard library.")
simplifying the proofs of inequalities on expressions of real numbers for the
Coq proof assistant.")
(license license:cecill-c)))
+
+(define-public dedukti
+ (package
+ (name "dedukti")
+ (version "2.6.0")
+ (home-page "https://deducteam.github.io/")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/deducteam/dedukti.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0frl3diff033i4fmq304b8wbsdnc9mvlhmwd7a3zd699ng2lzbxb"))))
+ (inputs
+ `(("ocaml" ,ocaml)
+ ("menhir" ,ocaml-menhir)))
+ (native-inputs
+ `(("ocamlbuild" ,ocamlbuild)
+ ("ocamlfind" ,ocaml-findlib)
+ ("which" ,which)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; Set ocamlfind environment vars
+ (lambda _
+ (let ((out (assoc-ref %outputs "out"))
+ (libpath "/lib/ocaml/site-lib"))
+ (begin
+ (setenv "OCAMLFIND_DESTDIR" (string-append out libpath))
+ (mkdir-p (string-append out libpath "/dedukti"))
+ (setenv "PREFIX" out)
+ #t))))
+ (replace 'build
+ (lambda _
+ (invoke "make")))
+ (replace 'check
+ (lambda _
+ (invoke "make" "tests")))
+ ;; (delete 'check)
+ (add-before 'install 'set-binpath
+ ;; Change binary path in the makefile
+ (lambda _
+ (let ((out (assoc-ref %outputs "out")))
+ (substitute* "GNUmakefile"
+ (("BINDIR = (.*)$")
+ (string-append "BINDIR = " out "/bin")))))))))
+ (synopsis "Implementation of the ΛΠ-calculus modulo rewriting")
+ (description "Dedukti is a logical framework based on the
+ΛΠ-calculus modulo in which many theories and logics can be expressed.")
+ (license license:cecill-c)))
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwiBRwACgkQMbyBBfZZ
1CUfrRAAoFhfPNQnIPgMG4ajAte/bhALhqdeLxswjQKHjcMRNpcZObnC73npPUGo
MjGO9yIWmnsl+TIb9LzK9S+248XVzka+RMI4giePbn3GsAuYPZgJW59DbwdVLeP5
jkiQFh+D66wuKbM/EUL1D1ARBaMcrSVCL5CBTBFkoOhsg+j9xWEwhNXEeExYXggy
YZK6juwUd3if9bPwNaue+0VmnaD5Ulvsyl1ovqhywEveOmpbO1xa9Ee0LRJScB32
1d7dvkcymSnQOixISfCgRIFjsHRxUXoU6YGVclWCcjlO2xJ27T1T6bZsO/DTjX1/
72/hyen8h2y8UpUmQ2uzgZfydPog//xkQAxUh+idaNKBiLl4z77+XQ7w20lHl8jx
sTwJP1Y6TJUOz/DKXYXfMbuTHI3aIt3213zyiX5R3MiWz5mUJzRhHr2Bxkgsq1Hr
ZSH2PW6r9qBhvqP//Fu0PUsDyiT721D/MlcMbe1WkD+VVHUDdPCG3JqH2oyWr/Al
bmBzjbPfCP9ILCByy8qpG8WV5Aou5rrwRRrJX2DkmUMzTCKBoeVnU0PlVg1VSKzR
k/t+SJ4I1N9pzX30rgXtvFD7R4vzK+xM80b3MhDQ8G+vkBueWoVrpUCfcr40QWcn
VMfRmKK5hSpv1rht1FRwdM4beFfTuYWuoHWRXjUQt4EeuJ/mEhM=
=2xtu
-----END PGP SIGNATURE-----