[PATCH] gnu: Add font-mononoki.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Hondet
  • Ludovic Courtès
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
87h8f4oc11.fsf@gmail.com
* gnu/packages/fonts.scm (font-mononoki): New variable.
---
gnu/packages/fonts.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index b0cb78c5c..b4ca0cfd1 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1351,3 +1351,25 @@ reproduction and display environments. This package provides only TrueType
files (TTF).")
(home-page "https://software.sil.org/charis/")
(license license:silofl1.1)))
+
+(define-public font-mononoki
+ (package
+ (name "font-mononoki")
+ (version "1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/madmalik/mononoki/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "14bd2sk6z24kq5q8wyr1vcjr380vvjdm5i7zqa0f0ynk9jkz57qq"))
+ (file-name (string-append "font-mononoki-"
+ version ".tar.gz"))))
+ (build-system font-build-system)
+ (synopsis "Font for programming and code review")
+ (description
+ "Mononoki is a typeface by Matthias Tellen, created to enhance code
+formatting")
+ (home-page "https://madmalik.github.io/mononoki/")
+ (license license:silofl1.1)))
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlwfThoACgkQMbyBBfZZ
1CVLpxAAqGp9nW+o9WaW7s5cLfcndsWCoHqT3I+1H8OKQ5XxgJK0SKeERhz5vHOo
ozLPxwfa725+RG/J+WLkse5z8minUxhV7ZAxH0txInzoKGFPLriXr8e+nAsc5E96
J7z5hT/P2arLyW4ZYYgPhrGoE7cYhq8TTsy59tap0XZneYNLpoc1JVWqzIbxRWsa
nBHluUKKYMrGObPFMySUz7t8okjSRfdYbUxJitTWliYHBw9CahandCnoafd3BzhN
jvI9H/kZ3AZIKsFmn+9yAQ09fMZrmS+pil1inrzAfQ6Gom2immXPjQCUhWqglrNj
TSbhA1jFbNwSkYgFqfK4UqVB6oIK5EJoA586/IIMazsDdDeOgnB0EEHX+QjAPLCj
StU4x70UEDkCACq1LaL4EOkInoDJJRS0eQZxieXZrtYfTWgrQx+P8cIL/rJTnUjo
NkJdWjKZevg0+MFzBnhpoO/CvDzkl4gtwpBc/AD3/AX4rNUJAd+w3RaqI44nUXTo
Q+pWPFIh34UsjVQFy2lga4DE1eNUWj8NpsoPldKXZwRDg0+VG7lxPexiUDfA1+Kt
4SpzeElhokE4U07OKJ/fD8irGTE6CnL+77jFlY05uZy8pjuVJjqMum7D+roh6QcW
NixEa8RxYtlc0dMtL5KTJuEZa3H4fnMzPoWBimqpSX1K4ibTYp8=
=EHjP
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 33853-done@debbugs.gnu.org)
87k1jzeytq.fsf@gnu.org
Hello Gabriel,

Gabriel Hondet <gabrielhondet@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/fonts.scm (font-mononoki): New variable.

Thanks for the patch! I made the changes below on your behalf. The
‘git-fetch’ bit is to avoid relying on tarballs generated by github.com
since they can change over time.

Thank you!

Ludo’.
Toggle diff (39 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index b4ca0cfd10..88315008bd 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Mohammed Sadiq <sadiq@sadiqpk.org>
;;; Copyright © 2018 Charlie Ritter <chewzerita@posteo.net>
+;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1357,19 +1358,18 @@ files (TTF).")
(name "font-mononoki")
(version "1.2")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/madmalik/mononoki/archive/"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/madmalik/mononoki/")
+ (commit version)))
(sha256
(base32
- "14bd2sk6z24kq5q8wyr1vcjr380vvjdm5i7zqa0f0ynk9jkz57qq"))
- (file-name (string-append "font-mononoki-"
- version ".tar.gz"))))
+ "1rkzyxn30rn8qv2h2xz324j7q15hzg2lci8790a7cdl1dfgic4xi"))
+ (file-name (git-file-name name version))))
(build-system font-build-system)
(synopsis "Font for programming and code review")
(description
"Mononoki is a typeface by Matthias Tellen, created to enhance code
-formatting")
+formatting.")
(home-page "https://madmalik.github.io/mononoki/")
(license license:silofl1.1)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33853@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33853
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help