[PATCH] gnu: mit-scheme: Enable tests.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20181220210550.17484-1-kkebreau@posteo.net
* gnu/packages/scheme.scm (mit-scheme)[arguments]: Remove #:tests?. Add
'patch-/bin/sh' phase.
[native-inputs]: Add autoconf, automake, and libtool.
---
gnu/packages/scheme.scm | 24 +++++++++++++++++++++---
1 file changed, 21 insertions(+), 3 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 3c688e120..16904dce3 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -37,6 +37,7 @@
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages compression)
#:use-module (gnu packages libevent)
@@ -85,8 +86,7 @@
(outputs '("out" "doc"))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no "check" target
- #:modules ((guix build gnu-build-system)
+ `(#:modules ((guix build gnu-build-system)
(guix build utils)
(srfi srfi-1))
#:phases
@@ -103,6 +103,20 @@
(find-files "src/compiler" "^make\\."))
(chdir "src")
#t))
+ (add-after 'unpack 'patch-/bin/sh
+ (lambda _
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (substitute* '("../tests/ffi/autogen.sh"
+ "../tests/ffi/autobuild.sh"
+ "../tests/ffi/test-ffi.sh"
+ "../tests/runtime/test-process.scm"
+ "runtime/unxprm.scm")
+ (("/bin/sh") (which "sh"))
+ (("\\./autogen\\.sh")
+ (string-append (which "sh") " autogen.sh"))
+ (("\\./configure")
+ (string-append (which "sh") " configure")))
+ #t))
;; FIXME: the texlive-union insists on regenerating fonts. It stores
;; them in HOME, so it needs to be writeable.
(add-before 'build 'set-HOME
@@ -150,7 +164,11 @@
(delete-file-recursively old-doc-dir)
#t))))))
(native-inputs
- `(("texlive" ,(texlive-union (list texlive-tex-texinfo)))
+ `(;; Autoconf, Automake, and Libtool are necessary for the FFI tests.
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("texlive" ,(texlive-union (list texlive-tex-texinfo)))
("texinfo" ,texinfo)
("m4" ,m4)))
(inputs
--
2.20.0
Ludovic Courtès wrote 6 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 33815@debbugs.gnu.org)
87muoscica.fsf@gnu.org
Hello Kei,

Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (4 lines)
> * gnu/packages/scheme.scm (mit-scheme)[arguments]: Remove #:tests?. Add
> 'patch-/bin/sh' phase.
> [native-inputs]: Add autoconf, automake, and libtool.

Nice, LGTM!

Ludo’.
Kei Kebreau wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33815-done@debbugs.gnu.org)
87o997gaz5.fsf@posteo.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (12 lines)
> Hello Kei,
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/scheme.scm (mit-scheme)[arguments]: Remove #:tests?. Add
>> 'patch-/bin/sh' phase.
>> [native-inputs]: Add autoconf, automake, and libtool.
>
> Nice, LGTM!
>
> Ludo’.

Pushed to master! Thanks for reviewing.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33815@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33815
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help