pkill9 wrote 6 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
I modified the 'kernel->boot-label' function in gnu/system.scm to check if the kernel passed to it is a regular package, and if it isn't then it will try to get the package name and version using 'inferior-package-name' and 'inferior-package-version'.
Note: I wasn't sure if the hack at the beginning of this patch was neccessary and I didn't add it: http://git.savannah.gnu.org/cgit/guix.git/commit/?id=811b21fb15d36b06fde994ca7ef5916a9a19f250
```
(define inferiors-loaded?
;; This hack allows us to provide seamless integration for inferior
;; packages while not having a hard dependency on (guix inferior).
(resolve-module '(guix inferior) #f #f #:ensure #f))
(define (inferior->entry)
(module-ref (resolve-interface '(guix inferior))
'inferior-package->manifest-entry))
```
This is the only issue preventing using an inferior package as a kernel, which is very useful as it means you can avoid recompiling a custom kernel when you reconfigure the system with a newer guix revision that changes the kernel package dependencies.
From 6c0bbaa0a73f4c6043211df6af100877dc9a4094 Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Wed, 19 Dec 2018 20:22:20 +0000
Subject: [PATCH] system: 'kernel->boot-label' now accepts inferior packages.
* gnu/system.scm (kernel->boot-label): Get package name and version
using the functions for inferior packages if the kernel is not a
regular package.
---
gnu/system.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)
Toggle diff (34 lines)
diff --git a/gnu/system.scm b/gnu/system.scm
index a5a8f40d6..afe39278d 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -21,6 +21,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu system)
+ #:use-module (guix inferior)
#:use-module (guix store)
#:use-module (guix monads)
#:use-module (guix gexp)
@@ -905,10 +906,15 @@ listed in OS. The C library expects to find it under
(define (kernel->boot-label kernel)
"Return a label for the bootloader menu entry that boots KERNEL."
- (string-append "GNU with "
- (string-titlecase (package-name kernel)) " "
- (package-version kernel)
- " (beta)"))
+ (if (package? kernel)
+ (string-append "GNU with "
+ (string-titlecase (package-name kernel)) " "
+ (package-version kernel)
+ " (beta)")
+ (string-append "GNU with "
+ (string-titlecase (inferior-package-name kernel))
+ (inferior-package-version kernel)
+ " (beta)")))
(define (store-file-system file-systems)
"Return the file system object among FILE-SYSTEMS that contains the store."
--
2.19.2