guix 0.16.0-4.60b0402 fails tests on aarch64

  • Done
  • quality assurance status badge
Details
5 participants
  • Danny Milosavljevic
  • Efraim Flashner
  • Ludovic Courtès
  • Mark H Weaver
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 6 years ago
(address . bug-guix@gnu.org)
87imztr601.fsf@ponder.i-did-not-set--mail-host-address--so-tickle-me
I've been unable to successfully build guix on aarch64 for a while, as
it fails several tests. This prevents "guix system reconfigure" from
working. It also fails with "guix build guix" as well as trying to build
from a local git checkout.

FAIL: tests/graph.scm
FAIL: tests/guix-package.sh
FAIL: tests/graph
FAIL: tests/guix-package

More details in the attached build log.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXBZJ3wAKCRDcUY/If5cW
qqxeAQDkZMnDiueZlUZOSympBiceJTYUr3N80CtMbbcvEAoCdgEA3CvFd3v5Jav5
vcw5jzEszxE4X5NrwRv4XZrcQpQxMgo=
=tBLr
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 33768@debbugs.gnu.org)
20181216160110.50654fc2@scratchpost.org
Possible workaround (not that mit-scheme works on aarch64 then, but at least guix does):

Toggle diff (39 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index c7ab00380..25852d2af 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -70,12 +70,7 @@
#:use-module (ice-9 match))
(define (mit-scheme-source-directory system version)
- (string-append "mit-scheme-"
- (if (or (string-prefix? "x86_64" system)
- (string-prefix? "i686" system))
- ""
- "c-")
- version))
+ (string-append "mit-scheme-" version))
(define-public mit-scheme
(package
@@ -173,7 +168,7 @@
("i686-linux"
(string-append version "-i386"))
(_
- (string-append "c-" version)))
+ version))
".tar.gz"))
(sha256
(match (%current-system)
@@ -182,7 +177,10 @@
"03m7cc035w3avs91j2pcz9f15ssgvgp3rm045d1vbydqrkzfyw8k"))
("i686-linux"
(base32
- "05sjyz90xxfnmi87qv8x0yx0fcallnzl1dciygdafp317pn489is"))))))))
+ "05sjyz90xxfnmi87qv8x0yx0fcallnzl1dciygdafp317pn489is"))
+ (_
+ (base32
+ "18kllckm3iky59wk3nvx41kfn56lpp468savvrk41agjza2hqqhy"))))))))
;; Fails to build on MIPS, see <http://bugs.gnu.org/18221>.
;; Also, the portable C version of MIT/GNU Scheme did not work in time for
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlwWaLYACgkQ5xo1VCww
uqVgtgf/dj8foHWebpAF7H4S1p5o5x6RFVv2mNvRIiP/tTitTfHhOVj5q5enTr9J
TdGcksf9wDoj7Qj8M954ruopfOGsh6GXnCLnGKBY5yoI0jS9+5kHMixvQDqOIYi2
Ir49L5rFWIlWqRLJ+x2CIOAjI1qMnKA/LCD2izrfRV4qlQETaOYsRFAnAKJUq3Mf
4/QIAvLbpv3WAV6hD2aX3MnYB9vmQ1JpnAXl1iWliOhu18ZGwnR4ZmUGk6R8DsFE
NBH/YaOEZKULL3ydmFjwAZTsSXDGk2a1J2u0KDngLK17OCs6ANumzQ9yh7ZuhJkd
M/s2eJyAE9Y16rlu/s3ekF8YelO+dw==
=sQJH
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 33768@debbugs.gnu.org)
20181216211208.5e86b797@scratchpost.org
Should be fixed on master. Can you confirm?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlwWsZgACgkQ5xo1VCww
uqWiMQgAo89fU7vvZYwyX4f880ldsnHGWDQAxLMipJppWsY3L+Bv48XNKnzi4v+d
VJF7YBA96B6txvH/SMyOWBYP8SgWOC29cU91PSLe8d1P8r2dOaXbIsILQKFKhYNO
eTSQC27JhrDO9xASABaWVnBDqPmZHAl0OwHBHqsIhh+zR9cQjDEkujVb9bqZjomC
AQZ07ZRpUz4NJSkQsuYq+MRn131KU3q5DmlfIFf13btfHcEEgOg5k32Te9UH9K2c
3bfgCL8QwEeBkSNmuD3kAPI0Oxdg/s3bqE6ua0YjLUCzLcNv7LwNp1zmcEH6lsMP
KawDv7J6qQMHVTQ1XfOEI1vwLIyEew==
=Z5gc
-----END PGP SIGNATURE-----


Efraim Flashner wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20181217073124.GH3468@macbook41
On Sun, Dec 16, 2018 at 09:12:08PM +0100, Danny Milosavljevic wrote:
Toggle quote (2 lines)
> Should be fixed on master. Can you confirm?

Vagrant confirmed on IRC that it is fixed on master.

As suggested in the armhf bug about the same issue, now that it's
working we should tag a new commit.


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAlwXUMwACgkQQarn3Mo9
g1FDUw/+NA5Ja+Ngx+TaXMnxNrUoQH8BfanMsDJmoPFk3T9CZKQIG+lGmcImy2ts
fktHfUgD4bW769Aypy2jgzZRNZWWRAaumb9n3Fsdl4XdwcL/f1yLE06TsmJP2kTE
aQfdw9lFwmd/RPfD3mBrcrnL3zNwdH5lX/UTumhLN52tdIWUPs9pmI7WWHrUKefL
VGK6nT8A3JYX1WqjTml/K4xPs0WZwXFxDV2WDQNUiVvhD9p09XR2gKTZkZs3DHHF
TgIMrmAPfuMvA7r5F3xzKg0Yjarlao9ee9xoERfqTY6X5RUtTCGj8+GiTafCLl3k
1GFTporPNH6ffPoXcQur1zvyv5Y+l6a0kAGysUk98HHW/wE79yHB2DTp4JBINQFp
0Hd/zBj35fcrnxNwT0VLUX6Ss0yhHuAMZof8Ahlpe0+sUNXhgg1w98zOlkJOu9i7
oJrBiLI/m3ir5g74+eMIlWAA00hCOkwy7/jv1qSt65aRsoj55y05Hb9f//I5nZpe
NtkRg2hH6hWGzmOtzmxOPY/gsuacRtmDRabjBFpK1fIEaXUHP10dLdfD3aU+RAQw
FlsbOZyc41QBD1ZqwAe+22wz6vWwP94lZGeEnEkwQk+6jjT8JhkTZUbhvZkvO6f/
5XVj0gqYm7248FsSkCzpM7cLVziyIQbjEO0ZVnXvh9lt2L6Uuv4=
=Lx7G
-----END PGP SIGNATURE-----


Vagrant Cascadian wrote 6 years ago
(address . 33768@debbugs.gnu.org)
87bm5ihm16.fsf@ponder.i-did-not-set--mail-host-address--so-tickle-me
On 2018-12-17, Efraim Flashner wrote:
Toggle quote (5 lines)
> On Sun, Dec 16, 2018 at 09:12:08PM +0100, Danny Milosavljevic wrote:
>> Should be fixed on master. Can you confirm?
>
> Vagrant confirmed on IRC that it is fixed on master.

I think that was a different bug.

As of 2119cd3a350cb5544418a0e8ac6c7fb6dcbf0a13 it still wasn't fixed; I
haven't checked more recently.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXBkXNgAKCRDcUY/If5cW
qgPdAQCo2LmWD7HH8rYxDChm/ULvVmz+gYuhJOdXRZygkjcVxAEAqNNImaEKvy4Q
TMFtno1UIFOZQAAhmiknFZC+uXUHSAA=
=oo38
-----END PGP SIGNATURE-----

Mark H Weaver wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)
87lg4mjxr4.fsf@netris.org
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (11 lines)
> On 2018-12-17, Efraim Flashner wrote:
>> On Sun, Dec 16, 2018 at 09:12:08PM +0100, Danny Milosavljevic wrote:
>>> Should be fixed on master. Can you confirm?
>>
>> Vagrant confirmed on IRC that it is fixed on master.
>
> I think that was a different bug.
>
> As of 2119cd3a350cb5544418a0e8ac6c7fb6dcbf0a13 it still wasn't fixed; I
> haven't checked more recently.

If I'm not mistaken, although the bug is fixed on our 'master' branch,
the problem is that our 'guix' package still uses an older commit from
before the bug was fixed. Now we need to update our 'guix' package.

Mark
Ludovic Courtès wrote 6 years ago
(name . Mark H Weaver)(address . mhw@netris.org)
87lg4lwqvo.fsf@gnu.org
Mark H Weaver <mhw@netris.org> skribis:

Toggle quote (18 lines)
> Vagrant Cascadian <vagrant@debian.org> writes:
>
>> On 2018-12-17, Efraim Flashner wrote:
>>> On Sun, Dec 16, 2018 at 09:12:08PM +0100, Danny Milosavljevic wrote:
>>>> Should be fixed on master. Can you confirm?
>>>
>>> Vagrant confirmed on IRC that it is fixed on master.
>>
>> I think that was a different bug.
>>
>> As of 2119cd3a350cb5544418a0e8ac6c7fb6dcbf0a13 it still wasn't fixed; I
>> haven't checked more recently.
>
> If I'm not mistaken, although the bug is fixed on our 'master' branch,
> the problem is that our 'guix' package still uses an older commit from
> before the bug was fixed. Now we need to update our 'guix' package.
> See also <https://bugs.gnu.org/33754>.

I’ve done it a few hours ago. Please close the bug if we’re all set!

Ludo’.
Vagrant Cascadian wrote 6 years ago
(address . 33768@debbugs.gnu.org)
87r2edl7hf.fsf@ponder.i-did-not-set--mail-host-address--so-tickle-me
On 2018-12-19, Ludovic Courtès wrote:
Toggle quote (22 lines)
> Mark H Weaver <mhw@netris.org> skribis:
>
>> Vagrant Cascadian <vagrant@debian.org> writes:
>>
>>> On 2018-12-17, Efraim Flashner wrote:
>>>> On Sun, Dec 16, 2018 at 09:12:08PM +0100, Danny Milosavljevic wrote:
>>>>> Should be fixed on master. Can you confirm?
>>>>
>>>> Vagrant confirmed on IRC that it is fixed on master.
>>>
>>> I think that was a different bug.
>>>
>>> As of 2119cd3a350cb5544418a0e8ac6c7fb6dcbf0a13 it still wasn't fixed; I
>>> haven't checked more recently.
>>
>> If I'm not mistaken, although the bug is fixed on our 'master' branch,
>> the problem is that our 'guix' package still uses an older commit from
>> before the bug was fixed. Now we need to update our 'guix' package.
>> See also <https://bugs.gnu.org/33754>.
>
> I’ve done it a few hours ago. Please close the bug if we’re all set!

It built for me on aarch64-linux as of
af8c90e86230e1bae93b5ba9b6f77a76f302e203.

Thanks everyone!

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXBqH3AAKCRDcUY/If5cW
qsG/AP9ulLBRQpDVsrXUduUrKgwcEizU9S9pljey6COjCLo4bgD6Ao91skJU1rzH
/FMmLx95wvGn34687b4/imbTyD57xwA=
=k1Gu
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)
871s6dussw.fsf@gnu.org
Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (26 lines)
> On 2018-12-19, Ludovic Courtès wrote:
>> Mark H Weaver <mhw@netris.org> skribis:
>>
>>> Vagrant Cascadian <vagrant@debian.org> writes:
>>>
>>>> On 2018-12-17, Efraim Flashner wrote:
>>>>> On Sun, Dec 16, 2018 at 09:12:08PM +0100, Danny Milosavljevic wrote:
>>>>>> Should be fixed on master. Can you confirm?
>>>>>
>>>>> Vagrant confirmed on IRC that it is fixed on master.
>>>>
>>>> I think that was a different bug.
>>>>
>>>> As of 2119cd3a350cb5544418a0e8ac6c7fb6dcbf0a13 it still wasn't fixed; I
>>>> haven't checked more recently.
>>>
>>> If I'm not mistaken, although the bug is fixed on our 'master' branch,
>>> the problem is that our 'guix' package still uses an older commit from
>>> before the bug was fixed. Now we need to update our 'guix' package.
>>> See also <https://bugs.gnu.org/33754>.
>>
>> I’ve done it a few hours ago. Please close the bug if we’re all set!
>
> It built for me on aarch64-linux as of
> af8c90e86230e1bae93b5ba9b6f77a76f302e203.

Awesome, closing!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33768@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33768
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help