[PATCH] gnu: linkchecker: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20181215121700.11320-1-mail@cbaines.net
For some reason, the tests fail due to the lack of pytest. But when that's
added as an input, then some tests fail in other ways.

* gnu/packages/web.scm (linkchecker)[native-inputs]: Add python2-pytest.
[arguments]: Set #:tests? to #f.
---
gnu/packages/web.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 84bd795a8..607f8efe6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5814,8 +5814,13 @@ Instagram and YouTube.")
`(("python2-dnspython" ,python2-dnspython)
("python2-pyxdg" ,python2-pyxdg)
("python2-requests" ,python2-requests)))
+ (native-inputs
+ `(("python2-pytest" ,python2-pytest)))
(arguments
- `(#:python ,python-2))
+ `(#:python ,python-2
+ ;; TODO: Tests currently fail. Looks to be a mixture of trying to use
+ ;; /homeless-shelter and maybe the network.
+ #:tests? #f))
(home-page "https://linkcheck.github.io/linkchecker")
(synopsis "Check websites for broken links")
(description "LinkChecker is a website validator. It checks for broken
--
2.20.0
Ludovic Courtès wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 33759@debbugs.gnu.org)
87h8fdv73c.fsf@gnu.org
Hello Chris!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (6 lines)
> For some reason, the tests fail due to the lack of pytest. But when that's
> added as an input, then some tests fail in other ways.
>
> * gnu/packages/web.scm (linkchecker)[native-inputs]: Add python2-pytest.
> [arguments]: Set #:tests? to #f.

[...]

Toggle quote (5 lines)
> + `(#:python ,python-2
> + ;; TODO: Tests currently fail. Looks to be a mixture of trying to use
> + ;; /homeless-shelter and maybe the network.
> + #:tests? #f))

Did you try adding a phase that does (setenv "HOME" (getcwd))?

IMO it would be best to get some confidence that the test failures are
benign, possibly working around them with tricks as above.

Thanks!

Ludo’.
Christopher Baines wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33759@debbugs.gnu.org)
874lasvvd9.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (22 lines)
> Hello Chris!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> For some reason, the tests fail due to the lack of pytest. But when that's
>> added as an input, then some tests fail in other ways.
>>
>> * gnu/packages/web.scm (linkchecker)[native-inputs]: Add python2-pytest.
>> [arguments]: Set #:tests? to #f.
>
> [...]
>
>> + `(#:python ,python-2
>> + ;; TODO: Tests currently fail. Looks to be a mixture of trying to use
>> + ;; /homeless-shelter and maybe the network.
>> + #:tests? #f))
>
> Did you try adding a phase that does (setenv "HOME" (getcwd))?
>
> IMO it would be best to get some confidence that the test failures are
> benign, possibly working around them with tricks as above.

I've finally made some time to look at thsi more. The HOME issue seems
to not exist, and I think I've got the testsuite working now.

I noticed that some tests are skipped because they depend on the
network, and this seems helpful, but I think it's just been missed for
some tests. I've pushed a patch upstream to mark some more tests as
needing the network [1].


I'll try to wrangle that patch in to Guix, and neaten up the other
changes, and send some updated patches soon.

Thanks for taking a look,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlwr8HJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XeHiA/+KxGCNbyXxacfsKuv9kw04BKH2fnbjGJiQECEwmlTksg5B876SgPp2Nqo
8cR1aZNJyVEqt0/txJ7TsnsIXPOgNtaSWeedX8haMGv8uDIr0UC8+rV3gBhuJORx
8GeOkixFC5vbjd4stz5q2E+lqw+Y84ItVz183ZuHt6HPYuaIBAckcwS00UjfQWVK
hm3L5CskhF4qJWTpVd9i3aMilzfDFBReviAYWRBAyESoVYGXn/SUPJ2chVPajkgK
Ps0hHQ9wiT3NwuvF9nBRwMiEkk6W7R/NriFABWuYERKWnZoBhtkMoOlYwCyiqHY5
roD497T7gYQW3zr/OThAye6N0ZqpfuWabNg85c/Bh8N45cz3MOAVN5LrvGo85Qa9
nKIHHhC0o7znNTFKk96yFOaKkQ/11TkAhFHgyp2Tf7XVAi1+sEzQYGNaDMfa8SU+
3b/D5pmmWHGLlE6ti33yxtMoaqQMSaL5HicT4UPdNCAJFnGfEaVxvUGu/1sTzb0X
AmyYXj+D4jn0Yx7U6TnmqhU4csb8s+j+tXtS9oW/CoPn6GI71jlOsjyk28TIFRF0
XtygoCb4yktS0dNXTgD+Cc9NwyA619aOuuITPgQVXuq+8h1l9NiprwXXdpbVw0OJ
QPoQ1mcBzjKepg6fYQCJtIJ13OVrXkNGNC7u/8cwv1wlGH6pS4M=
=Z2Vk
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
[PATCH v2 2/5] gnu: Add python-miniboa.
(address . 33759@debbugs.gnu.org)
20190103213452.1829-2-mail@cbaines.net
python2-miniboa is required for the linkchecker testsuite.

* gnu/packages/python.scm (python-miniboa, python2-miniboa): New variable.
---
gnu/packages/python.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 00d60333a4..852beb73da 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1755,6 +1755,28 @@ matching them against a list of media-ranges.")
(define-public python2-mimeparse
(package-with-python2 python-mimeparse))
+(define-public python-miniboa
+ (package
+ (name "python-miniboa")
+ (version "1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "miniboa" version))
+ (sha256
+ (base32
+ "09jh3pn4rh7kh7jayanf8jzy6gp03791b5a193w6148cf3i6k9m3"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/shmup/miniboa")
+ (synopsis "Simple, single-threaded Telnet server")
+ (description
+ "Miniboa is a simple, asynchronous, single-threaded, poll-based Telnet
+server.")
+ (license license:asl2.0)))
+
+(define-public python2-miniboa
+ (package-with-python2 python-miniboa))
+
(define-public python-pafy
(package
(name "python-pafy")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH v2 1/5] gnu: linkchecker: Fix build.
(address . 33759@debbugs.gnu.org)
20190103213452.1829-1-mail@cbaines.net
For some reason, the tests fail due to the lack of pytest. But when that's
added as an input, then some tests fail in other ways.

* gnu/packages/web.scm (linkchecker)[native-inputs]: Add python2-pytest.
[arguments]: Set #:tests? to #f.
---
gnu/packages/web.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 84bd795a85..607f8efe69 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5814,8 +5814,13 @@ Instagram and YouTube.")
`(("python2-dnspython" ,python2-dnspython)
("python2-pyxdg" ,python2-pyxdg)
("python2-requests" ,python2-requests)))
+ (native-inputs
+ `(("python2-pytest" ,python2-pytest)))
(arguments
- `(#:python ,python-2))
+ `(#:python ,python-2
+ ;; TODO: Tests currently fail. Looks to be a mixture of trying to use
+ ;; /homeless-shelter and maybe the network.
+ #:tests? #f))
(home-page "https://linkcheck.github.io/linkchecker")
(synopsis "Check websites for broken links")
(description "LinkChecker is a website validator. It checks for broken
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH v2 3/5] gnu: python-2.7: Include /lib/python.../test/support.
(address . 33759@debbugs.gnu.org)
20190103213452.1829-3-mail@cbaines.net
Don't remove the support directory from the /lib/python.../test/ directory, as
this is used from the test_support module.

/gnu/store/...-python2-2.7.15/lib/python2.7/test/test_support.py:2: in <module>
import test.support
E ImportError: No module named support

* gnu/packages/python.scm (python-2.7)[arguments]: Change the 'remove-tests
phase to not remove the support directory.
---
gnu/packages/python.scm | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 852beb73da..550643adb8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -260,12 +260,9 @@
(scandir testdir
(match-lambda
((or "." "..") #f)
+ ("support" #f)
(file
(not
- ;; FIXME: Add the 'support' directory
- ;; in the next rebuild cycle, since it
- ;; moved in 2.7.14. See also
- ;; python2-futures below.
(string-prefix? "test_support."
file))))))
(call-with-output-file "__init__.py" (const #t))
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH v2 4/5] gnu: python-futures: Enable tests.
(address . 33759@debbugs.gnu.org)
20190103213452.1829-4-mail@cbaines.net
Re-enable the tests, as the python-2 package now has the support
directory. Also, switch to running the tests via the test_futures.py script to
avoid errors like:

AttributeError: 'AsCompletedTests' object has no attribute 'executor'

* gnu/packages/python.scm (python2-futures)[arguments]: Run the
test_futures.py script to run the tests.
---
gnu/packages/python.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 550643adb8..54bc1d4d02 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7918,11 +7918,14 @@ otherwise matches 3.2’s API.")
(base32
"0rdjmmsab550kxsssdq49jcniz77zlkpw4pvi9hvib3lsskjmh4y"))))
(build-system python-build-system)
- (arguments `(#:python ,python-2
- ;; FIXME: Python 2.7.14 moved the test.support library,
- ;; but our package has not yet been adjusted. Enable
- ;; tests when the python2 package has been fixed.
- #:tests? #f))
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "test_futures.py")
+ #t)))))
(home-page "https://github.com/agronholm/pythonfutures")
(synopsis
"Backport of the concurrent.futures package from Python 3.2")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH v2 5/5] gnu: linkchecker: Fix the package building.
(address . 33759@debbugs.gnu.org)
20190103213452.1829-5-mail@cbaines.net
* gnu/packages/python.scm (linkchecker)[source]: Add patch.
[native-inputs]: Add more inputs required for the tests.
[arguments]: Enable the tests, move the 'check phase after 'install. Test
using the installed software, and use py.test.
---
gnu/local.mk | 1 +
...-more-tests-that-require-the-network.patch | 182 ++++++++++++++++++
gnu/packages/web.scm | 30 ++-
3 files changed, 209 insertions(+), 4 deletions(-)
create mode 100644 gnu/packages/patches/linkchecker-mark-more-tests-that-require-the-network.patch

Toggle diff (252 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 0bb0203354..e0a5fa60ae 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -935,6 +935,7 @@ dist_patch_DATA = \
%D%/packages/patches/lierolibre-newer-libconfig.patch \
%D%/packages/patches/lierolibre-remove-arch-warning.patch \
%D%/packages/patches/lierolibre-try-building-other-arch.patch \
+ %D%/packages/patches/linkchecker-mark-more-tests-that-require-the-network.patch.patch \
%D%/packages/patches/linux-pam-no-setfsuid.patch \
%D%/packages/patches/lirc-localstatedir.patch \
%D%/packages/patches/lirc-reproducible-build.patch \
diff --git a/gnu/packages/patches/linkchecker-mark-more-tests-that-require-the-network.patch b/gnu/packages/patches/linkchecker-mark-more-tests-that-require-the-network.patch
new file mode 100644
index 0000000000..f3e488cec2
--- /dev/null
+++ b/gnu/packages/patches/linkchecker-mark-more-tests-that-require-the-network.patch
@@ -0,0 +1,182 @@
+From f24c88a0732024028fffe0372039a847e91722ea Mon Sep 17 00:00:00 2001
+From: Christopher Baines <mail@cbaines.net>
+Date: Tue, 1 Jan 2019 22:36:29 +0000
+Subject: [PATCH] Mark more tests that require the network
+
+I believe all these tests require the network, at least they seem to
+fail if it's I run them without connecting my computer to the web.
+
+I'm looking at this as part of packaging linkchecker for GNU Guix,
+where the package is build and the tests are run in a isolated
+environment, intentionally without network access, to avoid issues
+with non-reproducible package builds.
+---
+ tests/checker/test_http.py | 2 ++
+ tests/checker/test_http_misc.py | 2 ++
+ tests/checker/test_http_redirect.py | 2 ++
+ tests/checker/test_httpbin.py | 5 +++++
+ tests/checker/test_misc.py | 4 ++++
+ tests/checker/test_whitespace.py | 3 +++
+ 6 files changed, 18 insertions(+)
+
+diff --git a/tests/checker/test_http.py b/tests/checker/test_http.py
+index e4c1e097..8a8af567 100644
+--- a/tests/checker/test_http.py
++++ b/tests/checker/test_http.py
+@@ -20,6 +20,7 @@
+
+ import pytest
+
++from tests import need_network
+ from .httpserver import HttpServerTest, CookieRedirectHttpRequestHandler
+
+ class TestHttp (HttpServerTest):
+@@ -29,6 +30,7 @@ def __init__(self, methodName='runTest'):
+ super(TestHttp, self).__init__(methodName=methodName)
+ self.handler = CookieRedirectHttpRequestHandler
+
++ @need_network
+ def test_html (self):
+ confargs = dict(recursionlevel=1)
+ self.file_test("http.html", confargs=confargs)
+diff --git a/tests/checker/test_http_misc.py b/tests/checker/test_http_misc.py
+index 9922d85f..c6b6afdb 100644
+--- a/tests/checker/test_http_misc.py
++++ b/tests/checker/test_http_misc.py
+@@ -20,11 +20,13 @@
+ import os
+ import sys
+ from .httpserver import HttpServerTest
++from tests import need_network
+ from linkcheck.network import iputil
+
+ class TestHttpMisc (HttpServerTest):
+ """Test http:// misc link checking."""
+
++ @need_network
+ def test_html (self):
+ self.swf_test()
+ self.obfuscate_test()
+diff --git a/tests/checker/test_http_redirect.py b/tests/checker/test_http_redirect.py
+index f212d98e..2253a70d 100644
+--- a/tests/checker/test_http_redirect.py
++++ b/tests/checker/test_http_redirect.py
+@@ -17,6 +17,7 @@
+ """
+ Test http checking.
+ """
++from tests import need_network
+ from .httpserver import HttpServerTest, CookieRedirectHttpRequestHandler
+
+ class TestHttpRedirect (HttpServerTest):
+@@ -26,6 +27,7 @@ def __init__(self, methodName='runTest'):
+ super(TestHttpRedirect, self).__init__(methodName=methodName)
+ self.handler = CookieRedirectHttpRequestHandler
+
++ @need_network
+ def test_redirect (self):
+ self.redirect1()
+ self.redirect2()
+diff --git a/tests/checker/test_httpbin.py b/tests/checker/test_httpbin.py
+index 0319c2f6..4c8fa846 100644
+--- a/tests/checker/test_httpbin.py
++++ b/tests/checker/test_httpbin.py
+@@ -18,6 +18,7 @@
+ Test http stuff with httpbin.org.
+ """
+ import re
++from tests import need_network
+ from . import LinkCheckTest
+
+
+@@ -30,6 +31,7 @@ def get_httpbin_url(path):
+ class TestHttpbin(LinkCheckTest):
+ """Test http:// link redirection checking."""
+
++ @need_network
+ def test_http_link(self):
+ linkurl = u"http://www.example.com"
+ nlinkurl = self.norm(linkurl)
+@@ -48,6 +50,7 @@ def test_http_link(self):
+ ]
+ self.direct(url, resultlines, recursionlevel=1)
+
++ @need_network
+ def test_basic_auth(self):
+ user = u"testuser"
+ password = u"testpassword"
+@@ -67,6 +70,7 @@ def test_basic_auth(self):
+ ]
+ self.direct(url, resultlines, confargs=confargs)
+
++ @need_network
+ def test_http_refresh_header(self):
+ linkurl = u"http://www.example.com"
+ nlinkurl = self.norm(linkurl)
+@@ -85,6 +89,7 @@ def test_http_refresh_header(self):
+ ]
+ self.direct(url, resultlines, recursionlevel=1)
+
++ @need_network
+ def test_http_content_location_header(self):
+ linkurl = u"http://www.example.com"
+ nlinkurl = self.norm(linkurl)
+diff --git a/tests/checker/test_misc.py b/tests/checker/test_misc.py
+index 2e4cfd07..f9591f9d 100644
+--- a/tests/checker/test_misc.py
++++ b/tests/checker/test_misc.py
+@@ -17,6 +17,7 @@
+ """
+ Test miscellaneous html tag parsing and URL types
+ """
++from tests import need_network
+ from . import LinkCheckTest
+
+
+@@ -25,15 +26,18 @@ class TestMisc (LinkCheckTest):
+ Test misc link types.
+ """
+
++ @need_network
+ def test_misc (self):
+ self.file_test("misc.html")
+
+ def test_html5 (self):
+ self.file_test("html5.html")
+
++ @need_network
+ def test_archive (self):
+ self.file_test("archive.html")
+
++ @need_network
+ def test_itms_services(self):
+ url = u"itms-services:?action=download-manifest&url=http://www.example.com/"
+ resultlines = [
+diff --git a/tests/checker/test_whitespace.py b/tests/checker/test_whitespace.py
+index 609c108a..fc2727d6 100644
+--- a/tests/checker/test_whitespace.py
++++ b/tests/checker/test_whitespace.py
+@@ -17,6 +17,7 @@
+ """
+ Test whitespace handling.
+ """
++from tests import need_network
+ from . import LinkCheckTest
+
+
+@@ -25,6 +26,7 @@ class TestWhitespace (LinkCheckTest):
+ Test whitespace in URLs.
+ """
+
++ @need_network
+ def test_leading_whitespace (self):
+ # Leading whitespace
+ url = u" http://www.example.org/"
+@@ -50,6 +52,7 @@ def test_leading_whitespace (self):
+ ]
+ self.direct(url, resultlines)
+
++ @need_network
+ def test_trailing_whitespace (self):
+ # Trailing whitespace
+ url = u"http://www.example.org/ "
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 607f8efe69..65901a5aeb 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5805,6 +5805,9 @@ Instagram and YouTube.")
(uri (git-reference
(url "https://github.com/linkchecker/linkchecker")
(commit (string-append "v" version))))
+ (patches
+ (search-patches
+ "linkchecker-mark-more-tests-that-require-the-network.patch"))
(file-name (git-file-name name version))
(sha256
(base32
@@ -5815,12 +5818,31 @@ Instagram and YouTube.")
("python2-pyxdg" ,python2-pyxdg)
("python2-requests" ,python2-requests)))
(native-inputs
- `(("python2-pytest" ,python2-pytest)))
+ `(("gettext" ,gettext-minimal)
+ ("python2-pytest" ,python2-pytest)
+ ("python2-miniboa" ,python2-miniboa)
+ ("python2-parameterized" ,python2-parameterized)))
(arguments
`(#:python ,python-2
- ;; TODO: Tests currently fail. Looks to be a mixture of trying to use
- ;; /homeless-shelter and maybe the network.
- #:tests? #f))
+ #:phases
+ (modify-phases %standard-phases
+ ;; Move the 'check phase to after 'install, so that the installed
+ ;; library can be used
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; Set PYTHONPATH so that the installed linkchecker is used
+ (setenv "PYTHONPATH"
+ (string-append out "/lib/python2.7/site-packages"
+ ":"
+ (getenv "PYTHONPATH")))
+ ;; Remove this directory to avoid it being used when running
+ ;; the tests
+ (delete-file-recursively "linkcheck")
+
+ (invoke "py.test" "tests"))
+ #t)))))
(home-page "https://linkcheck.github.io/linkchecker")
(synopsis "Check websites for broken links")
(description "LinkChecker is a website validator. It checks for broken
--
2.20.1
Christopher Baines wrote 6 years ago
Re: [bug#33759] [PATCH] gnu: linkchecker: Fix build.
(address . 33759@debbugs.gnu.org)
874l9widv4.fsf@cbaines.net
I've pushed all these patches now in one form or another as I didn't
want to forget about them. The linkchecker package still isn't building
anywhere, but once the Python fix on core-updates reaches master, then
it should be fixed.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxLik9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xfn8Q//XGzz+B+gNVZlAcXpkF5v24uUYF9TNgJvfcXRiIlTJCwpAY5L2DO7QYxC
8ppruoOOZ6Vlgoqh1Y7vLwFidvWrTHA6LArV63f1SoXdyea5SA5bOvd5nrWu+rQY
I5KsBMzvrTLWXRho+9h5Oxrm/Y5K6tXeo34mfwZAEbjDH8QLpqpHSdqWKkp+XJ7C
c0ziITBqbQx9FgR+xOdSrL4UMsDmeFaP1AUENFJKgRyQ6OvdmjW5WUqDOKFI5v90
y2NjOualiq7+M9IgqnJcDMVqT654jjShRSWWfJJx9YYWNSQ1wdND8FMuk6El767R
wqADv4l9JJlLUJ61psoApIU72eyS8AleB6wOV63VjgFxgDSQ0ZHYDDhZlsJECXed
WGx3HF4pqWE9MKeZL0pJuH1iXwgxxOiL4v1TrQavuHs9AkHcYkc8Lf1FMxG+l6/V
t9MBpSI02isL3dBkHevGCotRpISNNWsDgXUUTG+BQzALZ3TPApi625f64JlDzxy5
/kG9L0XqT+efGrpQTzX2VoEt0by7lPFYHLcXdYWRfyhC9ctM4XYhNIQci7cXhvby
IjqOK3hEztA9NpmDrzif1r/emQ5/W0xGyUpe+DdDL/ztRpZ5oZsl+L84y5hGMdnz
H6q7NfNU9t8UW4cVT0RI8zOAnN9o/Ri9r4fo3g+b2aNRZzSS17o=
=DffR
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
control message for bug #33759
(address . control@debbugs.gnu.org)
8736pgidrj.fsf@cbaines.net
tags 33759 pending
Christopher Baines wrote 5 years ago
Re: [bug#33759] [PATCH] gnu: linkchecker: Fix build.
(address . 33759-done@debbugs.gnu.org)
87y2xvf5k4.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (5 lines)
> I've pushed all these patches now in one form or another as I didn't
> want to forget about them. The linkchecker package still isn't building
> anywhere, but once the Python fix on core-updates reaches master, then
> it should be fixed.

Core updates has been merged! So linkchecker finally builds on master
again.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl2c1xtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfiCxAAnuHSsRrvZCNqGdaPtheDOmUfPF2+zoMunirmwYyB+trHslAT9YJkoryj
e8gqYQhqegAUWuEAg6Xaa+hcMqiky3/4KU/dbIOH2mz83+Yu9nsIisbLGJQ8/r71
r1MQfSkbFshumW7iv06FIFdynMHoc/2LmPtngef2A6rSgUA47PRzMTqtRqZFWgAD
6tgHBjOFmYwioGehJoQJW6Hf809dZDgkibou7G8O8SVD8YhqwEdPGxcUNLSLvfu/
bmPNU0PdMLppQkMWn2slsVil28qYdm+3ra7MHhw3avtNRQzj5ZNQFfHc1PN2ESB2
VR3C+Tr2pgDpc7BejML3NcwVOO0asJroeZTZT3ahE0ZpdHW0aIYa9yccXc7yh5LW
FPD0LYSti+lrcdgh/QRTedg+7xyA9EGymUbP88c5KHJrMOogV7MksaM0HBda0GMk
/qcgKsZY6TXiuBBI3u3tcPOQ3Iw5IntuH6c5mumw4gSmFplCStd7CGMX1IwGovvE
Plfc16v0m4MbOfFdDMZAwGYuNpFJ79q/e1C0o5YZ8jJFnIp08nmEK7t26xF0XWWe
bPL/tliI8NFL6fSgFC9PbX6e384wYjW7bTM2WbmUF0f3hXzUK2gWO08Uj2eBeaKT
cjuDlC0U6gTLPAnT1snW2o913ToUaJwZZqt+hPCG8hgUEOpLmjU=
=1JEp
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33759@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33759
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help