No longer possible to run ./pre-inst-env guix without compiling first

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Ricardo Wurmus
  • swedebugia
Owner
unassigned
Submitted by
swedebugia
Severity
normal
S
S
swedebugia wrote on 15 Dec 2018 08:49
(address . bug-guix@gnu.org)
0ed7e834dd4cfdaef62b5dbe334b8d72@riseup.net
Hi

Is this a bug?

first
*clone repository*

then ./bootstrap && ./configure

then
./pre-inst-env guix weather -m ~/sdb.scm
--substitute-urls="https://ci.guix.infohttp://mirror.hydra.gnu.org"
Backtrace:
In ice-9/boot-9.scm:
222:29 19 (map1 _)
222:29 18 (map1 _)
222:29 17 (map1 _)
222:29 16 (map1 _)
222:29 15 (map1 _)
222:29 14 (map1 _)
222:29 13 (map1 _)
222:29 12 (map1 _)
222:29 11 (map1 _)
222:29 10 (map1 (((gnu system nss)) ((gnu system locale)) ((…)) …))
222:17 9 (map1 (((gnu system locale)) ((gnu system pam)) ((…)) …))
2800:17 8 (resolve-interface (gnu system locale) #:select _ #:hide …)
In ice-9/threads.scm:
390:8 7 (_ _)
In ice-9/boot-9.scm:
2726:13 6 (_)
In ice-9/threads.scm:
390:8 5 (_ _)
In ice-9/boot-9.scm:
2994:20 4 (_)
2312:4 3 (save-module-excursion #<procedure d2988b8 at ice-9/boo…>)
3014:26 2 (_)
In unknown file:
1 (primitive-load-path "gnu/system/locale" #<procedure d9…>)
In /home/sdb/src/guix/gnu/system/locale.scm:
124:0 0 (_)

/home/sdb/src/guix/gnu/system/locale.scm:124:0: In procedure
private-lookup: No variable bound to glibc-for-target in module (gnu
packages base)

This was introduced a little before merging of the latest core-updates.

--
Cheers
Swedebugia
R
R
Ricardo Wurmus wrote on 15 Dec 2018 11:45
(address . swedebugia@riseup.net)(address . 33758@debbugs.gnu.org)
87y38rvzja.fsf@elephly.net
swedebugia@riseup.net writes:

Toggle quote (2 lines)
> Is this a bug?

I’m inclined to say that it is not.
What is the use case here?

--
Ricardo
L
L
Ludovic Courtès wrote on 15 Dec 2018 19:17
(address . swedebugia@riseup.net)(address . 33758@debbugs.gnu.org)
87zht6wt60.fsf@gnu.org
Hi,

swedebugia@riseup.net skribis:

Toggle quote (9 lines)
> In unknown file:
> 1 (primitive-load-path "gnu/system/locale" #<procedure d9…>)
> In /home/sdb/src/guix/gnu/system/locale.scm:
> 124:0 0 (_)
>
> /home/sdb/src/guix/gnu/system/locale.scm:124:0: In procedure
> private-lookup: No variable bound to glibc-for-target in module (gnu
> packages base)

That indicates you should run “make clean-go && make”.

The gnu/system/locale.go file you have is presumably older than the
‘core-updates’ merge. That branch removed ‘glibc-for-target’.

HTH!

Ludo’.
S
S
swedebugia wrote on 17 Dec 2018 10:08
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33758@debbugs.gnu.org)
2b8316f9213f49905af48b82b16787b5@riseup.net
On 2018-12-15 19:17, Ludovic Courtès wrote:
Toggle quote (18 lines)
> Hi,
>
> swedebugia@riseup.net skribis:
>
>> In unknown file:
>> 1 (primitive-load-path "gnu/system/locale" #<procedure d9…>)
>> In /home/sdb/src/guix/gnu/system/locale.scm:
>> 124:0 0 (_)
>>
>> /home/sdb/src/guix/gnu/system/locale.scm:124:0: In procedure
>> private-lookup: No variable bound to glibc-for-target in module (gnu
>> packages base)
>
> That indicates you should run “make clean-go && make”.
>
> The gnu/system/locale.go file you have is presumably older than the
> ‘core-updates’ merge. That branch removed ‘glibc-for-target’.

I had figured that out and make clean worked. :)

Thanks anyway!

--
Cheers
Swedebugia
S
S
swedebugia wrote on 17 Dec 2018 10:23
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 33758@debbugs.gnu.org)
1b022b144a36e5f9c674cac616ac119a@riseup.net
On 2018-12-15 11:45, Ricardo Wurmus wrote:
Toggle quote (7 lines)
> swedebugia@riseup.net writes:
>
>> Is this a bug?
>
> I’m inclined to say that it is not.
> What is the use case here?

Well my use case is browsing commits and settling on one with good
"weather".

Its not that important to me actually because close to master (a few
days back there are often >93% substitutes availiable.

We could definitely improve the "running from git" section with some
kind of best-practice.

e.g. keep close to master
run clean-go if you get weird guile errors during make (especially after
merging of core-updates)
etc.

Would that be accepted?

--
Cheers
Swedebugia
R
R
Ricardo Wurmus wrote on 17 Dec 2018 12:03
(address . swedebugia@riseup.net)(address . 33758@debbugs.gnu.org)
877eg8wh3f.fsf@elephly.net
swedebugia@riseup.net writes:

Toggle quote (8 lines)
> We could definitely improve the "running from git" section with some
> kind of best-practice.
>
> e.g. keep close to master
> run clean-go if you get weird guile errors during make (especially after
> merging of core-updates)
> etc.

It’s perfectly fine to stray from the ’master’ branch. The reason why
you need “make clean-go” is due to ABI changes. I’d rather see this
class of problems disappear with changes to the Makefile or compiler
checks than to add more noise.

Note that you don’t have this problem if you compile everything from
source after a fresh checkout. You only get this when you reuse
compiled .go files that were built for a different ABI.

--
Ricardo
L
L
Ludovic Courtès wrote on 17 Dec 2018 23:05
(address . swedebugia@riseup.net)(address . 33758@debbugs.gnu.org)
878t0n24ix.fsf@gnu.org
Hi swedebugia,

swedebugia@riseup.net skribis:

Toggle quote (21 lines)
> On 2018-12-15 19:17, Ludovic Courtès wrote:
>> Hi,
>>
>> swedebugia@riseup.net skribis:
>>
>>> In unknown file:
>>> 1 (primitive-load-path "gnu/system/locale" #<procedure d9…>)
>>> In /home/sdb/src/guix/gnu/system/locale.scm:
>>> 124:0 0 (_)
>>>
>>> /home/sdb/src/guix/gnu/system/locale.scm:124:0: In procedure
>>> private-lookup: No variable bound to glibc-for-target in module (gnu
>>> packages base)
>>
>> That indicates you should run “make clean-go && make”.
>>
>> The gnu/system/locale.go file you have is presumably older than the
>> ‘core-updates’ merge. That branch removed ‘glibc-for-target’.
>
> I had figured that out and make clean worked. :)

Great, thanks for confirming! I’m closing this bug now.

Ludo’.
L
L
Ludovic Courtès wrote on 17 Dec 2018 23:05
control message for bug #33758
(address . control@debbugs.gnu.org)
877eg724in.fsf@gnu.org
tags 33758 notabug
close 33758
?