[PATCH] gnu: llvm-rtti: Remove it.

  • Done
  • quality assurance status badge
Details
4 participants
  • Christopher Baines
  • Leo Famulari
  • Christopher Baines
  • Marius Bakke
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20181213130011.21616-1-mail@cbaines.net
This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.

It sounds from the comment that this can hopefully be removed now.

* gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
* gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
llvm-without-rtti.
---
gnu/packages/gl.scm | 3 +--
gnu/packages/llvm.scm | 20 --------------------
2 files changed, 1 insertion(+), 22 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index d7c112928f..5313a74e5c 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -255,8 +255,7 @@ also known as DXTn or DXTC) for Mesa.")
("libxvmc" ,libxvmc)
,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
- ;; FIXME: Change to 'llvm' in the next rebuild cycle.
- `(("llvm" ,llvm-without-rtti)))
+ `(("llvm" ,llvm)))
(_
`()))
("makedepend" ,makedepend)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 8a9d1d312b..4be86f3d21 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -95,26 +95,6 @@ languages is in development. The compiler infrastructure includes mirror sets
of programming tools as well as libraries with equivalent functionality.")
(license license:ncsa)))
-;; FIXME: This package is here to prevent many rebuilds on x86_64 and i686
-;; from commit fc9dbf41311d99d0fd8befc789ea7c0e35911890. Update users of
-;; this in the next rebuild cycle.
-(define-public llvm-without-rtti
- (package
- (inherit llvm)
- (arguments
- `(#:configure-flags '("-DCMAKE_SKIP_BUILD_RPATH=FALSE"
- "-DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE"
- "-DBUILD_SHARED_LIBS:BOOL=TRUE"
- "-DLLVM_ENABLE_FFI:BOOL=TRUE"
- "-DLLVM_INSTALL_UTILS=ON")
- #:build-type "Release"
- #:phases (modify-phases %standard-phases
- (add-before 'build 'shared-lib-workaround
- (lambda _
- (setenv "LD_LIBRARY_PATH"
- (string-append (getcwd) "/lib"))
- #t)))))))
-
(define* (clang-runtime-from-llvm llvm hash
#:optional (patches '()))
(package
--
2.18.0
Christopher Baines wrote 6 years ago
[PATCH v2] gnu: llvm-rtti: Remove it.
(address . 33725@debbugs.gnu.org)
20181213132832.24877-1-mail@cbaines.net
This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.

It sounds from the comment that this can hopefully be removed now.

* gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
* gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
llvm-without-rtti.
---
gnu/packages/gl.scm | 3 +--
gnu/packages/llvm.scm | 20 --------------------
2 files changed, 1 insertion(+), 22 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index d7c112928f..5313a74e5c 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -255,8 +255,7 @@ also known as DXTn or DXTC) for Mesa.")
("libxvmc" ,libxvmc)
,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
- ;; FIXME: Change to 'llvm' in the next rebuild cycle.
- `(("llvm" ,llvm-without-rtti)))
+ `(("llvm" ,llvm)))
(_
`()))
("makedepend" ,makedepend)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 7eb785c364..ec79bcc95c 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -110,26 +110,6 @@ of programming tools as well as libraries with equivalent functionality.")
(base32
"08p27wv1pr9ql2zc3f3qkkymci46q7myvh8r5ijippnbwr2gihcb"))))))
-;; FIXME: This package is here to prevent many rebuilds on x86_64 and i686
-;; from commit fc9dbf41311d99d0fd8befc789ea7c0e35911890. Update users of
-;; this in the next rebuild cycle.
-(define-public llvm-without-rtti
- (package
- (inherit llvm)
- (arguments
- `(#:configure-flags '("-DCMAKE_SKIP_BUILD_RPATH=FALSE"
- "-DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE"
- "-DBUILD_SHARED_LIBS:BOOL=TRUE"
- "-DLLVM_ENABLE_FFI:BOOL=TRUE"
- "-DLLVM_INSTALL_UTILS=ON")
- #:build-type "Release"
- #:phases (modify-phases %standard-phases
- (add-before 'build 'shared-lib-workaround
- (lambda _
- (setenv "LD_LIBRARY_PATH"
- (string-append (getcwd) "/lib"))
- #t)))))))
-
(define* (clang-runtime-from-llvm llvm hash
#:optional (patches '()))
(package
--
2.18.0
Leo Famulari wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 33725@debbugs.gnu.org)
20181213202732.GC22790@jasmine.lan
On Thu, Dec 13, 2018 at 02:28:32PM +0100, Christopher Baines wrote:
Toggle quote (8 lines)
> This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.
>
> It sounds from the comment that this can hopefully be removed now.
>
> * gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
> * gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
> llvm-without-rtti.

Thanks! If the change doesn't trigger any rebuilds (that is, if the
package is really unused), please push!

Ideally, the commit message will say which commit made this package
unnecessary.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlwSwLMACgkQJkb6MLrK
fwjpkRAA4QdBJwavPRr8QcTQsv1H7hleBehP90uwLBIrwfY7ymvH5Z7x3sZ0NXuP
XFDz/5BOyeuBcwkLqQDgC/UhWQQyaO8mw1+cFG3eBr/vkBU5ZNCG+APjFAx/dnaW
sXEZ08FRW1FUTYVqa48aNn2cpy97zeUTX3oxX1ySlnhZ4lx60G4oNrUxbdPgTBlR
dT+hgMdnUV52QzUWpWlIeogh18PBMABJYoN5/mqXfCOgksgLTz1akgIFS1xqtGNQ
cieREiX6VAY5+T7zoej2G06fmxoHf7HKFAxvQgcVRY7xYZ8xLTXI1bQIh0KKvpQh
QTomEmbc7nfJb7wLlHUC3/DTXcUp7dvt7rxOz4sotHUO1F4eO03VNYvum1wSb5uH
o7z7WUe/0CZvySaHgcHtVSxZXHZSsSJJD/J9UsEUVG6H0hrY8wNnFEZnoK/aohqE
Q01LwDcx7EpcOiaYwxXiBjg68lNsY0e3NhSSkyx4DqXI6RDRCcmGW0u6Jk2w2x0G
RkB1/q6ffslm6d3sgbeJl+LuWAjf6lsyhtah/A5rhgwW5n8w8f0ffMReoOzToHR2
VQEZ5XaG88F5NpnsSdJJQcV1y/22I7tgXLrFTwVLFnuXvjn7p8WdXl6ullOayAyc
HdXQHYNb8Xxk1A1io7Ga5FuKZOdOLbME+b+5MYME83JRuB9vRHw=
=Jlz/
-----END PGP SIGNATURE-----


Christopher Baines wrote 6 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 33725@debbugs.gnu.org)
87r2ekw01h.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (15 lines)
> On Thu, Dec 13, 2018 at 02:28:32PM +0100, Christopher Baines wrote:
>> This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.
>>
>> It sounds from the comment that this can hopefully be removed now.
>>
>> * gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
>> * gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
>> llvm-without-rtti.
>
> Thanks! If the change doesn't trigger any rebuilds (that is, if the
> package is really unused), please push!
>
> Ideally, the commit message will say which commit made this package
> unnecessary.

So, my understanding of this is that this change was made to prevent
some rebuilds a while ago. It does trigger quite a few rebuilds (1120),
so it'll need pushing to staging/core-updates.

I'll test some of these packages locally, and then probably push it to
core-updates, as there's some other stuff on staging I'd like to see
merged to master soonish.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlwT2MpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdKTg//c+dfMwFlq4DNpiUSs2xIiaJg8tHnF1uicwX7+eaxVgrfZ8CKV8ARShgH
oh60YwynCwYgUKZVNTspzXGwRUsA/QYjAzx25bvwSDxZcH678Iq8ST6dblfAs/qI
terdd8dBEpm4QRMM/WbLH87Z7WS7YVUgpziXfs2ofLy+ZrjK8K8el8KgeUkd3O9J
ys0ShO1jnMeuvA5MnjTw0JlVeDv0eM4z4hyxC5N7Xra24NE+OwKntkEWDdW84GUg
if+JzoYuKUKG6XvqYEp66hs30zbdGzqgx/aBBgzTPj4P02Z2qBRMzX08C07YGt2a
Ew4ac79fwdzHbt5ByLpnXCDD5b6a3PZbvU8win/MclazfZ4ZgCS7wHaGRF2iSBxB
nHSiNqi/IzhFc3Tbg+dLLqlzu6251Zte69MCx7X+6vmGhm5lRnrtmK26mnOjAg8Y
cR4CwKrLy2eO1LhORwvJXetdT3FiuhlShsdXp065zyK91hW39m+7t8+lvmlLtb9R
1KuXQ9oI3caWHQ4lGkC6cilylPlgfH6KzqxquPdTlwpj56nM8/jNG2RxlbE+VqtU
7yCwHslGhArjZdoV0YhRj8rpCuVPqNe08n3VzPHKj1WnHvc9tRloPQgVQlTLUK9i
dvbCJwQfm30qstwN2L7o+KzS5wCYFCK4ZN/GRMC7O1dq8fu6tuM=
=cp0v
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 33725@debbugs.gnu.org)
877egamsc2.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (25 lines)
> Leo Famulari <leo@famulari.name> writes:
>
>> On Thu, Dec 13, 2018 at 02:28:32PM +0100, Christopher Baines wrote:
>>> This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.
>>>
>>> It sounds from the comment that this can hopefully be removed now.
>>>
>>> * gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
>>> * gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
>>> llvm-without-rtti.
>>
>> Thanks! If the change doesn't trigger any rebuilds (that is, if the
>> package is really unused), please push!
>>
>> Ideally, the commit message will say which commit made this package
>> unnecessary.
>
> So, my understanding of this is that this change was made to prevent
> some rebuilds a while ago. It does trigger quite a few rebuilds (1120),
> so it'll need pushing to staging/core-updates.
>
> I'll test some of these packages locally, and then probably push it to
> core-updates, as there's some other stuff on staging I'd like to see
> merged to master soonish.

I've tweaked the commit message, and tested this on top of core-updates
now. With a tweak to fix the build for python2-(minimal), I've
successfully built mesa and a few of it's dependnecies. So I've now
pushed to core-updates.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlwVaA1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd0vA/+J5KsCcna+bXFd73rx/1Ntgo9fWo/pXZawFJhY34fXmzEhxc6dRzgRbuL
w/Qs2ab6pnTVEbQJqkmiJdRQDzXOhQ9FadKVFx4ysZnuPrpCilyg04tA2aoKdW2C
0L/UclS1+go8hIOfsT1QtbaoFo2IxP7SFgXUqmFabWRhzb3zJa3JKt3wQs5o66AV
mN1npvHw9fceraW7GHE5eI7NkTWk8Wa9b6OsakZUixzCRqSgMllqO8PbS+nDDXo5
L1Pi8vvd54NQSOQ5cgn8lu19FmEU8jaNmh4Iq8hvtdQTGYErmISreP/po1Lew2/R
e05r6lkDMzouJv3B8Y1cHsIRiKBGaQ0u4OHKIywiX8xCvgYcio+tLh4b0mPbskCU
l7bu0qOWaIyk00QS9K7TpN0Lta89MdICXUT7XkjoArwYZ/QBCJ9JG/c69zKRmjm+
yRce8ihb1B9earp2U7cXOymMfUrF05uEb7Nj8XN8zuNvOPlifKEfR9WkztnIepoE
lmRyH8xVZ/BM7WYeyyPbPAUOaNdJno2NlDnVqPVzt5gp6t0GxuveSgmYiRjBsE+0
TjHSYHtyFV43wGLWbg4ZUQhCikXRptZVErX82V7GQi0Bs6T2yewfLzZ31cSZGGS6
P4HdJ5G8fJC3hSV16H/u0iGh5MRzLVsKAXqhb1QiWhCbAgH4TTY=
=6lyG
-----END PGP SIGNATURE-----

Marius Bakke wrote 6 years ago
(address . 33725@debbugs.gnu.org)
87tvj68tri.fsf@fastmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (25 lines)
> Leo Famulari <leo@famulari.name> writes:
>
>> On Thu, Dec 13, 2018 at 02:28:32PM +0100, Christopher Baines wrote:
>>> This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.
>>>
>>> It sounds from the comment that this can hopefully be removed now.
>>>
>>> * gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
>>> * gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
>>> llvm-without-rtti.
>>
>> Thanks! If the change doesn't trigger any rebuilds (that is, if the
>> package is really unused), please push!
>>
>> Ideally, the commit message will say which commit made this package
>> unnecessary.
>
> So, my understanding of this is that this change was made to prevent
> some rebuilds a while ago. It does trigger quite a few rebuilds (1120),
> so it'll need pushing to staging/core-updates.
>
> I'll test some of these packages locally, and then probably push it to
> core-updates, as there's some other stuff on staging I'd like to see
> merged to master soonish.

Good news! This commit is already on 'staging' and should be merged
soonish:


:-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlwdWFEACgkQoqBt8qM6
VPq/rAgAiA761A+SM4yaBn4N6s9LZ9pNfpmP+NYNxLzdLTKCL+Le4njDW+RmLFGR
CrcS+i8C6lwDVqyqAY2nU34K+NPMzUF1FpUB3Q0GOAjP0fH+IBl5+Obh+9UcqKyd
MFkNcbIjRpVigrVegSUxsjO6wfdrN/JAR9MjkJmuFhM5Xu5Ajo4D2endqquDIXI1
VBkOG9FEmj0QOqz0KOHXaaCMJC++jUnktoUrO0TmAVKTNZpYMg/itxXCC7eQ+LQw
wlw/BFEBFwzy5CIB/cmRr58rnF5mKrw4NCcNJFUn/+DqQkqvDmMrhII0+YFWRD4Q
u//4NrEWirixCFYoLkiG5uMoD0yKQw==
=QSbZ
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
control message for bug #33725
(address . control@debbugs.gnu.org)
87o989j0qf.fsf@gmail.com
tags 33725 pending
Christopher Baines wrote 6 years ago
Re: [bug#33725] [PATCH] gnu: llvm-rtti: Remove it.
(address . 33725-done@debbugs.gnu.org)
8736ow54yr.fsf@cbaines.net
Staging has been merged, so this bug can be closed now.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxf+JxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xcrwg//cWddYaGIPz+p0i5xOesMvqeNTyi6oKTh1wdaXbXLOoqhIujbMGSm9PoV
SX82uGG1Y7Mqrm/e7jndp8M3sXSqfgU3Sm6hVhUkhcqi2V5vYAfawxd3Ayx0llqN
YaLYVhIdYVhy4FXYdDLcVLr+AS7BVN8getllfO+SdUHSh2lVmx3Y2XjIsGbs9kCl
f2hXfYIX4fx7VS9J9Uf7jw/g0rWm03vrWXl8oAui5OVSizfby7O1gqatc6sFlPca
Vci2cke/1r+sd0xgy0zDzkPhs7TMg6L7+mV1q2W0fKTpBcAclC0EEhPmLsAp9dCp
zSHQ+muJd1kgBxcUeWcWxeX9aWbSCh7XkHfk4butRvKXFvLaXJILpFVP9bUek57X
STLregceJVYw06f4fYr6rSLtL0oqOENA/cQKBYLebUGLkNUzeaoeRZ7JgWzhM0QB
ZjMVIZKV1OT1F7nFj3KR2qbtsDvS8MzmImw3WK88p9w3VAkpVper2B9ICOosn2eM
lsGMAYKc08LI/R/a7g/l29V1gmPH9++NzHCVh545y9x3SXvtm4BJJrYLSyIDQLPp
25mSKn6/2oHa3ArJ5ShmZEDaacTEvhMzyw0MZOFwOZTCGC4QSH9fsRiZSAdjHoVi
zi2+Q4mkLwHStQh/b8Dzjoo0GFSw1d9FdEpD6kF8P7Wu0eSgxlo=
=v66S
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33725@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33725
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help