[PATCH] gnu: ghc-call-stack-boot: Make it a hidden package.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20181213125641.20767-1-mail@cbaines.net
This package doesn't sound like it should be directly used, so hide it.

* gnu/packages/haskell.scm (ghc-call-stack-boot): Use hidden-package to hide
the package.
---
gnu/packages/haskell.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 57435dca07..8d0e2aef69 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5069,10 +5069,11 @@ call stacks with different versions of the compiler.")
;; This is used as an input to ghc-hunit. We cannot use ghc-call-stack there,
;; because it depends on ghc-nanospec, which depends on ghc-hunit.
(define-public ghc-call-stack-boot
- (package
- (inherit ghc-call-stack)
- (arguments '(#:tests? #f))
- (inputs '())))
+ (hidden-package
+ (package
+ (inherit ghc-call-stack)
+ (arguments '(#:tests? #f))
+ (inputs '()))))
(define-public ghc-statevar
(package
--
2.18.0
Leo Famulari wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 33724@debbugs.gnu.org)
20181213202818.GD22790@jasmine.lan
On Thu, Dec 13, 2018 at 01:56:41PM +0100, Christopher Baines wrote:
Toggle quote (5 lines)
> This package doesn't sound like it should be directly used, so hide it.
>
> * gnu/packages/haskell.scm (ghc-call-stack-boot): Use hidden-package to hide
> the package.

LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlwSwOIACgkQJkb6MLrK
fwg84g//cYwPms5OLF8ZZpTXMumBv2gNiqMsJuwWni0y45NHfX0MpQFntX6IxdMa
NIXHAjkqOR9q4eV9uj7JTVjcgp+ifWKyyJ0QRfC0jotV2/bvv1V9Ql8XLPvcuySn
ZcwLq6jl+YOig8fj4FRr2NEBr5k23zPjpUlNILYzHYDELWDOnWL9NdnWfSGZyQ8o
kFf9EAsVSf9oq+vEuZmOd6cgTKYX+wxCVwBDUcAtXrk66HEZOn/oRTaT4APpXdFV
9Db508BiZ7SWxeA8D56qGrd89Lwy/21GVpRuMdjsKXWdj+EX1Z5RO7Ku9/FnN5fx
7RESXFCPP9JXLEGr9EXFH/gUzot6smxzuQQqJPTSTI1lCFEh9RdzzikBIpkzXl/Q
MRVUsV8QOMmst094DH2DldrSUu9tFABH5X2Xjuf8mEpsMMGTBsdMV3GBSQPw2q8J
9Ynw1CuOn0LPuZBekZ/Rmdg9cmtF0afW8s2P38QXsjFqJveaQLKAIps/wPn7qoQU
jKYp/riDit6vPpNEB90p8tQ272Gb+pl+K2DkDK9aKD0Qcl2BxoigTI0ono56Fkyc
zIbCA9CpkCB7zwJETAlvZKBvhkpy6BDVQxdnyRmHqUFSoyaGQG/+dJCG1pIX9xOn
AvJsIm/Pr6Rn2jf6zSNdFoHwCL8R+GWiGw2NACcdEgGm4GqAIlY=
=lRvc
-----END PGP SIGNATURE-----


Christopher Baines wrote 6 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 33724-done@debbugs.gnu.org)
87sgz0w0c2.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (8 lines)
> On Thu, Dec 13, 2018 at 01:56:41PM +0100, Christopher Baines wrote:
>> This package doesn't sound like it should be directly used, so hide it.
>>
>> * gnu/packages/haskell.scm (ghc-call-stack-boot): Use hidden-package to hide
>> the package.
>
> LGTM, thanks!

Great, I've pushed this now :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlwT105fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcyVRAAqDjSNL7wPQSmeBcGtlTjRWT71mxEbvpl1sCDR6TdTZ9g9b7x2zUVyP12
FaXLPJYNtcJgME/YQ8TJjs6pGDWITPugKCZBKa8NwHyyr6yDKqlJUlFI5H4WXhwa
2G6hB9ZxYcHQSJKyfZL2PBSUGpd+yFy24vDvxz2/Q1jmD79DdoADWM8Qb6P9XJuS
KO7EJYnTGNPJenZ0KXs9Q+kk7b3H7W34SR3vg2gHIX14re1kD/jyfY9esZyfVIAl
zfetB89/9LmsY0lq0MjMeUWktuwey/aBu3IJkWzWJ/vA20Ba40wx3EViD6nGPhrd
82SYfC+xUetwjMxMV0rihosS5G+bXNO8E3rfG5MnxzFJUirs2ojNKSRjNn4ax1xX
j4VgymnAU9agHEe2F0KCA8iMLdofxeqjj98s7A+JJBDDgCPXrqbIEq6muastnQo4
CgimtgTy7mAwvJNDwejsUuXqWrtVjrjGtm2JcqiFSr3umS5Nltpawvd6++YZyQDv
Xf8JWV26hGWwO7us6U4PFoBUIS3G+Cv9g+D1OY5PGXsBXZDbq1MeGsjgBFdYuVG9
ExgwmpaMiH7UiAGoLGqPLsCy+/N2TyzgzNdtVAJCWvums0xLMT9few02ThDziqAz
fvF8dwc+GB63Sgiii765uIWT4UBffD6YmBy98Cgeygr9yzmUGnM=
=Gpzw
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33724@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33724
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help