(address . bug-guix@gnu.org)
When I set the time or toggle automatic time in the gnome-control-center
it errors out. The time is still wrong.
sdb@antelope ~$ gnome-control-center
(gnome-control-center:1556): datetime-cc-panel-WARNING **: 13:24:15.745:
Timezone '(null)' is unhandled, setting Europe/London as default
(gnome-control-center:1556): datetime-cc-panel-WARNING **: 13:24:24.324:
Could not set system to use NTP:
GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name
org.freedesktop.timedate1 was not provided by any .service files
(gnome-control-center:1556): GLib-GIO-CRITICAL **: 13:24:34.673:
g_dbus_connection_call_internal: assertion 'object_path != NULL &&
g_variant_is_object_path (object_path)' failed
sdb@antelope ~$ guix --version
guix (GNU Guix) 0.16.0-3.6ddc63e
Installed from git with sudo -E reconf...
config.scm attached.
--
Cheers
Swedebugia
;; This is an operating system configuration template
;; for a "desktop" setup with GNOME and Xfce where the
;; root partition is encrypted with LUKS.
(use-modules (gnu) (gnu system nss))
(use-service-modules desktop networking)
(use-package-modules certs gnome
;; for my-base-packages
linux less base nano pciutils admin man texinfo
bash guile gawk compression)
(define %my-base-packages
;; Like upstream but without wifi-programs and zile.
;; Default set of packages globally visible. It should include anything
;; required for basic administrator tasks.
(cons* procps psmisc which less
;;zile
nano
pciutils usbutils
util-linux
inetutils isc-dhcp
(@ (gnu packages admin) shadow) ;for 'passwd'
;; wireless-tools is deprecated in favor of iw, but it's still what
;; many people are familiar with, so keep it around.
;;iw wireless-tools
iproute
net-tools ; XXX: remove when Inetutils suffices
man-db
info-reader ;the standalone Info reader (no Perl)
;; The 'sudo' command is already in %SETUID-PROGRAMS, but we also
;; want the other commands and the man pages (notably because
;; auto-completion in Emacs shell relies on man pages.)
sudo
;; Get 'insmod' & co. from kmod, not module-init-tools, since udev
;; already depends on it anyway.
kmod eudev
e2fsprogs kbd
bash-completion
;; XXX: We don't use (canonical-package guile-2.2) here because that
;; would create a collision in the global profile between the GMP
;; variant propagated by 'guile-final' and the GMP variant propagated
;; by 'gnutls', itself propagated by 'guix'.
guile-2.2
;; The packages below are also in %FINAL-INPUTS, so take them from
;; there to avoid duplication.
(map canonical-package
(list bash coreutils findutils grep sed
diffutils patch gawk tar gzip bzip2 xz lzip))))
(operating-system
(host-name "antelope")
(timezone "Europe/Paris")
(locale "en_US.utf8")
;; Use the UEFI variant of GRUB with the EFI System
;; Partition mounted on /boot/efi.
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/sda")))
(file-systems (cons (file-system
(device (file-system-label "my-root"))
(mount-point "/")
(type "ext4"))
%base-file-systems))
(swap-devices '("/dev/sda2"))
(users (cons (user-account
(name "sdb")
(comment "Alice's brother")
(group "users")
(supplementary-groups '("wheel" "netdev"
"audio" "video"))
(home-directory "/home/sdb"))
%base-user-accounts))
;; This is where we specify system-wide packages.
(packages (cons* nss-certs ;for HTTPS access
gvfs ;for user mounts
gnome-shell-extensions
network-manager-openvpn
%my-base-packages))
;; Add GNOME and/or Xfce---we can choose at the log-in
;; screen with F1. Use the "desktop" services, which
;; include the X11 log-in service, networking with
;; NetworkManager, and more.
(services (cons* (gnome-desktop-service)
;;(xfce-desktop-service)
(console-keymap-service "se-latin1")
(modify-services %desktop-services ; Add berlin as first priority
; substitute server
(guix-service-type config =>
(guix-configuration
(inherit config)
(substitute-urls '(
"https://berlin.guixsd.org https://mirror.hydra.gnu.org"))))
(network-manager-service-type config =>
(network-manager-configuration
(inherit config)
(vpn-plugins (list network-manager-openvpn)))))))
;; Allow resolution of '.local' host names with mDNS.
;;(name-service-switch %mdns-host-lookup-nss)
)