[PATCH 1/3] gnu: ardour: Add a phase to install Freedesktop files.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brendan Tildesley
  • Efraim Flashner
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 8 Dec 2018 09:00
(address . guix-patches@gnu.org)
79055647-0d66-755e-1220-d55e42aa55a7@gmail.com

From 8139a2013cdbb81c8b332ed7cd6e88212d6354d5 Mon Sep 17 00:00:00 2001
From: Brendan Tildesley <brendan.tildesley@openmailbox.org>
Date: Fri, 7 Dec 2018 22:00:14 +1100
Subject: [PATCH 1/3] gnu: ardour: Add a phase to install Freedesktop files.

* gnu/packages/audio.scm (ardour): [arguments]:
- Correct comment about --freedesktop flag.
- Adjust pretty printing for consistency.
- Add 'install-free-desktop-files phase to actually install the files that
were build. Fixes bug#33585 reported by baconicsynergy.
---
gnu/packages/audio.scm | 23 +++++++++++++++++++----
1 file changed, 19 insertions(+), 4 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a65cfa238e..3d77987062 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -229,13 +229,28 @@ namespace ARDOUR { const char* revision = \"" version "\" ; }"))
(arguments
`(#:configure-flags '("--cxx11" ; required by gtkmm
"--no-phone-home" ; don't contact ardour.org
- "--freedesktop" ; install .desktop file
+ "--freedesktop" ; build .desktop file
"--test") ; build unit tests
#:phases
(modify-phases %standard-phases
- (add-after
- 'unpack 'set-rpath-in-LDFLAGS
- ,(ardour-rpath-phase (version-major version))))
+ (add-after 'unpack 'set-rpath-in-LDFLAGS
+ ,(ardour-rpath-phase (version-major version)))
+ (add-after 'install 'install-freedesktop-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (v ,(version-major version)))
+ (for-each
+ (lambda (s)
+ (let ((d (string-append out "/share/icons/hicolor/" s "x" s "/apps")))
+ (mkdir-p d)
+ (copy-file
+ (string-append "gtk2_ardour/resources/Ardour-icon_" s "px.png")
+ (string-append d "/ardour" v ".png"))))
+ '("16" "22" "32" "48" "256"))
+ (install-file (string-append "build/gtk2_ardour/ardour" v ".desktop")
+ (string-append out "/share/applications/"))
+ (install-file (string-append "build/gtk2_ardour/ardour" v ".appdata.xml")
+ (string-append out "/share/appdata/"))))))
#:test-target "test"
#:python ,python-2))
(inputs
--
2.19.2
B
B
Brendan Tildesley wrote on 8 Dec 2018 09:02
[PATCH 2/3] gnu: ardour: Add libusb input.
(address . 33671@debbugs.gnu.org)
c7fd8bb9-498e-a687-ca48-4f5cbeec745a@gmail.com

From 330711e40df3c016a9f6c10c42bce0fd65733166 Mon Sep 17 00:00:00 2001
From: Brendan Tildesley <brendan.tildesley@openmailbox.org>
Date: Sat, 8 Dec 2018 02:34:12 +1100
Subject: [PATCH 2/3] gnu: ardour: Add libusb input.

* gnu/packages/audio.scm (ardour): [inputs]: add libusb.
---
gnu/packages/audio.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3d77987062..d751a4904b 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -74,6 +74,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages llvm)
#:use-module (gnu packages mp3) ;taglib
#:use-module (gnu packages perl)
@@ -271,6 +272,7 @@ namespace ARDOUR { const char* revision = \"" version "\" ; }"))
("libsamplerate" ,libsamplerate)
("libxml2" ,libxml2)
("libogg" ,libogg)
+ ("libusb" ,libusb)
("libvorbis" ,libvorbis)
("flac" ,flac)
("lv2" ,lv2)
--
2.19.2
B
B
Brendan Tildesley wrote on 8 Dec 2018 09:03
[PATCH 3/3] gnu: ardour: Sort inputs and native-inputs.
(address . 33671@debbugs.gnu.org)
c21b3e0b-6e90-b829-c4a3-38f6c37517b8@gmail.com

From 4444b720b1e035c25ecd36c9244f514d76ca121f Mon Sep 17 00:00:00 2001
From: Brendan Tildesley <brendan.tildesley@openmailbox.org>
Date: Sat, 8 Dec 2018 14:42:07 +1100
Subject: [PATCH 3/3] gnu: ardour: Sort inputs and native-inputs.

* gnu/packages/audio.scm (ardour): Sort inputs and native-inputs.
---
gnu/packages/audio.scm | 44 +++++++++++++++++++++---------------------
1 file changed, 22 insertions(+), 22 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d751a4904b..528eddf3c7 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -256,47 +256,47 @@ namespace ARDOUR { const char* revision = \"" version "\" ; }"))
#:python ,python-2))
(inputs
`(("alsa-lib" ,alsa-lib)
+ ("atkmm" ,atkmm)
("aubio" ,aubio)
- ("lrdf" ,lrdf)
("boost" ,boost)
- ("atkmm" ,atkmm)
("cairomm" ,cairomm)
+ ("curl" ,curl)
("eudev" ,eudev)
- ("gtkmm" ,gtkmm-2)
+ ("fftw" ,fftw)
+ ("fftwf" ,fftwf)
+ ("flac" ,flac)
("glibmm" ,glibmm)
+ ("gtkmm" ,gtkmm-2)
+ ("jack" ,jack-1)
+ ("libarchive" ,libarchive)
("libart-lgpl" ,libart-lgpl)
("libgnomecanvasmm" ,libgnomecanvasmm)
- ("pangomm" ,pangomm)
("liblo" ,liblo)
- ("libsndfile" ,libsndfile)
- ("libsamplerate" ,libsamplerate)
- ("libxml2" ,libxml2)
("libogg" ,libogg)
+ ("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
("libusb" ,libusb)
("libvorbis" ,libvorbis)
- ("flac" ,flac)
+ ("libxml2" ,libxml2)
+ ("lilv" ,lilv)
+ ("lrdf" ,lrdf)
("lv2" ,lv2)
- ("vamp" ,vamp)
- ("curl" ,curl)
- ("fftw" ,fftw)
- ("fftwf" ,fftwf)
- ("jack" ,jack-1)
+ ("pangomm" ,pangomm)
+ ("python-rdflib" ,python-rdflib)
+ ("readline" ,readline)
+ ("redland" ,redland)
+ ("rubberband" ,rubberband)
("serd" ,serd)
("sord" ,sord)
("sratom" ,sratom)
("suil" ,suil)
- ("lilv" ,lilv)
- ("readline" ,readline)
- ("redland" ,redland)
- ("rubberband" ,rubberband)
- ("libarchive" ,libarchive)
("taglib" ,taglib)
- ("python-rdflib" ,python-rdflib)))
+ ("vamp" ,vamp)))
(native-inputs
- `(("perl" ,perl)
- ("cppunit" ,cppunit)
- ("itstool" ,itstool)
+ `(("cppunit" ,cppunit)
("gettext" ,gettext-minimal)
+ ("itstool" ,itstool)
+ ("perl" ,perl)
("pkg-config" ,pkg-config)))
(home-page "http://ardour.org")
(synopsis "Digital audio workstation")
--
2.19.2
E
E
Efraim Flashner wrote on 24 Dec 2018 11:08
Re: [bug#33671] [PATCH 1/3] gnu: ardour: Add a phase to install Freedesktop files.
(name . Brendan Tildesley)(address . brendan.tildesley@gmail.com)(address . 33671-done@debbugs.gnu.org)
20181224100830.GK2581@macbook41
Pushed with minor changes

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAlwgsB4ACgkQQarn3Mo9
g1ENeg//TXQadRw9fxHwxXKLGkBiJItKE/GPyf5DV3/jICXYPcjS9TDkJe4uUL5c
3SWtTZQHobNTefe1w4BrIFUj8hhoPmjfveV5RfaPwRoX9ANNKiLc50LI6t5cD6/n
+kexSk7Wghgim1NPDfU3G6CKBt8AQc9PldhT8xKT0yP5eOzFQDSHWfvfphSqlPXP
ecODQ5vd2fdPGKAKv5e2Bo4twwQSHd55Gnx8dcfGjuGAvEFq/9SSSo14UarN8ANo
re1DqAwc/xnowiEePz3I+1LwMzWRHD49/UqPYNsWFT53GesRyxjiCDGY3F1IYHUC
bCEASkdBXjFP64+Y9oW8a+3Y8yjn/iIBMcbZfro9CUmRBeTLtsMkRe+0XLhCG8qd
ZWxSPD5utH5Do34Jkrsol7x8efKcpzS809gPrlRQPW0jQN3oHXtm/ZZpQHTTui43
2A8cVKyMmvvmGmEeygmtvzCIFR5AWwpQi8n4/HAt7zlBSNCEUttwLIzoOQCGSCeg
OornLdrA08eCj/6RI45Vzsqa381qCHjGJHy6KI78r4BQh3iAKcnAtxTPyFR9qGyD
gsXZoYqDv73V16XZ7d1C9VSzT2XPdjc7i95IYlInm92XrLW59Yiz5dvQSIu1gmF9
DVuMDZGXnUEL59zqQIA8GmpA6X0Q65J8qam6KUIjS1nU2s9JpPQ=
=pG1j
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33671@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33671
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch