A recent Guix pull failed

DoneSubmitted by Joshua Branson.
Details
2 participants
  • Joshua Branson
  • Ricardo Wurmus
Owner
unassigned
Severity
normal
J
J
Joshua Branson wrote on 7 Dec 2018 15:47
(address . bug-guix@gnu.org)
87tvjp4cnq.fsf@fastmail.com
Hello,

I'm tried looking to see if someone else was experiencing this bug, but
I couldn't find a easy way to search the guix bug database, so I'm sorry
if I am making a duplicate bug report.

Anyway, I'm using a Macbook 7,1. guix version reports this:

guix (GNU Guix) 17cfb7aeffaaba70e67e9afb50d7100614ffca7f
Copyright (C) 2018 the Guix authors
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.


And guix pull shows this:

Updating channel 'my-personal-packages' from Git repository at 'https://notabug.org/jbranso/guix-packages.git'...
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Building from these channels:
;;; compiling /gnu/store/nnawlikz0n644rh05p9fyggq30qk5lis-my-personal-packages/share/guile/site/2.2/myemacs.scm
;;; compiled /home/joshua/.cache/guile/ccache/2.2-LE-8-3.A/gnu/store/xgd83571ijj6karrs8sykk0f5i4kqa39-guix-packages-862909a/myemacs.scm.go
guix pull: warning: failed to load '(myemacs)':
no code for module (myemacs)
Computing Guix derivation for 'x86_64-linux'... -@ build-started /gnu/store/4s6w1cz1srv9vh1bj5wim71sr4v8y22a-guix-0.16.0-2.5227d93-checkout.drv - x86_64-linux /var/log/guix/drvs/4s//6w1cz1srv9vh1bj5wim71sr4v8y22a-guix-0.16.0-2.5227d93-checkout.drv.bz2
environment variable `PATH' set to `/gnu/store/q09sy224qnxrp982z4xfaxi19721mjx8-gzip-1.9/bin:/gnu/store/ipx79bfj2mrc8npj7s3qi3zri11jfhaw-tar-1.30/bin'
Initialized empty Git repository in /gnu/store/yj0ly310dvzc4bxbvpa9d44wx93r7jql-guix-0.16.0-2.5227d93-checkout/.git/
\error: Server does not allow request for unadvertised object 5227d938e2b7bda22e2a7aa733e1e09a6c726f18
Failed to do a shallow fetch; retrying a full fetch...
* [new branch] core-updates-next -> origin/core-updates-next
* [new branch] guile-daemon -> origin/guile-daemon
* [new branch] imagemagick-updates -> origin/imagemagick-updates
* [new branch] master -> origin/master
* [new branch] nix -> origin/nix
* [new branch] python-updates -> origin/python-updates
* [new branch] qt-updates -> origin/qt-updates
* [new branch] reproduce-bug-29774 -> origin/reproduce-bug-29774
* [new branch] rhel6 -> origin/rhel6
* [new branch] staging -> origin/staging
* [new branch] version-0.10.0 -> origin/version-0.10.0
* [new branch] version-0.11.0 -> origin/version-0.11.0
* [new branch] version-0.12.0 -> origin/version-0.12.0
* [new branch] version-0.13.0 -> origin/version-0.13.0
* [new branch] version-0.14.0 -> origin/version-0.14.0
* [new branch] version-0.15.0 -> origin/version-0.15.0
* [new branch] version-0.16.0 -> origin/version-0.16.0
* [new branch] version-0.8.3 -> origin/version-0.8.3
* [new branch] version-0.9.0 -> origin/version-0.9.0
* [new branch] wip-bootstrap -> origin/wip-bootstrap
* [new branch] wip-build-systems-gexp -> origin/wip-build-systems-gexp
* [new branch] wip-check -> origin/wip-check
* [new branch] wip-container -> origin/wip-container
* [new branch] wip-deploy -> origin/wip-deploy
* [new branch] wip-gcc7 -> origin/wip-gcc7
* [new branch] wip-gexp-grafts -> origin/wip-gexp-grafts
* [new branch] wip-gexp-hygiene -> origin/wip-gexp-hygiene
* [new branch] wip-git-https -> origin/wip-git-https
* [new branch] wip-gnome-upgrades -> origin/wip-gnome-upgrades
* [new branch] wip-grafts -> origin/wip-grafts
* [new branch] wip-haskell -> origin/wip-haskell
* [new branch] wip-hurd -> origin/wip-hurd
* [new branch] wip-installer -> origin/wip-installer
* [new branch] wip-installer-2 -> origin/wip-installer-2
* [new branch] wip-ipfs -> origin/wip-ipfs
* [new branch] wip-ipfs2 -> origin/wip-ipfs2
* [new branch] wip-kde-frameworks-update -> origin/wip-kde-frameworks-update
* [new branch] wip-loongson2f -> origin/wip-loongson2f
* [new branch] wip-mediagoblin -> origin/wip-mediagoblin
* [new branch] wip-newt-installer -> origin/wip-newt-installer
* [new branch] wip-next-browser -> origin/wip-next-browser
* [new branch] wip-next-browser2 -> origin/wip-next-browser2
* [new branch] wip-next-browser3 -> origin/wip-next-browser3
* [new branch] wip-next4 -> origin/wip-next4
* [new branch] wip-offload-compression -> origin/wip-offload-compression
* [new branch] wip-potluck -> origin/wip-potluck
* [new branch] wip-rails -> origin/wip-rails
* [new branch] wip-rust -> origin/wip-rust
| * [new tag] v0.0 -> v0.0
* [new tag] v0.1 -> v0.1
* [new tag] v0.10.0 -> v0.10.0
* [new tag] v0.11.0 -> v0.11.0
* [new tag] v0.12.0 -> v0.12.0
* [new tag] v0.13.0 -> v0.13.0
* [new tag] v0.14.0 -> v0.14.0
* [new tag] v0.15.0 -> v0.15.0
* [new tag] v0.16.0 -> v0.16.0
* [new tag] v0.2 -> v0.2
* [new tag] v0.3 -> v0.3
* [new tag] v0.4 -> v0.4
* [new tag] v0.5 -> v0.5
* [new tag] v0.6 -> v0.6
* [new tag] v0.7 -> v0.7
* [new tag] v0.8 -> v0.8
* [new tag] v0.8.1 -> v0.8.1
* [new tag] v0.8.2 -> v0.8.2
* [new tag] v0.8.3 -> v0.8.3
* [new tag] v0.9.0 -> v0.9.0
fatal: reference is not a tree: 5227d938e2b7bda22e2a7aa733e1e09a6c726f18
Backtrace:
3 (primitive-load "/gnu/store/7z2k7nlc1zlsngmbinmmly4gma5?")
In ice-9/eval.scm:
293:34 2 (_ #<directory (guile-user) 5ce140>)
In ./guix/build/git.scm:
51:10 1 (git-fetch "https://git.savannah.gnu.org/r/guix.git""?" ?)
In ./guix/build/utils.scm:
616:6 0 (invoke _ . _)

./guix/build/utils.scm:616:6: In procedure invoke:
Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "/gnu/store/sddrm4n6w4mvm8isaakk4ffwy5rgzskk-git-minimal-2.19.2/bin/git" arguments: ("checkout" "5227d938e2b7bda22e2a7aa733e1e09a6c726f18") exit-status: 128 term-signal: #f stop-signal: #f] 5fb640>)'.
builder for `/gnu/store/4s6w1cz1srv9vh1bj5wim71sr4v8y22a-guix-0.16.0-2.5227d93-checkout.drv' failed with exit code 1
@ build-failed /gnu/store/4s6w1cz1srv9vh1bj5wim71sr4v8y22a-guix-0.16.0-2.5227d93-checkout.drv - 1 builder for `/gnu/store/4s6w1cz1srv9vh1bj5wim71sr4v8y22a-guix-0.16.0-2.5227d93-checkout.drv' failed with exit code 1
cannot build derivation `/gnu/store/x137ahjky1mk0iihbq0ww5l5yj2ma56b-guix-daemon-0.16.0-2.5227d93.drv': 1 dependencies couldn't be built
Backtrace:
15 (primitive-load "/gnu/store/bmbjmh64xk6hr632balpfllfs0v���")
In ice-9/eval.scm:
155:9 14 (_ _)
159:9 13 (_ #(#(#(#(#(#(#(#(#(#(#(���) ���) ���) ���) ���) ���) ���) ���) ���) ���) ���))
In ./guix/store.scm:
1659:24 12 (run-with-store _ _ #:guile-for-build _ #:system _ # _)
1532:8 11 (_ _)
In ./guix/gexp.scm:
702:2 10 (_ _)
In ./guix/monads.scm:
485:9 9 (_ _)
In ./guix/gexp.scm:
572:22 8 (_ _)
In ./guix/store.scm:
1532:8 7 (_ _)
1555:38 6 (_ #<build-daemon 256.97 af671e0>)
In ./guix/packages.scm:
873:14 5 (cache! #<weak-table 484/883> #<package guix-daemon@0.���> ���)
In unknown file:
4 (_ #<procedure thunk ()> #<procedure list _> #<undefined>)
In ./guix/grafts.scm:
314:4 3 (graft-derivation #<build-daemon 256.97 af671e0> #<der���> ���)
192:4 2 (references-oracle #<build-daemon 256.97 af671e0> #<der���>)
201:20 1 (_ _ _)
In ./guix/store.scm:
1104:15 0 (_ #<build-daemon 256.97 af671e0> _ _)

./guix/store.scm:1104:15: Throw to key `srfi-34' with args `(#<condition &nix-protocol-error [message: "build of `/gnu/store/x137ahjky1mk0iihbq0ww5l5yj2ma56b-guix-daemon-0.16.0-2.5227d93.drv' failed" status: 1] 65f5840>)'.
guix pull: error: You found a bug: the program '/gnu/store/bmbjmh64xk6hr632balpfllfs0v7768i-compute-guix-derivation'
failed to compute the derivation for Guix (version: "6ddc63e599a26c302f74d0622f67cfd987f0dc5f"; system: "x86_64-linux";
host version: "17cfb7aeffaaba70e67e9afb50d7100614ffca7f"; pull-version: 1).
Please report it by email to <bug-guix@gnu.org>.


Thanks,

Joshua


* I tried to find a duplicate of my bug by searching through this page https://debbugs.gnu.org/db/pa/lguix.html
J
J
Joshua Branson wrote on 7 Dec 2018 16:33
(name . Gábor Boskovits)(address . boskovits@gmail.com)(address . bug-guix@gnu.org)
87pnud4aia.fsf@fastmail.com
cat .config/guix/channels.scm

;; Add my personal packages to those Guix provides.
(cons (channel
(name 'my-personal-packages)
%default-channels)

My channel is probably not correct. I'm not certain if I am specifying
packages correctly.

Thanks,

Joshua
R
R
Ricardo Wurmus wrote on 7 Dec 2018 16:44
(name . Joshua Branson)(address . jbranso@fastmail.com)
87tvjpfij9.fsf@elephly.net
Hi Joshua,

there was a bug with commit 6eac835f178c0c78637b0db8a4585a617b2f7622,
which has already been fixed in commit
23a1f738b1ef83c3dcb329e1c68617b0452e6a07.

Please try again.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send email to 33661@debbugs.gnu.org