[PATCH] gnu: python: Update to 3.7.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Marius Bakke
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20181205211933.15313-1-mail@cbaines.net
Remove the replacement, as version 3.7.1 includes the fix for this issue.

* gnu/packages/python.scm (python-3.7): Update to 3.7.1.
(python-3/fixed): Remove this.
---
gnu/packages/python.scm | 13 ++-----------
1 file changed, 2 insertions(+), 11 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d0401b7bd..1abf2e816 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -343,8 +343,7 @@ data types.")
(define-public python-3.7
(package (inherit python-2)
(name "python")
- (version "3.7.0")
- (replacement python-3/fixed)
+ (version "3.7.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
@@ -357,7 +356,7 @@ data types.")
(patch-flags '("-p0"))
(sha256
(base32
- "0j9mic5c9lbd2b20wka7hily7szz740wy9ilfrczxap63rnrk0h3"))
+ "0v9x4h22rh5cwpsq1mwpdi3c9lc9820lzp2nmn9g20llij72nzps"))
(snippet
'(begin
(for-each delete-file
@@ -416,14 +415,6 @@ data types.")
;; Current 3.x version.
(define-public python-3 python-3.7)
-(define python-3/fixed
- (package
- (inherit python-3)
- (source (origin
- (inherit (package-source python-3))
- (patches (append (origin-patches (package-source python-3))
- (search-patches "python-CVE-2018-14647.patch")))))))
-
;; Current major version.
(define-public python python-3)
--
2.19.2
Marius Bakke wrote 6 years ago
87o99vsjsk.fsf@fastmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (5 lines)
> Remove the replacement, as version 3.7.1 includes the fix for this issue.
>
> * gnu/packages/python.scm (python-3.7): Update to 3.7.1.
> (python-3/fixed): Remove this.

OK for 'core-updates', thanks!

(I suppose we should rename the -next branch too, can you do it?)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlwMTcsACgkQoqBt8qM6
VPoHlQgAsbkjlBUp+GDkFH0l2bDOvp9nDd3jD6Eeaz0Ws8fp7WEkca/qDqZdLPAx
O8N2XjtqWC2FGj+gi69shHq/k2oKf+60LI1kKYbEv6z0KANmMVxk3PrxCZA6n5tz
tQQMoE8eI1w+dPyVWzpVttGq6+um727uFbubd5M7Jdp351h/BnQC8r2BtU5syCFV
a5N7zcUmd7xHTg7BbGsjePX8FdIzPIiO7NQjNqoUOiyw9OjLbvvj6ZXXU078cdwv
VJ8wh2DZrj8ZAMjpCGy+vQPrF/ythbExv/karkXJeDITAi5WhK2XpbARf0Ttw2BQ
Lgcoh8UUBkwNgZumQI9GQkiEAOJYIQ==
=g14O
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 33637@debbugs.gnu.org)
87a7leyk16.fsf@cbaines.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (11 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> Remove the replacement, as version 3.7.1 includes the fix for this issue.
>>
>> * gnu/packages/python.scm (python-3.7): Update to 3.7.1.
>> (python-3/fixed): Remove this.
>
> OK for 'core-updates', thanks!
>
> (I suppose we should rename the -next branch too, can you do it?)

Great, I've renamed the branch now (hopefully correctly), and I've also
pushed this patch to the newly created core-updates (was
core-updates-next) branch.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlwNBxZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xeccg//UybmLE7/I+mTjR8DDVSUoPdc/Xl5UgrptcxtzTpes5YXpzxA8OtNYDrL
cSKoTrt3tgc+edLT9elKnDaE1nX23Oe7FnilBT0jgXETDKipHR4Sx9/40B/B2hVP
Oyou11eRJg3+px8IwaOZBVVly6sNwYwlrGcL9DX+5+a1HfhT3Wv0vK58tvx/gMMv
BMQMSPTizBZ8m4KVjHVpRUg0Wdt7PtAVHiqW6tpcczD5oCDc7Eb40JtDZpnI+Fv5
+gQqRjalka0YKd+nz5of0UYKQ4CYEuvlmJbYIb8Xk6ZiGhqsrrg6PvsjzuHbw7CJ
BYWQK+6/qfcpDGY7Ufw6rmGgnDRKMowe0hjku7Q8AmwibjGpTceh0NKmGR1uNzig
9tAc5oDiIeJfE9I8Zz2ysUKb5BFyRj/wgw7TyHLNGWUIukC9Mf6g82brp4IFvNYo
RWVav2EY9/tzUr19R2WIJXllIfK4OBiYU9xnwvmpGiZ6hmgPXVZq5wVhpEbl5Qmk
fKiPj+Ya4JrcS4eT7mtiMUcKoy0vlfhgOHeZuOI9FHP4Pwnib7t5QCWGCIDugFTr
lkiZqiw6fdfyVhtSdlIIf2ATDGCpiKM1koHoHO8m4Dy6VZwvyRJqd0V8oaKtb+dM
e/Jy2BMv0n8ZT/ZTIkEdNV9CgERcOiiXS5ar2PrKuMq3fXTZqiw=
=4Hp+
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
control message for bug #33637
(address . control@debbugs.gnu.org)
87lg3dj0fc.fsf@cbaines.net
tags 33637 pending
Christopher Baines wrote 5 years ago
Re: [bug#33637] [PATCH] gnu: python: Update to 3.7.1.
(address . 33637-done@debbugs.gnu.org)
87wodff5i6.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (17 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Christopher Baines <mail@cbaines.net> writes:
>>
>>> Remove the replacement, as version 3.7.1 includes the fix for this issue.
>>>
>>> * gnu/packages/python.scm (python-3.7): Update to 3.7.1.
>>> (python-3/fixed): Remove this.
>>
>> OK for 'core-updates', thanks!
>>
>> (I suppose we should rename the -next branch too, can you do it?)
>
> Great, I've renamed the branch now (hopefully correctly), and I've also
> pushed this patch to the newly created core-updates (was
> core-updates-next) branch.

So there were obviously more updates pushed to core-updates, as Python
3.7.4 has hit master now, but that means this bug can be closed :D
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl2c12FfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xdz9w//dHpjaL/0URnsYZGU7594rXotBFMdASURTTncIMncl2/pDDk4yjt/kWu2
Q+UJ+OfqGCWOOcLxmUwtEmcIa5gy3WbtMYDh4+YiJ67Y4ipgXW9STzyz+OEslVB1
FNheDSBNSQWNMq+5dleFyfJAes3ajbmhbz/js32ZWQsBynNQIyqD/oY7ETlXZ5qB
QtLKQ0YmjeaiTJT6ckYt2v5h4H/PHVg3TAxDGwVwl5uTuJliQGxEkAEvwTnJiK84
B37ZHb6KAhaqSMAANIRE9LmVXXx/z49sBdjDFfmailrqRsKylvqet2z3EzUcadZu
rXaZotNxwyt79lXWDwVMuJxBZsI43bAJWFIKfcCNpHGl88oVgal8Ok/4JKDo3emb
8WfCo2R1zdzL7SAZRT1pCMx8lSIcIYmz+NbBgsGiQgzkR54dTzyigHF4ekatatB8
VYtUmL171XOinLxwuNHYXQGh8ze1Ioik+MCE1Y7l2WvR24qa7Fb7t9bh82kh6mrN
2wDH8rryfEwoVErfdDZ1V2Kh+36GAnxaHvtd6atDFn670QVnkqaGriziazZ/e5sU
RblcynI0m9T7Na7NjnlmAqissqPU5wcsHCeYjK08UA81fGo6dsxeuzYADfC64EMp
WaOwhh6HFTyoUDX6VZNBdSc3LZhaMp4Gg1r5rSfwzos1jNOkP70=
=zH1G
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33637@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33637
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help