[PATCH 0/2] Enable use of hypre via petsc

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Paul Garlick
Owner
unassigned
Submitted by
Paul Garlick
Severity
normal
P
P
Paul Garlick wrote on 28 Nov 2018 20:42
(address . guix-patches@gnu.org)(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)
1543434150-32152-1-git-send-email-pgarlick@tourbillion-technology.com
Hi Guix,

These two patches enable the HYPRE preconditioners to be used by packages
that use PETSc, such as FEniCS.

The first patch adds the necessary configure flag for petsc-openmpi. The
second patch is needed to ensure that the check phase of the fenics build
continues to succeed.

Best regards,

Paul.

Paul Garlick (2):
gnu: petsc-openmpi: Configure with support for HYPRE preconditioner.
gnu: fenics: Skip extra demo in 'check' phase.

gnu/packages/maths.scm | 4 +++-
gnu/packages/simulation.scm | 1 +
2 files changed, 4 insertions(+), 1 deletion(-)

--
1.8.3.1
P
P
Paul Garlick wrote on 28 Nov 2018 20:48
[PATCH 1/2] gnu: petsc-openmpi: Configure with support for HYPRE preconditioner.
(address . 33545@debbugs.gnu.org)(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)
1543434500-32200-1-git-send-email-pgarlick@tourbillion-technology.com
* gnu/packages/maths.scm (petsc-openmpi)[inputs]: Add hypre-openmpi.
[arguments]: Add 'with-hypre=1' flag.
---
gnu/packages/maths.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0cf8916..85af458 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1767,6 +1767,7 @@ scientific applications modeled by partial differential equations.")
(name "petsc-openmpi")
(inputs
`(("hdf5" ,hdf5-parallel-openmpi)
+ ("hypre" ,hypre-openmpi)
("metis" ,metis)
("mumps" ,mumps-openmpi)
("openmpi" ,openmpi)
@@ -1776,7 +1777,8 @@ scientific applications modeled by partial differential equations.")
(arguments
(substitute-keyword-arguments (package-arguments petsc)
((#:configure-flags cf)
- ``("--with-mpiexec=mpirun"
+ ``("--with-hypre=1"
+ "--with-mpiexec=mpirun"
"--with-metis=1"
"--with-mumps=1"
"--with-scalapack=1"
--
1.8.3.1
P
P
Paul Garlick wrote on 28 Nov 2018 20:48
[PATCH 2/2] gnu: fenics: Skip extra demo in 'check' phase.
(address . 33545@debbugs.gnu.org)(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)
1543434500-32200-2-git-send-email-pgarlick@tourbillion-technology.com
* gnu/packages/simulation.scm (fenics)[arguments]: Add 'curl-curl'
demo to list of demos that require meshes supplied by git-lfs.
---
gnu/packages/simulation.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 6144e23..bbe6d53 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -639,6 +639,7 @@ user interface to the FEniCS core components and external libraries.")
"'lift-drag', \n"
"'elastodynamics', \n"
"'dg-advection-diffusion', \n"
+ "'curl-curl', \n"
"'contact-vi-tao', \n"
"'contact-vi-snes', \n"
"'collision-detection', \n"
--
1.8.3.1
L
L
Ludovic Courtès wrote on 4 Dec 2018 11:13
Re: [bug#33545] [PATCH 0/2] Enable use of hypre via petsc
(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)(address . 33545-done@debbugs.gnu.org)
87va4961lp.fsf@gnu.org
Hello,

Paul Garlick <pgarlick@tourbillion-technology.com> skribis:

Toggle quote (4 lines)
> Paul Garlick (2):
> gnu: petsc-openmpi: Configure with support for HYPRE preconditioner.
> gnu: fenics: Skip extra demo in 'check' phase.

Applied both patches, thank you!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33545@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33545
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch